<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>5 brilliant games on Game Pass you must play right now | May 2020 edition - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href='https://fonts.googleapis.com/css?family=PT+Sans&subset=' rel='stylesheet' type='text/css'> 
<link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    
<!-- NetworkN CMP Tool -->
<script>!function(t,n){if(function(e){"string"==typeof e&&(e=[e]);for(var a=0;a<e.length;a++)n.cookie=e[a]+
"=;max-age=-1;domain=."+n.domain+";path=/"}(["euconsent","eupubconsent","googlepersonalization"]),
!t.__cmp){t.__cmp=function(){(t.attachEvent||t.addEventListener)("message",function(e){t.__cmp.receiveMessage(e)}
,!1),function e(){if(!t.frames.__cmpLocator)if(n.body){var a=n.createElement("iframe");a.style.display="none",
a.name="__cmpLocator",n.body.appendChild(a)}else setTimeout(e,5)}();var o=[],e=function(e,a,n){"ping"===e?n&&n({
gdprAppliesGlobally:!!(t.__cmp&&t.__cmp.config&&t.__cmp.config.storeConsentGlobally),cmpLoaded:!1}):
o.push({command:e,parameter:a,callback:n})};return e.commandQueue=o,e.receiveMessage=function(e){
var a=e&&e.data&&e.data.__cmpCall;a&&o.push({callId:a.callId,command:a.command,parameter:a.parameter,
event:e})},e.config=t.cmpConfig||{},e}()}}(window,document);
</script>
<script src="//cmp.network-n.com/js/cmp.complete.bundle.js" async></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@GodisaGeek">
<meta name="twitter:site" content="@GodisaGeek">
<meta name="twitter:title" content="5 brilliant games on Game Pass you must play right now | May 2020 edition">
<meta name="twitter:description" content="I made no secret of it when Game Pass was first announced and launched I was a little lukewarm on it. I looked at the list of games and thought to myself that I owned, or had already played most of th">
<meta name="twitter:image" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name='OBKey' content='58bwlG/ydjwzfnl1e4+OTg==' />

<!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="This is just a small list of five brilliant game pass games that are part of your subscription in May 2020 that are all amazing must play titles."/>
<link rel="canonical" href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 brilliant games on Game Pass you must play right now | May 2020 edition" />
<meta property="og:description" content="This is just a small list of five brilliant game pass games that are part of your subscription in May 2020 that are all amazing must play titles." />
<meta property="og:url" content="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/" />
<meta property="og:site_name" content="GodisaGeek.com" />
<meta property="article:tag" content="feat" />
<meta property="article:tag" content="rdr2" />
<meta property="article:tag" content="red dead redemption 2" />
<meta property="article:tag" content="Rockstar" />
<meta property="article:tag" content="SoR4" />
<meta property="article:tag" content="streets of rage 4" />
<meta property="article:tag" content="SUPERHOT" />
<meta property="article:tag" content="The Witcher 3: Wild Hunt" />
<meta property="article:tag" content="yakuza 0" />
<meta property="article:section" content="Features" />
<meta property="article:published_time" content="2020-05-28T18:03:39+00:00" />
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" />
<meta property="og:image:secure_url" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","potentialAction":{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/#primaryimage","url":"https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg","width":1920,"height":1080,"caption":"Red Dead Redemption 2 review"},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/#webpage","url":"https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/","inLanguage":"en-US","name":"5 brilliant games on Game Pass you must play right now | May 2020 edition - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/#primaryimage"},"datePublished":"2020-05-28T18:03:39+00:00","dateModified":"2020-05-28T18:03:39+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/4bb8e726030f19a005a316490fa50902"},"description":"This is just a small list of five brilliant game pass games that are part of your subscription in May 2020 that are all amazing must play titles."},{"@type":["Person"],"@id":"https://www.godisageek.com/#/schema/person/4bb8e726030f19a005a316490fa50902","name":"Nicola Ardron","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#authorlogo","url":"https://secure.gravatar.com/avatar/d0f23695bb4e740bf7a4775f90a027fc?s=96&d=mm&r=g","caption":"Nicola Ardron"},"description":"Likes to shoot stuff and wear pretty shoes. Is a BEAST at Titanfall.","sameAs":["https://twitter.com/http://twitter.com/wavey_gravey","https://www.youtube.com/user/MsWaveygravey"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; 5 brilliant games on Game Pass you must play right now | May 2020 edition Comments Feed" href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='sh9bk-style-css'  href='http://www.godisageek.com/wp-content/plugins/wp-keys-giveaway/css/style.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.godisageek.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.86.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/10/jwplayer.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.godisageek.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"236912","token":"4dddb7959f","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var myAjax = {"ajaxurl":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.godisageek.com/wp-content/plugins/wp-keys-giveaway/js/getkey.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<!-- OG: 2.7.5 -->
<link rel="image_src" href="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" /><meta itemprop="image" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" /><meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" /><meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review.jpg" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1080" /><meta property="og:image:alt" content="Red Dead Redemption 2 review" /><meta property="og:video" content="https://youtu.be/RtPcM8NGr6A" /><meta property="og:description" content="I made no secret of it when Game Pass was first announced and launched I was a little lukewarm on it. I looked at the list of games and thought to myself that I owned, or had already played most of them, and therefore the service was going to be of little use to me...." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_us" /><meta property="og:site_name" content="GodisaGeek.com" /><meta property="og:title" content="5 brilliant games on Game Pass you must play right now | May 2020 edition" /><meta property="og:url" content="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/" /><meta property="og:updated_time" content="2020-05-28T19:03:39+00:00" /><meta property="article:tag" content="feat" /><meta property="article:tag" content="rdr2" /><meta property="article:tag" content="red dead redemption 2" /><meta property="article:tag" content="Rockstar" /><meta property="article:tag" content="SoR4" /><meta property="article:tag" content="streets of rage 4" /><meta property="article:tag" content="SUPERHOT" /><meta property="article:tag" content="The Witcher 3: Wild Hunt" /><meta property="article:tag" content="yakuza 0" /><meta property="article:published_time" content="2020-05-28T19:03:39+00:00" /><meta property="article:modified_time" content="2020-05-28T19:03:39+00:00" /><meta property="article:author" content="https://www.godisageek.com/author/nicola-ardron/" /><meta property="article:section" content="Features" /><meta property="article:section" content="Opinion" /><meta property="twitter:player" content="https://youtu.be/RtPcM8NGr6A" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:title" content="5 brilliant games on Game Pass you must play right now | May 2020 edition" /><meta property="twitter:description" content="I made no secret of it when Game Pass was first announced and launched I was a little lukewarm on it. I looked at the list of games and thought to myself that I owned, or had already played most of them, and therefore the service was going to be of little use to me...." /><meta property="twitter:image:width" content="1920" /><meta property="twitter:image:height" content="1080" /><meta property="twitter:image:alt" content="Red Dead Redemption 2 review" /><meta property="twitter:url" content="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/" /><meta property="profile:first_name" content="Nicola" /><meta property="profile:last_name" content="Ardron" /><meta property="profile:username" content="Nicola Ardron" /><!-- /OG -->
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://www.godisageek.com/?p=236912' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F05%2F5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F05%2F5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>
            <script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

            <script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.godisageek.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '236912';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = true;
	window._wp_rp_post_title = '5+brilliant+games+on+Game+Pass+you+must+play+right+now+%7C+May+2020+edition';
	window._wp_rp_post_tags = ['superhot', 'feat', 'the+witcher+3%3A+wild+hunt', 'rdr2', 'yakuza+0', 'red+dead+redemption+2', 'rockstar', 'sor4', 'streets+of+rage+4', 'features', 'opinion', 'secret', 'game', 'dai', '2020', 'parti', 'singl', 'librari', 'a', 'download', 'list', 'alt', '5', 'servic', 'xbox', 'plai'];
	window._wp_rp_promoted_content = true;
</script>
<link rel="stylesheet" href="https://www.godisageek.com/wp-content/plugins/wordpress-23-related-posts-plugin/static/themes/vertical-m.css?version=3.6.4" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-236912 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/">The 2020 Pokémon GO Fest will be a total digital experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The 2020 Pokémon GO Fest will be a total digital experience" srcset="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/new-pokemon-masters-content-now-live/">New Pokémon Masters Content Now Live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="New Pokémon Masters Content Now Live" srcset="https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-700x675.png 700w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/catherine-full-body-is-available-to-pre-order-on-the-eshop/">Catherine: Full Body is available to pre-order on the eShop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Catherine - Full Body" title="Catherine: Full Body is available to pre-order on the eShop" srcset="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/my-arcade-celebrates-40-years-of-pac-man-with-micro-player/">My Arcade celebrates 40 years of PAC-MAN with Micro Player<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-49-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="My Arcade celebrates 40 years of PAC-MAN with Micro Player" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-49-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/take-a-look-behind-the-scenes-of-dirt-5-in-new-video/">Take a Look Behind the Scenes of DIRT 5 in New Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dirt-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Take a Look Behind the Scenes of DIRT 5 in New Video" srcset="https://www.godisageek.com/wp-content/uploads/Dirt-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dirt-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dirt-5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dirt-5-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dirt-5-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/dead-by-daylight-chapter-is-silent-hill/">Next month&#8217;s Dead by Daylight chapter is Silent Hill<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Next month&#8217;s Dead by Daylight chapter is Silent Hill" srcset="https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/">Red Wings: Aces of the Sky review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="red wings aces of the sky" title="Red Wings: Aces of the Sky review" srcset="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/star-horizon-review/">Star Horizon review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Horizon review" title="Star Horizon review" srcset="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/those-who-remain-review/">Those Who Remain review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Those Who Remain review" title="Those Who Remain review" srcset="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/resolutiion-review/">Resolutiion review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Resolutiion" title="Resolutiion review" srcset="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/">Nimbatus &#8211; The Space Drone Constructor review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nimbatus The Space Drone Constructor" title="Nimbatus &#8211; The Space Drone Constructor review" srcset="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/atomicrops-review/">Atomicrops review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Atomicrops review" title="Atomicrops review" srcset="https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/">A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia" srcset="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-700x675.jpeg 700w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/">5 brilliant games on Game Pass you must play right now | May 2020 edition<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Dead Redemption 2 review" title="5 brilliant games on Game Pass you must play right now | May 2020 edition" srcset="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/interview-with-paul-chaloner-esports-commentator-this-is-esports/">“I thought I was the king of the arcades on Brighton pier”: Interview with Paul Chaloner, esports commentator and author of This is esports (and How to Spell it)<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/This-is-esports-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Paul on stage at the Intel Extreme Masters 2015 at the Spodek Arena in Katowice, Poland. Photo: Adela Sznajder, ESL" title="“I thought I was the king of the arcades on Brighton pier”: Interview with Paul Chaloner, esports commentator and author of This is esports (and How to Spell it)" srcset="https://www.godisageek.com/wp-content/uploads/This-is-esports-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/podcast-397-star-wars-uncharted-4-tacoma/">Podcast #397: Hole to Hole &#8211; Star Wars, Uncharted 4, Tacoma<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dance-Monkey-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #397: Hole to Hole - Star Wars, Uncharted 4, Tacoma" title="Podcast #397: Hole to Hole &#8211; Star Wars, Uncharted 4, Tacoma" srcset="https://www.godisageek.com/wp-content/uploads/Dance-Monkey-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/podcast-396-red-dead-online-f1-2020-xbox-series-x/">Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #396: Where&#039;s the Internet? - Gears 5, F1 2020, Xenoblade Chronicles" title="Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles" srcset="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/tips-for-beginners-to-get-started-in-minecraft-dungeons/">Tips for beginners to get started in Minecraft Dungeons<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Minecraft Dungeons tips" title="Tips for beginners to get started in Minecraft Dungeons" srcset="https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/tips-to-help-you-in-wavey-the-rocket/">6 tips to help you in Wavey The Rocket<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wavey The Rocket tips" title="6 tips to help you in Wavey The Rocket" srcset="https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/04/7-mount-blade-ii-bannerlord-tips-to-help-you-get-started/">7 Mount &#038; Blade II: Bannerlord tips to help you get started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Mount &amp; Blade II Bannerlord Tips" title="7 Mount &#038; Blade II: Bannerlord tips to help you get started" srcset="https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/04/bleeding-edge-complete-character-guide/">A complete guide to every character in Bleeding Edge<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bleeding Edge Character Guide" title="A complete guide to every character in Bleeding Edge" srcset="https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/51-worldwide-games-is-a-quaint-mix-of-entertainment-and-education/">51 Worldwide Games is a quaint mix of entertainment and education<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="51 Worldwide Games Preview" title="51 Worldwide Games is a quaint mix of entertainment and education" srcset="https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-preview-new-features-combat-side-quests/">Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?" title="Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?" srcset="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/early-access-preview-drift21-has-the-potential-to-be-excellent/">Early Access Preview | Drift21 has the potential to be excellent<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Drift21-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Early Access Preview | Drift21 has the potential to be excellent" srcset="https://www.godisageek.com/wp-content/uploads/Drift21-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/rogue-heroes-ruins-of-tasos-is-90-zelda-and-10-added-stuff-and-its-great/">Rogue Heroes: Ruins of Tasos is 90% Zelda and 10% added stuff (and it&#8217;s great)<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Heroes: Ruins of Tasos main" title="Rogue Heroes: Ruins of Tasos is 90% Zelda and 10% added stuff (and it&#8217;s great)" srcset="https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/population-zero-takes-survival-on-an-alien-world-seven-days-at-a-time/">Population Zero takes survival on an alien world seven days at a time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PopZero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Population Zero early access preview" title="Population Zero takes survival on an alien world seven days at a time" srcset="https://www.godisageek.com/wp-content/uploads/PopZero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PopZero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PopZero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/PopZero-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/PopZero-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/vigor-is-a-survival-shooter-that-focuses-on-loot-and-evasion/">Vigor is a Survival Shooter that focuses on loot and evasion<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vigor-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vigor Beta impressions" title="Vigor is a Survival Shooter that focuses on loot and evasion" srcset="https://www.godisageek.com/wp-content/uploads/Vigor-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/">The 2020 Pokémon GO Fest will be a total digital experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The 2020 Pokémon GO Fest will be a total digital experience" srcset="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/new-pokemon-masters-content-now-live/">New Pokémon Masters Content Now Live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="New Pokémon Masters Content Now Live" srcset="https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-700x675.png 700w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Dawn-Story-Event-Banner-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/catherine-full-body-is-available-to-pre-order-on-the-eshop/">Catherine: Full Body is available to pre-order on the eShop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Catherine - Full Body" title="Catherine: Full Body is available to pre-order on the eShop" srcset="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/my-arcade-celebrates-40-years-of-pac-man-with-micro-player/">My Arcade celebrates 40 years of PAC-MAN with Micro Player<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-49-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="My Arcade celebrates 40 years of PAC-MAN with Micro Player" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-49-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/maxresdefault-49-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/take-a-look-behind-the-scenes-of-dirt-5-in-new-video/">Take a Look Behind the Scenes of DIRT 5 in New Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dirt-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Take a Look Behind the Scenes of DIRT 5 in New Video" srcset="https://www.godisageek.com/wp-content/uploads/Dirt-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dirt-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dirt-5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dirt-5-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dirt-5-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/dead-by-daylight-chapter-is-silent-hill/">Next month&#8217;s Dead by Daylight chapter is Silent Hill<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Next month&#8217;s Dead by Daylight chapter is Silent Hill" srcset="https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/silent_hill_dead_by_daylight_pyramidhead-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/">Red Wings: Aces of the Sky review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="red wings aces of the sky" title="Red Wings: Aces of the Sky review" srcset="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/star-horizon-review/">Star Horizon review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Horizon review" title="Star Horizon review" srcset="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/those-who-remain-review/">Those Who Remain review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Those Who Remain review" title="Those Who Remain review" srcset="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/resolutiion-review/">Resolutiion review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Resolutiion" title="Resolutiion review" srcset="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/">Nimbatus &#8211; The Space Drone Constructor review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nimbatus The Space Drone Constructor" title="Nimbatus &#8211; The Space Drone Constructor review" srcset="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/atomicrops-review/">Atomicrops review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Atomicrops review" title="Atomicrops review" srcset="https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/">A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia" srcset="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-700x675.jpeg 700w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/">5 brilliant games on Game Pass you must play right now | May 2020 edition<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Dead Redemption 2 review" title="5 brilliant games on Game Pass you must play right now | May 2020 edition" srcset="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/interview-with-paul-chaloner-esports-commentator-this-is-esports/">“I thought I was the king of the arcades on Brighton pier”: Interview with Paul Chaloner, esports commentator and author of This is esports (and How to Spell it)<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/This-is-esports-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Paul on stage at the Intel Extreme Masters 2015 at the Spodek Arena in Katowice, Poland. Photo: Adela Sznajder, ESL" title="“I thought I was the king of the arcades on Brighton pier”: Interview with Paul Chaloner, esports commentator and author of This is esports (and How to Spell it)" srcset="https://www.godisageek.com/wp-content/uploads/This-is-esports-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/This-is-esports-2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/podcast-397-star-wars-uncharted-4-tacoma/">Podcast #397: Hole to Hole &#8211; Star Wars, Uncharted 4, Tacoma<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dance-Monkey-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #397: Hole to Hole - Star Wars, Uncharted 4, Tacoma" title="Podcast #397: Hole to Hole &#8211; Star Wars, Uncharted 4, Tacoma" srcset="https://www.godisageek.com/wp-content/uploads/Dance-Monkey-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dance-Monkey-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/podcast-396-red-dead-online-f1-2020-xbox-series-x/">Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #396: Where&#039;s the Internet? - Gears 5, F1 2020, Xenoblade Chronicles" title="Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles" srcset="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/tips-for-beginners-to-get-started-in-minecraft-dungeons/">Tips for beginners to get started in Minecraft Dungeons<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Minecraft Dungeons tips" title="Tips for beginners to get started in Minecraft Dungeons" srcset="https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-tips-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/tips-to-help-you-in-wavey-the-rocket/">6 tips to help you in Wavey The Rocket<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wavey The Rocket tips" title="6 tips to help you in Wavey The Rocket" srcset="https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Wavey-The-Rocket-tips-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/04/7-mount-blade-ii-bannerlord-tips-to-help-you-get-started/">7 Mount &#038; Blade II: Bannerlord tips to help you get started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Mount &amp; Blade II Bannerlord Tips" title="7 Mount &#038; Blade II: Bannerlord tips to help you get started" srcset="https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Mount-Blade-II-Bannerlord-Tips-8-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/04/bleeding-edge-complete-character-guide/">A complete guide to every character in Bleeding Edge<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bleeding Edge Character Guide" title="A complete guide to every character in Bleeding Edge" srcset="https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Bleeding-Edge-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/05/51-worldwide-games-is-a-quaint-mix-of-entertainment-and-education/">51 Worldwide Games is a quaint mix of entertainment and education<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="51 Worldwide Games Preview" title="51 Worldwide Games is a quaint mix of entertainment and education" srcset="https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/51-Worldwide-Games-Preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-preview-new-features-combat-side-quests/">Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?" title="Xenoblade Chronicles: Definitive Edition preview | Everything we wanted?" srcset="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-Definitive-Edition-Preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/early-access-preview-drift21-has-the-potential-to-be-excellent/">Early Access Preview | Drift21 has the potential to be excellent<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Drift21-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Early Access Preview | Drift21 has the potential to be excellent" srcset="https://www.godisageek.com/wp-content/uploads/Drift21-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Drift21-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/rogue-heroes-ruins-of-tasos-is-90-zelda-and-10-added-stuff-and-its-great/">Rogue Heroes: Ruins of Tasos is 90% Zelda and 10% added stuff (and it&#8217;s great)<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Heroes: Ruins of Tasos main" title="Rogue Heroes: Ruins of Tasos is 90% Zelda and 10% added stuff (and it&#8217;s great)" srcset="https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/RogueHeroes-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/population-zero-takes-survival-on-an-alien-world-seven-days-at-a-time/">Population Zero takes survival on an alien world seven days at a time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PopZero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Population Zero early access preview" title="Population Zero takes survival on an alien world seven days at a time" srcset="https://www.godisageek.com/wp-content/uploads/PopZero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PopZero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PopZero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/PopZero-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/PopZero-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/vigor-is-a-survival-shooter-that-focuses-on-loot-and-evasion/">Vigor is a Survival Shooter that focuses on loot and evasion<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vigor-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vigor Beta impressions" title="Vigor is a Survival Shooter that focuses on loot and evasion" srcset="https://www.godisageek.com/wp-content/uploads/Vigor-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Vigor-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">The 2020 Pokémon GO Fest will be a total digital experience</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2017/10/destiny-2s-expansion-revealed-paris-games-week/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">A visual tour of BioShock’s ominous cities: Rapture & Columbia</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-236912" class="post-236912 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-opinion tag-feat tag-rdr2 tag-red-dead-redemption-2 tag-rockstar tag-sor4 tag-streets-of-rage-4 tag-superhot tag-the-witcher-3-wild-hunt tag-yakuza-0" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                5 brilliant games on Game Pass you must play right now | May 2020 edition                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/nicola-ardron/"><span itemprop="author">Nicola Ardron </span></a></span><span class="date">on <meta itemprop="datePublished" content="May 28, 2020">May 28, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Red Dead Redemption 2 review" title="5 brilliant games on Game Pass you must play right now | May 2020 edition" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-267x150.jpg 267w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>I made no secret of it when <a href="https://www.xbox.com/en-GB/xbox-game-pass/">Game Pass</a> was first announced and launched I was a little lukewarm on it. I looked at the list of games and thought to myself that I owned, or had already played most of them, and therefore the service was going to be of little use to me. Over time my position on it has changed, significantly. Now I am of the opinion that if you own an Xbox, then you absolutely must have a Game Pass subscription. The breadth of games available to download and play is too varied and too great to ignore it any more. Not only is every single first party title available to play from day one of release, there&#8217;s also an extensive library of third party content that changes regularly. I really do believe that it is an absolutely essential subscription.</p>
<p>To give a flavour of the quality that is available, I have put together a small list of five brilliant games that I consider to be an absolute steal as part of your subscription.</p>
<h3>5. Superhot</h3>
<p><img class="alignnone size-full wp-image-189145" src="http://www.godisageek.com/wp-content/uploads/Superhot-vr.jpg" alt="" width="1920" height="1080" srcset="https://www.godisageek.com/wp-content/uploads/Superhot-vr.jpg 1920w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-300x168.jpg 300w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-360x202.jpg 360w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Superhot-vr-1130x635.jpg 1130w" sizes="(max-width: 1920px) 100vw, 1920px" /></p>
<p><a href="http://www.godisageek.com/reviews/superhot-review/" target="_blank" rel="noopener">Superhot</a> is an exercise in discipline. Everything about it is so refined that it feels perfect in almost every single way. It is a first-person shooter where the central conceit is that time only occurs when you move. Stay still and everything is frozen in time, including the bullets whirring through the air.</p>
<p>Some of the very best examples of the shooter genre of games make me feel like I am performing a dance. Each shot an accent or flourish to my movement around the screen. 2016 was a perfect year for producing some of the very best examples of what I am talking about: Doom, Titanfall 2 and Superhot. Everything about what makes an FPS feel good to play has been distilled into Superhot, so much so that I can&#8217;t summon enough superlatives for it. Slowly lining up shots, firing at one enemy, throwing your weapon at another to kick their weapon into the air for you to catch, swing round and shoot another enemy emerging is like a slow-motion ballet. To cap it all off, once you have navigated your way through the level you can watch your entire movement at normal speed and it makes you look like you have superhuman levels of accuracy.</p>
<p>The campaign is roughly two to three hours long so it won&#8217;t take you long to play at all, but there&#8217;s plenty of challenges and timed modes to keep you engaged for quite a while.</p>
<h3>4. Yakuza 0</h3>
<p><img class="alignnone size-full wp-image-188083" src="http://www.godisageek.com/wp-content/uploads/yakuza_0_img_08.jpg" alt="" width="740" height="433" srcset="https://www.godisageek.com/wp-content/uploads/yakuza_0_img_08.jpg 740w, https://www.godisageek.com/wp-content/uploads/yakuza_0_img_08-300x175.jpg 300w, https://www.godisageek.com/wp-content/uploads/yakuza_0_img_08-180x105.jpg 180w, https://www.godisageek.com/wp-content/uploads/yakuza_0_img_08-360x210.jpg 360w" sizes="(max-width: 740px) 100vw, 740px" /></p>
<p>I am new to the <a href="http://www.godisageek.com/reviews/yakuza-0-review/" target="_blank" rel="noopener">Yakuza</a> series, and if you are too this prequel to the Yakuza series is a great place to start.</p>
<p>Describing what Yakuza is exactly is a challenge, it&#8217;s part gritty crime drama mixed with kitsch party games and bonkers activities, as well as an excellent beat-em up with a variety of fight styles to master, all in a contained open-world setting. One minute you are fighting for your life sparring with one of the many Yakuza bosses, the next you are helping a school girl get out of a sordid situation where her class mate is forcing her to sell her knickers to strangers.</p>
<p>Set in the 80s you follow Kiryu, a disgraced former Yakuza on his quest to clear his name from a murder that has been pinned on him. You wander the streets of Tokyo and Osaka fighting gangs, eating in restaurants and singing karaoke. As the story progresses you will also follow the path of Majima, himself a former Yakuza too who runs a cabaret bar in Osaka. As you progress the story, the paths of Kiryu and Majima will cross. You&#8217;ll learn different fighting styles for each characters and engage in some genuinely bizarre and funny sub-stories.</p>
<p>It&#8217;s utterly bonkers and brilliant.</p>
<h3>3. Streets of Rage 4</h3>
<div class='video_frame'><iframe id='youtube_video_2' class='youtube_video' src='https://www.youtube.com/embed/RtPcM8NGr6A?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p></br></p>
<p><a href="http://www.godisageek.com/reviews/streets-of-rage-4-review/" target="_blank" rel="noopener">Streets of Rage 4</a> has only just recently been released, and yet it is available on Game Pass. What a game it is, managing to faithfully deliver a nostalgia hit of the classic games from the 90s.</p>
<p>If you played the original games you will recognise each character, despite their lick of HD paint and updated looks. The action is as simple and compelling as it always has been; a side scrolling beat-em up with simple to learn moves and a banging soundtrack.</p>
<p>Each area is beautifully hand-drawn, and there is a suitably cheesy story pulling you through. There&#8217;s a number of characters to unlock, each with their own special moves, as well as a number of difficulty levels and modes to keep you busy for quite some time.</p>
<h3>2. Red Dead Redemption 2</h3>
<p><img class="alignnone size-full wp-image-236915" src="http://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6.png" alt="" width="3840" height="2160" srcset="https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6.png 3840w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-300x169.png 300w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-768x432.png 768w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-1024x576.png 1024w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-180x101.png 180w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-360x203.png 360w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-790x444.png 790w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Redemption-2-6-1130x636.png 1130w" sizes="(max-width: 3840px) 100vw, 3840px" /></p>
<p>Rockstar has only just released <a href="http://www.godisageek.com/reviews/red-dead-redemption-2-review/" target="_blank" rel="noopener">Red Dead Redemption 2</a> on Game Pass, and if this is the only game that you choose to download, your subscription has already earned its price.</p>
<p>The story, follows the plight of Arthur Morgan and his role in Dutch&#8217;s gang of outlaws. It is a prequel to Red Dead Redemption, which released in 2010 so you will see some familiar sights and characters. Some may find the pace too slow, and certainly at the beginning it takes some time to get going, however stick with it because you will be rewarded with a cast of wonderfully created characters, and a well told, emotional story of a man&#8217;s quest for redemption.</p>
<p>By far the biggest star of RDR2 is the world that Rockstar has created. It is huge and so beautifully realised that it is perfectly possible to spend most of your time just riding around and existing within it. I think it is quite possibly the best open-world I have ever experience in a video game. Furthermore, Rockstar added in a new photo mode functionality back in January, so if you have already played the campaign, you have an excuse to dive right back in again to capture that world in all it&#8217;s beauty.</p>
<p>There is also an extensive online world to dive into as well, with regular updates to increase the content and activities you can partake in.</p>
<h3>1. The Witcher 3: Wild Hunt</h3>
<p><img class="alignnone size-full wp-image-157054" src="http://www.godisageek.com/wp-content/uploads/The-Witcher-3-background.jpg" alt="" width="1920" height="1080" srcset="https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background.jpg 1920w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-300x168.jpg 300w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-360x202.jpg 360w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/The-Witcher-3-background-1130x635.jpg 1130w" sizes="(max-width: 1920px) 100vw, 1920px" /></p>
<p>When I think of game&#8217;s of the generation, <a href="http://www.godisageek.com/reviews/the-witcher-3-review/" target="_blank" rel="noopener">The Witcher 3</a> is always in that list, and very close to the top. For me personally, it is the finest high fantasy western-style RPG I have ever played.</p>
<p>Everything about it is perfectly curated, from the world to the stories and quests you will encounter. Not only is the main quest line wonderfully written and compelling, you are also treated to the same high quality in the various side quests you stumble upon. Describing any of them would spoil much of the joy of discovery, but much of them are as interesting as many main quest lines in less accomplished games.</p>
<p>There&#8217;s a beautiful world for you to discover, an interesting combat and spells system to learn, and lots of characters for you to fall in love with, or hate. Geralt is the perfect protagonist on your journey with you, managing to be both gruff and cold and warm and light-hearted.</p>
<p>If you haven&#8217;t played The Witcher 3, what are you waiting for? You really have no excuse not to as part of your subscription. If you already have played it before, then it is probably time for a replay.</p>
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/features/opinion/" title="View all posts in Opinion">Opinion</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/feat/" title="feat Tag" class="feat">feat</a><a href="https://www.godisageek.com/tag/rdr2/" title="rdr2 Tag" class="rdr2">rdr2</a><a href="https://www.godisageek.com/tag/red-dead-redemption-2/" title="red dead redemption 2 Tag" class="red-dead-redemption-2">red dead redemption 2</a><a href="https://www.godisageek.com/tag/rockstar/" title="Rockstar Tag" class="rockstar">Rockstar</a><a href="https://www.godisageek.com/tag/sor4/" title="SoR4 Tag" class="sor4">SoR4</a><a href="https://www.godisageek.com/tag/streets-of-rage-4/" title="streets of rage 4 Tag" class="streets-of-rage-4">streets of rage 4</a><a href="https://www.godisageek.com/tag/superhot/" title="SUPERHOT Tag" class="superhot">SUPERHOT</a><a href="https://www.godisageek.com/tag/the-witcher-3-wild-hunt/" title="The Witcher 3: Wild Hunt Tag" class="the-witcher-3-wild-hunt">The Witcher 3: Wild Hunt</a><a href="https://www.godisageek.com/tag/yakuza-0/" title="yakuza 0 Tag" class="yakuza-0">yakuza 0</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/nicola-ardron/"><img alt='' src='https://secure.gravatar.com/avatar/d0f23695bb4e740bf7a4775f90a027fc?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d0f23695bb4e740bf7a4775f90a027fc?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/nicola-ardron/"><h3>Nicola Ardron</h3></a>Likes to shoot stuff and wear pretty shoes. Is a BEAST at Titanfall.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/http://twitter.com/wavey_gravey" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/https://www.youtube.com/user/MsWaveygravey" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:nicola@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                                                        
                            
<div id="disqus_thread"></div>
                                                        
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank'><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide</a><div class="article-meta clearfix"><a class="like-button do-like 237107 info-bottom" data-postid="237107" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners</a></div><a class="hover-link" href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia" srcset="https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-700x675.jpeg 700w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/bioshock-feature-image-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/">A visual tour of BioShock’s ominous cities: Rapture &#038; Columbia</a></div><a class="hover-link" href="https://www.godisageek.com/2020/05/a-visual-tour-of-bioshocks-ominous-cities-rapture-columbia/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Dead Redemption 2 review" title="5 brilliant games on Game Pass you must play right now | May 2020 edition" srcset="https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-dead-redemption-2-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/">5 brilliant games on Game Pass you must play right now | May 2020 edition</a></div><a class="hover-link" href="https://www.godisageek.com/2020/05/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The 2020 Pokémon GO Fest will be a total digital experience" srcset="https://www.godisageek.com/wp-content/uploads/pokemongofest2020-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/pokemongofest2020-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/">The 2020 Pokémon GO Fest will be a total digital experience</a></div><a class="hover-link" href="https://www.godisageek.com/2020/05/the-2020-pokemon-go-fest-will-be-a-total-digital-experience/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="red wings aces of the sky" title="Red Wings: Aces of the Sky review" srcset="https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/">Red Wings: Aces of the Sky review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 236945 info-bottom" data-postid="236945" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/star-horizon-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Horizon review" title="Star Horizon review" srcset="https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/star-horizon-review/">Star Horizon review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/star-horizon-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/those-who-remain-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Those Who Remain review" title="Those Who Remain review" srcset="https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/those-who-remain-review/">Those Who Remain review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/those-who-remain-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/resolutiion-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Resolutiion" title="Resolutiion review" srcset="https://www.godisageek.com/wp-content/uploads/Resolutiion-main-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Resolutiion-main-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resolutiion-review/">Resolutiion review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/resolutiion-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nimbatus The Space Drone Constructor" title="Nimbatus &#8211; The Space Drone Constructor review" srcset="https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/">Nimbatus &#8211; The Space Drone Constructor review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/podcast-396-red-dead-online-f1-2020-xbox-series-x/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Podcast #396: Where&#039;s the Internet? - Gears 5, F1 2020, Xenoblade Chronicles" title="Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles" srcset="https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gears-5-podcast-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/podcast-396-red-dead-online-f1-2020-xbox-series-x/">Podcast #396: Where&#8217;s the Internet? &#8211; Gears 5, F1 2020, Xenoblade Chronicles</a><div class="article-meta clearfix"><a class="like-button do-like 236404 info-bottom" data-postid="236404" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/05/podcast-396-red-dead-online-f1-2020-xbox-series-x/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/streets-of-rage-4-nintendo-switch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Streets of Rage 4 Switch review | Switch Re:port" title="Streets of Rage 4 Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Streets-of-Rage-4-Axel-1-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/streets-of-rage-4-nintendo-switch-review/">Streets of Rage 4 Switch review | Switch Re:port</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 235938 info-bottom" data-postid="235938" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/streets-of-rage-4-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/streets-of-rage-4-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Streets of Rage 4 review" srcset="https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/streets-of-rage-4-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/streets-of-rage-4-review/">Streets of Rage 4 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/streets-of-rage-4-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/what-the-golf-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="What the Golf? review" srcset="https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/what-the-golf-switch-review-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/what-the-golf-switch-review/">What the Golf? review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/what-the-golf-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/xenoblade-chronicles-definitive-edition-review-nintendo-switch/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Xenoblade Chronicles: Definitive Edition review" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/xenoblade-chronicles-definitive-edition-review-nintendo-switch/">Xenoblade Chronicles: Definitive Edition review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/xenoblade-chronicles-definitive-edition-review-nintendo-switch/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/indivisible-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/indivisible-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Indivisible Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/indivisible-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/indivisible-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/indivisible-switch-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/indivisible-switch-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/indivisible-switch-report/">Indivisible Switch review | Switch Re:port</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/indivisible-switch-report/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/red-wings-aces-of-the-sky-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/red-wings-aces-of-the-sky-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.0</div></div></div><div class="article-info">Red Wings: Aces of the Sky review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Star-Horizon-review-3-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/star-horizon-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">4.0</div></div></div><div class="article-info">Star Horizon review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Those-Who-Remain-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/those-who-remain-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.0</div></div></div><div class="article-info">Those Who Remain review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Resolutiion-main-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/resolutiion-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Resolutiion review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nimbatus_Keyvisual-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/nimbatus-the-space-drone-constructor-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Nimbatus &#8211; The Space Drone Constructor review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Atomicrops-review-1-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/atomicrops-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.5</div></div></div><div class="article-info">Atomicrops review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/xenoblade-chronicles-definitive-edition-review-nintendo-switch/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Xenoblade Chronicles: Definitive Edition review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GOLFWYF-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/golf-with-your-friends-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Golf With Your Friends review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/super-mega-baseball-3-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/super-mega-baseball-3-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Super Mega Baseball 3 review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Minecraft-Dungeons-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/minecraft-dungeons-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.5</div></div></div><div class="article-info">Minecraft Dungeons review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="//www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//plus.google.com/communities/101571468730792116217" class="icon-googleplus info" title="Googleplus" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"godisageek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"236912 http:\/\/www.godisageek.com\/?p=236912","disqusShortname":"godisageek","disqusTitle":"5 brilliant games on Game Pass you must play right now | May 2020 edition","disqusUrl":"https:\/\/www.godisageek.com\/2020\/05\/5-brilliant-games-on-game-pass-you-must-play-right-now-may-2020\/","postId":"236912"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.godisageek.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"stars","image_ext":"gif","max":"5","show_loading":"1","show_fading":"1","custom":"0"};
var ratings_mouseover_image=new Image();ratings_mouseover_image.src="https://www.godisageek.com/wp-content/plugins/wp-postratings/images/stars/rating_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.86.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
