<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Wonder Boy: Asha in Monster World is coming May 28th | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-85x85.png" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Today ININ Games and STUDIOARTDINK revealed that Wonder Boy: Asha in Monster World is coming May 28th." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Wonder Boy: Asha in Monster World is coming May 28th | GodisaGeek.com" />
	<meta property="og:description" content="Today ININ Games and STUDIOARTDINK revealed that Wonder Boy: Asha in Monster World is coming May 28th." />
	<meta property="og:url" content="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2021-05-05T21:43:49+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04.png" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04.png","width":1920,"height":1080,"caption":"Wonder Boy: Asha in Monster World is coming May 28th"},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/#webpage","url":"https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/","name":"Wonder Boy: Asha in Monster World is coming May 28th | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/#primaryimage"},"datePublished":"2021-05-05T21:43:49+00:00","dateModified":"2021-05-05T21:43:49+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/490a0b0497964a0236cb46289f2ba8ea"},"description":"Today ININ Games and STUDIOARTDINK revealed that Wonder Boy: Asha in Monster World is coming May 28th.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/490a0b0497964a0236cb46289f2ba8ea","name":"Lyle Carr","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=96&d=mm&r=g","caption":"Lyle Carr"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"05","day":"05","hour":"22","minute":"43","second":"49","post_id":"249774","postname":"wonder-boy-asha-in-monster-world-is-coming-may-28th","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/' />
<meta name='shareaholic:keywords' content='tag:monster world, tag:monster world iv, tag:wonder boy, tag:wonder boy in monster world, tag:wonder boy: asha in monster world, tag:wonder boy: the dragon&amp;#039;s drap, tag:asha in monster world is coming may 28th, cat:news, type:post' />
<meta name='shareaholic:article_published_time' content='2021-05-05T22:43:49+01:00' />
<meta name='shareaholic:article_modified_time' content='2021-05-05T22:43:49+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Lyle Carr' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-640x360.png' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-1024x576.png' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=249774' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F05%2Fwonder-boy-asha-in-monster-world-is-coming-may-28th%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F05%2Fwonder-boy-asha-in-monster-world-is-coming-may-28th%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-249774 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/">Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content." title="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content" srcset="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-250x250.jpeg 250w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-1024x1024.jpeg 1024w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-768x768.jpeg 768w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-180x180.jpeg 180w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-360x360.jpeg 360w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-790x790.jpeg 790w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-640x640.jpeg 640w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511.jpeg 1080w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/">Wonder Boy: Asha in Monster World is coming May 28th<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Wonder Boy: Asha in Monster World is coming May 28th" title="Wonder Boy: Asha in Monster World is coming May 28th" srcset="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/">New Back 4 Blood trailer shows off new card system<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Back 4 Blood trailer" title="New Back 4 Blood trailer shows off new card system" srcset="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/two-retro-fps-games-launch-exclusively-on-gog-today/">Two retro FPS games launch exclusively on GOG today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="retro games gog" title="Two retro FPS games launch exclusively on GOG today" srcset="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/v-rising-announced-for-pc/">V Rising announced for PC, Beta coming soon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/V-Rising-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="V Rising" title="V Rising announced for PC, Beta coming soon" srcset="https://www.godisageek.com/wp-content/uploads/V-Rising-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/V-Rising-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/V-Rising-700x675.png 700w, https://www.godisageek.com/wp-content/uploads/V-Rising-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/vermintide-2-chaos-wastes-coming-to-consoles-in-june/">Vermintide 2 Chaos Wastes coming to consoles in June<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Vermintide 2 Chaos Wastes" title="Vermintide 2 Chaos Wastes coming to consoles in June" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Village" title="Resident Evil Village review" srcset="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">New Pokemon Snap review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokemon Snap title image" title="New Pokemon Snap review" srcset="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-10-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-10-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">Saviours of Sapphire Wings review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Saviours of Sapphire Wings title image" title="Saviours of Sapphire Wings review" srcset="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-8-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-8-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">Atelier Mysterious Trilogy Deluxe Pack review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atelier Mysterious title image" title="Atelier Mysterious Trilogy Deluxe Pack review" srcset="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/returnal-review/">Returnal review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal review" title="Returnal review" srcset="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/disco-elysium-the-final-cut-review/">Disco Elysium: The Final Cut review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium The Final Cut review" title="Disco Elysium: The Final Cut review" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">Sniper Ghost Warrior Contracts 2 | Video preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper Ghost Warrior Contracts 2 Sniping Position" title="Sniper Ghost Warrior Contracts 2 | Video preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-blends-intensity-and-patience-superbly-hands-on-preview/">Sniper Ghost Warrior Contracts 2 blends intensity and patience superbly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper ghost Warrior Contracts 2 Preview" title="Sniper Ghost Warrior Contracts 2 blends intensity and patience superbly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/podcast-442-returnal-nier-replicant-resident-evil-7/">Podcast 442: Returnal, Nier Replicant, Resident Evil 7<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 442: Returnal, Nier Replicant, Resident Evil 7" title="Podcast 442: Returnal, Nier Replicant, Resident Evil 7" srcset="https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-use-grapple-points/">Returnal: How to use grapple points<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal grappel guide" title="Returnal: How to use grapple points" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/monster-hunter-rise-is-it-friendly-for-the-newcomers/">Monster Hunter Rise: Is it friendly for the newcomers?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Is it friendly for the newcomers?" title="Monster Hunter Rise: Is it friendly for the newcomers?" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-the-house-key/">Returnal: How to get the house key<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal House Key Guide" title="Returnal: How to get the house key" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">Sniper Ghost Warrior Contracts 2 | Video preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper Ghost Warrior Contracts 2 Sniping Position" title="Sniper Ghost Warrior Contracts 2 | Video preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-gameplay-video/">Gameplay Video: Returnal looks great, and might be our new obsesssion<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal packs Housemarque&#039;s trademark shooting into a rogue-like" title="Gameplay Video: Returnal looks great, and might be our new obsesssion" srcset="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/you-need-to-play-lost-words-beyond-the-page-and-heres-why/">You need to play Lost Words: Beyond the Page, and here&#8217;s why<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Let&#039;s Play Lost Words: Beyond the Page" title="You need to play Lost Words: Beyond the Page, and here&#8217;s why" srcset="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/watch-gameplay-of-the-first-oddworld-soulstorm-level/">Watch gameplay of the first Oddworld: Soulstorm level<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="oddworld soulstorm gameplay" title="Watch gameplay of the first Oddworld: Soulstorm level" srcset="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/balan-wonderworld-lets-play/">Balan Wonderworld | Let&#8217;s Play<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld Let&#039;s Play" title="Balan Wonderworld | Let&#8217;s Play" srcset="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-character-buddy-creation-detail/">Monster Hunter Rise: Character &#038; Buddy Creation in detail<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Character &amp; Buddy Creation" title="Monster Hunter Rise: Character &#038; Buddy Creation in detail" srcset="https://www.godisageek.com/wp-content/uploads/MHR-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/04/returnal-how-to-use-grapple-points/">Returnal: How to use grapple points<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal grappel guide" title="Returnal: How to use grapple points" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-the-house-key/">Returnal: How to get the house key<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal House Key Guide" title="Returnal: How to get the house key" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-an-extra-life/">Returnal: How to get an Extra Life<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal Extra Life Guide" title="Returnal: How to get an Extra Life" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-past-the-red-barriers/">Returnal: How to get past the Red Barriers<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-Sword-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Retunal Guide Red Barriers" title="Returnal: How to get past the Red Barriers" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-Sword-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-a-guide-on-how-to-farm-ether/">Returnal: A guide on how to farm Ether<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal - Ether farm" title="Returnal: A guide on how to farm Ether" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/nier-replicant-how-to-complete-the-lost-eggs-quest/">NieR Replicant | How to complete the &#8220;Lost Eggs&#8221; Quest<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nier Replicant Lost Eggs" title="NieR Replicant | How to complete the &#8220;Lost Eggs&#8221; Quest" srcset="https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-245728" class="menu-item menu-item-245728 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/monster-hunter-rise-complete-guide/">Monster Hunter Rise Guide</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/">Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content." title="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content" srcset="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-250x250.jpeg 250w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-1024x1024.jpeg 1024w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-768x768.jpeg 768w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-180x180.jpeg 180w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-360x360.jpeg 360w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-790x790.jpeg 790w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-640x640.jpeg 640w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511.jpeg 1080w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/">Wonder Boy: Asha in Monster World is coming May 28th<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Wonder Boy: Asha in Monster World is coming May 28th" title="Wonder Boy: Asha in Monster World is coming May 28th" srcset="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/">New Back 4 Blood trailer shows off new card system<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Back 4 Blood trailer" title="New Back 4 Blood trailer shows off new card system" srcset="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/two-retro-fps-games-launch-exclusively-on-gog-today/">Two retro FPS games launch exclusively on GOG today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="retro games gog" title="Two retro FPS games launch exclusively on GOG today" srcset="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/v-rising-announced-for-pc/">V Rising announced for PC, Beta coming soon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/V-Rising-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="V Rising" title="V Rising announced for PC, Beta coming soon" srcset="https://www.godisageek.com/wp-content/uploads/V-Rising-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/V-Rising-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/V-Rising-700x675.png 700w, https://www.godisageek.com/wp-content/uploads/V-Rising-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/vermintide-2-chaos-wastes-coming-to-consoles-in-june/">Vermintide 2 Chaos Wastes coming to consoles in June<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Vermintide 2 Chaos Wastes" title="Vermintide 2 Chaos Wastes coming to consoles in June" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-Vermintide-2-Chaos-Wastesa-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Village" title="Resident Evil Village review" srcset="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">New Pokemon Snap review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokemon Snap title image" title="New Pokemon Snap review" srcset="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-10-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-10-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">Saviours of Sapphire Wings review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Saviours of Sapphire Wings title image" title="Saviours of Sapphire Wings review" srcset="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-8-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-8-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">Atelier Mysterious Trilogy Deluxe Pack review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atelier Mysterious title image" title="Atelier Mysterious Trilogy Deluxe Pack review" srcset="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/returnal-review/">Returnal review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal review" title="Returnal review" srcset="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/disco-elysium-the-final-cut-review/">Disco Elysium: The Final Cut review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium The Final Cut review" title="Disco Elysium: The Final Cut review" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">Sniper Ghost Warrior Contracts 2 | Video preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper Ghost Warrior Contracts 2 Sniping Position" title="Sniper Ghost Warrior Contracts 2 | Video preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-blends-intensity-and-patience-superbly-hands-on-preview/">Sniper Ghost Warrior Contracts 2 blends intensity and patience superbly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper ghost Warrior Contracts 2 Preview" title="Sniper Ghost Warrior Contracts 2 blends intensity and patience superbly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/podcast-442-returnal-nier-replicant-resident-evil-7/">Podcast 442: Returnal, Nier Replicant, Resident Evil 7<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 442: Returnal, Nier Replicant, Resident Evil 7" title="Podcast 442: Returnal, Nier Replicant, Resident Evil 7" srcset="https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-442-returnal-nier-replicant-resident-evil-7-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-use-grapple-points/">Returnal: How to use grapple points<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal grappel guide" title="Returnal: How to use grapple points" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/monster-hunter-rise-is-it-friendly-for-the-newcomers/">Monster Hunter Rise: Is it friendly for the newcomers?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Is it friendly for the newcomers?" title="Monster Hunter Rise: Is it friendly for the newcomers?" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-newcomers-perspective-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-the-house-key/">Returnal: How to get the house key<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal House Key Guide" title="Returnal: How to get the house key" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">Sniper Ghost Warrior Contracts 2 | Video preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sniper Ghost Warrior Contracts 2 Sniping Position" title="Sniper Ghost Warrior Contracts 2 | Video preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-gameplay-video/">Gameplay Video: Returnal looks great, and might be our new obsesssion<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal packs Housemarque&#039;s trademark shooting into a rogue-like" title="Gameplay Video: Returnal looks great, and might be our new obsesssion" srcset="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/you-need-to-play-lost-words-beyond-the-page-and-heres-why/">You need to play Lost Words: Beyond the Page, and here&#8217;s why<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Let&#039;s Play Lost Words: Beyond the Page" title="You need to play Lost Words: Beyond the Page, and here&#8217;s why" srcset="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/watch-gameplay-of-the-first-oddworld-soulstorm-level/">Watch gameplay of the first Oddworld: Soulstorm level<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="oddworld soulstorm gameplay" title="Watch gameplay of the first Oddworld: Soulstorm level" srcset="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/balan-wonderworld-lets-play/">Balan Wonderworld | Let&#8217;s Play<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld Let&#039;s Play" title="Balan Wonderworld | Let&#8217;s Play" srcset="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-character-buddy-creation-detail/">Monster Hunter Rise: Character &#038; Buddy Creation in detail<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Character &amp; Buddy Creation" title="Monster Hunter Rise: Character &#038; Buddy Creation in detail" srcset="https://www.godisageek.com/wp-content/uploads/MHR-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/04/returnal-how-to-use-grapple-points/">Returnal: How to use grapple points<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal grappel guide" title="Returnal: How to use grapple points" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-the-house-key/">Returnal: How to get the house key<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal House Key Guide" title="Returnal: How to get the house key" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-house-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-house-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-an-extra-life/">Returnal: How to get an Extra Life<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal Extra Life Guide" title="Returnal: How to get an Extra Life" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-how-to-get-past-the-red-barriers/">Returnal: How to get past the Red Barriers<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-Sword-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Retunal Guide Red Barriers" title="Returnal: How to get past the Red Barriers" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-Sword-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-Sword-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/returnal-a-guide-on-how-to-farm-ether/">Returnal: A guide on how to farm Ether<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal - Ether farm" title="Returnal: A guide on how to farm Ether" srcset="https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/04/nier-replicant-how-to-complete-the-lost-eggs-quest/">NieR Replicant | How to complete the &#8220;Lost Eggs&#8221; Quest<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nier Replicant Lost Eggs" title="NieR Replicant | How to complete the &#8220;Lost Eggs&#8221; Quest" srcset="https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-245728" class="menu-item menu-item-245728 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/monster-hunter-rise-complete-guide/">Monster Hunter Rise Guide</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">New Back 4 Blood trailer shows off new card system</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2017/05/digimon-story-cyber-sleuth-hackers-memory-screenshots/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-249774" class="post-249774 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-monster-world tag-monster-world-iv tag-wonder-boy tag-wonder-boy-in-monster-world tag-wonder-boy-asha-in-monster-world tag-wonder-boy-the-dragons-drap" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Wonder Boy: Asha in Monster World is coming May 28th                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/lyle-carr/"><span itemprop="author">Lyle Carr </span></a></span><span class="date">on <meta itemprop="datePublished" content="May 5, 2021">May 5, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-1024x576.png"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-790x444.png" class="attachment-single-790 size-single-790 wp-post-image" alt="Wonder Boy: Asha in Monster World is coming May 28th" title="Wonder Boy: Asha in Monster World is coming May 28th" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-790x444.png 790w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-300x169.png 300w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-1024x576.png 1024w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-768x432.png 768w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-1536x864.png 1536w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-180x101.png 180w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-360x203.png 360w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-1130x636.png 1130w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-640x360.png 640w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04.png 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Wonder Boy: Asha in Monster World is coming May 28th' data-link='https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/' data-summary='Back to Monster World' data-app-id-name='post_above_content'></div>
<p style="text-align: left;">Today ININ Games and STUDIOARTDINK revealed that Wonder Boy: Asha in Monster World is coming May 28th. This remake of Monster World IV will be available physically and digitally on both Switch and PS4.</p>
<p>&#8220;ININ Games and STUDIOARTDINK are delighted to announce the official release for Wonder Boy: Asha in Monster World for the Western retail release for both physical and digital Nintendo Switch and PS4 versions will be on May 28th 2021 for North America, Europe and Australia.</p>
<p>The retail editions for Nintendo Switch and PlayStation 4 will be available for €39.99 / $39.99 / £34.99 and include the original Monster World IV exclusively.</p>
<p>Asha, with her companion, Pepelogoo, must free the four spirits confined by evil forces whose origin she discovers throughout her journey. While the story remains true to the original 1994 game it is a full remake of <a href="https://en.m.wikipedia.org/wiki/Monster_World_IV">Monster World IV</a>, with cell-shaded 3D graphics and 2D gameplay that stays close to the beloved original, including enhanced visuals and refined play content.&#8221;</p>
<p>The <a href="https://www.godisageek.com/reviews/wonder-boy-the-dragons-trap-review/">previous Wonder Boy</a> remakes have been absolutely fantastic, and I&#8217;m so ready to jump back into this often overlooked series for another 2d adventure.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Wonder Boy: Asha in Monster World is coming May 28th' data-link='https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/' data-summary='Back to Monster World' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Wonder Boy: Asha in Monster World is coming May 28th' data-link='https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/' data-summary='Back to Monster World' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/monster-world/" title="Monster World Tag" class="monster-world">Monster World</a><a href="https://www.godisageek.com/tag/monster-world-iv/" title="Monster World IV Tag" class="monster-world-iv">Monster World IV</a><a href="https://www.godisageek.com/tag/wonder-boy/" title="wonder boy Tag" class="wonder-boy">wonder boy</a><a href="https://www.godisageek.com/tag/wonder-boy-in-monster-world/" title="Wonder Boy in Monster World Tag" class="wonder-boy-in-monster-world">Wonder Boy in Monster World</a><a href="https://www.godisageek.com/tag/wonder-boy-asha-in-monster-world/" title="Wonder Boy: Asha in Monster World Tag" class="wonder-boy-asha-in-monster-world">Wonder Boy: Asha in Monster World</a><a href="https://www.godisageek.com/tag/wonder-boy-the-dragons-drap/" title="wonder boy: the dragon's drap Tag" class="wonder-boy-the-dragons-drap">wonder boy: the dragon's drap</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/lyle-carr/"><img alt='' src='https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/lyle-carr/"><h3>Lyle Carr</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:fishchipswhips@gmail.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="24002" data-method="tags" class="info active" title="More articles tagged: Monster World IV">Monster World IV<span class="bottom-arrow"></span></a><a data-sorter="18464" data-method="tags" class="info" title="More articles tagged: wonder boy">wonder boy<span class="bottom-arrow"></span></a><a data-sorter="23993" data-method="tags" class="info" title="More articles tagged: Wonder Boy in Monster World">Wonder Boy in Monster World<span class="bottom-arrow"></span></a><a data-sorter="18260" data-method="tags" class="info" title="More articles tagged: wonder boy: the dragon's drap">wonder boy: the dragon's drap<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/06/tetris-darius-join-sega-mega-drive-mini-library-bringing-total-42-games/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tetris and Darius to join SEGA Mega Drive Mini library bringing the total to 42 games" srcset="https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/12_1559642093._Darius_5-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/06/tetris-darius-join-sega-mega-drive-mini-library-bringing-total-42-games/">Tetris and Darius to join SEGA Mega Drive Mini library bringing the total to 42 games</a></div><a class="hover-link" href="https://www.godisageek.com/2019/06/tetris-darius-join-sega-mega-drive-mini-library-bringing-total-42-games/">&nbsp;</a></div><br class="visible-desktop clearer" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-85x85.jpeg" class="attachment-widget-post size-widget-post wp-post-image" alt="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content." title="Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content" srcset="https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-250x250.jpeg 250w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-1024x1024.jpeg 1024w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-768x768.jpeg 768w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-180x180.jpeg 180w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-360x360.jpeg 360w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-790x790.jpeg 790w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511-640x640.jpeg 640w, https://www.godisageek.com/wp-content/uploads/f5e43322-879d-4340-ac0b-c27fb35ba511.jpeg 1080w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/">Ahead of release, Bioware releases Mass Effect Legendary Edition bonus content</a><div class="article-meta clearfix"><a class="like-button do-like 249778 info-bottom" data-postid="249778" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/05/ahead-of-release-bioware-releases-mass-effect-legendary-edition-bonus-content/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Wonder Boy: Asha in Monster World is coming May 28th" title="Wonder Boy: Asha in Monster World is coming May 28th" srcset="https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Wonder_Boy_Screenshot_04-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/">Wonder Boy: Asha in Monster World is coming May 28th</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/wonder-boy-asha-in-monster-world-is-coming-may-28th/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/resident-evil-village-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Village" title="Resident Evil Village review" srcset="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Back 4 Blood trailer" title="New Back 4 Blood trailer shows off new card system" srcset="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-trailer1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/">New Back 4 Blood trailer shows off new card system</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/new-back-4-blood-trailer-shows-off-new-card-system/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/two-retro-fps-games-launch-exclusively-on-gog-today/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="retro games gog" title="Two retro FPS games launch exclusively on GOG today" srcset="https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/retro-90s-shooters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/two-retro-fps-games-launch-exclusively-on-gog-today/">Two retro FPS games launch exclusively on GOG today</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/two-retro-fps-games-launch-exclusively-on-gog-today/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/resident-evil-village-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Resident Evil Village" title="Resident Evil Village review" srcset="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 249425 info-bottom" data-postid="249425" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokemon Snap title image" title="New Pokemon Snap review" srcset="https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-10-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-10-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">New Pokemon Snap review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Saviours of Sapphire Wings title image" title="Saviours of Sapphire Wings review" srcset="https://www.godisageek.com/wp-content/uploads/hero-8-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-8-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-8-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">Saviours of Sapphire Wings review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atelier Mysterious title image" title="Atelier Mysterious Trilogy Deluxe Pack review" srcset="https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atelier-Mysterious-Trilogy_02-02-21-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">Atelier Mysterious Trilogy Deluxe Pack review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/returnal-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal review" title="Returnal review" srcset="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/returnal-review/">Returnal review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/returnal-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Sniper Ghost Warrior Contracts 2 Sniping Position" title="Sniper Ghost Warrior Contracts 2 | Video preview" srcset="https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sniper-Ghost-Warrior-Contracts-2-preview-2-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">Sniper Ghost Warrior Contracts 2 | Video preview</a><div class="article-meta clearfix"><a class="like-button do-like 249704 info-bottom" data-postid="249704" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/05/sniper-ghost-warrior-contracts-2-video-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/04/returnal-gameplay-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal packs Housemarque&#039;s trademark shooting into a rogue-like" title="Gameplay Video: Returnal looks great, and might be our new obsesssion" srcset="https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/returnal-preview-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/04/returnal-gameplay-video/">Gameplay Video: Returnal looks great, and might be our new obsesssion</a></div><a class="hover-link" href="https://www.godisageek.com/2021/04/returnal-gameplay-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/04/you-need-to-play-lost-words-beyond-the-page-and-heres-why/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Let&#039;s Play Lost Words: Beyond the Page" title="You need to play Lost Words: Beyond the Page, and here&#8217;s why" srcset="https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lost-Words-Beyond-the-Page-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/04/you-need-to-play-lost-words-beyond-the-page-and-heres-why/">You need to play Lost Words: Beyond the Page, and here&#8217;s why</a></div><a class="hover-link" href="https://www.godisageek.com/2021/04/you-need-to-play-lost-words-beyond-the-page-and-heres-why/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/04/watch-gameplay-of-the-first-oddworld-soulstorm-level/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="oddworld soulstorm gameplay" title="Watch gameplay of the first Oddworld: Soulstorm level" srcset="https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/oddworld-soulstorm-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/04/watch-gameplay-of-the-first-oddworld-soulstorm-level/">Watch gameplay of the first Oddworld: Soulstorm level</a></div><a class="hover-link" href="https://www.godisageek.com/2021/04/watch-gameplay-of-the-first-oddworld-soulstorm-level/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/03/balan-wonderworld-lets-play/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld Let&#039;s Play" title="Balan Wonderworld | Let&#8217;s Play" srcset="https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Balan-Wonderworld-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/03/balan-wonderworld-lets-play/">Balan Wonderworld | Let&#8217;s Play</a></div><a class="hover-link" href="https://www.godisageek.com/2021/03/balan-wonderworld-lets-play/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/hero-10-85x85.jpeg" class="attachment-widget-post size-widget-post wp-post-image" alt="New Pokemon Snap title image" title="New Pokemon Snap review" srcset="https://www.godisageek.com/wp-content/uploads/hero-10-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/hero-10-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-10-35x35.jpeg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">New Pokemon Snap review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 249568 info-bottom" data-postid="249568" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/disco-elysium-the-final-cut-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium The Final Cut review" title="Disco Elysium: The Final Cut review" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-hero-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/disco-elysium-the-final-cut-review/">Disco Elysium: The Final Cut review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/disco-elysium-the-final-cut-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/returnal-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Returnal review" title="Returnal review" srcset="https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RETURNAL-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/returnal-review/">Returnal review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/returnal-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/before-your-eyes-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Before-your-Eyes-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Before Your Eyes review" title="Before Your Eyes review" srcset="https://www.godisageek.com/wp-content/uploads/Before-your-Eyes-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Before-your-Eyes-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Before-your-Eyes-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Before-your-Eyes-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/before-your-eyes-review/">Before Your Eyes review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/before-your-eyes-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/resident-evil-village-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Village" title="Resident Evil Village review" srcset="https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/resident-evil-village-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Returnal-grapnel-point-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/returnal-how-to-use-grapple-points/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Returnal: How to use grapple points</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Returnal-house-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/returnal-how-to-get-the-house-key/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Returnal: How to get the house key</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Returnal-Extra-Life-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/returnal-how-to-get-an-extra-life/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Returnal: How to get an Extra Life</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Returnal-Sword-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/returnal-how-to-get-past-the-red-barriers/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Returnal: How to get past the Red Barriers</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Returnal-ETHER-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/returnal-a-guide-on-how-to-farm-ether/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Returnal: A guide on how to farm Ether</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nier-Replicant-Lost-Eggs-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/2021/04/nier-replicant-how-to-complete-the-lost-eggs-quest/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">NieR Replicant | How to complete the &#8220;Lost Eggs&#8221; Quest</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-review/">Resident Evil Village review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">New Pokemon Snap review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/new-pokemon-snap-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">Saviours of Sapphire Wings review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/saviours-of-sapphire-wings-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">Atelier Mysterious Trilogy Deluxe Pack review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/atelier-mysterious-trilogy-deluxe-pack-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/returnal-review/">Returnal review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/returnal-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 13.119402985075px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 19.164179104478px;" aria-label="Activision (775 items)">Activision</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-3" style="font-size: 12.671641791045px;" aria-label="Call of Duty (393 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-4" style="font-size: 17.597014925373px;" aria-label="Capcom (666 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-5" style="font-size: 14.462686567164px;" aria-label="DLC (479 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-6" style="font-size: 22.746268656716px;" aria-label="EA (1,125 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-7" style="font-size: 12.89552238806px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-8" style="font-size: 16.029850746269px;" aria-label="Konami (560 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-9" style="font-size: 20.955223880597px;" aria-label="Microsoft (937 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-10" style="font-size: 27px;" aria-label="nintendo (1,731 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-11" style="font-size: 19.164179104478px;" aria-label="nintendo switch (781 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-12" style="font-size: 24.761194029851px;" aria-label="PC (1,371 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-13" style="font-size: 21.850746268657px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-14" style="font-size: 14.686567164179px;" aria-label="PlayStation 4 (491 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-15" style="font-size: 22.522388059701px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-16" style="font-size: 23.641791044776px;" aria-label="PS4 (1,230 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-17" style="font-size: 17.597014925373px;" aria-label="Sega (665 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-18" style="font-size: 21.179104477612px;" aria-label="Sony (946 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-19" style="font-size: 20.507462686567px;" aria-label="square enix (900 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-20" style="font-size: 14.238805970149px;" aria-label="Steam (469 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-21" style="font-size: 17.820895522388px;" aria-label="Trailer (680 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-22" style="font-size: 23.865671641791px;" aria-label="Ubisoft (1,270 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/wii-u/" class="tag-cloud-link tag-link-4747 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (370 items)">Wii U</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.55223880597px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24.089552238806px;" aria-label="Xbox One (1,281 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 13.470588235294px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.955882352941px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.735294117647px;" aria-label="Competition (217 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 14.426470588235px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.161764705882px;" aria-label="Features (2,243 items)">Features</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-6" style="font-size: 12.735294117647px;" aria-label="Interview (216 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-7" style="font-size: 14.279411764706px;" aria-label="iOS (354 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-8" style="font-size: 27px;" aria-label="News (19,273 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-9" style="font-size: 15.970588235294px;" aria-label="Opinion (596 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-10" style="font-size: 14.426470588235px;" aria-label="Paid Placement Advertorials (372 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-11" style="font-size: 19.794117647059px;" aria-label="PC (2,000 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-12" style="font-size: 16.852941176471px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-13" style="font-size: 18.838235294118px;" aria-label="PlayStation 4 (1,475 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 16.485294117647px;" aria-label="Podcasts (712 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.926470588235px;" aria-label="Previews (817 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 14.058823529412px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 22.073529411765px;" aria-label="Reviews (4,093 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.338235294118px;" aria-label="Switch (674 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 13.25px;" aria-label="Tech (256 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.735294117647px;" aria-label="Trailers (1,053 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 13.691176470588px;" aria-label="Uncategorised (295 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 17.588235294118px;" aria-label="Video Features (1,009 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/wiiu/" class="tag-cloud-link tag-link-9285 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (171 items)">Wii U</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 16.485294117647px;" aria-label="Xbox 360 (713 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.102941176471px;" aria-label="Xbox One (1,162 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.372093023256px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.5px;" aria-label="Android (77 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.790697674419px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.837209302326px;" aria-label="Google Stadia (17 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.709302325581px;" aria-label="HTC Vive (25 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.604651162791px;" aria-label="iOS (118 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.406976744186px;" aria-label="Mac (33 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (3 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.709302325581px;" aria-label="Oculus Rift (25 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,527 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 21.186046511628px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.825581395349px;" aria-label="PlayStation 4 (1,421 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 19.093023255814px;" aria-label="PlayStation 5 (65 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.686046511628px;" aria-label="PlayStation VR (55 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 21.302325581395px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.139534883721px;" aria-label="Switch (716 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12.581395348837px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.976744186047px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 20.255813953488px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.244186046512px;" aria-label="Xbox One (1,109 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 17.93023255814px;" aria-label="Xbox Series S (41 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 18.511627906977px;" aria-label="Xbox Series X (51 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
