<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Wildcat Gun Machine | First Look Video | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="We wanted to bring you &quot;first impressions&quot; of some games we may not get to cover fully, so here&#039;s Adam taking a look at Wildcat Gun Machine." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Wildcat Gun Machine | First Look Video | GodisaGeek.com" />
	<meta property="og:description" content="We wanted to bring you &quot;first impressions&quot; of some games we may not get to cover fully, so here&#039;s Adam taking a look at Wildcat Gun Machine." />
	<meta property="og:url" content="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-05-08T11:25:05+00:00" />
	<meta property="article:modified_time" content="2022-05-08T11:26:05+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine.jpg","width":1920,"height":1080,"caption":"Wildcat Gun Machine | First Look Video"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#webpage","url":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/","name":"Wildcat Gun Machine | First Look Video | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#primaryimage"},"datePublished":"2022-05-08T11:25:05+00:00","dateModified":"2022-05-08T11:26:05+00:00","description":"We wanted to bring you \"first impressions\" of some games we may not get to cover fully, so here's Adam taking a look at Wildcat Gun Machine.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"headline":"Wildcat Gun Machine | First Look Video","datePublished":"2022-05-08T11:25:05+00:00","dateModified":"2022-05-08T11:26:05+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/#primaryimage"},"keywords":"Wildcat Gun Machine","articleSection":"Features,Video Features","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief.","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"05","day":"08","hour":"12","minute":"25","second":"05","post_id":"262999","postname":"wildcat-gun-machine-first-look-video","category":"features"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/' />
<meta name='shareaholic:keywords' content='tag:wildcat gun machine, cat:features, cat:video features, type:post' />
<meta name='shareaholic:article_published_time' content='2022-05-08T12:25:05+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-05-08T12:26:05+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Adam Cook' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=262999' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F05%2Fwildcat-gun-machine-first-look-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F05%2Fwildcat-gun-machine-first-look-video%2F&#038;format=xml" />
    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '5519b3fce8'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"},"headline":"Wildcat Gun Machine | First Look Video","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine.jpg","width":1920,"height":1080},"datePublished":"2022-05-08T12:25:05+0000","dateModified":"2022-05-08T12:26:05+0000","author":{"@type":"Person","name":"Adam Cook","url":"https://www.godisageek.com/author/mhddacia993146/john-adams"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}},"description":"We wanted to bring you \"first impressions\" of some games we may not get to cover fully, so here's Adam taking a look at Wildcat Gun Machine."}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"2022 Release Dates","url":"https:\/\/www.godisageek.com\/2022\/01\/2022-game-release-dates-ps5-xbox-nintendo-switch-pc\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/05\/wildcat-gun-machine-first-look-video\/","name":"Wildcat Gun Machine | First Look Video"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-262999 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/the-batman-movie-review/">The Batman movie review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Batman-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Batman review" title="The Batman movie review" srcset="https://www.godisageek.com/wp-content/uploads/Batman-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Batman-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Batman-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Batman-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/loot-river-review/">Loot River review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Loot River Review" title="Loot River review" srcset="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">Imp of the Sun review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Imp of the Sun title image" title="Imp of the Sun review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">King Arthur: Knight&#8217;s Tale review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="King Arthur" title="King Arthur: Knight&#8217;s Tale review" srcset="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/KAKT-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/KAKT-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/KAKT-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">Rogue Legacy 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Review" title="Rogue Legacy 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bugsnax-the-isle-of-bigsnax-review/">Bugsnax: The Isle of Bigsnax review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Isle of Bigsnax title image" title="Bugsnax: The Isle of Bigsnax review" srcset="https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/podcast-486-rogue-legacy-2-chinatown-detective-agency-astroneer/">Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer" title="Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/hard-west-2-closed-beta-shows-fast-paced-tactical-promise/">Hard West 2 closed beta shows fast-paced tactical promise<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hard West 2 preview" title="Hard West 2 closed beta shows fast-paced tactical promise" srcset="https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/apex-legends-saviours-is-looking-very-promising-new-hero-details-storm-points-changes/">Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes" title="Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/nis-virtual-press-tour-spring-showcase-2022/">NIS Virtual Press Tour &#8211; Spring Showcase 2022 report<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Yurukill from the NIS Virtual Press Tour" title="NIS Virtual Press Tour &#8211; Spring Showcase 2022 report" srcset="https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/patreon-exclusive-why-i-love-professional-wrestling/">Protected: Patreon Exclusive: Why I Love Professional Wrestling<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Why I Love Professional Wrestling" title="Protected: Patreon Exclusive: Why I Love Professional Wrestling" srcset="https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/03/tiny-tinas-wonderlands-active-shift-codes-get-free-loot-via-skeleton-keys/">Tiny Tina&#8217;s Wonderlands active shift codes: Get free loot via Skeleton Keys<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tiny Tina&#039;s Wonderlands active shift codes: Get free loot via Skeleton Keys" title="Tiny Tina&#8217;s Wonderlands active shift codes: Get free loot via Skeleton Keys" srcset="https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-toyoi-shrine/">Ghostwire Tokyo Jizo Statue locations | Toyoi Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Toyoi Shrine" title="Ghostwire Tokyo Jizo Statue locations | Toyoi Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hitani-shrine/">Ghostwire Tokyo Jizo Statue locations | Hitani Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Hitani Shrine" title="Ghostwire Tokyo Jizo Statue locations | Hitani Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-onten-shrine/">Ghostwire Tokyo Tanuki locations | Onten Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Tanuki Onten Shrine" title="Ghostwire Tokyo Tanuki locations | Onten Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hatsuike-shrine/">Ghostwire Tokyo Jizo Statue locations | Hatsuike Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Hatsuike Shrine" title="Ghostwire Tokyo Jizo Statue locations | Hatsuike Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-toyoi-shrine/">Ghostwire Tokyo Tanuki locations | Toyoi Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Tanuki Toyoi Shrine" title="Ghostwire Tokyo Tanuki locations | Toyoi Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/">New House of the Dragon trailer shows glimpse of Game of Thrones prequel<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="House of the Dragon trailer" title="New House of the Dragon trailer shows glimpse of Game of Thrones prequel" srcset="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/dying-light-enhanced-edition-now-free-to-owners-of-the-base-game/">Dying Light Enhanced Edition now free to owners of the base game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light Enhanced Edition Free Upgrade News" title="Dying Light Enhanced Edition now free to owners of the base game" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/we-were-here-forever-launch-trailer-released/">We Were Here Forever launch trailer released<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="We Were Here Forever Launch Trailer News" title="We Were Here Forever launch trailer released" srcset="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/formula-1-and-mclaren-content-comes-to-rocket-league/">Formula 1 and McLaren content comes to Rocket League!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket League" title="Formula 1 and McLaren content comes to Rocket League!" srcset="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/new-kenobi-trailer-released-on-star-wars-day/">New Kenobi trailer released on Star Wars Day<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Kenobi Trailer News" title="New Kenobi trailer released on Star Wars Day" srcset="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/halo-infinite-season-2-lone-wolves-has-launched/">Halo Infinite Season 2 Lone Wolves has launched!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite Lone Wolves Season 2" title="Halo Infinite Season 2 Lone Wolves has launched!" srcset="https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-258806" class="menu-item menu-item-258806 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="post" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/2022/01/2022-game-release-dates-ps5-xbox-nintendo-switch-pc/">2022 Release Dates</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/the-batman-movie-review/">The Batman movie review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Batman-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Batman review" title="The Batman movie review" srcset="https://www.godisageek.com/wp-content/uploads/Batman-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Batman-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Batman-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Batman-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/loot-river-review/">Loot River review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Loot River Review" title="Loot River review" srcset="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">Imp of the Sun review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Imp of the Sun title image" title="Imp of the Sun review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">King Arthur: Knight&#8217;s Tale review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="King Arthur" title="King Arthur: Knight&#8217;s Tale review" srcset="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/KAKT-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/KAKT-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/KAKT-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">Rogue Legacy 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Review" title="Rogue Legacy 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bugsnax-the-isle-of-bigsnax-review/">Bugsnax: The Isle of Bigsnax review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Isle of Bigsnax title image" title="Bugsnax: The Isle of Bigsnax review" srcset="https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ezgif-5-d8ef027a2f-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/podcast-486-rogue-legacy-2-chinatown-detective-agency-astroneer/">Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer" title="Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-486-Rogue-Legacy-2-Chinatown-Detective-Agency-Astroneer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/hard-west-2-closed-beta-shows-fast-paced-tactical-promise/">Hard West 2 closed beta shows fast-paced tactical promise<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hard West 2 preview" title="Hard West 2 closed beta shows fast-paced tactical promise" srcset="https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hard-West-2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/apex-legends-saviours-is-looking-very-promising-new-hero-details-storm-points-changes/">Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes" title="Apex Legends: Saviours is looking very promising | New Hero details, Storm Points changes" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Saviours-Newcastle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/nis-virtual-press-tour-spring-showcase-2022/">NIS Virtual Press Tour &#8211; Spring Showcase 2022 report<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Yurukill from the NIS Virtual Press Tour" title="NIS Virtual Press Tour &#8211; Spring Showcase 2022 report" srcset="https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/YUK_-_Sengoku-Rina_Cutscene_SS_75-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/patreon-exclusive-why-i-love-professional-wrestling/">Protected: Patreon Exclusive: Why I Love Professional Wrestling<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Why I Love Professional Wrestling" title="Protected: Patreon Exclusive: Why I Love Professional Wrestling" srcset="https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Why-I-love-professional-wrestling-Chris-White-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/03/tiny-tinas-wonderlands-active-shift-codes-get-free-loot-via-skeleton-keys/">Tiny Tina&#8217;s Wonderlands active shift codes: Get free loot via Skeleton Keys<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tiny Tina&#039;s Wonderlands active shift codes: Get free loot via Skeleton Keys" title="Tiny Tina&#8217;s Wonderlands active shift codes: Get free loot via Skeleton Keys" srcset="https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-toyoi-shrine/">Ghostwire Tokyo Jizo Statue locations | Toyoi Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Toyoi Shrine" title="Ghostwire Tokyo Jizo Statue locations | Toyoi Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hitani-shrine/">Ghostwire Tokyo Jizo Statue locations | Hitani Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Hitani Shrine" title="Ghostwire Tokyo Jizo Statue locations | Hitani Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-onten-shrine/">Ghostwire Tokyo Tanuki locations | Onten Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Tanuki Onten Shrine" title="Ghostwire Tokyo Tanuki locations | Onten Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hatsuike-shrine/">Ghostwire Tokyo Jizo Statue locations | Hatsuike Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Jizo Statue Hatsuike Shrine" title="Ghostwire Tokyo Jizo Statue locations | Hatsuike Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-toyoi-shrine/">Ghostwire Tokyo Tanuki locations | Toyoi Shrine<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostwire Tokyo Tanuki Toyoi Shrine" title="Ghostwire Tokyo Tanuki locations | Toyoi Shrine" srcset="https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/">New House of the Dragon trailer shows glimpse of Game of Thrones prequel<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="House of the Dragon trailer" title="New House of the Dragon trailer shows glimpse of Game of Thrones prequel" srcset="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/dying-light-enhanced-edition-now-free-to-owners-of-the-base-game/">Dying Light Enhanced Edition now free to owners of the base game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light Enhanced Edition Free Upgrade News" title="Dying Light Enhanced Edition now free to owners of the base game" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/we-were-here-forever-launch-trailer-released/">We Were Here Forever launch trailer released<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="We Were Here Forever Launch Trailer News" title="We Were Here Forever launch trailer released" srcset="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/formula-1-and-mclaren-content-comes-to-rocket-league/">Formula 1 and McLaren content comes to Rocket League!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket League" title="Formula 1 and McLaren content comes to Rocket League!" srcset="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/new-kenobi-trailer-released-on-star-wars-day/">New Kenobi trailer released on Star Wars Day<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Kenobi Trailer News" title="New Kenobi trailer released on Star Wars Day" srcset="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/halo-infinite-season-2-lone-wolves-has-launched/">Halo Infinite Season 2 Lone Wolves has launched!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite Lone Wolves Season 2" title="Halo Infinite Season 2 Lone Wolves has launched!" srcset="https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-infinite-s2-main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-258806" class="menu-item menu-item-258806 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="post" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/2022/01/2022-game-release-dates-ps5-xbox-nintendo-switch-pc/">2022 Release Dates</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/05/wildcat-gun-machine-first-look-video/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/05/wildcat-gun-machine-first-look-video/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">New House of the Dragon trailer shows glimpse of Game of Thrones prequel</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2011/07/ps-vita-trailer-shows-social-side-gaming/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/05/podcast-486-rogue-legacy-2-chinatown-detective-agency-astroneer/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Podcast 486: Rogue Legacy 2, Chinatown Detective Agency, Astroneer</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-262999" class="post-262999 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-video-features tag-wildcat-gun-machine" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Wildcat Gun Machine | First Look Video                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="May 8, 2022">May 8, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Wildcat Gun Machine | First Look Video' data-link='https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/' data-summary='Cats and Guns, what&#039;s not to like, right?' data-app-id-name='post_above_content'></div>
<p>We wanted to bring you &#8220;first impressions&#8221; of some games we may not get to cover fully with reviews on the site or channel, so here&#8217;s Adam taking a look at <a href="https://www.youtube.com/watch?v=_Tv48RU5eyc" target="_blank" rel="noopener noreferrer">Wildcat Gun Machine</a>, available now. This version is the one from <a href="https://www.godisageek.com/2021/04/epic-games-store-adds-new-pc-apps/">Epic Games Store</a>.</p>
<p>&#8220;First Look&#8221; will often be the first time we&#8217;ve ever played a game, but in some cases it might be the first time a specific team member has played the game. We may do it for a bigger game, as an interesting way to see if the eventual review lines up with first look impressions after hours upon hours with a game. Make sure you subscribe to the YouTube Channel so you never miss a video in the series.</p>
<p><iframe title="Wildcat Gun Machine | First Look" width="500" height="281" src="https://www.youtube.com/embed/_Tv48RU5eyc?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>Here&#8217;s the official description of the game, directly from Steam (currently at £12.99):</p>
<blockquote><p>Wildcat Gun Machine is an explosion roller coaster ride! Enter a bullet hell dungeon crawler where you take on hordes of disgusting flesh beasts with a wide variety of guns, giant mech robots, and cute kittens.</p>
<p>Explore sprawling maze-like dungeons and liberate giant mech robots from demonic elder gods. Enemy encounters are challenging and specifically designed &#8211; not randomized &#8211; to provide difficult combat puzzles.</p>
<p>Gear Up &#8211; Mow Down &#8211; Get Killed &#8211; Retaliate! Over 40 gun types to choose from. Each has their own unique features like auto-aim bullets, long-range laser beams or exploding rounds with a huge blast radius.</p>
<p>Super abilities that disintegrate everything on the screen!<br />
Character upgrades to suit the player’s gameplay style. Players wanting a more forgiving difficulty can increase the times they’re able to respawn, while speedrunners can upgrade their movement speed and improve their dash skill.</p></blockquote>
<p><em>Wildcat Gun Machine is available now for PC, Nintendo Switch, Xbox One, and PS4.</em></p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Wildcat Gun Machine | First Look Video' data-link='https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/' data-summary='Cats and Guns, what&#039;s not to like, right?' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Wildcat Gun Machine | First Look Video' data-link='https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/' data-summary='Cats and Guns, what&#039;s not to like, right?' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/features/video-features/" title="View all posts in Video Features">Video Features</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/wildcat-gun-machine/" title="Wildcat Gun Machine Tag" class="wildcat-gun-machine">Wildcat Gun Machine</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                                                        
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="House of the Dragon trailer" title="New House of the Dragon trailer shows glimpse of Game of Thrones prequel" srcset="https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-the-Dragon-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/">New House of the Dragon trailer shows glimpse of Game of Thrones prequel</a><div class="article-meta clearfix"><a class="like-button do-like 262937 info-bottom" data-postid="262937" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/05/new-house-of-the-dragon-trailer-shows-glimpse-of-game-of-thrones-prequel/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/dying-light-enhanced-edition-now-free-to-owners-of-the-base-game/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light Enhanced Edition Free Upgrade News" title="Dying Light Enhanced Edition now free to owners of the base game" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dying-Light-Enhanced-Edition-Free-Upgrade-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/dying-light-enhanced-edition-now-free-to-owners-of-the-base-game/">Dying Light Enhanced Edition now free to owners of the base game</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/dying-light-enhanced-edition-now-free-to-owners-of-the-base-game/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/we-were-here-forever-launch-trailer-released/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="We Were Here Forever Launch Trailer News" title="We Were Here Forever launch trailer released" srcset="https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/We-Were-Here-Forever-Launch-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/we-were-here-forever-launch-trailer-released/">We Were Here Forever launch trailer released</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/we-were-here-forever-launch-trailer-released/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/formula-1-and-mclaren-content-comes-to-rocket-league/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket League" title="Formula 1 and McLaren content comes to Rocket League!" srcset="https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Formula-1-Fan-Pass-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/formula-1-and-mclaren-content-comes-to-rocket-league/">Formula 1 and McLaren content comes to Rocket League!</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/formula-1-and-mclaren-content-comes-to-rocket-league/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/new-kenobi-trailer-released-on-star-wars-day/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Kenobi Trailer News" title="New Kenobi trailer released on Star Wars Day" srcset="https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Kenobi-Trailer-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/new-kenobi-trailer-released-on-star-wars-day/">New Kenobi trailer released on Star Wars Day</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/new-kenobi-trailer-released-on-star-wars-day/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-batman-movie-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Batman-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="The Batman review" title="The Batman movie review" srcset="https://www.godisageek.com/wp-content/uploads/Batman-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Batman-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Batman-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Batman-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-batman-movie-review/">The Batman movie review</a><div class="clearfix"></div><div class="article-meta clearfix"><a class="like-button do-like 262918 info-bottom" data-postid="262918" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-batman-movie-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/loot-river-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Loot River Review" title="Loot River review" srcset="https://www.godisageek.com/wp-content/uploads/Loot-River-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Loot-River-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/loot-river-review/">Loot River review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/loot-river-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/imp-of-the-sun-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Imp of the Sun title image" title="Imp of the Sun review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-2-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">Imp of the Sun review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="King Arthur" title="King Arthur: Knight&#8217;s Tale review" srcset="https://www.godisageek.com/wp-content/uploads/KAKT-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/KAKT-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/KAKT-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/KAKT-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">King Arthur: Knight&#8217;s Tale review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Review" title="Rogue Legacy 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">Rogue Legacy 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video</a><div class="article-meta clearfix"><a class="like-button do-like 262999 info-bottom" data-postid="262999" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage</a></div><a class="hover-link" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage</a></div><a class="hover-link" href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video</a></div><a class="hover-link" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nobody-saves-the-world-switch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Switch-3-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Nobody Saves the World Switch" title="Nobody Saves the World Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Switch-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Switch-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Switch-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Switch-3-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nobody-saves-the-world-switch-review/">Nobody Saves the World Switch review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 262184 info-bottom" data-postid="262184" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/nobody-saves-the-world-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Review" title="Rogue Legacy 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">Rogue Legacy 2 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/slipstream-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Slipstream-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Slipstream review" title="Slipstream review" srcset="https://www.godisageek.com/wp-content/uploads/Slipstream-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Slipstream-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Slipstream-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Slipstream-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/slipstream-review/">Slipstream review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/slipstream-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/teardown-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Teardown-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Teardown Review" title="Teardown review" srcset="https://www.godisageek.com/wp-content/uploads/Teardown-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Teardown-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Teardown-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Teardown-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/teardown-review/">Teardown review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/teardown-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/green-hell-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/greenhell_immagine0-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Green Hell" title="Green Hell review" srcset="https://www.godisageek.com/wp-content/uploads/greenhell_immagine0-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/greenhell_immagine0-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/greenhell_immagine0-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/greenhell_immagine0-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/green-hell-review/">Green Hell review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/green-hell-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Tiny-Tinas-Wonderlands-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/tiny-tinas-wonderlands-active-shift-codes-get-free-loot-via-skeleton-keys/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Tiny Tina&#8217;s Wonderlands active shift codes: Get free loot via Skeleton Keys</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-50a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-toyoi-shrine/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ghostwire Tokyo Jizo Statue locations | Toyoi Shrine</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-46a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hitani-shrine/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ghostwire Tokyo Jizo Statue locations | Hitani Shrine</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-21a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-onten-shrine/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ghostwire Tokyo Tanuki locations | Onten Shrine</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GWT-Jizo-Statue-51a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/ghostwire-tokyo-jizo-statue-locations-hatsuike-shrine/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ghostwire Tokyo Jizo Statue locations | Hatsuike Shrine</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/GWT-Tanuki-Hunt-23a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/03/ghostwire-tokyo-tanuki-locations-toyoi-shrine/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ghostwire Tokyo Tanuki locations | Toyoi Shrine</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-batman-movie-review/">The Batman movie review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-batman-movie-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/loot-river-review/">Loot River review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/loot-river-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">Imp of the Sun review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/imp-of-the-sun-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">King Arthur: Knight&#8217;s Tale review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/king-arthur-knights-tale-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">Rogue Legacy 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/rogue-legacy-2-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.234375px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.5625px;" aria-label="Activision (780 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.46875px;" aria-label="Bandai Namco (426 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.625px;" aria-label="Capcom (712 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.640625px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.78125px;" aria-label="EA (1,163 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (409 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.28125px;" aria-label="Konami (567 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.4375px;" aria-label="Microsoft (939 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,780 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.03125px;" aria-label="nintendo switch (814 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.421875px;" aria-label="PC (1,392 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.375px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.875px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.078125px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.25px;" aria-label="PS4 (1,239 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.390625px;" aria-label="Sega (697 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.671875px;" aria-label="Sony (961 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.4375px;" aria-label="square enix (934 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.640625px;" aria-label="Steam (477 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.390625px;" aria-label="Trailer (683 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.953125px;" aria-label="Ubisoft (1,308 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.296875px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.71875px;" aria-label="Xbox One (1,286 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.765306122449px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.30612244898px;" aria-label="Articles (237 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.076530612245px;" aria-label="Competition (223 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.760204081633px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.265306122449px;" aria-label="Features (2,656 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 13.989795918367px;" aria-label="Guides (397 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (220 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.683673469388px;" aria-label="iOS (358 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,899 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.520408163265px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 15.137755102041px;" aria-label="Paid Placement Advertorials (564 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.80612244898px;" aria-label="PC (2,272 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.285714285714px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.734693877551px;" aria-label="PlayStation 4 (1,666 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.132653061224px;" aria-label="Podcasts (762 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.744897959184px;" aria-label="Previews (919 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.377551020408px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 22.025510204082px;" aria-label="Reviews (4,449 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.515306122449px;" aria-label="Switch (846 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.765306122449px;" aria-label="Tech (273 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.892857142857px;" aria-label="Trailers (1,283 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13.071428571429px;" aria-label="Uncategorised (299 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.127551020408px;" aria-label="Video Features (1,025 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.90306122449px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.045918367347px;" aria-label="Xbox One (1,339 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.8515625px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.1484375px;" aria-label="Android (82 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.2265625px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.16015625px;" aria-label="Google Stadia (25 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.27734375px;" aria-label="HTC Vive (26 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.14453125px;" aria-label="iOS (122 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.0390625px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 13.7578125px;" aria-label="Oculus Quest 2 (9 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.453125px;" aria-label="Oculus Rift (28 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,802 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.671875px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.70703125px;" aria-label="PlayStation 4 (1,617 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 21.609375px;" aria-label="PlayStation 5 (217 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.38671875px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.7890625px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.18359375px;" aria-label="Switch (889 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.4453125px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.79296875px;" aria-label="Xbox 360 (106 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.12109375px;" aria-label="Xbox One (1,282 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.140625px;" aria-label="Xbox Series S (180 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 21.2578125px;" aria-label="Xbox Series X (190 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
