<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Nintendo Direct Mini: Here&#039;s everything that was announced - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href='https://fonts.googleapis.com/css?family=PT+Sans&subset=' rel='stylesheet' type='text/css'> 
<link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    
<!-- NetworkN CMP Tool -->
<script>!function(t,n){if(function(e){"string"==typeof e&&(e=[e]);for(var a=0;a<e.length;a++)n.cookie=e[a]+
"=;max-age=-1;domain=."+n.domain+";path=/"}(["euconsent","eupubconsent","googlepersonalization"]),
!t.__cmp){t.__cmp=function(){(t.attachEvent||t.addEventListener)("message",function(e){t.__cmp.receiveMessage(e)}
,!1),function e(){if(!t.frames.__cmpLocator)if(n.body){var a=n.createElement("iframe");a.style.display="none",
a.name="__cmpLocator",n.body.appendChild(a)}else setTimeout(e,5)}();var o=[],e=function(e,a,n){"ping"===e?n&&n({
gdprAppliesGlobally:!!(t.__cmp&&t.__cmp.config&&t.__cmp.config.storeConsentGlobally),cmpLoaded:!1}):
o.push({command:e,parameter:a,callback:n})};return e.commandQueue=o,e.receiveMessage=function(e){
var a=e&&e.data&&e.data.__cmpCall;a&&o.push({callId:a.callId,command:a.command,parameter:a.parameter,
event:e})},e.config=t.cmpConfig||{},e}()}}(window,document);
</script>
<script src="//cmp.network-n.com/js/cmp.complete.bundle.js" async></script>

<!-- Begin ComScore Tag -->
<script>
!function(o,n){if(o._localCS={consent:null,loaded:!1,tx:null},o._comscore=o._comscore||[],o.__cmp){
o.__cmp("getVendorConsents",[77],function(o,c){function e(o){return"object"==typeof o}c&&(_localCS.consent=e(o)
&&e(o.vendorConsents)&&o.vendorConsents[77],_localCS.consent=_localCS.consent?"1":"0",t())}),function c(){
o.__cmp("ping",null,function(o){if(!1===o.cmpLoaded){if(null===_localCS.tx)return void(_localCS.tx=setTimeout(c,3e3));
t()}o.cmpLoaded&&(clearTimeout(_localCS.tx),t())})}()}function t(){var o,c,e;_localCS.loaded||
(_comscore.push({c1:"2",c2:"25110922",cs_ucfr:_localCS.consent}),c=(o=n).createElement("script"),
e=o.getElementsByTagName("script")[0],c.async=!0,c.src=("https:"==o.location.protocol?"https://sb":"http://b")
+".scorecardresearch.com/beacon.js",e.parentNode.insertBefore(c,e),_localCS.loaded=!0)}o.__cmp||t()}(window,document);
</script>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=25110922&cv=2.0&cj=1" /></noscript>
<!-- End ComScore Tag -->
<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Today&#039;s Nintendo Direct Mini: Partner Showcase showed off some nice surprises, including a full remaster of Shin Megami Tensei III Nocturne" />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Nintendo Direct Mini: Here&#039;s everything that was announced - GodisaGeek.com" />
	<meta property="og:description" content="Today&#039;s Nintendo Direct Mini: Partner Showcase showed off some nice surprises, including a full remaster of Shin Megami Tensei III Nocturne" />
	<meta property="og:url" content="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:author" content="http://facebook.com/christopherppwhitepoet" />
	<meta property="article:published_time" content="2020-07-20T15:40:32+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news.jpg" />
	<meta property="og:image:width" content="1000" />
	<meta property="og:image:height" content="600" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Reviews, News, Previews, Videos, Podcasts: the one stop you need for gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news.jpg","width":1000,"height":600},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/#webpage","url":"https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/","name":"Nintendo Direct Mini: Here's everything that was announced - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/#primaryimage"},"datePublished":"2020-07-20T15:40:32+00:00","dateModified":"2020-07-20T15:40:32+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646"},"description":"Today's Nintendo Direct Mini: Partner Showcase showed off some nice surprises, including a full remaster of Shin Megami Tensei III Nocturne","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/"]}]},{"@type":["Person"],"@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646","name":"Chris White","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=96&d=mm&r=g","caption":"Chris White"},"description":"Video games are cool. Don't let anybody tell you any different.","sameAs":["http://facebook.com/christopherppwhitepoet","https://twitter.com/http://twitter.com/firstavenger83"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Nintendo Direct Mini: Here&#8217;s everything that was announced Comments Feed" href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=239516' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F07%2Fnintendo-direct-mini-heres-everything-that-was-announced%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F07%2Fnintendo-direct-mini-heres-everything-that-was-announced%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-239516 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/spider-man-miles-morales-to-have-a-4k-60-fps-performance-mode/">Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode" srcset="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/">Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles" srcset="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-700x672.jpg 700w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/">Nintendo Direct Mini: Here&#8217;s everything that was announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nintendo Direct Mini: Here&#8217;s everything that was announced" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/">Sea of Thieves has reached 15 million players!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sea of Thieves" title="Sea of Thieves has reached 15 million players!" srcset="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/outfit7-celebrates-10-years-of-talking-tom-with-pok-a-tom-event/">Outfit7 celebrates 10 years of Talking Tom with POK-A-TOM event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/talkingtom-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Outfit7 celebrates 10 years of Talking Tom with POK-A-TOM event" srcset="https://www.godisageek.com/wp-content/uploads/talkingtom-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/talkingtom-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/talkingtom-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/talkingtom-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/marvel-and-funko-team-up-to-launch-marvel-battleworld/">Marvel and Funko team up to launch Marvel Battleworld: Mystery of the Thanostones. <img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/1595055498244_image001-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel and Funko team up to launch Marvel Battleworld: Mystery of the Thanostones. " srcset="https://www.godisageek.com/wp-content/uploads/1595055498244_image001-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/rocket-arena-review/">Rocket Arena review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket Arena review" title="Rocket Arena review" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/">Sword Art Online: Alicization Lycoris review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sword Art Online: Alicization Lycoris review" title="Sword Art Online: Alicization Lycoris review" srcset="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/">Marvel&#8217;s Iron Man VR review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Iron Man VR review" srcset="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/">Radical Rabbit Stew review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radical Rabbit Stew review" title="Radical Rabbit Stew review" srcset="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RRS-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RRS-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RRS-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/">Warhammer 40000: Mechanicus review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer 40,000: Mechanicus review" title="Warhammer 40000: Mechanicus review" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/never-breakup-review/">Never Breakup review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Never Breakup" title="Never Breakup review" srcset="https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/medieval-dynasty-first-look-create-your-own-legacy-from-the-ground-up/">Medieval Dynasty first look: Create your own legacy from the ground up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Medieval Dynasty First Look" title="Medieval Dynasty first look: Create your own legacy from the ground up" srcset="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ooblets-may-be-in-early-access-but-theres-already-so-much-to-love-about-it/">Ooblets may be in Early Access, but there&#8217;s already so much to love about it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ooblets may be in Early Access, but there&#8217;s already so much to love about it" srcset="https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/podcast-404-assassins-creed-valhalla-deadly-premonition-2/">Podcast #404: Toast your Buns &#8211; Assassin&#8217;s Creed Valhalla, Deadly Premonition 2, SUPERHOT<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #404: Toast your Buns - Assassin&#039;s Creed Valhalla, Deadly Premonition 2, SUPERHOT" title="Podcast #404: Toast your Buns &#8211; Assassin&#8217;s Creed Valhalla, Deadly Premonition 2, SUPERHOT" srcset="https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/10-things-we-loved-about-death-stranding/">10 things to love about Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="10 things to love about Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/assassins-creed-valhalla-has-authentic-combat-and-an-engaging-world-hands-on-preview/">Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/complete-guide-the-last-of-us-part-2-every-weapon-collectable/">A Complete Guide to The Last of Us Part II | Every Collectable and Weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A Complete Guide to The Last of Us Part II | Every Collectable and Weapon" srcset="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/desperados-iii-character-guide/">Desperados III | Character Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III Character Guide" title="Desperados III | Character Guide" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/10-desperados-iii-tips-to-help-you-out-in-the-wild-west/">10 Desperados III tips to help you out in the Wild West<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III tips" title="10 Desperados III tips to help you out in the Wild West" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/medieval-dynasty-first-look-create-your-own-legacy-from-the-ground-up/">Medieval Dynasty first look: Create your own legacy from the ground up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Medieval Dynasty First Look" title="Medieval Dynasty first look: Create your own legacy from the ground up" srcset="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/assassins-creed-valhalla-has-authentic-combat-and-an-engaging-world-hands-on-preview/">Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/madden-nfl-21s-huge-gameplay-improvements-provide-more-fluidity-and-control-beta-impressions/">Madden NFL 21&#8217;s huge gameplay improvements provide more fluidity and control | Beta impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Madden NFL 21 closed beta" title="Madden NFL 21&#8217;s huge gameplay improvements provide more fluidity and control | Beta impressions" srcset="https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/paper-mario-the-origami-king-is-that-nintendo-charm-in-raw-powerful-form-preview/">Paper Mario: The Origami King is that “Nintendo Charm™” in raw, powerful form | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Paper Mario: The Origami King" title="Paper Mario: The Origami King is that “Nintendo Charm™” in raw, powerful form | Preview" srcset="https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/fuser-is-harmonix-redefining-the-music-game-genre-all-over-again-hands-on-preview/">Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview" title="Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/no-straight-roads-is-a-vibrant-and-unique-musical-adventure/">No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview" title="No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/spider-man-miles-morales-to-have-a-4k-60-fps-performance-mode/">Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode" srcset="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/">Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles" srcset="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-700x672.jpg 700w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/">Nintendo Direct Mini: Here&#8217;s everything that was announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nintendo Direct Mini: Here&#8217;s everything that was announced" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/">Sea of Thieves has reached 15 million players!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sea of Thieves" title="Sea of Thieves has reached 15 million players!" srcset="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/outfit7-celebrates-10-years-of-talking-tom-with-pok-a-tom-event/">Outfit7 celebrates 10 years of Talking Tom with POK-A-TOM event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/talkingtom-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Outfit7 celebrates 10 years of Talking Tom with POK-A-TOM event" srcset="https://www.godisageek.com/wp-content/uploads/talkingtom-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/talkingtom-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/talkingtom-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/talkingtom-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/marvel-and-funko-team-up-to-launch-marvel-battleworld/">Marvel and Funko team up to launch Marvel Battleworld: Mystery of the Thanostones. <img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/1595055498244_image001-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel and Funko team up to launch Marvel Battleworld: Mystery of the Thanostones. " srcset="https://www.godisageek.com/wp-content/uploads/1595055498244_image001-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/1595055498244_image001-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/rocket-arena-review/">Rocket Arena review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket Arena review" title="Rocket Arena review" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/">Sword Art Online: Alicization Lycoris review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sword Art Online: Alicization Lycoris review" title="Sword Art Online: Alicization Lycoris review" srcset="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/">Marvel&#8217;s Iron Man VR review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Iron Man VR review" srcset="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/">Radical Rabbit Stew review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radical Rabbit Stew review" title="Radical Rabbit Stew review" srcset="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RRS-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RRS-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RRS-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/">Warhammer 40000: Mechanicus review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer 40,000: Mechanicus review" title="Warhammer 40000: Mechanicus review" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/never-breakup-review/">Never Breakup review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Never Breakup" title="Never Breakup review" srcset="https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/medieval-dynasty-first-look-create-your-own-legacy-from-the-ground-up/">Medieval Dynasty first look: Create your own legacy from the ground up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Medieval Dynasty First Look" title="Medieval Dynasty first look: Create your own legacy from the ground up" srcset="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ooblets-may-be-in-early-access-but-theres-already-so-much-to-love-about-it/">Ooblets may be in Early Access, but there&#8217;s already so much to love about it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ooblets may be in Early Access, but there&#8217;s already so much to love about it" srcset="https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ooblets-early-acces-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/podcast-404-assassins-creed-valhalla-deadly-premonition-2/">Podcast #404: Toast your Buns &#8211; Assassin&#8217;s Creed Valhalla, Deadly Premonition 2, SUPERHOT<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #404: Toast your Buns - Assassin&#039;s Creed Valhalla, Deadly Premonition 2, SUPERHOT" title="Podcast #404: Toast your Buns &#8211; Assassin&#8217;s Creed Valhalla, Deadly Premonition 2, SUPERHOT" srcset="https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/podcast-404-assassins-creed-valhalla-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/10-things-we-loved-about-death-stranding/">10 things to love about Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="10 things to love about Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/10-things-that-have-us-excited-for-death-stranding-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/assassins-creed-valhalla-has-authentic-combat-and-an-engaging-world-hands-on-preview/">Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/complete-guide-the-last-of-us-part-2-every-weapon-collectable/">A Complete Guide to The Last of Us Part II | Every Collectable and Weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A Complete Guide to The Last of Us Part II | Every Collectable and Weapon" srcset="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/desperados-iii-character-guide/">Desperados III | Character Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III Character Guide" title="Desperados III | Character Guide" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/10-desperados-iii-tips-to-help-you-out-in-the-wild-west/">10 Desperados III tips to help you out in the Wild West<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III tips" title="10 Desperados III tips to help you out in the Wild West" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-combat-guide/">Xenoblade Chronicles: Definitive Edition | Combat Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles Definitive Edition Combat" title="Xenoblade Chronicles: Definitive Edition | Combat Guide" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-title-screen-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/05/xenoblade-chronicles-definitive-edition-tips-guide-nintendo-switch/">Xenoblade Chronicles: Definitive Edition | 10 tips for beginners<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="xenoblade chronicles definitive edition tips" title="Xenoblade Chronicles: Definitive Edition | 10 tips for beginners" srcset="https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/xenoblade-chronicles-definitive-edition-eshop-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/07/medieval-dynasty-first-look-create-your-own-legacy-from-the-ground-up/">Medieval Dynasty first look: Create your own legacy from the ground up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Medieval Dynasty First Look" title="Medieval Dynasty first look: Create your own legacy from the ground up" srcset="https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Medieval-Dynasty-First-Look-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/assassins-creed-valhalla-has-authentic-combat-and-an-engaging-world-hands-on-preview/">Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Assassin&#8217;s Creed Valhalla has authentic combat and an engaging world | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-preview-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/madden-nfl-21s-huge-gameplay-improvements-provide-more-fluidity-and-control-beta-impressions/">Madden NFL 21&#8217;s huge gameplay improvements provide more fluidity and control | Beta impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Madden NFL 21 closed beta" title="Madden NFL 21&#8217;s huge gameplay improvements provide more fluidity and control | Beta impressions" srcset="https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/madden-nfl-21-closed-beta-impressions-3-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/paper-mario-the-origami-king-is-that-nintendo-charm-in-raw-powerful-form-preview/">Paper Mario: The Origami King is that “Nintendo Charm™” in raw, powerful form | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Paper Mario: The Origami King" title="Paper Mario: The Origami King is that “Nintendo Charm™” in raw, powerful form | Preview" srcset="https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Paper-Mario-The-Origami-King-dance-scene-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/fuser-is-harmonix-redefining-the-music-game-genre-all-over-again-hands-on-preview/">Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview" title="Fuser is Harmonix redefining the music game genre all over again | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Fuser-hands-on-preview-gameplay-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/no-straight-roads-is-a-vibrant-and-unique-musical-adventure/">No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview" title="No Straight Roads Is Looking Like a Vibrant and Unique Musical Adventure | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/No-straight-roads-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Sea of Thieves has reached 15 million players!</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2018/01/gta-onlines-newest-car-ubermacht-revolter/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-239516" class="post-239516 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-cadence-of-hyrule tag-nintendo-direct-mini tag-nintendo-switch tag-rogue-company tag-shin-megami-tensei-iii-nocturne-remaster tag-shin-megami-tensei-v tag-wwe-2k-battlegrounds" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Nintendo Direct Mini: Here&#8217;s everything that was announced                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-white/"><span itemprop="author">Chris White </span></a></span><span class="date">on <meta itemprop="datePublished" content="July 20, 2020">July 20, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news.jpg"><img width="790" height="474" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-790x474.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="" title="Nintendo Direct Mini: Here&#8217;s everything that was announced" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-790x474.jpg 790w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-300x180.jpg 300w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-768x461.jpg 768w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-180x108.jpg 180w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-360x216.jpg 360w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news.jpg 1000w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>Today&#8217;s Nintendo Direct Mini: Partner Showcase featured a rather eclectic mix of announcements, but perhaps the biggest news is that the Nintendo Switch will be getting Shin Megami Tensei V in 2021, as well as Shin Megami Tensei III Nocturne HD Remaster next spring. We got more information on Hi-Rez&#8217;s upcoming online shooter Rogue Company, DLC for Cadence of Hyrule, and a trailer showing off WWE 2K Battlegrounds for the Switch.</p>
<h3>Cadence of Hyrule receiving three DLC packs this year</h3>
<p><iframe src="https://www.youtube.com/embed/tPycD9OwojQ" width="740" height="416" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p>In a nice little surprise, it was revealed that there will be three DLC packs for Cadence of Hyrule coming this year, with the first releasing later today. The Character Pack features five additional characters, including Impa and Aria, and will be the first of the three. The Melody Pack adds 39 songs to the game, allowing you to change the background music whenever you want. Finally, Symphony of the Mask adds all-new story content, where you play as Skull Kid in a new map. The Character Pack and Melody Pack will cost $5.99 each, with Symphony of the Night costing £9.99. Ad well as being able to buy the Character Pack later on today, you&#8217;ll also be able to purchase the Season Pass for $14.99. Pack two and three will release before the end of October, with a physical release including the base game and all DLC coming on October 23, 2020 at £39.99.</p>
<h3>Cross-play coming to Rogue Company</h3>
<p><img class="aligncenter size-full wp-image-239518" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company.jpg" alt="" width="1280" height="720" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company.jpg 1280w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-rogue-company-1130x636.jpg 1130w" sizes="(max-width: 1280px) 100vw, 1280px" /></p>
<p>More details are set to be released later today, but it was announced as footage from Rogue Company was shown, that cross-play and cross-progression, AI opponents, and various skins would be available when the game launches. It was also revealed that the game would support motion-controlled aiming.</p>
<h3>WWE 2K Battlegrounds trailer shown off</h3>
<p><img class="aligncenter size-full wp-image-239517" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds.jpg" alt="" width="1280" height="720" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds.jpg 1280w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-wwe-2k-battlegrounds-1130x636.jpg 1130w" sizes="(max-width: 1280px) 100vw, 1280px" /></p>
<p>We got to see WWE Superstars Big E, Kofi Kingston, Cesaro, and Asuka all playing WWE 2K Battlegrounds, releasing September 18, 2020. This could be just what 2K needs to reinvigorate their WWE franchise. With a brand-new WWE sim not coming until next year, this will be the only wrestling game coming from 2K, but it looks like it will be a lot of fun.</p>
<h3>Shin Megami Tensei III Nocturne Remaster coming spring 2021</h3>
<p><iframe src="https://www.youtube.com/embed/diEAe3eNvEA" width="740" height="416" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p>A full high definition remake of Shin Megami Tensei III Nocturne is coming next spring, 17 years since the original released on the PlayStation 2. The student/demon hybrid returns to save Tokyo from the Vortex World, and from the trailer, it&#8217;s looking pretty darn good.</p>
<h3>Shin Megami Tensei V will launch globally in 2021</h3>
<p><iframe src="https://www.youtube.com/embed/zaM1zXLvUJY" width="740" height="416" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p>Although very little was revealed, we did get to see some new footage from the newest title in the Shin Megami Tensei series. Coming at some point in 2021, Shin Megami Tensei V will receive a simultaneous global launch.</p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/cadence-of-hyrule/" title="Cadence of Hyrule Tag" class="cadence-of-hyrule">Cadence of Hyrule</a><a href="https://www.godisageek.com/tag/nintendo-direct-mini/" title="Nintendo Direct Mini Tag" class="nintendo-direct-mini">Nintendo Direct Mini</a><a href="https://www.godisageek.com/tag/nintendo-switch/" title="nintendo switch Tag" class="nintendo-switch">nintendo switch</a><a href="https://www.godisageek.com/tag/rogue-company/" title="rogue company Tag" class="rogue-company">rogue company</a><a href="https://www.godisageek.com/tag/shin-megami-tensei-iii-nocturne-remaster/" title="shin megami tensei III nocturne remaster Tag" class="shin-megami-tensei-iii-nocturne-remaster">shin megami tensei III nocturne remaster</a><a href="https://www.godisageek.com/tag/shin-megami-tensei-v/" title="shin megami tensei v Tag" class="shin-megami-tensei-v">shin megami tensei v</a><a href="https://www.godisageek.com/tag/wwe-2k-battlegrounds/" title="wwe 2k battlegrounds Tag" class="wwe-2k-battlegrounds">wwe 2k battlegrounds</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><img alt='' src='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><h3>Chris White</h3></a>Video games are cool. Don't let anybody tell you any different.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/http://twitter.com/firstavenger83" target="_blank"></a><a class="icon-facebook info" title="Find me on Facebook" href="http://www.facebook.com/http://facebook.com/christopherppwhitepoet" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:chris@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="24075" data-method="tags" class="info active" title="More articles tagged: Cadence of Hyrule">Cadence of Hyrule<span class="bottom-arrow"></span></a><a data-sorter="21310" data-method="tags" class="info" title="More articles tagged: Nintendo Direct Mini">Nintendo Direct Mini<span class="bottom-arrow"></span></a><a data-sorter="17513" data-method="tags" class="info" title="More articles tagged: nintendo switch">nintendo switch<span class="bottom-arrow"></span></a><a data-sorter="21061" data-method="tags" class="info" title="More articles tagged: shin megami tensei v">shin megami tensei v<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cadence-hyrule-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Cadence of Hyrule review" srcset="https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Cadence-of-Hyrule-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cadence-hyrule-review/">Cadence of Hyrule review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cadence-hyrule-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/06/nintendo-switch-e3-2019-trailer-round-up/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-E319-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Announced Nintendo Switch games E3 2019 trailer round up" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-E319-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-E319-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-E319-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Nintendo-E319-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/06/nintendo-switch-e3-2019-trailer-round-up/">Announced Nintendo Switch games E3 2019 trailer round up</a></div><a class="hover-link" href="https://www.godisageek.com/2019/06/nintendo-switch-e3-2019-trailer-round-up/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                             

        
<div id="comments">
    <div class="filterbar">
        <div class="sort-buttons" data-number="" data-type="comment">
        	<div class="ribbon-wrapper">
				<div class="ribbon">
					<span class="icon-comments"></span>
					Be the first to comment!                    <div class="ribbon-separator">&nbsp;</div>
				</div>
			</div>
           
            <a class="reply-link" href="#reply-form">Leave a reply &raquo;</a>
            
             
                       
        </div>
        <br class="clearer" />
    </div>
     
    <div class="loading"><div>&nbsp;</div></div>
    
    <div class="comment-list-wrapper">
         <ul class="comment-list">            
        	 
         </ul>
    </div>
</div>


	<div id="reply-form">

		        
                    
            	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="ribbon-wrapper"><span class="ribbon"><span class="icon-pencil"></span>Leave a Response<span class="ribbon-separator">&nbsp;</span></span></span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.godisageek.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><div class="comment-fields-container full"><div class="comment-fields-inner"><textarea id="comment" class="input-block-level" name="comment" aria-required="true" rows="8" placeholder="Comment"></textarea><input id="author" class="input-block-level" name="author" type="text" value="" placeholder="Name" />
<input id="email" class="input-block-level" name="email" type="text" value="" placeholder="E-mail" />
<input id="url" class="input-block-level" name="url" type="text" value="" placeholder="Website (optional)" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post" /> <input type='hidden' name='comment_post_ID' value='239516' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></div></div></form>	</div><!-- #respond -->
	 
    
            
    </div>

                                                        
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/spider-man-miles-morales-to-have-a-4k-60-fps-performance-mode/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode" srcset="https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/spider-man-miles-morales-performance-mode-news-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/spider-man-miles-morales-to-have-a-4k-60-fps-performance-mode/">Spider-Man: Miles Morales to have a 4K/60 FPS Performance Mode</a><div class="article-meta clearfix"><a class="like-button do-like 239524 info-bottom" data-postid="239524" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/07/spider-man-miles-morales-to-have-a-4k-60-fps-performance-mode/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles" srcset="https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-700x672.jpg 700w, https://www.godisageek.com/wp-content/uploads/overcooked-all-you-can-eat-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/">Remastered bundle Overcooked: All You Can Eat! coming to next-gen consoles</a></div><a class="hover-link" href="https://www.godisageek.com/2020/07/remastered-bundle-overcooked-all-you-can-eat-coming-to-next-gen-consoles/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nintendo Direct Mini: Here&#8217;s everything that was announced" srcset="https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nintendo-direct-mini-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/">Nintendo Direct Mini: Here&#8217;s everything that was announced</a></div><a class="hover-link" href="https://www.godisageek.com/2020/07/nintendo-direct-mini-heres-everything-that-was-announced/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sea of Thieves" title="Sea of Thieves has reached 15 million players!" srcset="https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sea-of-Thieves-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/">Sea of Thieves has reached 15 million players!</a></div><a class="hover-link" href="https://www.godisageek.com/2020/07/sea-of-thieves-has-reached-15-million-players/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rocket-arena-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket Arena review" title="Rocket Arena review" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rocket-arena-review/">Rocket Arena review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/rocket-arena-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rocket-arena-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Rocket Arena review" title="Rocket Arena review" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rocket-arena-review/">Rocket Arena review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 239399 info-bottom" data-postid="239399" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/rocket-arena-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sword Art Online: Alicization Lycoris review" title="Sword Art Online: Alicization Lycoris review" srcset="https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/">Sword Art Online: Alicization Lycoris review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Iron Man VR review" srcset="https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/">Marvel&#8217;s Iron Man VR review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radical Rabbit Stew review" title="Radical Rabbit Stew review" srcset="https://www.godisageek.com/wp-content/uploads/RRS-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RRS-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RRS-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RRS-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/">Radical Rabbit Stew review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer 40,000: Mechanicus review" title="Warhammer 40000: Mechanicus review" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Warhammer-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/">Warhammer 40000: Mechanicus review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great</a><div class="article-meta clearfix"><a class="like-button do-like 231548 info-bottom" data-postid="231548" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">-36</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/crosscode-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/CrossCode-3-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="CrossCode" title="CrossCode review" srcset="https://www.godisageek.com/wp-content/uploads/CrossCode-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/CrossCode-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/CrossCode-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/CrossCode-3-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crosscode-review/">CrossCode review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 238854 info-bottom" data-postid="238854" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/crosscode-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/superhot-mind-control-delete-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="SUPERHOT MIND CONTROL DELETE" title="Superhot: MIND CONTROL DELETE review" srcset="https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-700x672.jpg 700w, https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/SUPERHOT-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/superhot-mind-control-delete-review/">Superhot: MIND CONTROL DELETE review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/superhot-mind-control-delete-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Catherine: Full Body Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/">Catherine: Full Body Switch review | Switch Re:port</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ghost-of-tsushima-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima review" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ghost-of-tsushima-review/">Ghost of Tsushima review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ghost-of-tsushima-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/f1-2020-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="F1 2020 review" title="F1 2020 review" srcset="https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/F1-2020-Main-1-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/f1-2020-review/">F1 2020 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/f1-2020-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Rocket-Arena-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/rocket-arena-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Rocket Arena review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Sword-Art-Online-review-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/sword-art-online-alicization-lycoris-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.5</div></div></div><div class="article-info">Sword Art Online: Alicization Lycoris review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/iron-man-vr-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/marvels-iron-man-vr-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.0</div></div></div><div class="article-info">Marvel&#8217;s Iron Man VR review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/RRS-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/radical-rabbit-stew-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Radical Rabbit Stew review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Warhammer-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/warhammer-40000-mechanicus-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Warhammer 40000: Mechanicus review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Never-Breakup-3-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/never-breakup-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.5</div></div></div><div class="article-info">Never Breakup review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/earfun2-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/earfun-air-true-wireless-earphones-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">EarFun Air True Wireless Earphones review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/anker1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/anker-powerexpand-elite-13-in-1-docking-station-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Anker PowerExpand Elite 13-in-1 Docking Station review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Trackmania-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/trackmania-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Trackmania review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Rez-Plz-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/rez-plz-pc-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">REZ PLZ review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/


Served from: godisageek.com @ 2020-07-20 17:42:08 by W3 Total Cache
-->