<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>GodisaGeek Podcast #420: The PS5 Dualsense, Pacer, Little Hope</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="We&#039;re under so many embargoes, but can talk about the PS5 Dualsense, Pacer, Little Hope, Astro&#039;s Playroom, and Cyberpunk 2077&#039;s delay." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Podcast 420: Cooling Springs - Astro&#039;s Playroom, Little Hope, Pacer" />
	<meta property="og:description" content="We&#039;re under so many embargoes, but can talk about the PS5 Dualsense, Pacer, Little Hope, Astro&#039;s Playroom, and Cyberpunk 2077&#039;s delay." />
	<meta property="og:url" content="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2020-11-02T07:01:40+00:00" />
	<meta property="article:modified_time" content="2020-10-30T17:01:15+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Reviews, News, Previews, Videos, Podcasts: the one stop you need for gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast.jpg","width":1920,"height":1080,"caption":"Podcast 420: Cooling Springs - Astro's Playroom, Little Hope, Pacer"},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/#webpage","url":"https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/","name":"GodisaGeek Podcast #420: The PS5 Dualsense, Pacer, Little Hope","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/#primaryimage"},"datePublished":"2020-11-02T07:01:40+00:00","dateModified":"2020-10-30T17:01:15+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"description":"We're under so many embargoes, but can talk about the PS5 Dualsense, Pacer, Little Hope, Astro's Playroom, and Cyberpunk 2077's delay.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=243191' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F11%2Fpodcast-420-astros-playroom-little-hope-pacer-ps5-dualsense%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F11%2Fpodcast-420-astros-playroom-little-hope-pacer-ps5-dualsense%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-243191 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/square-enix-releases-teaser-website-for-brand-new-final-fantasy-xvi/">Square Enix releases teaser website for brand new FINAL FANTASY XVI<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="teaser website final fantasy" title="Square Enix releases teaser website for brand new FINAL FANTASY XVI" srcset="https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/borderlands-3-ultimate-edition-arms-race-gameplay-and-more-revealed-on-the-borderlands-show/">Borderlands 3 Ultimate Edition, Arms Race gameplay, and more revealed on The Borderlands Show<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/borderlands-3-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Borderlands 3 Ultimate Edition, Arms Race gameplay, and more revealed on The Borderlands Show" srcset="https://www.godisageek.com/wp-content/uploads/borderlands-3-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/2k-announce-first-ever-wnba-myplayer-experience-in-nba-2k21-for-next-gen/">2K announce first ever WNBA MyPLAYER experience in NBA 2K21 for next-gen<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="2K announce first ever WNBA MyPLAYER experience in NBA 2K21 for next-gen" srcset="https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/season-7-of-wwe-supercard-is-coming-soon-in-november/">Season 7 of WWE SuperCard is coming soon in November.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Season 7 WWE SuperCard" title="Season 7 of WWE SuperCard is coming soon in November." srcset="https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/black-ops-cold-war-launch-trailer/">Call of Duty: Black Ops Cold War launch trailer drops ahead of release<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Black Ops Cold War launch trailer is now live" title="Call of Duty: Black Ops Cold War launch trailer drops ahead of release" srcset="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/world-of-tanks-collaborate-with-masahiro-ito-and-akira-yamaoka-for-halloween-event-mirny-13/">World of Tanks collaborate with Masahiro Ito and Akira Yamaoka for Halloween Event &#8216;Mirny-13&#8217;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="World of Tanks collaborate with Masahiro Ito and Akira Yamaoka for Halloween Event &#8216;Mirny-13&#8217;" srcset="https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/">The Dark Pictures Anthology: Little Hope review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope" title="The Dark Pictures Anthology: Little Hope review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pacer-review/">Pacer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pacer review" srcset="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pacer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pacer-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/">Röki Nintendo Switch Review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Roki Switch review" title="Röki Nintendo Switch Review" srcset="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/">Foregone Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Foregone review" title="Foregone Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Foregone-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Foregone-main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Foregone-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/">Anker PowerCore 10k Wireless review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Anker PowerCore 10k Wireless" title="Anker PowerCore 10k Wireless review" srcset="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/jbl-quantum-one-headset-review/">JBL Quantum ONE Headset review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/JBL-MAin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="JBL Quantum ONE Headset review" title="JBL Quantum ONE Headset review" srcset="https://www.godisageek.com/wp-content/uploads/JBL-MAin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/">Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 420: Cooling Springs - Astro&#039;s Playroom, Little Hope, Pacer" title="Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer" srcset="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">Little Hope guide | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope keep everyone alive" title="Little Hope guide | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">Little Hope guide | Where to find all the hidden Pictures<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope Pictures" title="Little Hope guide | Where to find all the hidden Pictures" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-10-tips-to-help-you-get-started/">10 tips to help you get started in Pikmin 3 Deluxe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe tips" title="10 tips to help you get started in Pikmin 3 Deluxe" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">Little Hope guide | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope keep everyone alive" title="Little Hope guide | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">Little Hope guide | Where to find all the hidden Pictures<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope Pictures" title="Little Hope guide | Where to find all the hidden Pictures" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-10-tips-to-help-you-get-started/">10 tips to help you get started in Pikmin 3 Deluxe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe tips" title="10 tips to help you get started in Pikmin 3 Deluxe" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/ghostrunner-beginners-tips/">Ghostrunner | 7 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostrunner | 7 Beginner&#039;s Tips" title="Ghostrunner | 7 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-gift-guide/">Super Mario Gift Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Gift Guides" title="Super Mario Gift Guide" srcset="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-bros-35-6-tips-to-help-you-win/">Super Mario Bros 35 | 8 Tips to help you win<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario Bros 35 tips" title="Super Mario Bros 35 | 8 Tips to help you win" srcset="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/apex-legends-season-7-is-flying-high/">Apex Legends Season 7 is flying high<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 7" title="Apex Legends Season 7 is flying high" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/bakugan-champions-of-vestroia-preview/">Bakugan: Champions of Vestroia could be a must play title for fans of the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Bakugan: Champions of Vestroia" title="Bakugan: Champions of Vestroia could be a must play title for fans of the series" srcset="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-nightmares-ii-is-scarier-than-ever-and-i-love-it/">Little Nightmares II is scarier than ever, and I love it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Little Nightmares II is scarier than ever, and I love it" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/square-enix-releases-teaser-website-for-brand-new-final-fantasy-xvi/">Square Enix releases teaser website for brand new FINAL FANTASY XVI<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="teaser website final fantasy" title="Square Enix releases teaser website for brand new FINAL FANTASY XVI" srcset="https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/final-fantasy-xvi-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/borderlands-3-ultimate-edition-arms-race-gameplay-and-more-revealed-on-the-borderlands-show/">Borderlands 3 Ultimate Edition, Arms Race gameplay, and more revealed on The Borderlands Show<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/borderlands-3-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Borderlands 3 Ultimate Edition, Arms Race gameplay, and more revealed on The Borderlands Show" srcset="https://www.godisageek.com/wp-content/uploads/borderlands-3-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/borderlands-3-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/2k-announce-first-ever-wnba-myplayer-experience-in-nba-2k21-for-next-gen/">2K announce first ever WNBA MyPLAYER experience in NBA 2K21 for next-gen<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="2K announce first ever WNBA MyPLAYER experience in NBA 2K21 for next-gen" srcset="https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-WNBA-Breanna-Steweart-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/season-7-of-wwe-supercard-is-coming-soon-in-november/">Season 7 of WWE SuperCard is coming soon in November.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Season 7 WWE SuperCard" title="Season 7 of WWE SuperCard is coming soon in November." srcset="https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/EjMDI2HU4AAgEuZ-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/black-ops-cold-war-launch-trailer/">Call of Duty: Black Ops Cold War launch trailer drops ahead of release<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Black Ops Cold War launch trailer is now live" title="Call of Duty: Black Ops Cold War launch trailer drops ahead of release" srcset="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-image-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/world-of-tanks-collaborate-with-masahiro-ito-and-akira-yamaoka-for-halloween-event-mirny-13/">World of Tanks collaborate with Masahiro Ito and Akira Yamaoka for Halloween Event &#8216;Mirny-13&#8217;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="World of Tanks collaborate with Masahiro Ito and Akira Yamaoka for Halloween Event &#8216;Mirny-13&#8217;" srcset="https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/world-of-tanks-halloween-event-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/">The Dark Pictures Anthology: Little Hope review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope" title="The Dark Pictures Anthology: Little Hope review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pacer-review/">Pacer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pacer review" srcset="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pacer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pacer-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/">Röki Nintendo Switch Review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Roki Switch review" title="Röki Nintendo Switch Review" srcset="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/">Foregone Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Foregone review" title="Foregone Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Foregone-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Foregone-main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Foregone-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/">Anker PowerCore 10k Wireless review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Anker PowerCore 10k Wireless" title="Anker PowerCore 10k Wireless review" srcset="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/jbl-quantum-one-headset-review/">JBL Quantum ONE Headset review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/JBL-MAin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="JBL Quantum ONE Headset review" title="JBL Quantum ONE Headset review" srcset="https://www.godisageek.com/wp-content/uploads/JBL-MAin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/JBL-MAin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/">Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 420: Cooling Springs - Astro&#039;s Playroom, Little Hope, Pacer" title="Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer" srcset="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">Little Hope guide | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope keep everyone alive" title="Little Hope guide | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">Little Hope guide | Where to find all the hidden Pictures<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope Pictures" title="Little Hope guide | Where to find all the hidden Pictures" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-10-tips-to-help-you-get-started/">10 tips to help you get started in Pikmin 3 Deluxe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe tips" title="10 tips to help you get started in Pikmin 3 Deluxe" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">Little Hope guide | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope keep everyone alive" title="Little Hope guide | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">Little Hope guide | Where to find all the hidden Pictures<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope Pictures" title="Little Hope guide | Where to find all the hidden Pictures" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-10-tips-to-help-you-get-started/">10 tips to help you get started in Pikmin 3 Deluxe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe tips" title="10 tips to help you get started in Pikmin 3 Deluxe" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/ghostrunner-beginners-tips/">Ghostrunner | 7 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostrunner | 7 Beginner&#039;s Tips" title="Ghostrunner | 7 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-Tips-thumb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-gift-guide/">Super Mario Gift Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Gift Guides" title="Super Mario Gift Guide" srcset="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-bros-35-6-tips-to-help-you-win/">Super Mario Bros 35 | 8 Tips to help you win<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario Bros 35 tips" title="Super Mario Bros 35 | 8 Tips to help you win" srcset="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/apex-legends-season-7-is-flying-high/">Apex Legends Season 7 is flying high<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 7" title="Apex Legends Season 7 is flying high" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/bakugan-champions-of-vestroia-preview/">Bakugan: Champions of Vestroia could be a must play title for fans of the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Bakugan: Champions of Vestroia" title="Bakugan: Champions of Vestroia could be a must play title for fans of the series" srcset="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-nightmares-ii-is-scarier-than-ever-and-i-love-it/">Little Nightmares II is scarier than ever, and I love it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Little Nightmares II is scarier than ever, and I love it" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Little Hope guide | How to keep everyone alive</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2012/12/family-guy-multiverse-dlc-details-revealed/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-243191" class="post-243191 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-podcasts" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="November 2, 2020">November 2, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Podcast 420: Cooling Springs - Astro&#039;s Playroom, Little Hope, Pacer" title="Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>There&#8217;s so many games we can&#8217;t talk about on this week&#8217;s show, but thankfully Chris White is back to talk about <a href="https://www.godisageek.com/reviews/pacer-review/">Pacer</a> and <a href="https://www.godisageek.com/reviews/amnesia-rebirth-review/">Amnesia: Rebirth</a>, while Adam Cook has time to wax lyrical about <a href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/">The Dark Pictures Anthology: Little Hope</a>, a specific level of the <a href="https://www.youtube.com/watch?v=GaayfNoP9oY&amp;feature=youtu.be">PS5 Astro&#8217;s Playroom game</a>, the PS5 Dualsense controller, and nothing more.</p>
<p>Adam Carroll is back, too, and he has feelings about Nintendo&#8217;s Switch Cloud Gaming service as well as the demo of Hyrule Warriors: Age of Calamity. Before the show ends, we talk about the delay to Cyberpunk 2077, as well. Will it come out in 2020? We&#8217;ll have to find out, I suppose.</p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/ar4W_Jv-y20" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p><a href="https://mcdn.podbean.com/mf/web/atxr8b/420.mp3">Download the show in MP3 format, here (right click and save file as</a>).</p>
<p><iframe src="https://open.spotify.com/embed-podcast/show/3fwGcJMBQCFjbIm3r8eruZ" width="100%" height="232" frameborder="0"></iframe></p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/features/podcasts/" title="View all posts in Podcasts">Podcasts</a></div><br class="clearer" /><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                                                        
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Podcast 420: Cooling Springs - Astro&#039;s Playroom, Little Hope, Pacer" title="Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer" srcset="https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Astros-Playroom-screenshot-ps5-podcast-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/">Podcast 420: Cooling Springs &#8211; Astro&#8217;s Playroom, Little Hope, Pacer</a><div class="article-meta clearfix"><a class="like-button do-like 243191 info-bottom" data-postid="243191" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/11/podcast-420-astros-playroom-little-hope-pacer-ps5-dualsense/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope keep everyone alive" title="Little Hope guide | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-keep-everyone-alive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">Little Hope guide | How to keep everyone alive</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/little-hope-guide-how-to-keep-everyone-alive/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Hope Pictures" title="Little Hope guide | Where to find all the hidden Pictures" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Picture-Guide-a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">Little Hope guide | Where to find all the hidden Pictures</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/little-hope-guide-where-to-find-all-the-hidden-pictures/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Little Hope" title="The Dark Pictures Anthology: Little Hope review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-4-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-4-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/">The Dark Pictures Anthology: Little Hope review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 243356 info-bottom" data-postid="243356" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/pacer-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pacer review" srcset="https://www.godisageek.com/wp-content/uploads/pacer-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pacer-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pacer-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/pacer-review/">Pacer review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/pacer-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Roki Switch review" title="Röki Nintendo Switch Review" srcset="https://www.godisageek.com/wp-content/uploads/roki-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/roki-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/">Röki Nintendo Switch Review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Foregone review" title="Foregone Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Foregone-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Foregone-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Foregone-main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Foregone-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/">Foregone Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Anker PowerCore 10k Wireless" title="Anker PowerCore 10k Wireless review" srcset="https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/">Anker PowerCore 10k Wireless review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a><div class="article-meta clearfix"><a class="like-button do-like 243566 info-bottom" data-postid="243566" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/oculus-quest-2-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Oculus Quest 2 review" title="Oculus Quest 2 review" srcset="https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/oculus-quest-2-review/">Oculus Quest 2 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 242675 info-bottom" data-postid="242675" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/oculus-quest-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/i-am-dead-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/i-am-dead-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="I Am Dead review" srcset="https://www.godisageek.com/wp-content/uploads/i-am-dead-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/i-am-dead-review/">I Am Dead review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/i-am-dead-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ghostrunner-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghostrunner-MAin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghostrunner Review" title="Ghostrunner review" srcset="https://www.godisageek.com/wp-content/uploads/Ghostrunner-MAin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-MAin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-MAin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghostrunner-MAin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ghostrunner-review/">Ghostrunner review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ghostrunner-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ikenfell-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ikenfell-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ikenfell review" srcset="https://www.godisageek.com/wp-content/uploads/Ikenfell-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ikenfell-review/">Ikenfell review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ikenfell-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/pikmin-3-deluxe-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe" title="Pikmin 3 Deluxe review" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/pikmin-3-deluxe-review/">Pikmin 3 Deluxe review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/pikmin-3-deluxe-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Little-Hope-4-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/the-dark-pictures-anthology-little-hope-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">The Dark Pictures Anthology: Little Hope review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/pacer-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/pacer-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Pacer review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/roki-switch-hero-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/roki-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Röki Nintendo Switch Review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Foregone-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/foregone-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Foregone Nintendo Switch review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/ANKER-Main-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/anker-powercore-10k-wireless-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Anker PowerCore 10k Wireless review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/JBL-MAin-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/jbl-quantum-one-headset-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">JBL Quantum ONE Headset review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-4-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/pikmin-3-deluxe-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Pikmin 3 Deluxe review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Watch-Dogs-Legion-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/watch-dogs-legion-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Watch Dogs: Legion review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/drone-swarm-review-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/drone-swarm-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Drone Swarm review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/9-Monkeys-of-Shaolin-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/9-monkeys-of-shaolin-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.0</div></div></div><div class="article-info">9 Monkeys of Shaolin review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
