<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Dragon Ball FighterZ, is in development for PS5 and Xbox Series S|X, and it&#039;s even getting rollback netcode." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode | GodisaGeek.com" />
	<meta property="og:description" content="Dragon Ball FighterZ, is in development for PS5 and Xbox Series S|X, and it&#039;s even getting rollback netcode." />
	<meta property="og:url" content="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-08-08T08:48:49+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg" />
	<meta property="og:image:width" content="740" />
	<meta property="og:image:height" content="416" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg","width":740,"height":416,"caption":"Dragon Ball FighterZ"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#webpage","url":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/","name":"Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#primaryimage"},"datePublished":"2022-08-08T08:48:49+00:00","dateModified":"2022-08-08T08:48:49+00:00","description":"Dragon Ball FighterZ, is in development for PS5 and Xbox Series S|X, and it's even getting rollback netcode.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"headline":"Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode","datePublished":"2022-08-08T08:48:49+00:00","dateModified":"2022-08-08T08:48:49+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/#primaryimage"},"keywords":"Arc System Works,Bandai Namco,Dragon Ball,DRAGON Ball FighterZ","articleSection":"News","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief.","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"08","day":"08","hour":"09","minute":"48","second":"49","post_id":"266032","postname":"dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/' />
<meta name='shareaholic:keywords' content='tag:arc system works, tag:bandai namco, tag:dragon ball, tag:dragon ball fighterz, cat:news, type:post' />
<meta name='shareaholic:article_published_time' content='2022-08-08T09:48:49+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-08-08T09:48:49+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Adam Cook' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=266032' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F08%2Fdragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F08%2Fdragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: 'fc19d596a6'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/"},"headline":"Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg","width":740,"height":416},"datePublished":"2022-08-08T09:48:49+0000","dateModified":"2022-08-08T09:48:49+0000","author":{"@type":"Person","name":"Adam Cook","url":"https://www.godisageek.com/author/celinahailey3/john-adams"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}},"description":"Dragon Ball FighterZ, is in development for PS5 and Xbox Series S|X, and it's even getting rollback netcode."}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/08\/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode\/","name":"Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-266032 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/vampire-survivors-review/">Vampire Survivors review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vampire Survivors Review" title="Vampire Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/hard-west-2-review/">Hard West 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hard West 2 review" title="Hard West 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/two-point-campus-review/">Two Point Campus review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus" title="Two Point Campus review" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">Hooked on You: A Dead by Daylight Dating Sim review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hooked on You title image" title="Hooked on You: A Dead by Daylight Dating Sim review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">Bear and Breakfast review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bear and Breakfast Review" title="Bear and Breakfast review" srcset="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/frogun-review/">Frogun review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Frogun title image" title="Frogun review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/soulstice-hands-on-preview/">Soulstice is a dark tale of swords, spirits, and soul-sisters | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Soiulstice-003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Soulstice hands-on preview" title="Soulstice is a dark tale of swords, spirits, and soul-sisters | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Soiulstice-003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/apex-legends-season-14-preview-new-legend/">Apex Legends Season 14 preview: Vantage, level cap increase, more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 14 preview: Vantage, level cap increase, more" title="Apex Legends Season 14 preview: Vantage, level cap increase, more" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-493-xenoblade-chronicles-3-monster-hunter-rise-sunbreak-as-dusk-falls/">Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls" title="Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/dusk-diver-2-has-fast-paced-combat-and-creative-levels-hands-on-preview/">Dusk Diver 2 has fast paced combat and creative levels | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dusk Diver 2 title image" title="Dusk Diver 2 has fast paced combat and creative levels | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/mato-anomalies-preview-showing-a-lot-of-promise/">Mato Anomalies is showing a lot of promise | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mato Anomalies title image" title="Mato Anomalies is showing a lot of promise | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/multiversus-beta-impressions/">Multiversus has fast paced combat and it&#8217;s enthralling<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus title image" title="Multiversus has fast paced combat and it&#8217;s enthralling" srcset="https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/two-point-campus-5-ways-to-earn-kudosh-fast/">Two Point Campus | 5 Ways to earn Kudosh fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus Kudosh" title="Two Point Campus | 5 Ways to earn Kudosh fast" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/two-point-campus-11-tips-to-help-you-get-started/">Two Point Campus | 11 Tips to help you get started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus Tips" title="Two Point Campus | 11 Tips to help you get started" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/multiversus-beginners-tips-rack-up-those-wins/">MultiVersus beginners tips: rack up those wins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus beginners tips: rack up those wins" title="MultiVersus beginners tips: rack up those wins" srcset="https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-make-the-tea/">Lord Winklebottom Investigates Walkthrough | Make the Tea<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Tea" title="Lord Winklebottom Investigates Walkthrough | Make the Tea" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-have-a-seance/">Lord Winklebottom Investigates Walkthrough | Have a Seance<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Seance" title="Lord Winklebottom Investigates Walkthrough | Have a Seance" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-sail-away/">Lord Winklebottom Investigates Walkthrough | Sail Away<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Sail Away" title="Lord Winklebottom Investigates Walkthrough | Sail Away" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/drop-dead-the-cabin-coming-to-meta-quest-2-this-year/">Drop Dead: The Cabin coming to Meta Quest 2 this year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Drop Dead: The Cabin coming to Meta Quest this year" title="Drop Dead: The Cabin coming to Meta Quest 2 this year" srcset="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/">Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dragon Ball FighterZ" title="Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode" srcset="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/">Juri and Kimberly revealed for Street Fighter 6<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Juri and Kimberly revealed for Street Fighter 6" title="Juri and Kimberly revealed for Street Fighter 6" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/soul-hackers-2-twisted-fates-trailer/">Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Soul Hackers 2 Twisted Fates trailer" title="Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month" srcset="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/vampire-survivors-cheat-codes-added-with-latest-update/">Vampire Survivors cheat codes added with latest update<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vampire Survivors cheat codes news" title="Vampire Survivors cheat codes added with latest update" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/ea-sports-f1-22-cross-play-full-integration-coming-end-of-august/">EA SPORTS F1 22 cross-play full integration coming end of August<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="EA SPORTS F1 22 cross-play news" title="EA SPORTS F1 22 cross-play full integration coming end of August" srcset="https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/vampire-survivors-review/">Vampire Survivors review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vampire Survivors Review" title="Vampire Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/hard-west-2-review/">Hard West 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hard West 2 review" title="Hard West 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/two-point-campus-review/">Two Point Campus review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus" title="Two Point Campus review" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">Hooked on You: A Dead by Daylight Dating Sim review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hooked on You title image" title="Hooked on You: A Dead by Daylight Dating Sim review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">Bear and Breakfast review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bear and Breakfast Review" title="Bear and Breakfast review" srcset="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/frogun-review/">Frogun review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Frogun title image" title="Frogun review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitchDS_Frogun-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/soulstice-hands-on-preview/">Soulstice is a dark tale of swords, spirits, and soul-sisters | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Soiulstice-003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Soulstice hands-on preview" title="Soulstice is a dark tale of swords, spirits, and soul-sisters | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Soiulstice-003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Soiulstice-003-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/apex-legends-season-14-preview-new-legend/">Apex Legends Season 14 preview: Vantage, level cap increase, more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 14 preview: Vantage, level cap increase, more" title="Apex Legends Season 14 preview: Vantage, level cap increase, more" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-14-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-493-xenoblade-chronicles-3-monster-hunter-rise-sunbreak-as-dusk-falls/">Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls" title="Podcast 493: Xenoblade Chronicles 3, Monster Hunter Rise: Sunbreak, As Dusk Falls" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-493-Xenoblade-Chronicles-Monster-Hunter-Rise-As-Dusk-Falls-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/dusk-diver-2-has-fast-paced-combat-and-creative-levels-hands-on-preview/">Dusk Diver 2 has fast paced combat and creative levels | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dusk Diver 2 title image" title="Dusk Diver 2 has fast paced combat and creative levels | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_DuskDiver2_image1600w-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/mato-anomalies-preview-showing-a-lot-of-promise/">Mato Anomalies is showing a lot of promise | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mato Anomalies title image" title="Mato Anomalies is showing a lot of promise | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/matoanomaliesannouncementtrailer-ign-blogroll-1657835022604-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/multiversus-beta-impressions/">Multiversus has fast paced combat and it&#8217;s enthralling<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus title image" title="Multiversus has fast paced combat and it&#8217;s enthralling" srcset="https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Multiversus_alpha_impressions_header-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/two-point-campus-5-ways-to-earn-kudosh-fast/">Two Point Campus | 5 Ways to earn Kudosh fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus Kudosh" title="Two Point Campus | 5 Ways to earn Kudosh fast" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/two-point-campus-11-tips-to-help-you-get-started/">Two Point Campus | 11 Tips to help you get started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus Tips" title="Two Point Campus | 11 Tips to help you get started" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/multiversus-beginners-tips-rack-up-those-wins/">MultiVersus beginners tips: rack up those wins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus beginners tips: rack up those wins" title="MultiVersus beginners tips: rack up those wins" srcset="https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-make-the-tea/">Lord Winklebottom Investigates Walkthrough | Make the Tea<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Tea" title="Lord Winklebottom Investigates Walkthrough | Make the Tea" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-have-a-seance/">Lord Winklebottom Investigates Walkthrough | Have a Seance<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Seance" title="Lord Winklebottom Investigates Walkthrough | Have a Seance" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-sail-away/">Lord Winklebottom Investigates Walkthrough | Sail Away<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lord Winklebottom Investigates Sail Away" title="Lord Winklebottom Investigates Walkthrough | Sail Away" srcset="https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/08/drop-dead-the-cabin-coming-to-meta-quest-2-this-year/">Drop Dead: The Cabin coming to Meta Quest 2 this year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Drop Dead: The Cabin coming to Meta Quest this year" title="Drop Dead: The Cabin coming to Meta Quest 2 this year" srcset="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/">Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dragon Ball FighterZ" title="Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode" srcset="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/">Juri and Kimberly revealed for Street Fighter 6<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Juri and Kimberly revealed for Street Fighter 6" title="Juri and Kimberly revealed for Street Fighter 6" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/soul-hackers-2-twisted-fates-trailer/">Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Soul Hackers 2 Twisted Fates trailer" title="Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month" srcset="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/vampire-survivors-cheat-codes-added-with-latest-update/">Vampire Survivors cheat codes added with latest update<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vampire Survivors cheat codes news" title="Vampire Survivors cheat codes added with latest update" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/ea-sports-f1-22-cross-play-full-integration-coming-end-of-august/">EA SPORTS F1 22 cross-play full integration coming end of August<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="EA SPORTS F1 22 cross-play news" title="EA SPORTS F1 22 cross-play full integration coming end of August" srcset="https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EA-SPORTS-F1-22-cross-play-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Juri and Kimberly revealed for Street Fighter 6</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2013/08/white-xbox-public/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/08/soulstice-hands-on-preview/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Soulstice is a dark tale of swords, spirits, and soul-sisters | Hands-on preview</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-266032" class="post-266032 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-arc-system-works tag-bandai-namco tag-dragon-ball tag-dragon-ball-fighterz" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="August 8, 2022">August 8, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg"><img width="740" height="416" src="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Dragon Ball FighterZ" title="Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz.jpg 740w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-360x202.jpg 360w" sizes="(max-width: 740px) 100vw, 740px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode' data-link='https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/' data-summary='Accessible fighter gets more accessible!' data-app-id-name='post_above_content'></div>
<p>One of the best games ever made from the <a href="https://en.wikipedia.org/wiki/Dragon_Ball" target="_blank" rel="noopener noreferrer">Dragon Ball</a> series, Dragon Ball FighterZ, is coming to PS5 and Xbox Series S|X, and it&#8217;s even getting rollback netcode.</p>
<p>Announced during Evo 2022, Bandai Namco says &#8220;the new-gen editions will harness the power of these platforms to deliver even more breathtaking visuals with incredible responsiveness to player inputs. In addition, next-gen and PC players will soon experience smoother online play thanks to the integration of rollback netcode in a future update. More information on the game’s new-gen versions and rollback netcode will be released at a later date&#8221;.</p>
<div class='video_frame'><iframe id='youtube_video_1' class='youtube_video' src='https://www.youtube.com/embed/orH1bQl7uaA?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p>&nbsp;</p>
<p>Released back in 2018, I loved the game giving it a 9/10 saying &#8220;An exquisite feeling fighter that is both approachable and deep. Time will tell if it has staying power, but it&#8217;s the best use of the Dragon Ball Z name in quite some time&#8221;. It remains one of the most accessible fighters to date when it comes to just sitting down and smashing out combos.</p>
<blockquote><p>FighterZ is hugely successful in making almost anyone feel like a fighting game expert. It’s hard to find too much to fault with Arc’s DBZ game, and most of the concerns I have are regarding the fact it’s either too deep, or too simple. You might find you get exactly what you want from it, but I worry there’s not enough for the mid-level player here. Only time will tell, but otherwise this is yet another stellar Arc fighter, and one of the best uses of the DBZ license in some time. Dragon Ball FighterZ is fantastic, and it might finally be the accessible Arc game that shows people there is more to fighting games than Street Fighter, Tekken, and Mortal Kombat. An essential purchase for fans of Dragon Ball Z, and one that fighting game fans will be making look incredible for a while to come. Hopefully this is the Arc fighting game for everyone.</p></blockquote>
<p><em>Dragon Ball FighterZ is coming to PS5 and Xbox Series S|X at a later date.</em></p>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode' data-link='https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/' data-summary='Accessible fighter gets more accessible!' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode' data-link='https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/' data-summary='Accessible fighter gets more accessible!' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/arc-system-works/" title="Arc System Works Tag" class="arc-system-works">Arc System Works</a><a href="https://www.godisageek.com/tag/bandai-namco/" title="Bandai Namco Tag" class="bandai-namco">Bandai Namco</a><a href="https://www.godisageek.com/tag/dragon-ball/" title="Dragon Ball Tag" class="dragon-ball">Dragon Ball</a><a href="https://www.godisageek.com/tag/dragon-ball-fighterz/" title="DRAGON Ball FighterZ Tag" class="dragon-ball-fighterz">DRAGON Ball FighterZ</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="977" data-method="tags" class="info active" title="More articles tagged: Arc System Works">Arc System Works<span class="bottom-arrow"></span></a><a data-sorter="6186" data-method="tags" class="info" title="More articles tagged: Bandai Namco">Bandai Namco<span class="bottom-arrow"></span></a><a data-sorter="2327" data-method="tags" class="info" title="More articles tagged: Dragon Ball">Dragon Ball<span class="bottom-arrow"></span></a><a data-sorter="19938" data-method="tags" class="info" title="More articles tagged: DRAGON Ball FighterZ">DRAGON Ball FighterZ<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dnf-duel-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DNF Duel title image" title="DNF Duel review" srcset="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dnf-duel-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Guilty Gear STRIVE review" title="Guilty Gear STRIVE review" srcset="https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/">Guilty Gear STRIVE review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/guilty-gear-strive-soundtrack-teased-in-new-trailer/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-modes-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Guilty Gear Strive soundtrack" title="Guilty Gear Strive soundtrack teased in new trailer" srcset="https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-modes-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-modes-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-modes-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-modes-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/guilty-gear-strive-soundtrack-teased-in-new-trailer/">Guilty Gear Strive soundtrack teased in new trailer</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/guilty-gear-strive-soundtrack-teased-in-new-trailer/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/04/arc-system-works-developing-guilty-gear/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Guilty Gear Strive Beta" title="Guilty Gear Strive from Arc System Works is being published by Bandai Namco Entertainment in Europe" srcset="https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Guilty-Gear-Strive-Faust-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/04/arc-system-works-developing-guilty-gear/">Guilty Gear Strive from Arc System Works is being published by Bandai Namco Entertainment in Europe</a></div><a class="hover-link" href="https://www.godisageek.com/2020/04/arc-system-works-developing-guilty-gear/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/under-night-in-birth-exelatecl-r-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Under Night In-Birth Exe:Late[cl-r]" title="Under Night In-Birth Exe:Late[cl-r] review" srcset="https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Under-Night-In-Birth-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/under-night-in-birth-exelatecl-r-review/">Under Night In-Birth Exe:Late[cl-r] review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/under-night-in-birth-exelatecl-r-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/granblue-fantasy-versus-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Granblue Fantasy Versus" title="Granblue Fantasy Versus review" srcset="https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Granblue-Fantasy-Versus-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/granblue-fantasy-versus-review/">Granblue Fantasy Versus review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/granblue-fantasy-versus-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/drop-dead-the-cabin-coming-to-meta-quest-2-this-year/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Drop Dead: The Cabin coming to Meta Quest this year" title="Drop Dead: The Cabin coming to Meta Quest 2 this year" srcset="https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Drop-Dead-the-Cabin-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/drop-dead-the-cabin-coming-to-meta-quest-2-this-year/">Drop Dead: The Cabin coming to Meta Quest 2 this year</a><div class="article-meta clearfix"><a class="like-button do-like 266056 info-bottom" data-postid="266056" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/08/drop-dead-the-cabin-coming-to-meta-quest-2-this-year/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dragon Ball FighterZ" title="Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode" srcset="https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/dragon-ball-fighterz-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/">Dragon Ball FighterZ coming to PS5 and Xbox Series S|X along with rollback netcode</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/dragon-ball-fighterz-coming-to-ps5-and-xbox-series-sx-along-with-rollback-netcode/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Juri and Kimberly revealed for Street Fighter 6" title="Juri and Kimberly revealed for Street Fighter 6" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-Juri-and-Kimberly-revealed-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/">Juri and Kimberly revealed for Street Fighter 6</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/juri-and-kimberly-revealed-for-street-fighter-6/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/soul-hackers-2-twisted-fates-trailer/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Soul Hackers 2 Twisted Fates trailer" title="Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month" srcset="https://www.godisageek.com/wp-content/uploads/Untitled-1-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Untitled-1-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/soul-hackers-2-twisted-fates-trailer/">Soul Hackers 2 Twisted Fates trailer shows off all the neon drama coming later this month</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/soul-hackers-2-twisted-fates-trailer/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/vampire-survivors-cheat-codes-added-with-latest-update/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vampire Survivors cheat codes news" title="Vampire Survivors cheat codes added with latest update" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-cheat-codes-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/vampire-survivors-cheat-codes-added-with-latest-update/">Vampire Survivors cheat codes added with latest update</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/vampire-survivors-cheat-codes-added-with-latest-update/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/vampire-survivors-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Vampire Survivors Review" title="Vampire Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vampire-Survivors-Review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/vampire-survivors-review/">Vampire Survivors review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 266020 info-bottom" data-postid="266020" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/vampire-survivors-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hard-west-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hard West 2 review" title="Hard West 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Hard-West-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hard-West-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hard-west-2-review/">Hard West 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/hard-west-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/two-point-campus-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus" title="Two Point Campus review" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/two-point-campus-review/">Two Point Campus review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/two-point-campus-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hooked on You title image" title="Hooked on You: A Dead by Daylight Dating Sim review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-10-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">Hooked on You: A Dead by Daylight Dating Sim review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/bear-and-breakfast-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bear and Breakfast Review" title="Bear and Breakfast review" srcset="https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bear-and-Breakfast-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">Bear and Breakfast review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares</a><div class="article-meta clearfix"><a class="like-button do-like 264061 info-bottom" data-postid="264061" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage</a></div><a class="hover-link" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/portal-companion-collection-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Portal-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Portal: Companion Collection title image" title="Portal: Companion Collection review" srcset="https://www.godisageek.com/wp-content/uploads/Portal-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Portal-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Portal-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Portal-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/portal-companion-collection-review/">Portal: Companion Collection review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 264964 info-bottom" data-postid="264964" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/portal-companion-collection-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hell-pie-review-rude-crude-and-brilliant/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apps.27228.13689613666172979.76a3fc1e-e7fc-4cba-bf09-f3f4b68d86ed-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Hell Pie Title Image" title="Hell Pie review" srcset="https://www.godisageek.com/wp-content/uploads/apps.27228.13689613666172979.76a3fc1e-e7fc-4cba-bf09-f3f4b68d86ed-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/apps.27228.13689613666172979.76a3fc1e-e7fc-4cba-bf09-f3f4b68d86ed-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/apps.27228.13689613666172979.76a3fc1e-e7fc-4cba-bf09-f3f4b68d86ed-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/apps.27228.13689613666172979.76a3fc1e-e7fc-4cba-bf09-f3f4b68d86ed-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hell-pie-review-rude-crude-and-brilliant/">Hell Pie review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/hell-pie-review-rude-crude-and-brilliant/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ai-the-somnium-files-nirvana-initiative-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/1920x1080_KeyartSS-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="AI: The Somnium Files - nirvanA Initiative title image" title="AI: The Somnium Files &#8211; nirvanA Initiative review" srcset="https://www.godisageek.com/wp-content/uploads/1920x1080_KeyartSS-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/1920x1080_KeyartSS-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/1920x1080_KeyartSS-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/1920x1080_KeyartSS-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ai-the-somnium-files-nirvana-initiative-review/">AI: The Somnium Files &#8211; nirvanA Initiative review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ai-the-somnium-files-nirvana-initiative-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/two-point-campus-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Two Point Campus" title="Two Point Campus review" srcset="https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Main-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/two-point-campus-review/">Two Point Campus review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/two-point-campus-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/xenoblade-chronicles-3-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-3-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xenoblade Chronicles 3 review" title="Xenoblade Chronicles 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-3-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-3-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-3-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xenoblade-Chronicles-3-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/xenoblade-chronicles-3-review/">Xenoblade Chronicles 3 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/xenoblade-chronicles-3-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Kudosh-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/08/two-point-campus-5-ways-to-earn-kudosh-fast/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Two Point Campus | 5 Ways to earn Kudosh fast</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Two-Point-Campus-Tips-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/08/two-point-campus-11-tips-to-help-you-get-started/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Two Point Campus | 11 Tips to help you get started</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MultiVersus-beginners-tips-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/07/multiversus-beginners-tips-rack-up-those-wins/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">MultiVersus beginners tips: rack up those wins</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Tea-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-make-the-tea/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Lord Winklebottom Investigates Walkthrough | Make the Tea</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Seance-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-have-a-seance/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Lord Winklebottom Investigates Walkthrough | Have a Seance</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Lord-Winklebottom-Investigates-Sail-Away-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/07/lord-winklebottom-investigates-walkthrough-sail-away/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Lord Winklebottom Investigates Walkthrough | Sail Away</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/vampire-survivors-review/">Vampire Survivors review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/vampire-survivors-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hard-west-2-review/">Hard West 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/hard-west-2-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/two-point-campus-review/">Two Point Campus review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/two-point-campus-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">Hooked on You: A Dead by Daylight Dating Sim review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/hooked-on-you-a-dead-by-daylight-dating-sim-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">Bear and Breakfast review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/bear-and-breakfast-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.230769230769px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.461538461538px;" aria-label="Activision (782 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.692307692308px;" aria-label="Bandai Namco (431 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.769230769231px;" aria-label="Capcom (723 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.615384615385px;" aria-label="DLC (481 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,172 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (409 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (570 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.307692307692px;" aria-label="Microsoft (940 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,798 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.153846153846px;" aria-label="nintendo switch (830 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,396 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.230769230769px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.846153846154px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 21.923076923077px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.076923076923px;" aria-label="PS4 (1,241 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.538461538462px;" aria-label="Sega (708 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.538461538462px;" aria-label="Sony (963 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.307692307692px;" aria-label="square enix (942 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.615384615385px;" aria-label="Steam (477 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.307692307692px;" aria-label="Trailer (684 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,312 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.076923076923px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.538461538462px;" aria-label="Xbox One (1,287 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.692307692308px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.230769230769px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12px;" aria-label="Competition (223 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.692307692308px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.307692307692px;" aria-label="Features (2,695 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 14.461538461538px;" aria-label="Guides (463 items)">Guides</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-7" style="font-size: 13.615384615385px;" aria-label="iOS (359 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-8" style="font-size: 27px;" aria-label="News (20,131 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-10" style="font-size: 15.307692307692px;" aria-label="Paid Placement Advertorials (597 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-11" style="font-size: 19.846153846154px;" aria-label="PC (2,346 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-12" style="font-size: 16.230769230769px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-13" style="font-size: 18.769230769231px;" aria-label="PlayStation 4 (1,715 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/reviews/playstation-5/" class="tag-cloud-link tag-link-27592 tag-link-position-14" style="font-size: 12.307692307692px;" aria-label="PlayStation 5 (242 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.153846153846px;" aria-label="Podcasts (769 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.846153846154px;" aria-label="Previews (949 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.307692307692px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 22.076923076923px;" aria-label="Reviews (4,533 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.615384615385px;" aria-label="Switch (890 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.692307692308px;" aria-label="Tech (275 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.923076923077px;" aria-label="Trailers (1,323 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13px;" aria-label="Uncategorised (300 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.076923076923px;" aria-label="Video Features (1,028 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.846153846154px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.076923076923px;" aria-label="Xbox One (1,384 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.821011673152px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.120622568093px;" aria-label="Android (83 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.626459143969px;" aria-label="Apple Arcade (13 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.143968871595px;" aria-label="Google Stadia (25 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.377431906615px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.112840466926px;" aria-label="iOS (123 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.019455252918px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.217898832685px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.552529182879px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,877 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.63813229572px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.708171206226px;" aria-label="PlayStation 4 (1,666 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 22.038910505837px;" aria-label="PlayStation 5 (260 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.36186770428px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.75486381323px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.249027237354px;" aria-label="Switch (933 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.420233463035px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.762645914397px;" aria-label="Xbox 360 (107 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.124513618677px;" aria-label="Xbox One (1,325 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.455252918288px;" aria-label="Xbox Series S (206 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 21.688715953307px;" aria-label="Xbox Series S|X (229 items)">Xbox Series S|X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
