<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="I’m sure Evil Genius 2: World Domination will have everybody stroking their white cats while laughing maniacally come the full release." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview | GodisaGeek.com" />
	<meta property="og:description" content="I’m sure Evil Genius 2: World Domination will have everybody stroking their white cats while laughing maniacally come the full release." />
	<meta property="og:url" content="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2021-02-16T15:00:40+00:00" />
	<meta property="article:modified_time" content="2021-02-16T08:16:18+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek.jpg","width":1920,"height":1080,"caption":"Evil Genius 2: World Domination preview"},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/#webpage","url":"https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/","name":"Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/#primaryimage"},"datePublished":"2021-02-16T15:00:40+00:00","dateModified":"2021-02-16T08:16:18+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/2d96dbb274a1684f7fc4794b0f3df075"},"description":"I\u2019m sure Evil Genius 2: World Domination will have everybody stroking their white cats while laughing maniacally come the full release.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/2d96dbb274a1684f7fc4794b0f3df075","name":"Mick Fraser","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/873c02c769987572481f2e8f3e058034?s=96&d=mm&r=g","caption":"Mick Fraser"},"description":"Senior Content Editor Mick has been playing games for over 30 years and writing about them for around 12. After drifting from site to site for a while, settling briefly at the now-defunct Made2Game and freelancing for the gone-but-not-forgotten NintendoGamer Magazine, he came at last to rest at Godisageek.\u00a0Mick has been a reviewer, staff writer and content editor here for some time, while also moonlighting a little for Red Bull Games. He has 4 kids, has written 2 novels, and sometimes even manages to pay a bill or two. You'll usually find him defending the galaxy in Destiny 2, battling evil in Diablo 3, or lurking in the background on Twitter. Find him there @Jedi_Beats_Tank, or on XBL (JediWaster247), PSN (Jedi_Waster) or Nintendo (JediWaster).","sameAs":["https://www.linkedin.com/profile/view?id=113409759&trk=nav_responsive_tab_profile","https://twitter.com/@Jedi_Beats_Tank"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"02","day":"16","hour":"15","minute":"00","second":"40","post_id":"246991","postname":"evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview","category":"previews"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/' />
<meta name='shareaholic:keywords' content='tag:evil genius 2, tag:evil genius 2: world domination, tag:preview, tag:rebellion developments, cat:features, cat:previews, type:post' />
<meta name='shareaholic:article_published_time' content='2021-02-16T15:00:40+00:00' />
<meta name='shareaholic:article_modified_time' content='2021-02-16T08:16:18+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Mick Fraser' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=246991' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F02%2Fevil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F02%2Fevil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-246991 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/">Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fortnite Short Nite Film Festival" title="Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend" srcset="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2 Sandbox Mode News" title="Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/50-minute-nintendo-direct-happening-tomorrow-at-10pm-uk-time/">50-minute Nintendo Direct happening tomorrow at 10pm UK time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct News" title="50-minute Nintendo Direct happening tomorrow at 10pm UK time" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/rocket-leagues-lucky-lanterns-event-live-now/">Rocket League&#8217;s &#8216;Lucky Lanterns&#8217; event live now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket League Lucky Lanterns" title="Rocket League&#8217;s &#8216;Lucky Lanterns&#8217; event live now" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/loads-of-games-including-kingdom-hearts-coming-to-epic-games-store/">Loads of games including Kingdom Hearts coming to Epic Games Store<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kingdom Hearts coming to Epic Games Store" title="Loads of games including Kingdom Hearts coming to Epic Games Store" srcset="https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/ratchet-clank-rift-apart-release-date-announced/">Ratchet &#038; Clank: Rift Apart release date announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart Release Date News" title="Ratchet &#038; Clank: Rift Apart release date announced" srcset="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">Super Mario 3D World + Bowser&#8217;s Fury review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario 3D World + Bowser&#039;s Fury review" title="Super Mario 3D World + Bowser&#8217;s Fury review" srcset="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/little-nightmares-2-review/">Little Nightmares II review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II review" title="Little Nightmares II review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/persona-5-strikers-review/">Persona 5 Strikers review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Review" title="Persona 5 Strikers review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">Persona 5 Strikers Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Switch review" title="Persona 5 Strikers Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">Blue Fire Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Blue Fire" title="Blue Fire Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/kinetic-edge-review/">Kinetic Edge review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kinectic Edge review (PC)" title="Kinetic Edge review" srcset="https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/podcast-431-bravely-default-2-persona-5-strikers-little-nightmares-ii/">Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 431" title="Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-431-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-431-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-431-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/we-are-really-excited-to-bring-jurassic-world-evolution-to-a-whole-new-set-of-players-interview-with-producer-brendon-morgan/">&#8220;We are really excited to bring Jurassic World Evolution to a whole new set of players&#8221;: Interview with Producer, Brendon Morgan<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Jurassic World Evolution Interview" title="&#8220;We are really excited to bring Jurassic World Evolution to a whole new set of players&#8221;: Interview with Producer, Brendon Morgan" srcset="https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/10-things-you-didnt-know-about-jurassic-world-evolution/">10 things you didn&#8217;t know about Jurassic World Evolution<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Jurassic World Evolution Tyrannosaurus Rex" title="10 things you didn&#8217;t know about Jurassic World Evolution" srcset="https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/bravely-default-2-is-a-gorgeous-and-glorious-return-for-the-series-hands-on-preview/">Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bravely Default 2 Preview" title="Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/podcast-430-13-sentinels-aegis-rim-control-ultimate-edition-god-of-war/">Podcast #430: 13 Sentinels: Aegis Rim, Control Ultimate Edition, God of War<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-430-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #430" title="Podcast #430: 13 Sentinels: Aegis Rim, Control Ultimate Edition, God of War" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-430-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-430-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-430-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-430-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/how-to-win-at-project-winter-the-ultimate-survival-guide/">How to win at Project Winter | The Ultimate Survival Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project Winter | How to win as a survivor" title="How to win at Project Winter | The Ultimate Survival Guide" srcset="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/the-medium-guide-how-to-solve-clock-puzzle/">The Medium guide | How to solve the clock puzzle<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Guide how to solve the clock puzzle" title="The Medium guide | How to solve the clock puzzle" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/how-to-get-silent-assassin-in-hitman-3-guide/">Hitman 3 guide | How to get the Silent Assassin rank<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hitman 3 Silent Assassin Rank Guide" title="Hitman 3 guide | How to get the Silent Assassin rank" srcset="https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/cyberpunk-2077-guide-how-to-romance-panam/">Cyberpunk 2077 guide | How to romance Panam<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk 2077 Romance Panam Sandstorm" title="Cyberpunk 2077 guide | How to romance Panam" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/bravely-default-2-is-a-gorgeous-and-glorious-return-for-the-series-hands-on-preview/">Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bravely Default 2 Preview" title="Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/lab-rat-is-looking-to-merge-puzzles-and-humour-together-demo-impressions/">Lab Rat is looking to merge puzzles and humour together | Demo Impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lab-Rat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lab Rat" title="Lab Rat is looking to merge puzzles and humour together | Demo Impressions" srcset="https://www.godisageek.com/wp-content/uploads/Lab-Rat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/mass-effect-legendary-edition-gameplay-changes-release-date/">Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date" title="Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date" srcset="https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-energy-supercross-4-nails-the-handling-to-provide-a-solid-experience-hands-on-preview/">Monster Energy Supercross 4 nails the handling to provide a solid experience | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 4 Preview" title="Monster Energy Supercross 4 nails the handling to provide a solid experience | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/bowsers-fury-hands-on-gameplay-super-mario-3d-world-switch/">Bowser&#8217;s Fury might be Nintendo testing the waters, and Super Mario 3D World is still a joy | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bowser&#039;s Fury might be Nintendo testing the waters, but Super Mario 3D World remains a joy" title="Bowser&#8217;s Fury might be Nintendo testing the waters, and Super Mario 3D World is still a joy | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/">Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fortnite Short Nite Film Festival" title="Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend" srcset="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2 Sandbox Mode News" title="Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/50-minute-nintendo-direct-happening-tomorrow-at-10pm-uk-time/">50-minute Nintendo Direct happening tomorrow at 10pm UK time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct News" title="50-minute Nintendo Direct happening tomorrow at 10pm UK time" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/rocket-leagues-lucky-lanterns-event-live-now/">Rocket League&#8217;s &#8216;Lucky Lanterns&#8217; event live now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rocket League Lucky Lanterns" title="Rocket League&#8217;s &#8216;Lucky Lanterns&#8217; event live now" srcset="https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rocket-League-Lucky-Lanterns-Event-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/loads-of-games-including-kingdom-hearts-coming-to-epic-games-store/">Loads of games including Kingdom Hearts coming to Epic Games Store<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kingdom Hearts coming to Epic Games Store" title="Loads of games including Kingdom Hearts coming to Epic Games Store" srcset="https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/KingdomHearts3-10-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/ratchet-clank-rift-apart-release-date-announced/">Ratchet &#038; Clank: Rift Apart release date announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart Release Date News" title="Ratchet &#038; Clank: Rift Apart release date announced" srcset="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Release-Date-News-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">Super Mario 3D World + Bowser&#8217;s Fury review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario 3D World + Bowser&#039;s Fury review" title="Super Mario 3D World + Bowser&#8217;s Fury review" srcset="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/little-nightmares-2-review/">Little Nightmares II review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II review" title="Little Nightmares II review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/persona-5-strikers-review/">Persona 5 Strikers review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Review" title="Persona 5 Strikers review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">Persona 5 Strikers Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Switch review" title="Persona 5 Strikers Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">Blue Fire Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Blue Fire" title="Blue Fire Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/kinetic-edge-review/">Kinetic Edge review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kinectic Edge review (PC)" title="Kinetic Edge review" srcset="https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/podcast-431-bravely-default-2-persona-5-strikers-little-nightmares-ii/">Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 431" title="Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-431-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-431-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-431-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/we-are-really-excited-to-bring-jurassic-world-evolution-to-a-whole-new-set-of-players-interview-with-producer-brendon-morgan/">&#8220;We are really excited to bring Jurassic World Evolution to a whole new set of players&#8221;: Interview with Producer, Brendon Morgan<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Jurassic World Evolution Interview" title="&#8220;We are really excited to bring Jurassic World Evolution to a whole new set of players&#8221;: Interview with Producer, Brendon Morgan" srcset="https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Jurassic-World-Evolution-Interview-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/10-things-you-didnt-know-about-jurassic-world-evolution/">10 things you didn&#8217;t know about Jurassic World Evolution<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Jurassic World Evolution Tyrannosaurus Rex" title="10 things you didn&#8217;t know about Jurassic World Evolution" srcset="https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/10-Things-You-Didnt-Know-About-Jurassic-World-Evolution-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/bravely-default-2-is-a-gorgeous-and-glorious-return-for-the-series-hands-on-preview/">Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bravely Default 2 Preview" title="Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/podcast-430-13-sentinels-aegis-rim-control-ultimate-edition-god-of-war/">Podcast #430: 13 Sentinels: Aegis Rim, Control Ultimate Edition, God of War<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-430-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #430" title="Podcast #430: 13 Sentinels: Aegis Rim, Control Ultimate Edition, God of War" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-430-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-430-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-430-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-430-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/how-to-win-at-project-winter-the-ultimate-survival-guide/">How to win at Project Winter | The Ultimate Survival Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project Winter | How to win as a survivor" title="How to win at Project Winter | The Ultimate Survival Guide" srcset="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/the-medium-guide-how-to-solve-clock-puzzle/">The Medium guide | How to solve the clock puzzle<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Guide how to solve the clock puzzle" title="The Medium guide | How to solve the clock puzzle" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/how-to-get-silent-assassin-in-hitman-3-guide/">Hitman 3 guide | How to get the Silent Assassin rank<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hitman 3 Silent Assassin Rank Guide" title="Hitman 3 guide | How to get the Silent Assassin rank" srcset="https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hitman-3-Silent-Assassin-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/cyberpunk-2077-guide-how-to-romance-panam/">Cyberpunk 2077 guide | How to romance Panam<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk 2077 Romance Panam Sandstorm" title="Cyberpunk 2077 guide | How to romance Panam" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/bravely-default-2-is-a-gorgeous-and-glorious-return-for-the-series-hands-on-preview/">Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bravely Default 2 Preview" title="Bravely Default 2 is a gorgeous and glorious return for the series | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bravely-Default-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/lab-rat-is-looking-to-merge-puzzles-and-humour-together-demo-impressions/">Lab Rat is looking to merge puzzles and humour together | Demo Impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lab-Rat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lab Rat" title="Lab Rat is looking to merge puzzles and humour together | Demo Impressions" srcset="https://www.godisageek.com/wp-content/uploads/Lab-Rat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lab-Rat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/mass-effect-legendary-edition-gameplay-changes-release-date/">Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date" title="Mass Effect Legendary Edition: gameplay changes, visual upgrades, and release date" srcset="https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mass-effect-legendary-edition-release-date-gameplay-changes-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-energy-supercross-4-nails-the-handling-to-provide-a-solid-experience-hands-on-preview/">Monster Energy Supercross 4 nails the handling to provide a solid experience | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 4 Preview" title="Monster Energy Supercross 4 nails the handling to provide a solid experience | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-4-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/bowsers-fury-hands-on-gameplay-super-mario-3d-world-switch/">Bowser&#8217;s Fury might be Nintendo testing the waters, and Super Mario 3D World is still a joy | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bowser&#039;s Fury might be Nintendo testing the waters, but Super Mario 3D World remains a joy" title="Bowser&#8217;s Fury might be Nintendo testing the waters, and Super Mario 3D World is still a joy | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bowsers-fury-hands-on-gameplay-preview-super-mario-3d-world-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2012/02/namco-bandai-encourage-touch-katamari-playstation-vita/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Virtual film festival "Short Nite" coming to Fortnite this weekend</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-246991" class="post-246991 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-previews tag-evil-genius-2 tag-evil-genius-2-world-domination tag-preview tag-rebellion-developments" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/mick-fraser/"><span itemprop="author">Mick Fraser </span></a></span><span class="date">on <meta itemprop="datePublished" content="February 16, 2021">February 16, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview' data-link='https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/' data-summary='Despicable You' data-app-id-name='post_above_content'></div>
<p>Even having never played the first <a href="https://rebellion.com/games/evil-genius/">Evil Genius</a>, I knew the kind of experience I was in for with the sequel within just a few minutes of booting it up. This is Dungeon Keeper by way of The Incredibles, in which you play as an OTT supervillain complete with an island hideout, legions of dutiful yet expendable minions, and an array of weapons and gadgets with which to repel the advances of the “good guys”, which in <a href="https://www.godisageek.com/2021/01/rebellion-announce-release-date-for-evil-genius-2-world-domination/">Evil Genius 2: World Domination</a> are represented as the secret agents, spies and investigators of the Forces of Justice, who are hell-bent on taking you down.</p>
<p>So it’s lair management, then, with the usual heaps of humour and colour, and a ton of imagination that allows you to live out your most diabolical evil fantasies including kidnapping, torture and world domination. Before you scream outrage, though, I should inform you that most of the torture involves foot-tickling and such – although it still results in the unlucky victim in a zip-lock bag waiting to be carted off to the secret agent compost heap.</p>
<p><img class="alignright size-large wp-image-246992" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-1024x576.jpg" alt="Evil Genius 2: World Domination " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-001.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>In the preview build I had access to the main playable antagonist, Maximillian, although the full game will feature three others including Ivan the Red, voiced by the legendary Brian Blessed. While you’re technically playing as the villain themselves, you take the role of a disembodied, all-seeing entity that can move around the complex at will, assign roles to your minions, build rooms and install equipment. You can even move your villain around, opting to increase productivity speeds in certain rooms simply by having them stand there giving the side-eye to their minions.</p>
<p>As in the first game and indeed other games in the stable, your first job will be to begin construction on the lair. This means constructing specific rooms like a Vault, a barracks and mess hall for your minions, and a lab to research more and more evil creations. You’ll train minions to take on different roles such as guards and scientists, while building a mini prison, and laying traps throughout your corridors to catch any snooping agent or spy who comes sticking their nose into your business.</p>
<p>While it’s quite relaxing to watch your minions schlepp back and forth performing menial tasks, the successful villain is a proactive villain, and you’ll want to be building and researching at all times. Mostly this will involve clearing space and watching your minions dig it out before buying items. In the demo build a lot of stuff is already available, which may need to be researched first in the full game. One thing I will say though, is that you can never have too many generators. Even with two power rooms and 8 generators running, I was constantly running out of power and needing to build more.</p>
<p><img class="alignright size-large wp-image-246993" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-1024x576.jpg" alt="Evil Genius 2: World Domination " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-002.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>Outside the lair you can visit the World Stage, where you can assign minions to Schemes that bring in a steady revenue of gold, or even send them to kidnap specialists who you can then tickle torture for information in order to train your own or unlock new research. An ever-expanding list of optional objectives, Side Stories (which usually introduce new specialists and research), and primary goals keeps you moving and building.</p>
<p>While there’s no “war” state, you will be defending your base against incursions by spies and agents, or groups thereof. You’ll need to build traps and assign guards to take them out quickly and quietly before either terminating them or interrogating them first. The life of an international supervillain is rarely a quiet one, and Evil Genius 2 certainly gives you an awful lot to focus on – though the tutorial does a good job of explaining everything.</p>
<p>Interestingly, this is a preview build rather than an early access release, and its current state gives me a lot of confidence for the finished product. The aesthetic is clean and colourful, with the ability to zoom right in or out to inspect your minions or the island itself. The art style has a definite sense of The Incredibles, with bright cartoony visuals and exaggerated movements. Perhaps because of the preview build, there were sound effects I expected to hear but didn’t, such as indicators of when you’ve picked an item up or dropped it, or entered and exited certain menus. It might be that these sound effects will never exist, but I feel they’re needed to give some sense agency – especially for those gamers who maybe rely more on sound effects to navigate through game menus. Likewise, some of the dialogue didn’t always trigger during the mostly static dialogue screens between Max and his minions.</p>
<p><img class="alignright size-large wp-image-246995" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-1024x576.jpg" alt="Evil Genius 2: World Domination " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-004.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>That being said, the preview build is pretty stable, running smoothly and not crashing or stalling at all. I did, however, encounter a bizarre bug that wouldn’t allow me to open the Save/Load menu without using a controller.</p>
<p>Evil Genius 2 has the potential to be a lot of fun. Sending out minions on Evil Schemes gives you something to constantly monitor, while building and expanding your lair through level upon level of labs, vaults, training rooms, secret prisons and communication arrays. It doesn’t have quite the same level of casual cruelty as, say, Dungeon Keeper where you can smack your imps around and sacrifice them for funsies, but it’s a deeper and more involved game than many of its stable mates – and one I’m sure will have everybody stroking white cats while laughing maniacally at come the full release.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview' data-link='https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/' data-summary='Despicable You' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview' data-link='https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/' data-summary='Despicable You' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/previews/" title="View all posts in Previews">Previews</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/evil-genius-2/" title="evil genius 2 Tag" class="evil-genius-2">evil genius 2</a><a href="https://www.godisageek.com/tag/evil-genius-2-world-domination/" title="evil genius 2: world domination Tag" class="evil-genius-2-world-domination">evil genius 2: world domination</a><a href="https://www.godisageek.com/tag/preview/" title="Preview Tag" class="preview">Preview</a><a href="https://www.godisageek.com/tag/rebellion-developments/" title="Rebellion Developments Tag" class="rebellion-developments">Rebellion Developments</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/mick-fraser/"><img alt='' src='https://secure.gravatar.com/avatar/873c02c769987572481f2e8f3e058034?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/873c02c769987572481f2e8f3e058034?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/mick-fraser/"><h3>Mick Fraser</h3></a>Senior Content Editor Mick has been playing games for over 30 years and writing about them for around 12. After drifting from site to site for a while, settling briefly at the now-defunct Made2Game and freelancing for the gone-but-not-forgotten NintendoGamer Magazine, he came at last to rest at Godisageek. Mick has been a reviewer, staff writer and content editor here for some time, while also moonlighting a little for Red Bull Games. He has 4 kids, has written 2 novels, and sometimes even manages to pay a bill or two. You'll usually find him defending the galaxy in Destiny 2, battling evil in Diablo 3, or lurking in the background on Twitter. Find him there @Jedi_Beats_Tank, or on XBL (JediWaster247), PSN (Jedi_Waster) or Nintendo (JediWaster).<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/@Jedi_Beats_Tank" target="_blank"></a><a class="icon-linkedin info" title="Find me on LinkedIn" href="http://www.linkedin.com/in/https://www.linkedin.com/profile/view?id=113409759&trk=nav_responsive_tab_profile" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:mick@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://GodisaGeek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="19849" data-method="tags" class="info active" title="More articles tagged: evil genius 2">evil genius 2<span class="bottom-arrow"></span></a><a data-sorter="27947" data-method="tags" class="info" title="More articles tagged: evil genius 2: world domination">evil genius 2: world domination<span class="bottom-arrow"></span></a><a data-sorter="75" data-method="tags" class="info" title="More articles tagged: Preview">Preview<span class="bottom-arrow"></span></a><a data-sorter="6439" data-method="tags" class="info" title="More articles tagged: Rebellion Developments">Rebellion Developments<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2 Sandbox Mode News" title="Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions</a></div><a class="hover-link" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2017/07/evil-genius-2-development-focussing-pc/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/evil-genius-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Evil Genius 2 is in development, focussing on PC for now" srcset="https://www.godisageek.com/wp-content/uploads/evil-genius-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/evil-genius-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/evil-genius-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/evil-genius-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2017/07/evil-genius-2-development-focussing-pc/">Evil Genius 2 is in development, focussing on PC for now</a></div><a class="hover-link" href="https://www.godisageek.com/2017/07/evil-genius-2-development-focussing-pc/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Fortnite Short Nite Film Festival" title="Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend" srcset="https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Short-Nite-Film-Festival-News-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/">Virtual film festival &#8220;Short Nite&#8221; coming to Fortnite this weekend</a><div class="article-meta clearfix"><a class="like-button do-like 247010 info-bottom" data-postid="247010" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/02/virtual-film-festival-short-nite-coming-to-fortnite-this-weekend/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination preview" title="Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-preview-godisageek-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">Evil Genius 2: World Domination will be diabolically jolly | Hands-on preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/02/evil-genius-2-world-domination-will-be-diabolically-jolly-hands-on-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2 Sandbox Mode News" title="Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Genius-2-Sandbox-Mode-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">Sandbox mode coming to Evil Genius 2, pre-orders live now for different editions</a></div><a class="hover-link" href="https://www.godisageek.com/2021/02/sandbox-mode-coming-to-evil-genius-2-pre-orders-live-now-for-different-editions/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/50-minute-nintendo-direct-happening-tomorrow-at-10pm-uk-time/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct News" title="50-minute Nintendo Direct happening tomorrow at 10pm UK time" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/50-minute-nintendo-direct-happening-tomorrow-at-10pm-uk-time/">50-minute Nintendo Direct happening tomorrow at 10pm UK time</a></div><a class="hover-link" href="https://www.godisageek.com/2021/02/50-minute-nintendo-direct-happening-tomorrow-at-10pm-uk-time/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/02/podcast-431-bravely-default-2-persona-5-strikers-little-nightmares-ii/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 431" title="Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-431-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-431-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-431-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-431-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/02/podcast-431-bravely-default-2-persona-5-strikers-little-nightmares-ii/">Podcast #431: Bravely Default 2, Persona 5 Strikers, Little Nightmares II</a></div><a class="hover-link" href="https://www.godisageek.com/2021/02/podcast-431-bravely-default-2-persona-5-strikers-little-nightmares-ii/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Super Mario 3D World + Bowser&#039;s Fury review" title="Super Mario 3D World + Bowser&#8217;s Fury review" srcset="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">Super Mario 3D World + Bowser&#8217;s Fury review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 246584 info-bottom" data-postid="246584" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/little-nightmares-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II review" title="Little Nightmares II review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">Little Nightmares II review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/persona-5-strikers-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Review" title="Persona 5 Strikers review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-strikers-review/">Persona 5 Strikers review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-strikers-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Switch review" title="Persona 5 Strikers Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">Persona 5 Strikers Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Blue Fire" title="Blue Fire Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">Blue Fire Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview</a><div class="article-meta clearfix"><a class="like-button do-like 246383 info-bottom" data-postid="246383" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video</a></div><a class="hover-link" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Super Mario 3D World + Bowser&#039;s Fury review" title="Super Mario 3D World + Bowser&#8217;s Fury review" srcset="https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">Super Mario 3D World + Bowser&#8217;s Fury review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 246584 info-bottom" data-postid="246584" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-nioh-collection-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/the-nioh-collection-review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Nioh Collection review" title="The Nioh Collection PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/the-nioh-collection-review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/the-nioh-collection-review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/the-nioh-collection-review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/the-nioh-collection-review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-nioh-collection-ps5-review/">The Nioh Collection PS5 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-nioh-collection-ps5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cyber-shadow-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/cyber-shadow-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyber Shadow title image" title="Cyber Shadow review" srcset="https://www.godisageek.com/wp-content/uploads/cyber-shadow-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/cyber-shadow-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/cyber-shadow-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/cyber-shadow-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cyber-shadow-review/">Cyber Shadow review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/cyber-shadow-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/little-nightmares-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II review" title="Little Nightmares II review" srcset="https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">Little Nightmares II review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/warframe-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warframe-PS5-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Warframe PS5 review" title="Warframe PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/Warframe-PS5-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Warframe-PS5-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Warframe-PS5-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Warframe-PS5-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/warframe-ps5-review/">Warframe PS5 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/warframe-ps5-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/super-mario-3d-world-bowsers-fury-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div><div class="article-info">Super Mario 3D World + Bowser&#8217;s Fury review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Little-Nightmares-II-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/little-nightmares-2-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Little Nightmares II review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/persona-5-strikers-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Persona 5 Strikers review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Switch-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Persona 5 Strikers Switch review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Blue-Fire-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Blue Fire Nintendo Switch review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/kinetic-edge-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/kinetic-edge-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.0</div></div></div><div class="article-info">Kinetic Edge review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">Super Mario 3D World + Bowser&#8217;s Fury review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">Little Nightmares II review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/little-nightmares-2-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-strikers-review/">Persona 5 Strikers review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-strikers-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">Persona 5 Strikers Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-strikers-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">Blue Fire Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/blue-fire-nintendo-switch-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 13.119402985075px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 19.164179104478px;" aria-label="Activision (773 items)">Activision</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-3" style="font-size: 12.671641791045px;" aria-label="Call of Duty (393 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-4" style="font-size: 17.373134328358px;" aria-label="Capcom (644 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-5" style="font-size: 14.462686567164px;" aria-label="DLC (477 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-6" style="font-size: 22.746268656716px;" aria-label="EA (1,121 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-7" style="font-size: 12.89552238806px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-8" style="font-size: 16.029850746269px;" aria-label="Konami (559 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-9" style="font-size: 20.955223880597px;" aria-label="Microsoft (935 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-10" style="font-size: 27px;" aria-label="nintendo (1,723 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-11" style="font-size: 18.940298507463px;" aria-label="nintendo switch (761 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-12" style="font-size: 24.537313432836px;" aria-label="PC (1,359 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-13" style="font-size: 21.850746268657px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-14" style="font-size: 14.686567164179px;" aria-label="PlayStation 4 (490 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-15" style="font-size: 22.522388059701px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-16" style="font-size: 23.641791044776px;" aria-label="PS4 (1,224 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-17" style="font-size: 17.597014925373px;" aria-label="Sega (663 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-18" style="font-size: 20.955223880597px;" aria-label="Sony (942 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-19" style="font-size: 20.507462686567px;" aria-label="square enix (887 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-20" style="font-size: 14.238805970149px;" aria-label="Steam (464 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-21" style="font-size: 17.820895522388px;" aria-label="Trailer (680 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-22" style="font-size: 23.865671641791px;" aria-label="Ubisoft (1,268 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/wii-u/" class="tag-cloud-link tag-link-4747 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (370 items)">Wii U</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.55223880597px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24.089552238806px;" aria-label="Xbox One (1,277 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 13.470588235294px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.955882352941px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.661764705882px;" aria-label="Competition (213 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 14.426470588235px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.088235294118px;" aria-label="Features (2,172 items)">Features</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-6" style="font-size: 12.661764705882px;" aria-label="Interview (212 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-7" style="font-size: 14.279411764706px;" aria-label="iOS (351 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-8" style="font-size: 27px;" aria-label="News (19,166 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-9" style="font-size: 15.897058823529px;" aria-label="Opinion (586 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-10" style="font-size: 14.058823529412px;" aria-label="Paid Placement Advertorials (329 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-11" style="font-size: 19.720588235294px;" aria-label="PC (1,960 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-12" style="font-size: 16.852941176471px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-13" style="font-size: 18.764705882353px;" aria-label="PlayStation 4 (1,449 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 16.485294117647px;" aria-label="Podcasts (701 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.852941176471px;" aria-label="Previews (794 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 14.058823529412px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 22.073529411765px;" aria-label="Reviews (4,035 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.191176470588px;" aria-label="Switch (646 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 13.25px;" aria-label="Tech (255 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.588235294118px;" aria-label="Trailers (1,010 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 13.691176470588px;" aria-label="Uncategorised (292 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 17.588235294118px;" aria-label="Video Features (1,002 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/wiiu/" class="tag-cloud-link tag-link-9285 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (171 items)">Wii U</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 16.485294117647px;" aria-label="Xbox 360 (713 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.029411764706px;" aria-label="Xbox One (1,142 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.4046692607px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.470817120623px;" aria-label="Android (75 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.568093385214px;" aria-label="Apple Arcade (10 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.385214007782px;" aria-label="Google Stadia (14 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.727626459144px;" aria-label="HTC Vive (25 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.579766536965px;" aria-label="iOS (116 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.428015564202px;" aria-label="Mac (33 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (3 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.727626459144px;" aria-label="Oculus Rift (25 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,485 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 21.221789883268px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.824902723735px;" aria-label="PlayStation 4 (1,393 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 17.836575875486px;" aria-label="PlayStation 5 (39 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.712062256809px;" aria-label="PlayStation VR (55 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 21.338521400778px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.073929961089px;" aria-label="Switch (683 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12.583657587549px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 19.003891050584px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 20.287937743191px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.241245136187px;" aria-label="Xbox One (1,089 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 16.552529182879px;" aria-label="Xbox Series S (23 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 17.428015564202px;" aria-label="Xbox Series X (33 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
