<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Podcast #410: Battletoads, Tony Hawk, UFC 4 - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Chris has been sportsing it up with some UFC 4 and PGA Tour 2K21, he&#039;s also been being super cool and edgy because he really likes the Battletoads." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" />
	<meta property="og:description" content="Chris has been sportsing it up with some UFC 4 and PGA Tour 2K21, he&#039;s also been being super cool and edgy because he really likes the Battletoads." />
	<meta property="og:url" content="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2020-08-26T06:01:28+00:00" />
	<meta property="article:modified_time" content="2020-08-25T15:47:14+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Podcast-410-1.png" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Reviews, News, Previews, Videos, Podcasts: the one stop you need for gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4.jpg","width":1280,"height":720,"caption":"Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21"},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/#webpage","url":"https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/","name":"Podcast #410: Battletoads, Tony Hawk, UFC 4 - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/#primaryimage"},"datePublished":"2020-08-26T06:01:28+00:00","dateModified":"2020-08-25T15:47:14+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"description":"Chris has been sportsing it up with some UFC 4 and PGA Tour 2K21, he's also been being super cool and edgy because he really likes the Battletoads.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/"]}]},{"@type":["Person"],"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21 Comments Feed" href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.11.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<!-- Note: MonsterInsights is not currently configured on this site. The site owner needs to authenticate with Google Analytics in the MonsterInsights settings panel. -->
<!-- No UA code set -->
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=240557' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F08%2Fpodcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F08%2Fpodcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-240557 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">Games of Summer is coming to Call of Duty Modern Warfare<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Games of Summer" title="Games of Summer is coming to Call of Duty Modern Warfare" srcset="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/new-inside-final-fantasy-crystal-chronicles-remastered-edition-video-launched/">New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Inside Final Fantasy Crystal Chronicles Remastered Edition" title="New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched" srcset="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/sega-release-brand-new-trailer-for-yakuza-like-a-dragon/">SEGA releases brand new trailer for Yakuza: Like a Dragon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Trailer Yakuza like a dragon" title="SEGA releases brand new trailer for Yakuza: Like a Dragon" srcset="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unnamed-24-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unnamed-24-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/unnamed-24-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/new-technomancer-class-revealed-for-outriders-in-latest-broadcast/">New Technomancer class revealed for Outriders in latest broadcast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders Technomancer" title="New Technomancer class revealed for Outriders in latest broadcast" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/naturalists/">New naturalists missions and items in Red Dead Online<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naturalists-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naturalists" title="New naturalists missions and items in Red Dead Online" srcset="https://www.godisageek.com/wp-content/uploads/Naturalists-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naturalists-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naturalists-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/the-best-themed-casinos-for-geeks/">The Best Themed Casinos for Geeks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/slot-machine-image-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Best Themed Casinos for Geeks" srcset="https://www.godisageek.com/wp-content/uploads/slot-machine-image-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">Hypnospace Outlaw review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Hypnospace Outlaw review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/no-straight-roads-review/">No Straight Roads review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="No Straight Roads review" srcset="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/project-cars-3-review/">Project CARS 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project CARS 3" title="Project CARS 3 review" srcset="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nexomon-extinction-review/">Nexomon: Extinction review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nexomon: Extinction review" srcset="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/descenders-review/">Descenders review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Descenders review" srcset="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/descenders-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/descenders-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pga-tour-2k21-review/">PGA Tour 2K21 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="PGA Tour 2K21 review" srcset="https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/">Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" title="Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" srcset="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/okunoka-madness-preview/">OkunoKA Madness promises to be an absolute delight | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="OkunoKA Madness promises to be an absolute delight | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/podcast-409-microsoft-flight-simulator-rogue-legacy-2-mortal-shell/">Podcast #409: Thrust Master &#8211; Rogue Legacy 2, Microsoft Flight Simulator, Mortal Shell<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Microsoft Flight Simulator, Rogue Legacy 2, Total War: Troy" title="Podcast #409: Thrust Master &#8211; Rogue Legacy 2, Microsoft Flight Simulator, Mortal Shell" srcset="https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/rogue-legacy-2-has-huge-potential-but-limited-content-right-now-early-access-preview/">Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Early Access" title="Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/returning-to-the-warehouse-is-about-as-amazing-as-i-remember-tony-hawk-pro-skater-1-2-remaster-demo-impressions/">Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions" srcset="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/how-to-get-resources-easily-in-a-total-war-saga-troy/">How to get resources easily in A Total War Saga: Troy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="total war saga troy resources" title="How to get resources easily in A Total War Saga: Troy" srcset="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/complete-guide-the-last-of-us-part-2-every-weapon-collectable/">A Complete Guide to The Last of Us Part II | Every Collectable and Weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A Complete Guide to The Last of Us Part II | Every Collectable and Weapon" srcset="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/desperados-iii-character-guide/">Desperados III | Character Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III Character Guide" title="Desperados III | Character Guide" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/10-desperados-iii-tips-to-help-you-out-in-the-wild-west/">10 Desperados III tips to help you out in the Wild West<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III tips" title="10 Desperados III tips to help you out in the Wild West" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/okunoka-madness-preview/">OkunoKA Madness promises to be an absolute delight | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="OkunoKA Madness promises to be an absolute delight | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/rogue-legacy-2-has-huge-potential-but-limited-content-right-now-early-access-preview/">Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Early Access" title="Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/returning-to-the-warehouse-is-about-as-amazing-as-i-remember-tony-hawk-pro-skater-1-2-remaster-demo-impressions/">Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions" srcset="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/pacer-is-a-nice-wipeout-homage-but-needs-work/">Pacer is a nice Wipeout homage, but still needs a bit of work | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pacer-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pacer is a nice Wipeout homage, but still needs a bit of work | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Pacer-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/gamedec-preview-an-intriguing-cyberpunk-detective-experience/">Gamedec preview | An intriguing cyberpunk detective experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gamedec-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gamedec preview" title="Gamedec preview | An intriguing cyberpunk detective experience" srcset="https://www.godisageek.com/wp-content/uploads/Gamedec-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-beta-impressions-the-heroes-we-deserve/">Marvel&#8217;s Avengers beta impressions | The Heroes we deserve?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Marvel Avengers beta" title="Marvel&#8217;s Avengers beta impressions | The Heroes we deserve?" srcset="https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">Games of Summer is coming to Call of Duty Modern Warfare<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Games of Summer" title="Games of Summer is coming to Call of Duty Modern Warfare" srcset="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/new-inside-final-fantasy-crystal-chronicles-remastered-edition-video-launched/">New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Inside Final Fantasy Crystal Chronicles Remastered Edition" title="New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched" srcset="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/sega-release-brand-new-trailer-for-yakuza-like-a-dragon/">SEGA releases brand new trailer for Yakuza: Like a Dragon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Trailer Yakuza like a dragon" title="SEGA releases brand new trailer for Yakuza: Like a Dragon" srcset="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unnamed-24-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unnamed-24-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/unnamed-24-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/new-technomancer-class-revealed-for-outriders-in-latest-broadcast/">New Technomancer class revealed for Outriders in latest broadcast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders Technomancer" title="New Technomancer class revealed for Outriders in latest broadcast" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/naturalists/">New naturalists missions and items in Red Dead Online<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naturalists-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naturalists" title="New naturalists missions and items in Red Dead Online" srcset="https://www.godisageek.com/wp-content/uploads/Naturalists-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naturalists-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naturalists-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/the-best-themed-casinos-for-geeks/">The Best Themed Casinos for Geeks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/slot-machine-image-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Best Themed Casinos for Geeks" srcset="https://www.godisageek.com/wp-content/uploads/slot-machine-image-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/slot-machine-image-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">Hypnospace Outlaw review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Hypnospace Outlaw review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/no-straight-roads-review/">No Straight Roads review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="No Straight Roads review" srcset="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/project-cars-3-review/">Project CARS 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project CARS 3" title="Project CARS 3 review" srcset="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nexomon-extinction-review/">Nexomon: Extinction review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nexomon: Extinction review" srcset="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/descenders-review/">Descenders review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Descenders review" srcset="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/descenders-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/descenders-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pga-tour-2k21-review/">PGA Tour 2K21 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="PGA Tour 2K21 review" srcset="https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/">Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" title="Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" srcset="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/okunoka-madness-preview/">OkunoKA Madness promises to be an absolute delight | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="OkunoKA Madness promises to be an absolute delight | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/podcast-409-microsoft-flight-simulator-rogue-legacy-2-mortal-shell/">Podcast #409: Thrust Master &#8211; Rogue Legacy 2, Microsoft Flight Simulator, Mortal Shell<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Microsoft Flight Simulator, Rogue Legacy 2, Total War: Troy" title="Podcast #409: Thrust Master &#8211; Rogue Legacy 2, Microsoft Flight Simulator, Mortal Shell" srcset="https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-409-microsoft-flight-simulator-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/rogue-legacy-2-has-huge-potential-but-limited-content-right-now-early-access-preview/">Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Early Access" title="Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/returning-to-the-warehouse-is-about-as-amazing-as-i-remember-tony-hawk-pro-skater-1-2-remaster-demo-impressions/">Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions" srcset="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/how-to-get-resources-easily-in-a-total-war-saga-troy/">How to get resources easily in A Total War Saga: Troy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="total war saga troy resources" title="How to get resources easily in A Total War Saga: Troy" srcset="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/complete-guide-the-last-of-us-part-2-every-weapon-collectable/">A Complete Guide to The Last of Us Part II | Every Collectable and Weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="A Complete Guide to The Last of Us Part II | Every Collectable and Weapon" srcset="https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/TLoU2-Seattle-Day-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/desperados-iii-character-guide/">Desperados III | Character Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III Character Guide" title="Desperados III | Character Guide" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-Character-Guide-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/06/10-desperados-iii-tips-to-help-you-out-in-the-wild-west/">10 Desperados III tips to help you out in the Wild West<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Desperados III tips" title="10 Desperados III tips to help you out in the Wild West" srcset="https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Desperados-III-tips-11-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/08/okunoka-madness-preview/">OkunoKA Madness promises to be an absolute delight | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="OkunoKA Madness promises to be an absolute delight | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/okunoka-madness-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/rogue-legacy-2-has-huge-potential-but-limited-content-right-now-early-access-preview/">Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rogue Legacy 2 Early Access" title="Rogue Legacy 2 has huge potential, but limited content right now | Early Access preview" srcset="https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rogue-Legacy-2-Early-Access-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/returning-to-the-warehouse-is-about-as-amazing-as-i-remember-tony-hawk-pro-skater-1-2-remaster-demo-impressions/">Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Returning to The Warehouse is about as amazing as I remember | Tony Hawk Pro Skater 1 + 2 Remaster demo impressions" srcset="https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/THPS_WAREHOUSE-TOUT-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/pacer-is-a-nice-wipeout-homage-but-needs-work/">Pacer is a nice Wipeout homage, but still needs a bit of work | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pacer-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pacer is a nice Wipeout homage, but still needs a bit of work | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Pacer-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pacer-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/gamedec-preview-an-intriguing-cyberpunk-detective-experience/">Gamedec preview | An intriguing cyberpunk detective experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gamedec-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gamedec preview" title="Gamedec preview | An intriguing cyberpunk detective experience" srcset="https://www.godisageek.com/wp-content/uploads/Gamedec-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gamedec-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-beta-impressions-the-heroes-we-deserve/">Marvel&#8217;s Avengers beta impressions | The Heroes we deserve?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Marvel Avengers beta" title="Marvel&#8217;s Avengers beta impressions | The Heroes we deserve?" srcset="https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Marvel-Avengers-beta-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/?utm_source=rss&utm_medium=rss&utm_campaign=podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/?utm_source=rss&utm_medium=rss&utm_campaign=podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Games of Summer is coming to Call of Duty Modern Warfare</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2016/04/aliens-colonial-marines-overhauled-by-modders-mod/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-240557" class="post-240557 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-podcasts tag-battletoads tag-feat tag-microsoft-flight-simulator tag-pga-tour-2k21 tag-podcast tag-tony-hawks-pro-skater-1-2 tag-ufc-4" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="August 26, 2020">August 26, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" title="Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix">
<p>Chris has been sportsing it up with some <a href="https://www.godisageek.com/reviews/ufc-4-review/">UFC 4</a> and PGA Tour 2K21, which he and Adam Cook are both fans of. But he&#8217;s also been being super cool and edgy because he really likes the 2020 reboot of <a href="https://www.godisageek.com/reviews/battletoads-review/">Battletoads</a>.<br /><br />Adam Carroll, Cook, and Mr White have all fallen head over heels in love with the <a href="https://www.godisageek.com/2020/08/returning-to-the-warehouse-is-about-as-amazing-as-i-remember-tony-hawk-pro-skater-1-2-remaster-demo-impressions/">Tony Hawk&#8217;s Pro Skater 1 + 2 demo</a> and cannot wait for the full game, too.<br /><br />A few listener questions this week, which are about beating up game characters and remaking old classics.</p>
<div class='video_frame'><iframe id='youtube_video_2' class='youtube_video' src='https://www.youtube.com/embed/jFC798olX50?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p><a href="https://mcdn.podbean.com/mf/web/ysdx2e/podcast410-start-the-hole.mp3">Download this episode in mp3 format, here</a>.</p>
<p><iframe style="border: none;" title="410. Tony Hawk, Battletoads, UFC4" src="https://www.podbean.com/media/player/gbypb-e7f712?from=pb6admin&amp;download=1&amp;version=1&amp;auto=0&amp;share=1&amp;download=1&amp;rtl=0&amp;fonts=Helvetica&amp;skin=1&amp;pfauth=&amp;btn-skin=113" width="100%" height="122" scrolling="no" data-name="pb-iframe-player"></iframe></p>
<p>We&#8217;re on <a href="https://open.spotify.com/show/3fwGcJMBQCFjbIm3r8eruZ">Spotify, too</a>, so you can even listen there!</p>
<h4>Support and follow us!</h4>
<p>While we have you, you can <a href="http://patreon.com/godisageek">hear this podcast early on Patreon for as little as $1 a month</a>. That&#8217;s less than £1. Yep, around a tenner a year for early access as well as multiple other bonuses depending on the tier you back us at!</p>
<p>Is there a particular game you want us to talk about, by the way? You can email us at podcast@godisageek.com or Tweet us via <a href="http://twitter.com/GodisaGeek">@GodisaGeek</a>. Just drop us a line, even if it&#8217;s about food, or just how much you love us, your favourite gaming podcast.</p>
<p>&nbsp;</p>
<p></p><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/features/podcasts/" title="View all posts in Podcasts">Podcasts</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/battletoads/" title="Battletoads Tag" class="battletoads">Battletoads</a><a href="https://www.godisageek.com/tag/feat/" title="feat Tag" class="feat">feat</a><a href="https://www.godisageek.com/tag/microsoft-flight-simulator/" title="Microsoft Flight Simulator Tag" class="microsoft-flight-simulator">Microsoft Flight Simulator</a><a href="https://www.godisageek.com/tag/pga-tour-2k21/" title="PGA Tour 2K21 Tag" class="pga-tour-2k21">PGA Tour 2K21</a><a href="https://www.godisageek.com/tag/podcast/" title="Podcast Tag" class="podcast">Podcast</a><a href="https://www.godisageek.com/tag/tony-hawks-pro-skater-1-2/" title="Tony Hawk's Pro Skater 1 + 2 Tag" class="tony-hawks-pro-skater-1-2">Tony Hawk's Pro Skater 1 + 2</a><a href="https://www.godisageek.com/tag/ufc-4/" title="ufc 4 Tag" class="ufc-4">ufc 4</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="6795" data-method="tags" class="info active" title="More articles tagged: Battletoads">Battletoads<span class="bottom-arrow"></span></a><a data-sorter="13083" data-method="tags" class="info" title="More articles tagged: feat">feat<span class="bottom-arrow"></span></a><a data-sorter="27093" data-method="tags" class="info" title="More articles tagged: Microsoft Flight Simulator">Microsoft Flight Simulator<span class="bottom-arrow"></span></a><a data-sorter="26145" data-method="tags" class="info" title="More articles tagged: PGA Tour 2K21">PGA Tour 2K21<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/battletoads-achievements-list/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Battletoads-Achievements-List-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Battletoads Achievements List" title="The Battletoads achievements list has been revealed" srcset="https://www.godisageek.com/wp-content/uploads/Battletoads-Achievements-List-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Battletoads-Achievements-List-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Battletoads-Achievements-List-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Battletoads-Achievements-List-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/battletoads-achievements-list/">The Battletoads achievements list has been revealed</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/battletoads-achievements-list/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/battletoads-arrives-on-xbox-game-pass-in-august/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/BT2020_Toads_vs_Porkshank_PNG-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Battletoads Arrives on Xbox Game Pass in August" srcset="https://www.godisageek.com/wp-content/uploads/BT2020_Toads_vs_Porkshank_PNG-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/BT2020_Toads_vs_Porkshank_PNG-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/BT2020_Toads_vs_Porkshank_PNG-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/BT2020_Toads_vs_Porkshank_PNG-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/battletoads-arrives-on-xbox-game-pass-in-august/">Battletoads Arrives on Xbox Game Pass in August</a></div><a class="hover-link" href="https://www.godisageek.com/2020/07/battletoads-arrives-on-xbox-game-pass-in-august/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2018/06/battletoads-back-watch-teaser-trailer-microsoft-e3-2018-press-conference/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/battletoads-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Battletoads are back! Watch the teaser trailer from the Microsoft E3 2018 press conference." srcset="https://www.godisageek.com/wp-content/uploads/battletoads-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/battletoads-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/battletoads-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/battletoads-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/battletoads-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2018/06/battletoads-back-watch-teaser-trailer-microsoft-e3-2018-press-conference/">Battletoads are back! Watch the teaser trailer from the Microsoft E3 2018 press conference.</a></div><a class="hover-link" href="https://www.godisageek.com/2018/06/battletoads-back-watch-teaser-trailer-microsoft-e3-2018-press-conference/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rare-replay-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rare-Replay-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Rare Replay Review" srcset="https://www.godisageek.com/wp-content/uploads/Rare-Replay-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rare-Replay-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rare-Replay-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Rare-Replay-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rare-replay-review/">Rare Replay Review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/rare-replay-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2015/06/e3-2015-microsoft-predictions/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adam-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="E3 2015: What Will Microsoft Do?" srcset="https://www.godisageek.com/wp-content/uploads/Adam-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Adam-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Adam-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Adam-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Adam-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2015/06/e3-2015-microsoft-predictions/">E3 2015: What Will Microsoft Do?</a></div><a class="hover-link" href="https://www.godisageek.com/2015/06/e3-2015-microsoft-predictions/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2013/07/retrocast-21-battletoads-nes/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/battletoadsfeatured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Retrocast #21 - Battletoads (NES)" title="The Retrocast #21 &#8211; Battletoads (NES)" srcset="https://www.godisageek.com/wp-content/uploads/battletoadsfeatured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/battletoadsfeatured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/battletoadsfeatured-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/battletoadsfeatured-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2013/07/retrocast-21-battletoads-nes/">The Retrocast #21 &#8211; Battletoads (NES)</a></div><a class="hover-link" href="https://www.godisageek.com/2013/07/retrocast-21-battletoads-nes/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                             

        
<div id="comments">
    <div class="filterbar">
        <div class="sort-buttons" data-number="" data-type="comment">
        	<div class="ribbon-wrapper">
				<div class="ribbon">
					<span class="icon-comments"></span>
					Be the first to comment!                    <div class="ribbon-separator">&nbsp;</div>
				</div>
			</div>
           
            <a class="reply-link" href="#reply-form">Leave a reply &raquo;</a>
            
             
                       
        </div>
        <br class="clearer" />
    </div>
     
    <div class="loading"><div>&nbsp;</div></div>
    
    <div class="comment-list-wrapper">
         <ul class="comment-list">            
        	 
         </ul>
    </div>
</div>


	<div id="reply-form">

		        
            <p>You must&nbsp;<a href="https://www.godisageek.com/wp-login.php" title="log in">log in</a>&nbsp;to post a comment </p>
            
            
    </div>

                                                        
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Podcast #410: Start the Hole - Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" title="Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21" srcset="https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-410-tony-hawk-battletoads-ufc-4-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/">Podcast #410: Start the Hole &#8211; Battletoads, Tony Hawk demo, UFC 4, PGA Tour 2K21</a><div class="article-meta clearfix"><a class="like-button do-like 240557 info-bottom" data-postid="240557" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/08/podcast-410-start-the-hole-battletoads-tony-hawk-demo-ufc-4-pga-tour-2k21/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Games of Summer" title="Games of Summer is coming to Call of Duty Modern Warfare" srcset="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">Games of Summer is coming to Call of Duty Modern Warfare</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/new-inside-final-fantasy-crystal-chronicles-remastered-edition-video-launched/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Inside Final Fantasy Crystal Chronicles Remastered Edition" title="New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched" srcset="https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Inside-Final-Fantasy-Crystal-Chronicles-Remastered-Edition-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/new-inside-final-fantasy-crystal-chronicles-remastered-edition-video-launched/">New Inside Final Fantasy Crystal Chronicles Remastered Edition video launched</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/new-inside-final-fantasy-crystal-chronicles-remastered-edition-video-launched/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/sega-release-brand-new-trailer-for-yakuza-like-a-dragon/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Trailer Yakuza like a dragon" title="SEGA releases brand new trailer for Yakuza: Like a Dragon" srcset="https://www.godisageek.com/wp-content/uploads/unnamed-24-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unnamed-24-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unnamed-24-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/unnamed-24-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/sega-release-brand-new-trailer-for-yakuza-like-a-dragon/">SEGA releases brand new trailer for Yakuza: Like a Dragon</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/sega-release-brand-new-trailer-for-yakuza-like-a-dragon/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/new-technomancer-class-revealed-for-outriders-in-latest-broadcast/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders Technomancer" title="New Technomancer class revealed for Outriders in latest broadcast" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Technomancer-1-min-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/new-technomancer-class-revealed-for-outriders-in-latest-broadcast/">New Technomancer class revealed for Outriders in latest broadcast</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/new-technomancer-class-revealed-for-outriders-in-latest-broadcast/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Hypnospace Outlaw review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">Hypnospace Outlaw review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 240800 info-bottom" data-postid="240800" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/no-straight-roads-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="No Straight Roads review" srcset="https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/no-straight-roads-review/">No Straight Roads review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/no-straight-roads-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/project-cars-3-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project CARS 3" title="Project CARS 3 review" srcset="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/project-cars-3-review/">Project CARS 3 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/project-cars-3-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nexomon-extinction-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nexomon: Extinction review" srcset="https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nexomon-extinction-review/">Nexomon: Extinction review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/nexomon-extinction-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/descenders-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Descenders review" srcset="https://www.godisageek.com/wp-content/uploads/descenders-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/descenders-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/descenders-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/descenders-review/">Descenders review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/descenders-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great</a><div class="article-meta clearfix"><a class="like-button do-like 231548 info-bottom" data-postid="231548" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">-36</span></a><span class="metric info-bottom" title="Comments"><span class="icon icon-commented"></span><span class="numcount">55</span></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/horizon-zero-dawn-complete-edition-pc-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/horizon-zero-dawn-complete-edition-pc-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Horizon Zero Dawn: Complete Edition PC review" title="Horizon Zero Dawn: Complete Edition PC review" srcset="https://www.godisageek.com/wp-content/uploads/horizon-zero-dawn-complete-edition-pc-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/horizon-zero-dawn-complete-edition-pc-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/horizon-zero-dawn-complete-edition-pc-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/horizon-zero-dawn-complete-edition-pc-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/horizon-zero-dawn-complete-edition-pc-review/">Horizon Zero Dawn: Complete Edition PC review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 240054 info-bottom" data-postid="240054" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">3</span></a><span class="metric info-bottom" title="Comments"><span class="icon icon-commented"></span><span class="numcount">5</span></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/horizon-zero-dawn-complete-edition-pc-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/pistol-whip-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/pistol-whip-review-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Pistol Whip review" srcset="https://www.godisageek.com/wp-content/uploads/pistol-whip-review-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/pistol-whip-review-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/pistol-whip-review-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/pistol-whip-review-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/pistol-whip-review/">Pistol Whip review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/pistol-whip-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Hypnospace Outlaw review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">Hypnospace Outlaw review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/project-cars-3-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project CARS 3" title="Project CARS 3 review" srcset="https://www.godisageek.com/wp-content/uploads/PC-3-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/PC-3-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/project-cars-3-review/">Project CARS 3 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/project-cars-3-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/battletoads-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/battletoads-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Battletoads review" srcset="https://www.godisageek.com/wp-content/uploads/battletoads-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/battletoads-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/battletoads-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/battletoads-review/">Battletoads review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/battletoads-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Switch_HypnospaceOutlaw_Hero-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/hypnospace-outlaw-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div><div class="article-info">Hypnospace Outlaw review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/no-straight-roads-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/no-straight-roads-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">No Straight Roads review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/PC-3-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/project-cars-3-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Project CARS 3 review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/nexomon-extinction-switch-hero-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/nexomon-extinction-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Nexomon: Extinction review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/descenders-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/descenders-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Descenders review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/pga-tour-2k21-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/pga-tour-2k21-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">PGA Tour 2K21 review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Remnant-DLC-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/remnant-from-the-ashes-subject-2923-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Remnant: From the Ashes &#8211; Subject 2923 review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Samurai-Jack-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/samurai-jack-battle-through-time-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Samurai Jack: Battle Through Time review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Sades-Locuts-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/sades-locust-plus-gaming-headset-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Sades Locust Plus Gaming Headset review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/shenzhen-red-horse-technology-co-ltd-m-usd-headset-red5-nova-gaming-headset-16671048761388_2000x-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/red5-nova-gaming-headset-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">RED5 Nova Gaming Headset review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/


Served from: godisageek.com @ 2020-08-26 07:57:32 by W3 Total Cache
-->