<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Okinawa Rush review | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="A love letter to days of ninja platforming past, Okinawa Rush is a tough as teak challenge that will keep you glued to your Switch." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/reviews/okinawa-rush-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Okinawa Rush review | GodisaGeek.com" />
	<meta property="og:description" content="A love letter to days of ninja platforming past, Okinawa Rush is a tough as teak challenge that will keep you glued to your Switch." />
	<meta property="og:url" content="https://www.godisageek.com/reviews/okinawa-rush-review/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/reviews/okinawa-rush-review/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1.jpg","width":1280,"height":720,"caption":"Okinawa Rush"},{"@type":"WebPage","@id":"https://www.godisageek.com/reviews/okinawa-rush-review/#webpage","url":"https://www.godisageek.com/reviews/okinawa-rush-review/","name":"Okinawa Rush review | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/reviews/okinawa-rush-review/#primaryimage"},"datePublished":"2021-11-21T14:48:43+00:00","dateModified":"2021-11-21T14:48:43+00:00","description":"A love letter to days of ninja platforming past, Okinawa Rush is a tough as teak challenge that will keep you glued to your Switch.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/reviews/okinawa-rush-review/"]}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"11","day":"21","hour":"14","minute":"48","second":"43","post_id":"257741","postname":"okinawa-rush-review","category":"reviews\/switch-reviews"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/reviews/okinawa-rush-review/' />
<meta name='shareaholic:keywords' content='tag:just for games, tag:no gravity games, tag:okinawa rush, tag:sokaikan limited, tag:storybird games, cat:pc, cat:playstation 4, cat:reviews, cat:switch, cat:xbox one, type:it_reviews' />
<meta name='shareaholic:article_published_time' content='2021-11-21T14:48:43+00:00' />
<meta name='shareaholic:article_modified_time' content='2021-11-21T14:48:43+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Sean Smith' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=257741' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fokinawa-rush-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fokinawa-rush-review%2F&#038;format=xml" />
    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '5befbd9c56'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="it_reviews-template-default single single-it_reviews postid-257741 it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/world-war-z-switch-review/">World War Z Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="World War Z Nintendo Switch" title="World War Z Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-700x672.png 700w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">Wraith: The Oblivion &#8211; Afterlife review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wraith: The Oblivion - Afterlife" title="Wraith: The Oblivion &#8211; Afterlife review" srcset="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/okinawa-rush-review/">Okinawa Rush review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Okinawa Rush" title="Okinawa Rush review" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">Tandem: A Tale of Shadows review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tandem: A Tale of Shadows" title="Tandem: A Tale of Shadows review" srcset="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">Stealth SP-C160 V Ultimate Gaming Station for PS5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Stealth SP-C160 V Ultimate Gaming Station" title="Stealth SP-C160 V Ultimate Gaming Station for PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/gamesir-t4-mini-multiplatform-gaming-controller-review/">GameSir T4 Mini Multiplatform Gaming Controller review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GameSir T4 Mini" title="GameSir T4 Mini Multiplatform Gaming Controller review" srcset="https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/podcast-469-gta-trilogy-halo-infinite-pokemon-brilliant-diamond/">Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond" title="Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/wwe-2k22-is-looking-like-a-step-in-the-right-direciton-preview/">WWE 2K22 is looking like a step in the right direction | hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K22 is looking like a step in the right direction | hands-off preview" title="WWE 2K22 is looking like a step in the right direction | hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/far-cry-6-vaas-insanity-all-silver-dragon-blade-locations/">Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vaas Insanity Silver Dragon Blade Location Guide" title="Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations" srcset="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/outriders-new-horizon-update-hands-on/">Outriders: New Horizon update could be the beginning of an exciting new era | hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders New Horizon" title="Outriders: New Horizon update could be the beginning of an exciting new era | hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-archive-guide/">Sherlock Holmes: Chapter One archive guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One archive" title="Sherlock Holmes: Chapter One archive guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-chemical-analysis-guide/">Sherlock Holmes: Chapter One chemical analysis guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One chemical analysis" title="Sherlock Holmes: Chapter One chemical analysis guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/far-cry-6-vaas-insanity-all-silver-dragon-blade-locations/">Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vaas Insanity Silver Dragon Blade Location Guide" title="Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations" srcset="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-archive-guide/">Sherlock Holmes: Chapter One archive guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One archive" title="Sherlock Holmes: Chapter One archive guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-chemical-analysis-guide/">Sherlock Holmes: Chapter One chemical analysis guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One chemical analysis" title="Sherlock Holmes: Chapter One chemical analysis guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-tips-and-tricks/">Sherlock Holmes: Chapter One tips and tricks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One tips" title="Sherlock Holmes: Chapter One tips and tricks" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-cnt-tips-getting-started-in-the-lands-between/">Elden Ring CNT tips | Getting started in the Lands Between<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Elden Ring CNT tips | Getting started in the Lands Between" title="Elden Ring CNT tips | Getting started in the Lands Between" srcset="https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/fifa-22-fut-10-fastest-players/">FIFA 22 FUT | 10 Fastest players<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="FIFA 22 FUT 10 Fastest Players Guide" title="FIFA 22 FUT | 10 Fastest players" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/star-citizen-is-free-to-play-from-today/">Star Citizen is free to play from today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Citizen free" title="Star Citizen is free to play from today" srcset="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/disco-elysium-the-final-cut-physical-editions-out-now-for-xbox-one-and-ps4/">Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium – The Final Cut physical editions" title="Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-700x676.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/first-expansion-for-risk-of-rain-2-survivors-of-the-void-coming-2022/">First expansion for Risk of Rain 2, Survivors of the Void, coming 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Survivors of the Void Announcement News" title="First expansion for Risk of Rain 2, Survivors of the Void, coming 2022" srcset="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/multiversus-announced-by-warner-bros-games/">MultiVersus announced by Warner Bros. Games<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus Announcement News" title="MultiVersus announced by Warner Bros. Games" srcset="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/new-world-into-the-void-version-1-1-detailed-coming-today/">New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New World &quot;Into the Void&quot; version 1.1 detailed, coming today" title="New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today" srcset="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/warhammer-age-of-sigmar-tempestfall-out-now-for-vr/">Warhammer Age of Sigmar: Tempestfall out now for VR<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wa-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Age of Sigmar Tempestfall" title="Warhammer Age of Sigmar: Tempestfall out now for VR" srcset="https://www.godisageek.com/wp-content/uploads/wa-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wa-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wa-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/wa-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.youtube.com/user/GodisaGeek">Subscribe</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Support us</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/world-war-z-switch-review/">World War Z Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="World War Z Nintendo Switch" title="World War Z Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-700x672.png 700w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">Wraith: The Oblivion &#8211; Afterlife review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wraith: The Oblivion - Afterlife" title="Wraith: The Oblivion &#8211; Afterlife review" srcset="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/okinawa-rush-review/">Okinawa Rush review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Okinawa Rush" title="Okinawa Rush review" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">Tandem: A Tale of Shadows review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tandem: A Tale of Shadows" title="Tandem: A Tale of Shadows review" srcset="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">Stealth SP-C160 V Ultimate Gaming Station for PS5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Stealth SP-C160 V Ultimate Gaming Station" title="Stealth SP-C160 V Ultimate Gaming Station for PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/gamesir-t4-mini-multiplatform-gaming-controller-review/">GameSir T4 Mini Multiplatform Gaming Controller review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GameSir T4 Mini" title="GameSir T4 Mini Multiplatform Gaming Controller review" srcset="https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GameSir-T4-Mini-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/podcast-469-gta-trilogy-halo-infinite-pokemon-brilliant-diamond/">Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond" title="Podcast 469: GTA Trilogy, Halo Infinite, Pokemon Brilliant Diamond" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-469-GTA-Trilogy-Halo-Infinite-Pokemon-Brilliant-Diamond-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/wwe-2k22-is-looking-like-a-step-in-the-right-direciton-preview/">WWE 2K22 is looking like a step in the right direction | hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K22 is looking like a step in the right direction | hands-off preview" title="WWE 2K22 is looking like a step in the right direction | hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/far-cry-6-vaas-insanity-all-silver-dragon-blade-locations/">Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vaas Insanity Silver Dragon Blade Location Guide" title="Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations" srcset="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/outriders-new-horizon-update-hands-on/">Outriders: New Horizon update could be the beginning of an exciting new era | hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders New Horizon" title="Outriders: New Horizon update could be the beginning of an exciting new era | hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-New-Horizon-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-archive-guide/">Sherlock Holmes: Chapter One archive guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One archive" title="Sherlock Holmes: Chapter One archive guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-chemical-analysis-guide/">Sherlock Holmes: Chapter One chemical analysis guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One chemical analysis" title="Sherlock Holmes: Chapter One chemical analysis guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/far-cry-6-vaas-insanity-all-silver-dragon-blade-locations/">Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Vaas Insanity Silver Dragon Blade Location Guide" title="Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations" srcset="https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-archive-guide/">Sherlock Holmes: Chapter One archive guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One archive" title="Sherlock Holmes: Chapter One archive guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-chemical-analysis-guide/">Sherlock Holmes: Chapter One chemical analysis guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One chemical analysis" title="Sherlock Holmes: Chapter One chemical analysis guide" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-tips-and-tricks/">Sherlock Holmes: Chapter One tips and tricks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sherlock Holmes Chapter One tips" title="Sherlock Holmes: Chapter One tips and tricks" srcset="https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-cnt-tips-getting-started-in-the-lands-between/">Elden Ring CNT tips | Getting started in the Lands Between<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Elden Ring CNT tips | Getting started in the Lands Between" title="Elden Ring CNT tips | Getting started in the Lands Between" srcset="https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/fifa-22-fut-10-fastest-players/">FIFA 22 FUT | 10 Fastest players<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="FIFA 22 FUT 10 Fastest Players Guide" title="FIFA 22 FUT | 10 Fastest players" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/star-citizen-is-free-to-play-from-today/">Star Citizen is free to play from today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Citizen free" title="Star Citizen is free to play from today" srcset="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/disco-elysium-the-final-cut-physical-editions-out-now-for-xbox-one-and-ps4/">Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium – The Final Cut physical editions" title="Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-700x676.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/first-expansion-for-risk-of-rain-2-survivors-of-the-void-coming-2022/">First expansion for Risk of Rain 2, Survivors of the Void, coming 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Survivors of the Void Announcement News" title="First expansion for Risk of Rain 2, Survivors of the Void, coming 2022" srcset="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/multiversus-announced-by-warner-bros-games/">MultiVersus announced by Warner Bros. Games<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus Announcement News" title="MultiVersus announced by Warner Bros. Games" srcset="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/new-world-into-the-void-version-1-1-detailed-coming-today/">New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New World &quot;Into the Void&quot; version 1.1 detailed, coming today" title="New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today" srcset="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/warhammer-age-of-sigmar-tempestfall-out-now-for-vr/">Warhammer Age of Sigmar: Tempestfall out now for VR<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wa-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Age of Sigmar Tempestfall" title="Warhammer Age of Sigmar: Tempestfall out now for VR" srcset="https://www.godisageek.com/wp-content/uploads/wa-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wa-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wa-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/wa-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.youtube.com/user/GodisaGeek">Subscribe</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Support us</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/reviews/okinawa-rush-review/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/reviews/okinawa-rush-review/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Tandem: A Tale of Shadows review</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/reviews/close-sun-review/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Wraith: The Oblivion - Afterlife review</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                                                                
                                        <a class="like-button do-like 257741" data-postid="257741" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                                                            
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-257741" class="post-257741 it_reviews type-it_reviews status-publish has-post-thumbnail hentry category-pc category-ps4-reviews category-reviews category-switch-reviews category-xb1-reviews tag-just-for-games tag-no-gravity-games tag-okinawa-rush tag-sokaikan-limited tag-storybird-games reviews_platform-pc reviews_platform-playstation-4 reviews_platform-switch-2 reviews_platform-xbox-one reviews_developer-sokaikan-limited reviews_developer-storybird-games reviews_publisher-just-for-games reviews_publisher-no-gravity-games reviews_reviewedon-switch-3" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                Okinawa Rush review                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/sean-smith/"><span itemprop="author">Sean Smith </span></a></span><span class="date">on <meta itemprop="datePublished" content="November 21, 2021">November 21, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Okinawa Rush" title="Okinawa Rush review" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"><div class="detail-item"><span class="detail-label">Platform</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-platform/pc/" rel="tag">PC</a><a href="https://www.godisageek.com/reviews-platform/playstation-4/" rel="tag">PlayStation 4</a><a href="https://www.godisageek.com/reviews-platform/switch-2/" rel="tag">Switch</a><a href="https://www.godisageek.com/reviews-platform/xbox-one/" rel="tag">Xbox One</a></span></div><div class="detail-item"><span class="detail-label">Developer</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-developer/sokaikan-limited/" rel="tag">Sokaikan Limited</a><a href="https://www.godisageek.com/reviews-developer/storybird-games/" rel="tag">Storybird games</a></span></div><div class="detail-item"><span class="detail-label">Publisher</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-publisher/just-for-games/" rel="tag">Just For Games</a><a href="https://www.godisageek.com/reviews-publisher/no-gravity-games/" rel="tag">No Gravity Games</a></span></div><div class="detail-item"><span class="detail-label">Reviewed On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-reviewedon/switch-3/" rel="tag">Switch</a></span></div></div><div class="details-wrapper"><div class="detail-item"><span class="detail-label">Release Date</span><span class="detail-content"><p>October 28, 2021</p>
</span></div></div></div></div>                                            
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Okinawa Rush review' data-link='https://www.godisageek.com/reviews/okinawa-rush-review/' data-summary='Rush hour' data-app-id-name='post_above_content'></div>
<p>Firing up this highly enjoyable action platformer for the first time instantly transported me back to my youth. Not because I was once a vengeful martial artist seeking to take down the evil Black Mantis clan, but because of how evocative Okinawa Rush is of some fondly remembered fare from back in the day. There are little bits of Ninja Spirit, First Samurai, even Archer McLean’s peerless IK+.</p>
<p>Visually it is a love letter to the 16-bit era, to the arcades. There are glorious scanlines which can be switched on and off. The animations are excellent and everything is shot through with rivulets of visceral, crimson gore. There are cutscenes that have nods to vintage kung fu flicks, with some howlingly good cheesy voice acting. But this is no brainless pastiche, it all plays rather well too.</p>
<p><img class="aligncenter size-large wp-image-257745" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-1024x576.jpg" alt="Okinawa Rush " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-001.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>Split between Story and Arcade modes, the latter is the best recommended starting point, as you get drip fed the various nuances of combat and have a chance to test your skills in the dojo. Gameplay in Okinawa Rush is a multidirectional platform scrolling affair. The aim of each stage is to reach the boss after a punishing series of encounters with swathes of enemies, that often appear out of thin air. There are also plenty of environmental hazards, including some instant death spike traps that can sometimes be hitherto unseen and cause some annoyingly unfair lives lost in an already tough as teak game.</p>
<p>Dotted around the levels, sometimes hidden or accessed after solving little puzzles are treasures and artifacts which serve as in-game currency to beef up your dojo and boost your stats in some unlockable QTE minigames. You can also replenish your precious health by collecting food, and get stats buffs by finding limited time power ups.</p>
<p><img class="aligncenter size-large wp-image-257744" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-1024x576.jpg" alt="Okinawa Rush " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-003.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>Your hero has a wide range of different attacks, some of which are triggered using SFII style inputs. You can parry certain projectiles, and have a rangy, floaty jump and the ability to perform a super-high vertical leap to get some tricky out of reach areas. There are tonnes of special attacks to discover and use, including many that I instantly recognised from the world of professional wrestling. It is incredibly atisfying to nail an evil ninja foe with a perfectly executed piledriver.</p>
<p>You&#8217;ll find scattered weapons which have a limited use but are extremely varied and fun to use. There are three selectable characters, Hiro and his slightly more beefy brother, Shin – and the much quicker, more balletic Meilin. They all have unique movesets and feel, and mix things up rather nicely.</p>
<p><img class="aligncenter size-large wp-image-257746" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-1024x576.jpg" alt="Okinawa Rush " width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Okinawa-Rush-002.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>As I have alluded to, Okinawa Rush is one nails-hard game. Once you have met the conditions in story mode, there is an Arcade option to try which introduces a timer. On both modes you are given a rank at the end of each stage based upon your performance, but doing it all against the clock lends it an even more compulsive, anxiety-riddled edge. It feels like playing two distinctly different games.</p>
<p>If I was going to level any criticism at Sokaikan’s otherwise ace affair, which was in Kickstarter gestation since 2017, it would be the aforementioned leaps of faith, where the floaty gravity of your jumps can often see you meet your doom as you fall onto a bed of spikes or an unforeseen trap. The game does flash up warning signs when you are right on top of them, but it is often too late. In an arcade-style game with limited lives and an already high level of difficulty, this can frustrate and annoy. But then you learn the layouts of the levels just as you would have had to in myriad arcade games back in the day, and get back down to the satisfying business of knocking heads, and everything is alright in the world. Recommended.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Okinawa Rush review' data-link='https://www.godisageek.com/reviews/okinawa-rush-review/' data-summary='Rush hour' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Okinawa Rush review' data-link='https://www.godisageek.com/reviews/okinawa-rush-review/' data-summary='Rush hour' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                    <div class="procon-box-wrapper"><div class="procon-box clearfix"><div class="col-wrapper"><div class="procon pro"><div class="header"><span class="icon-plus"></span>Positives</div><p>Looks fantastic<br />
Vast array of attacks and specials<br />
Immensely fun to play</p>
</div></div><div class="col-wrapper"><div class="procon con"><div class="header"><span class="icon-minus"></span>Negatives</div><p>Some unfair deaths<br />
Difficulty will put off some</p>
</div></div></div></div>                                        
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix solo"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar"><div class="rating-meter">&nbsp;</div><div class="rating-label">Our Score</div><div class="rating-value"><div class="number color5">8.0</div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-20,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar color5"><div class="rating-label">SCORE OUT OF TEN</div><meta itemprop="worstRating" content="0"><div class="rating-value" itemprop="ratingValue"><div class="number color5">8.0</div></div><meta itemprop="bestRating" content="10"><br class="clearer" /></div></div></div></div></div><br class="clearer" />                                    
                                    <div class="bottomline-wrapper"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-quote-circled"></span>In Short<div class="ribbon-separator">&nbsp;</div></div></div><div class="bottomline"><p>A love letter to days of ninja platforming past, Okinawa Rush is a tough-as-teak challenge that will keep you glued to your Switch.</p>
</div></div>                                    
                                                                 
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>You may also like<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="25773" data-method="tags" class="info active" title="More articles tagged: no gravity games">no gravity games<span class="bottom-arrow"></span></a><a data-sorter="138" data-method="categories" class="info" title="More articles filed under: PC">PC<span class="bottom-arrow"></span></a><a data-sorter="11296" data-method="categories" class="info" title="More articles filed under: PlayStation 4">PlayStation 4<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/creepy-tale-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/creepy-tale-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Creepy Tale review" srcset="https://www.godisageek.com/wp-content/uploads/creepy-tale-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/creepy-tale-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/creepy-tale-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/creepy-tale-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/creepy-tale-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/creepy-tale-review/">Creepy Tale review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/creepy-tale-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/alders-blood-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Alders Blood review" title="Alder&#8217;s Blood review" srcset="https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Alders-Blood-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/alders-blood-review/">Alder&#8217;s Blood review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/alders-blood-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/star-citizen-is-free-to-play-from-today/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Star Citizen free" title="Star Citizen is free to play from today" srcset="https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Citizen-free-3-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/star-citizen-is-free-to-play-from-today/">Star Citizen is free to play from today</a><div class="article-meta clearfix"><a class="like-button do-like 257715 info-bottom" data-postid="257715" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/11/star-citizen-is-free-to-play-from-today/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/disco-elysium-the-final-cut-physical-editions-out-now-for-xbox-one-and-ps4/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium – The Final Cut physical editions" title="Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4" srcset="https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-700x676.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disco-Elysium-–-The-Final-Cut-physical-editions-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/disco-elysium-the-final-cut-physical-editions-out-now-for-xbox-one-and-ps4/">Disco Elysium – The Final Cut physical editions out now for Xbox One and PS4</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/disco-elysium-the-final-cut-physical-editions-out-now-for-xbox-one-and-ps4/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/first-expansion-for-risk-of-rain-2-survivors-of-the-void-coming-2022/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Survivors of the Void Announcement News" title="First expansion for Risk of Rain 2, Survivors of the Void, coming 2022" srcset="https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Survivors-of-the-Void-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/first-expansion-for-risk-of-rain-2-survivors-of-the-void-coming-2022/">First expansion for Risk of Rain 2, Survivors of the Void, coming 2022</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/first-expansion-for-risk-of-rain-2-survivors-of-the-void-coming-2022/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/multiversus-announced-by-warner-bros-games/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MultiVersus Announcement News" title="MultiVersus announced by Warner Bros. Games" srcset="https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MultiVersus-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/multiversus-announced-by-warner-bros-games/">MultiVersus announced by Warner Bros. Games</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/multiversus-announced-by-warner-bros-games/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/new-world-into-the-void-version-1-1-detailed-coming-today/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New World &quot;Into the Void&quot; version 1.1 detailed, coming today" title="New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today" srcset="https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/New-World-into-the-void-update-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/new-world-into-the-void-version-1-1-detailed-coming-today/">New World &#8220;Into the Void&#8221; version 1.1 detailed, coming today</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/new-world-into-the-void-version-1-1-detailed-coming-today/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/world-war-z-switch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="World War Z Nintendo Switch" title="World War Z Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WWZ-Switch-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/WWZ-Switch-35x35.png 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/world-war-z-switch-review/">World War Z Switch review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 257758 info-bottom" data-postid="257758" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/world-war-z-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wraith: The Oblivion - Afterlife" title="Wraith: The Oblivion &#8211; Afterlife review" srcset="https://www.godisageek.com/wp-content/uploads/Wraith-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wraith-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">Wraith: The Oblivion &#8211; Afterlife review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/okinawa-rush-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Okinawa Rush" title="Okinawa Rush review" srcset="https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Okinawa-Main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/okinawa-rush-review/">Okinawa Rush review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/okinawa-rush-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tandem: A Tale of Shadows" title="Tandem: A Tale of Shadows review" srcset="https://www.godisageek.com/wp-content/uploads/Tandem-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tandem-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">Tandem: A Tale of Shadows review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Stealth SP-C160 V Ultimate Gaming Station" title="Stealth SP-C160 V Ultimate Gaming Station for PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/SP-C160-V-WHT_01-800x800-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">Stealth SP-C160 V Ultimate Gaming Station for PS5 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game</a><div class="article-meta clearfix"><a class="like-button do-like 257415 info-bottom" data-postid="257415" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison</a></div><a class="hover-link" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/forza-horizon-5-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Forza Horizon 5 Review" title="Forza Horizon 5 review" srcset="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/forza-horizon-5-review/">Forza Horizon 5 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 257058 info-bottom" data-postid="257058" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/forza-horizon-5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/football-manager-2022-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Football-Manager-2022-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Football Manager 2022 Review" title="Football Manager 2022 review" srcset="https://www.godisageek.com/wp-content/uploads/Football-Manager-2022-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2022-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2022-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2022-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/football-manager-2022-review/">Football Manager 2022 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/football-manager-2022-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/unpacking-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Unpacking-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unpacking review" title="Unpacking review" srcset="https://www.godisageek.com/wp-content/uploads/Unpacking-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Unpacking-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Unpacking-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Unpacking-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/unpacking-review/">Unpacking review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/unpacking-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/far-cry-6-vaas-insanity-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Far-Cry-6-Vaas-Insanity-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Far Cry 6 Vaas Insanity Review" title="Far Cry 6 Vaas: Insanity review" srcset="https://www.godisageek.com/wp-content/uploads/Far-Cry-6-Vaas-Insanity-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Far-Cry-6-Vaas-Insanity-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Far-Cry-6-Vaas-Insanity-Review-700x691.jpg 700w, https://www.godisageek.com/wp-content/uploads/Far-Cry-6-Vaas-Insanity-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/far-cry-6-vaas-insanity-review/">Far Cry 6 Vaas: Insanity review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/far-cry-6-vaas-insanity-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/tails-of-iron-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tails-of-Iron-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tails of Iron Review" title="Tails of Iron review" srcset="https://www.godisageek.com/wp-content/uploads/Tails-of-Iron-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tails-of-Iron-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tails-of-Iron-Review-700x672.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tails-of-Iron-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tails-of-iron-review/">Tails of Iron review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/tails-of-iron-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Vaas-Insanity-Silver-Dragon-Blade-Location-Guide-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/far-cry-6-vaas-insanity-all-silver-dragon-blade-locations/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Far Cry 6 Vaas: Insanity | All Silver Dragon Blade Locations</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-archive-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-archive-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Sherlock Holmes: Chapter One archive guide</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-chemical-analysis-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-chemical-analysis-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Sherlock Holmes: Chapter One chemical analysis guide</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Sherlock-Holmes-Chapter-One-tips-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/sherlock-holmes-chapter-one-tips-and-tricks/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Sherlock Holmes: Chapter One tips and tricks</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Elden-ring-CNT-tips-to-get-you-started-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/elden-ring-cnt-tips-getting-started-in-the-lands-between/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Elden Ring CNT tips | Getting started in the Lands Between</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/FIFA-22-FUT-10-Fastest-Players-Guide-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/11/fifa-22-fut-10-fastest-players/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">FIFA 22 FUT | 10 Fastest players</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/world-war-z-switch-review/">World War Z Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/world-war-z-switch-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">Wraith: The Oblivion &#8211; Afterlife review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/wraith-the-oblivion-afterlife-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/okinawa-rush-review/">Okinawa Rush review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/okinawa-rush-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">Tandem: A Tale of Shadows review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/tandem-a-tale-of-shadows-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">Stealth SP-C160 V Ultimate Gaming Station for PS5 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/stealth-sp-c160-v-ultimate-gaming-station-for-ps5-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.461538461538px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.692307692308px;" aria-label="Activision (779 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.230769230769px;" aria-label="Bandai Namco (409 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-4" style="font-size: 12px;" aria-label="Call of Duty (399 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.769230769231px;" aria-label="Capcom (707 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.846153846154px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,155 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12.230769230769px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (565 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.538461538462px;" aria-label="Microsoft (938 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,764 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.153846153846px;" aria-label="nintendo switch (804 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,383 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.461538461538px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 14.076923076923px;" aria-label="PlayStation 4 (492 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.153846153846px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.307692307692px;" aria-label="PS4 (1,237 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.538461538462px;" aria-label="Sega (690 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.769230769231px;" aria-label="Sony (954 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (922 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.846153846154px;" aria-label="Steam (473 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.538461538462px;" aria-label="Trailer (683 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,295 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.307692307692px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.769230769231px;" aria-label="Xbox One (1,284 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.769230769231px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.230769230769px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.076923076923px;" aria-label="Competition (222 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.769230769231px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.076923076923px;" aria-label="Features (2,461 items)">Features</a>
<a href="https://www.godisageek.com/category/features/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 12.461538461538px;" aria-label="Guides (252 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (219 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.615384615385px;" aria-label="iOS (356 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,704 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.461538461538px;" aria-label="Opinion (610 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 14.615384615385px;" aria-label="Paid Placement Advertorials (482 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.692307692308px;" aria-label="PC (2,173 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.307692307692px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.615384615385px;" aria-label="PlayStation 4 (1,600 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.076923076923px;" aria-label="Podcasts (740 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.692307692308px;" aria-label="Previews (881 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.384615384615px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 22px;" aria-label="Reviews (4,315 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.307692307692px;" aria-label="Switch (791 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.615384615385px;" aria-label="Tech (265 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.846153846154px;" aria-label="Trailers (1,252 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13px;" aria-label="Uncategorised (297 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.153846153846px;" aria-label="Video Features (1,021 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.923076923077px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 17.923076923077px;" aria-label="Xbox One (1,276 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.944664031621px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.173913043478px;" aria-label="Android (80 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.252964426877px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.03162055336px;" aria-label="Google Stadia (23 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.328063241107px;" aria-label="HTC Vive (26 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.181818181818px;" aria-label="iOS (120 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.098814229249px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12.889328063241px;" aria-label="Oculus Quest 2 (6 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.446640316206px;" aria-label="Oculus Rift (27 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,701 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.774703557312px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.762845849802px;" aria-label="PlayStation 4 (1,548 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 20.893280632411px;" aria-label="PlayStation 5 (158 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.343873517787px;" aria-label="PlayStation VR (58 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.893280632411px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.162055335968px;" aria-label="Switch (834 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.521739130435px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.885375494071px;" aria-label="Xbox 360 (105 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.169960474308px;" aria-label="Xbox One (1,221 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 20.359683794466px;" aria-label="Xbox Series S (127 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 20.537549407115px;" aria-label="Xbox Series X (137 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
