<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>10 free games for Twitch Prime members in January - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/giag-favicon.png" />
    
    <link href='https://fonts.googleapis.com/css?family=PT+Sans&subset=' rel='stylesheet' type='text/css'> 
<link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Prime-Games-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    
<!-- NetworkN CMP Tool -->
<script>!function(t,n){if(function(e){"string"==typeof e&&(e=[e]);for(var a=0;a<e.length;a++)n.cookie=e[a]+
"=;max-age=-1;domain=."+n.domain+";path=/"}(["euconsent","eupubconsent","googlepersonalization"]),
!t.__cmp){t.__cmp=function(){(t.attachEvent||t.addEventListener)("message",function(e){t.__cmp.receiveMessage(e)}
,!1),function e(){if(!t.frames.__cmpLocator)if(n.body){var a=n.createElement("iframe");a.style.display="none",
a.name="__cmpLocator",n.body.appendChild(a)}else setTimeout(e,5)}();var o=[],e=function(e,a,n){"ping"===e?n&&n({
gdprAppliesGlobally:!!(t.__cmp&&t.__cmp.config&&t.__cmp.config.storeConsentGlobally),cmpLoaded:!1}):
o.push({command:e,parameter:a,callback:n})};return e.commandQueue=o,e.receiveMessage=function(e){
var a=e&&e.data&&e.data.__cmpCall;a&&o.push({callId:a.callId,command:a.command,parameter:a.parameter,
event:e})},e.config=t.cmpConfig||{},e}()}}(window,document);
</script>
<script src="//cmp.network-n.com/js/cmp.complete.bundle.js" async></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@GodisaGeek">
<meta name="twitter:site" content="@GodisaGeek">
<meta name="twitter:title" content="10 free games for Twitch Prime members in January">
<meta name="twitter:description" content="Twitch Prime members are in for a treat with 10 free games heading your way this January. Available now you can get your hands on:A Normal Lost PhoneAnarcuteApe OutDandaraEnter">
<meta name="twitter:image" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name='OBKey' content='58bwlG/ydjwzfnl1e4+OTg==' />

<!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Twitch have announced a total of 10 games available for free to Twitch Prime members as well as the calendar of loot available through January."/>
<link rel="canonical" href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="10 free games for Twitch Prime members in January - GodisaGeek.com" />
<meta property="og:description" content="Twitch have announced a total of 10 games available for free to Twitch Prime members as well as the calendar of loot available through January." />
<meta property="og:url" content="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/" />
<meta property="og:site_name" content="GodisaGeek.com" />
<meta property="article:tag" content="Twitch" />
<meta property="article:tag" content="Twitch Gaming" />
<meta property="article:tag" content="Twitch Loot" />
<meta property="article:tag" content="twitch prime" />
<meta property="article:tag" content="Twitch Prime Games" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2020-01-08T19:01:57+00:00" />
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" />
<meta property="og:image:secure_url" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="279" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","potentialAction":{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/#primaryimage","url":"https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg","width":600,"height":279,"caption":"Twitch Prime Games"},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/#webpage","url":"https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/","inLanguage":"en-US","name":"10 free games for Twitch Prime members in January - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/#primaryimage"},"datePublished":"2020-01-08T19:01:57+00:00","dateModified":"2020-01-08T19:01:57+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/a7525acfa3f50eb310e1d9c2f289f56f"},"description":"Twitch have announced a total of 10 games available for free to Twitch Prime members as well as the calendar of loot available through January."},{"@type":["Person"],"@id":"https://www.godisageek.com/#/schema/person/a7525acfa3f50eb310e1d9c2f289f56f","name":"Mick Doherty","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#authorlogo","url":"https://secure.gravatar.com/avatar/34fdcacd4010e7b0a00408a8d34701ea?s=96&d=mm&r=g","caption":"Mick Doherty"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; 10 free games for Twitch Prime members in January Comments Feed" href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.godisageek.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.86.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/10/jwplayer.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.godisageek.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"230878","token":"0554408a43","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<!-- OG: 2.7.5 -->
<link rel="image_src" href="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" /><meta itemprop="image" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" /><meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" /><meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="279" /><meta property="og:image:alt" content="Twitch Prime Games" /><meta property="og:description" content="Optimus Prime of Twitch Gaming" /><meta property="og:type" content="article" /><meta property="og:locale" content="en_us" /><meta property="og:site_name" content="GodisaGeek.com" /><meta property="og:title" content="10 free games for Twitch Prime members in January" /><meta property="og:url" content="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/" /><meta property="og:updated_time" content="2020-01-08T19:01:57+00:00" /><meta property="article:tag" content="Twitch" /><meta property="article:tag" content="Twitch Gaming" /><meta property="article:tag" content="Twitch Loot" /><meta property="article:tag" content="twitch prime" /><meta property="article:tag" content="Twitch Prime Games" /><meta property="article:published_time" content="2020-01-08T19:01:57+00:00" /><meta property="article:modified_time" content="2020-01-08T19:01:57+00:00" /><meta property="article:author" content="https://www.godisageek.com/author/mick-doherty/" /><meta property="article:section" content="News" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:title" content="10 free games for Twitch Prime members in January" /><meta property="twitter:description" content="Optimus Prime of Twitch Gaming" /><meta property="twitter:image:width" content="600" /><meta property="twitter:image:height" content="279" /><meta property="twitter:image:alt" content="Twitch Prime Games" /><meta property="twitter:url" content="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/" /><meta property="profile:first_name" content="Mick" /><meta property="profile:last_name" content="Doherty" /><meta property="profile:username" content="Mick Doherty" /><!-- /OG -->
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://www.godisageek.com/?p=230878' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F01%2F10-free-games-for-twitch-prime-members-in-january%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F01%2F10-free-games-for-twitch-prime-members-in-january%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>
            <script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

            <script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.godisageek.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '230878';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = true;
	window._wp_rp_post_title = '10+free+games+for+Twitch+Prime+members+in+January';
	window._wp_rp_post_tags = ['twitch+loot', 'twitch+prime', 'twitch+prime+games', 'twitch', 'twitch+gaming', 'news', 'legend', 'content', 'free', 'shadow', 'holi', 'prime', 'leagu', 'phone', 'king', 'game', 'twitch', 'bang', 'mobil', 'top', 'desert'];
	window._wp_rp_promoted_content = true;
</script>
<link rel="stylesheet" href="https://www.godisageek.com/wp-content/plugins/wordpress-23-related-posts-plugin/static/themes/vertical-m.css?version=3.6.4" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-230878 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/">The Surge 2&#8217;s First Expansion Arrives Next Week<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Surge 2&#8217;s First Expansion Arrives Next Week" srcset="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/">10 free games for Twitch Prime members in January<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Twitch Prime Games" title="10 free games for Twitch Prime members in January" srcset="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Prime-Games-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Prime-Games-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Prime-Games-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/">Team Ninja address how player feedback is helping to make Nioh 2 better<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="nioh 2 player feedback" title="Team Ninja address how player feedback is helping to make Nioh 2 better" srcset="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/razer-announce-new-kishi-controller-and-more-at-ces-2020/">Razer announce new Kishi controller and more at CES 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Razer announce new Kishi controller and more at CES 2020" srcset="https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/itta-is-coming-to-pc-and-nintendo-switch/">ITTA is coming to PC and Nintendo Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ITTA PC Nintendo Switch" title="ITTA is coming to PC and Nintendo Switch" srcset="https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/new-red-dead-online-content-adds-new-clothing-and-moonshiner-bonuses/">New Red Dead Online content adds new clothing and Moonshiner bonuses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Dead Online new" title="New Red Dead Online content adds new clothing and Moonshiner bonuses" srcset="https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/">Monster Hunter World: Iceborne PC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Iceborne_main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter World: Iceborne" title="Monster Hunter World: Iceborne PC review" srcset="https://www.godisageek.com/wp-content/uploads/Iceborne_main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/">Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/">Speedlink Reticos RGB Gaming Mouse review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Speedlink Reticos RGB Gaming Mouse review" title="Speedlink Reticos RGB Gaming Mouse review" srcset="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Reticosmain-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Reticosmain-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Reticosmain-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Reticosmain-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/down-to-hell-review/">Down to Hell review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Down to Hell review" title="Down to Hell review" srcset="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/">Steins;Gate 0 Switch Review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Steins;Gate 0 Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-chaosbane-tomb-kings-dlc-review/">Warhammer: Chaosbane &#8211; Tomb Kings DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tomb-kings-main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer: Chaosbane - Tomb Kings DLC" title="Warhammer: Chaosbane &#8211; Tomb Kings DLC review" srcset="https://www.godisageek.com/wp-content/uploads/tomb-kings-main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/podcast-377-brain-training-switch-outer-wilds-battlefront-2/">Podcast #377: A Good Bash<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #377: Outer Wilds, Brain Training Switch, Battlefront 2" title="Podcast #377: A Good Bash" srcset="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/every-game-release-of-january-2020/">Games of January 2020 &#8211; Tokyo Mirage Sessions #FE, Dragon Ball Z: Kakarot, Journey to the Savage Planet, Monster Hunter World: Iceborne PC, and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Games of January 2020 &#8211; Tokyo Mirage Sessions #FE, Dragon Ball Z: Kakarot, Journey to the Savage Planet, Monster Hunter World: Iceborne PC, and more" srcset="https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/goty-2019-lists-adam-cook/">GOTY 2019 Lists: Adam Cook<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Control-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Control review" title="GOTY 2019 Lists: Adam Cook" srcset="https://www.godisageek.com/wp-content/uploads/Control-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Control-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Control-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Control-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Control-Review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/goty-2019-lists-community-picks/">GOTY 2019 Lists: Community Picks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="GOTY 2019 Lists: Community Picks" srcset="https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/5-things-to-like-about-ghost-recon-breakpoint-positives/">5 things to like about Ghost Recon Breakpoint | The Breakpoint positives<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="5 things to like about Ghost Recon Breakpoint | The Positives!" title="5 things to like about Ghost Recon Breakpoint | The Breakpoint positives" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-safijiiva-siege-guide/">Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-horizon-zero-dawn-event-guide-part-2-the-survivor/">Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/11/10-beginners-tips-for-reconnecting-america-in-death-stranding/">10 beginner&#8217;s tips for reconnecting America in Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="10 beginner&#039;s tips for Death Stranding" title="10 beginner&#8217;s tips for reconnecting America in Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/09/how-to-use-your-xbox-one-controller-with-iphone-ipad/">How to pair your Xbox One controller with your iPhone or iPad to play Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apple Arcade? Play with Xbox One controller" title="How to pair your Xbox One controller with your iPhone or iPad to play Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">Monster Energy Supercross 3 Shows Signs of Great Improvement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 3 Shows Signs of Great Improvement" title="Monster Energy Supercross 3 Shows Signs of Great Improvement" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/death-stranding-has-defined-hideo-kojimas-legacy-once-and-for-all/">Death Stranding has defined Hideo Kojima&#8217;s legacy once and for all<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Death Stranding has defined Hideo Kojima&#8217;s legacy once and for all" srcset="https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/superliminal-preview-could-this-be-the-next-portal/">Superliminal preview | Could this be the next Portal?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Superliminal-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Superliminal preview" title="Superliminal preview | Could this be the next Portal?" srcset="https://www.godisageek.com/wp-content/uploads/Superliminal-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Superliminal-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Superliminal-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Superliminal-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Superliminal-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/planetside-arena-is-a-battle-royale-with-potential-but-it-needs-work/">Planetside Arena is a battle royale with potential, but it needs work<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Planetside Arena Early Access Preview" title="Planetside Arena is a battle royale with potential, but it needs work" srcset="https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/star-wars-jedi-fallen-order-3-hours-hands-on-preview/">Star Wars Jedi: Fallen Order looks and feels great from the three hours we played | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Wars Jedi Fallen Order preview" title="Star Wars Jedi: Fallen Order looks and feels great from the three hours we played | Preview" srcset="https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/wwe-2k20-preview-changes-looks-incredible-but-gameplay-still-needs-attention/">WWE 2K20 looks incredible, but gameplay is still very much a problem<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K20: preview hands on with the changes" title="WWE 2K20 looks incredible, but gameplay is still very much a problem" srcset="https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/">The Surge 2&#8217;s First Expansion Arrives Next Week<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Surge 2&#8217;s First Expansion Arrives Next Week" srcset="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/">10 free games for Twitch Prime members in January<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Twitch Prime Games" title="10 free games for Twitch Prime members in January" srcset="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Prime-Games-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Prime-Games-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Prime-Games-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/">Team Ninja address how player feedback is helping to make Nioh 2 better<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="nioh 2 player feedback" title="Team Ninja address how player feedback is helping to make Nioh 2 better" srcset="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/razer-announce-new-kishi-controller-and-more-at-ces-2020/">Razer announce new Kishi controller and more at CES 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Razer announce new Kishi controller and more at CES 2020" srcset="https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Razer-CES-2020-a-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/itta-is-coming-to-pc-and-nintendo-switch/">ITTA is coming to PC and Nintendo Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ITTA PC Nintendo Switch" title="ITTA is coming to PC and Nintendo Switch" srcset="https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ITTA-PC-Nintendo-Switch-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/new-red-dead-online-content-adds-new-clothing-and-moonshiner-bonuses/">New Red Dead Online content adds new clothing and Moonshiner bonuses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Dead Online new" title="New Red Dead Online content adds new clothing and Moonshiner bonuses" srcset="https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Red-Dead-Online-b-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/">Monster Hunter World: Iceborne PC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Iceborne_main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter World: Iceborne" title="Monster Hunter World: Iceborne PC review" srcset="https://www.godisageek.com/wp-content/uploads/Iceborne_main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/">Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/">Speedlink Reticos RGB Gaming Mouse review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Speedlink Reticos RGB Gaming Mouse review" title="Speedlink Reticos RGB Gaming Mouse review" srcset="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Reticosmain-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Reticosmain-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Reticosmain-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Reticosmain-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/down-to-hell-review/">Down to Hell review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Down to Hell review" title="Down to Hell review" srcset="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/">Steins;Gate 0 Switch Review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Steins;Gate 0 Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-chaosbane-tomb-kings-dlc-review/">Warhammer: Chaosbane &#8211; Tomb Kings DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tomb-kings-main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer: Chaosbane - Tomb Kings DLC" title="Warhammer: Chaosbane &#8211; Tomb Kings DLC review" srcset="https://www.godisageek.com/wp-content/uploads/tomb-kings-main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/tomb-kings-main-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/podcast-377-brain-training-switch-outer-wilds-battlefront-2/">Podcast #377: A Good Bash<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #377: Outer Wilds, Brain Training Switch, Battlefront 2" title="Podcast #377: A Good Bash" srcset="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/every-game-release-of-january-2020/">Games of January 2020 &#8211; Tokyo Mirage Sessions #FE, Dragon Ball Z: Kakarot, Journey to the Savage Planet, Monster Hunter World: Iceborne PC, and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Games of January 2020 &#8211; Tokyo Mirage Sessions #FE, Dragon Ball Z: Kakarot, Journey to the Savage Planet, Monster Hunter World: Iceborne PC, and more" srcset="https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/13D3352C-93D8-4731-A103-0CFF68465CF7-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/goty-2019-lists-adam-cook/">GOTY 2019 Lists: Adam Cook<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Control-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Control review" title="GOTY 2019 Lists: Adam Cook" srcset="https://www.godisageek.com/wp-content/uploads/Control-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Control-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Control-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Control-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Control-Review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/goty-2019-lists-community-picks/">GOTY 2019 Lists: Community Picks<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="GOTY 2019 Lists: Community Picks" srcset="https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Control-Jesse-Faden-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/5-things-to-like-about-ghost-recon-breakpoint-positives/">5 things to like about Ghost Recon Breakpoint | The Breakpoint positives<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="5 things to like about Ghost Recon Breakpoint | The Positives!" title="5 things to like about Ghost Recon Breakpoint | The Breakpoint positives" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-Recon-Breakpoint-5-things-we-to-like-The-positives-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-safijiiva-siege-guide/">Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-horizon-zero-dawn-event-guide-part-2-the-survivor/">Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/11/10-beginners-tips-for-reconnecting-america-in-death-stranding/">10 beginner&#8217;s tips for reconnecting America in Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="10 beginner&#039;s tips for Death Stranding" title="10 beginner&#8217;s tips for reconnecting America in Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/09/how-to-use-your-xbox-one-controller-with-iphone-ipad/">How to pair your Xbox One controller with your iPhone or iPad to play Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apple Arcade? Play with Xbox One controller" title="How to pair your Xbox One controller with your iPhone or iPad to play Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-image-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">Monster Energy Supercross 3 Shows Signs of Great Improvement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 3 Shows Signs of Great Improvement" title="Monster Energy Supercross 3 Shows Signs of Great Improvement" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/death-stranding-has-defined-hideo-kojimas-legacy-once-and-for-all/">Death Stranding has defined Hideo Kojima&#8217;s legacy once and for all<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Death Stranding has defined Hideo Kojima&#8217;s legacy once and for all" srcset="https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/hideo-kojima-feature-main-image-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/superliminal-preview-could-this-be-the-next-portal/">Superliminal preview | Could this be the next Portal?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Superliminal-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Superliminal preview" title="Superliminal preview | Could this be the next Portal?" srcset="https://www.godisageek.com/wp-content/uploads/Superliminal-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Superliminal-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Superliminal-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Superliminal-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Superliminal-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/planetside-arena-is-a-battle-royale-with-potential-but-it-needs-work/">Planetside Arena is a battle royale with potential, but it needs work<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Planetside Arena Early Access Preview" title="Planetside Arena is a battle royale with potential, but it needs work" srcset="https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Planetside-Arena_preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/star-wars-jedi-fallen-order-3-hours-hands-on-preview/">Star Wars Jedi: Fallen Order looks and feels great from the three hours we played | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Wars Jedi Fallen Order preview" title="Star Wars Jedi: Fallen Order looks and feels great from the three hours we played | Preview" srcset="https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Star-Wars-Jedi-Fallen-Order-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/wwe-2k20-preview-changes-looks-incredible-but-gameplay-still-needs-attention/">WWE 2K20 looks incredible, but gameplay is still very much a problem<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K20: preview hands on with the changes" title="WWE 2K20 looks incredible, but gameplay is still very much a problem" srcset="https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/wwe-2k20-preview-4-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/01/10-free-games-for-twitch-prime-members-in-january/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/01/10-free-games-for-twitch-prime-members-in-january/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Team Ninja address how player feedback is helping to make Nioh 2 better</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2011/04/sony-announces-50-million-playstation-3-consoles-shipped-worldwide/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">The Surge 2's First Expansion Arrives Next Week</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-230878" class="post-230878 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-twitch tag-twitch-gaming tag-twitch-loot tag-twitch-prime tag-twitch-prime-games" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                10 free games for Twitch Prime members in January                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/mick-doherty/"><span itemprop="author">Mick Doherty </span></a></span><span class="date">on <meta itemprop="datePublished" content="January 8, 2020">January 8, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg"><img width="600" height="279" src="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Twitch Prime Games" title="10 free games for Twitch Prime members in January" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Prime-Games.jpg 600w, https://www.godisageek.com/wp-content/uploads/Prime-Games-300x140.jpg 300w, https://www.godisageek.com/wp-content/uploads/Prime-Games-180x84.jpg 180w, https://www.godisageek.com/wp-content/uploads/Prime-Games-360x167.jpg 360w" sizes="(max-width: 600px) 100vw, 600px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>Twitch Prime members are in for a treat with 10 free games heading your way this January. Available now you can get your hands on:</p>
<ul>
<li><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"><span style="font-family: arial, sans-serif;">A Normal Lost Phone </span></span></li>
<li><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"><span style="font-family: arial, sans-serif;">Anarcute</span></span></li>
<li>Ape Out</li>
<li>Dandara</li>
<li>Enter the Gungeon</li>
<li>Gato Roboto</li>
<li>Heave Ho</li>
<li>Kingdom New Lands</li>
<li><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"><span style="font-family: arial, sans-serif;">Splasher</span></span></li>
<li><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"></span><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"><span style="font-family: arial, sans-serif;">Witcheye</span></span><span id="m_-3237658997356284113m_-2978114009674182886gmail-m_-3607623750391570296gmail-docs-internal-guid-848b71dc-7fff-4fac-aa72-a8ac4f23d1f2"><span style="font-family: arial, sans-serif;"><br />
</span></span></li>
</ul>
<p>On top of those free games there&#8217;s also some loot for games ready and waiting to be claimed for you Twitch Prime members. The January Twitch Prime Calendar is a bit long so here goes:</p>
<h5>Available Now:</h5>
<ul>
<li>The Prime Games listed above</li>
<li>Rocket League Content</li>
<li>Warframe Stater Pack</li>
<li>Black Desert Mobile Content</li>
<li>RAID: Shadow Legends Content</li>
<li>Mobile Legends: Bang Bang Content</li>
<li>League of Legends Content</li>
<li>Teamfight Tactics Content</li>
<li>Runescape Content</li>
<li>Fortress M Content</li>
</ul>
<h5>January 13:</h5>
<ul>
<li>RAID: Shadow Legends Content</li>
<li>The King of Fighters ALLSTAR Content</li>
</ul>
<h5>January 15:</h5>
<ul>
<li>Black Desert Mobile Content</li>
<li>Mobile Legends: Bang Bang Content</li>
</ul>
<h5>January 22:</h5>
<ul>
<li>Fortress M Content</li>
</ul>
<h5>January 27:</h5>
<ul>
<li>RAID: Shadow Legends Content</li>
</ul>
<h5>January 29:</h5>
<ul>
<li>Black Desert Mobile Content</li>
<li>Mobile Legends: Bang Bang Content</li>
</ul>
<p>Plenty of loot to keep you going for this month and plenty of new games to try if you haven&#8217;t had the chance yet.</p>
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/twitch/" title="Twitch Tag" class="twitch">Twitch</a><a href="https://www.godisageek.com/tag/twitch-gaming/" title="Twitch Gaming Tag" class="twitch-gaming">Twitch Gaming</a><a href="https://www.godisageek.com/tag/twitch-loot/" title="Twitch Loot Tag" class="twitch-loot">Twitch Loot</a><a href="https://www.godisageek.com/tag/twitch-prime/" title="twitch prime Tag" class="twitch-prime">twitch prime</a><a href="https://www.godisageek.com/tag/twitch-prime-games/" title="Twitch Prime Games Tag" class="twitch-prime-games">Twitch Prime Games</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/mick-doherty/"><img alt='' src='https://secure.gravatar.com/avatar/34fdcacd4010e7b0a00408a8d34701ea?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/34fdcacd4010e7b0a00408a8d34701ea?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/mick-doherty/"><h3>Mick Doherty</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:micksince86@gmail.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                                                        
                            
<div id="disqus_thread"></div>
                                                        
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="The Surge 2&#8217;s First Expansion Arrives Next Week" srcset="https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Surge-2-The-Kraken-2-150x150.png 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/">The Surge 2&#8217;s First Expansion Arrives Next Week</a><div class="article-meta clearfix"><a class="like-button do-like 230881 info-bottom" data-postid="230881" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-surge-2-first-expansion-arrives-next-week/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Twitch Prime Games" title="10 free games for Twitch Prime members in January" srcset="https://www.godisageek.com/wp-content/uploads/Prime-Games-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Prime-Games-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Prime-Games-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Prime-Games-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/">10 free games for Twitch Prime members in January</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/10-free-games-for-twitch-prime-members-in-january/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="nioh 2 player feedback" title="Team Ninja address how player feedback is helping to make Nioh 2 better" srcset="https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/nioh-2-player-feedback-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/">Team Ninja address how player feedback is helping to make Nioh 2 better</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/team-ninja-address-how-player-feedback-is-helping-to-make-nioh-2-better/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 3 Shows Signs of Great Improvement" title="Monster Energy Supercross 3 Shows Signs of Great Improvement" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">Monster Energy Supercross 3 Shows Signs of Great Improvement</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/podcast-377-brain-training-switch-outer-wilds-battlefront-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #377: Outer Wilds, Brain Training Switch, Battlefront 2" title="Podcast #377: A Good Bash" srcset="https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Outer-Wilds-artwork-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/podcast-377-brain-training-switch-outer-wilds-battlefront-2/">Podcast #377: A Good Bash</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/podcast-377-brain-training-switch-outer-wilds-battlefront-2/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Iceborne_main-85x85.jpeg" class="attachment-widget-post size-widget-post wp-post-image" alt="Monster Hunter World: Iceborne" title="Monster Hunter World: Iceborne PC review" srcset="https://www.godisageek.com/wp-content/uploads/Iceborne_main-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Iceborne_main-150x150.jpeg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/">Monster Hunter World: Iceborne PC review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 230836 info-bottom" data-postid="230836" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/">Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Speedlink Reticos RGB Gaming Mouse review" title="Speedlink Reticos RGB Gaming Mouse review" srcset="https://www.godisageek.com/wp-content/uploads/Reticosmain-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Reticosmain-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Reticosmain-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Reticosmain-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Reticosmain-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/">Speedlink Reticos RGB Gaming Mouse review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/down-to-hell-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Down to Hell review" title="Down to Hell review" srcset="https://www.godisageek.com/wp-content/uploads/Down-to-Hell-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Down-to-Hell-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/down-to-hell-review/">Down to Hell review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/down-to-hell-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Steins;Gate 0 Switch Review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/">Steins;Gate 0 Switch Review | Switch Re:port</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a><div class="article-meta clearfix"><a class="like-button do-like 230564 info-bottom" data-postid="230564" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">&nbsp;</a></div></div></div>		
		
	<div id="it_social_tabs-6" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#facebook-social-tab" class="info icon-facebook" title="Facebook"><span class="selector-arrow"></span></a></li><li><a href="#twitter-social-tab" class="info active icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a class="twitter-timeline" href="//twitter.com/GodisaGeek" data-widget-id="570944929174917120">Tweets by @GodisaGeek</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div><div id="facebook-social-tab"><div class="fb-like-box" data-href="//www.facebook.com/GodisaGeek" data-colorscheme="light" data-show-faces="true" data-stream="false" data-header="true" data-border-color=""></div></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Iceborne_main-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/monster-hunter-world-iceborne-pc-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div><div class="article-info">Monster Hunter World: Iceborne PC review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/neverwinter-nights-enhanced-edition-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/neverwinter-nights-enhanced-edition-switch-review-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">4.5</div></div></div><div class="article-info">Neverwinter Nights: Enhanced Edition Switch Review | Switch Re:port</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Reticosmain-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/speedlink-reticos-rgb-gaming-mouse-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Speedlink Reticos RGB Gaming Mouse review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Down-to-Hell-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/down-to-hell-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color2">3.0</div></div></div><div class="article-info">Down to Hell review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/steins-gate-0-switch-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/steins-gate-0-nintendo-switch-review-vs-ps4-ps-vita-pc/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Steins;Gate 0 Switch Review | Switch Re:port</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/tomb-kings-main-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/warhammer-chaosbane-tomb-kings-dlc-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Warhammer: Chaosbane &#8211; Tomb Kings DLC review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Brain-Training-for-Nintendo-Switch-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/dr-kawashima-brain-training-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Dr Kawashima&#8217;s Brain Training for Nintendo Switch review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Riverbond-Switch-RePort-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/riverbond-switch-review-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Riverbond Switch review | Switch Re:Port</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Gunslinger_Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/call-of-juarez-gunslinger-switch-review-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Call of Juarez: Gunslinger Switch Review | Switch Re:port</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/star-ocean-first-departure-r-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/star-ocean-first-departure-r-switch-review-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Star Ocean: First Departure R Switch Review | Switch Re:port</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="//www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//plus.google.com/communities/101571468730792116217" class="icon-googleplus info" title="Googleplus" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"godisageek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"230878 http:\/\/www.godisageek.com\/?p=230878","disqusShortname":"godisageek","disqusTitle":"10 free games for Twitch Prime members in January","disqusUrl":"https:\/\/www.godisageek.com\/2020\/01\/10-free-games-for-twitch-prime-members-in-january\/","postId":"230878"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.godisageek.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"stars","image_ext":"gif","max":"5","show_loading":"1","show_fading":"1","custom":"0"};
var ratings_mouseover_image=new Image();ratings_mouseover_image.src="https://www.godisageek.com/wp-content/plugins/wp-postratings/images/stars/rating_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.86.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
