<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>What to expect from Knockout City Season 2 | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="We got to see Knockout City Season 2 early and find out all about the new ball and new map. Here&#039;s a video showcasing both!" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="What to expect from Knockout City Season 2 | GodisaGeek.com" />
	<meta property="og:description" content="We got to see Knockout City Season 2 early and find out all about the new ball and new map. Here&#039;s a video showcasing both!" />
	<meta property="og:url" content="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2021-07-27T12:58:36+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/knockout-city-season-2.jpg","width":1920,"height":1080,"caption":"What to expect from Knockout City Season 2"},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/#webpage","url":"https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/","name":"What to expect from Knockout City Season 2 | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/#primaryimage"},"datePublished":"2021-07-27T12:58:36+00:00","dateModified":"2021-07-27T12:58:36+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"description":"We got to see Knockout City Season 2 early and find out all about the new ball and new map. Here's a video showcasing both!","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"07","day":"27","hour":"13","minute":"58","second":"36","post_id":"253617","postname":"what-to-expect-from-knockout-city-season-2","category":"features"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/' />
<meta name='shareaholic:keywords' content='tag:ea originals, tag:knockout city, tag:velan studios, tag:knockout city season 2, cat:features, cat:previews, cat:video features, type:post' />
<meta name='shareaholic:article_published_time' content='2021-07-27T13:58:36+01:00' />
<meta name='shareaholic:article_modified_time' content='2021-07-27T13:58:36+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Adam Cook' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=253617' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F07%2Fwhat-to-expect-from-knockout-city-season-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F07%2Fwhat-to-expect-from-knockout-city-season-2%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-253617 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/end-of-dragons-expansion-footage-for-guild-wars-2-revealed/">&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed" srcset="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/xbox-announces-summer-spotlight-2021/">Xbox announces Summer Spotlight 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xbox Summer Spotlight" title="Xbox announces Summer Spotlight 2021" srcset="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/">Coming soon to Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apple Arcade" title="Coming soon to Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/">MARVEL Future Revolution gets release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Marvel Future Revolution Release Date News" title="MARVEL Future Revolution gets release date" srcset="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/wickedly-arcane-mystery-sorcerous-has-been-released/">Wickedly arcane mystery Sorcerous has been released<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sorcerous2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sorcerous" title="Wickedly arcane mystery Sorcerous has been released" srcset="https://www.godisageek.com/wp-content/uploads/Sorcerous2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sorcerous2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sorcerous2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/warhammer-vermintide-2-gets-a-ps5-performance-update/">Warhammer Vermintide 2 gets a PS5 performance update<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Vermintide 2 PS5" title="Warhammer Vermintide 2 gets a PS5 performance update" srcset="https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">Samurai Warriors 5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-24-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Samurai Warriors 5 title image" title="Samurai Warriors 5 review" srcset="https://www.godisageek.com/wp-content/uploads/hero-24-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-24-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-24-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">NEO: The World Ends With You review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEO: The World Ends With You Review" title="NEO: The World Ends With You review" srcset="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">The Great Ace Attorney Chronicles review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles title image" title="The Great Ace Attorney Chronicles review" srcset="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-23-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-23-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">Ender Lilies: Quietus of the Knights review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ender Lilies: Quietus of the Knights review" title="Ender Lilies: Quietus of the Knights review" srcset="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/cris-tales-review/">Cris Tales review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Cris Tales title image" title="Cris Tales review" srcset="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-22-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-22-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/lumberhill-review/">Lumberhill review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LUM_meta-description-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lumberhill title image" title="Lumberhill review" srcset="https://www.godisageek.com/wp-content/uploads/LUM_meta-description-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/LUM_meta-description-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/LUM_meta-description-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-453-deaths-door-skyward-sword-hd-sekiro/">Podcast 453: Death&#8217;s Door, Skyward Sword HD, Sekiro<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 453: Death&#039;s Door, Skyward Sword HD, Sekiro" title="Podcast 453: Death&#8217;s Door, Skyward Sword HD, Sekiro" srcset="https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/space-punks-has-potential-but-isnt-as-charming-as-it-needs-to-be/">Space Punks has potential, but isn&#8217;t as charming as it needs to be | Early Access Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Space-Punks-001-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Space Punks" title="Space Punks has potential, but isn&#8217;t as charming as it needs to be | Early Access Preview" srcset="https://www.godisageek.com/wp-content/uploads/Space-Punks-001-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/">Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Velan Studios: &quot;We knew that if they got their hands on it, they&#039;d love it&quot; | Knockout City Interview" title="Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview" srcset="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-452-skyward-sword-hd-state-of-decay-2-kings-bounty-ii/">Podcast 452: Skyward Sword HD, State of Decay 2, King&#8217;s Bounty II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 452: Skyward Sword HD, State of Decay 2, King&#039;s Bounty II" title="Podcast 452: Skyward Sword HD, State of Decay 2, King&#8217;s Bounty II" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/beedles-airshop-skyward-sword-hd-floating-shop/">Skyward Sword HD | How to find and enter Beedle’s flying air shop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Skyward Sword HD | How to find and enter Beedle’s airshop" title="Skyward Sword HD | How to find and enter Beedle’s flying air shop" srcset="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/beedles-airshop-skyward-sword-hd-floating-shop/">Skyward Sword HD | How to find and enter Beedle’s flying air shop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Skyward Sword HD | How to find and enter Beedle’s airshop" title="Skyward Sword HD | How to find and enter Beedle’s flying air shop" srcset="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-s-rank/">Monster Hunter Stories 2 | How to get S Rank<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 S Rank" title="Monster Hunter Stories 2 | How to get S Rank" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-bottle-caps/">Monster Hunter Stories 2 | How to get Bottle Caps<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 bottle caps" title="Monster Hunter Stories 2 | How to get Bottle Caps" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-farm-monster-parts/">Monster Hunter Stories 2 | How to farm Monster Parts<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 farm parts" title="Monster Hunter Stories 2 | How to farm Monster Parts" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-rare-eggs/">Monster Hunter Stories 2 | How to get Rare Eggs<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 Rare Egg" title="Monster Hunter Stories 2 | How to get Rare Eggs" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-zenny-fast/">Monster Hunter Stories 2 | How to get Zenny fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 Zenny" title="Monster Hunter Stories 2 | How to get Zenny fast" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/monster-hunter-stories-2-wings-of-ruin/">Monster Hunter Stories 2</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/end-of-dragons-expansion-footage-for-guild-wars-2-revealed/">&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed" srcset="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/xbox-announces-summer-spotlight-2021/">Xbox announces Summer Spotlight 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xbox Summer Spotlight" title="Xbox announces Summer Spotlight 2021" srcset="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/">Coming soon to Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apple Arcade" title="Coming soon to Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/">MARVEL Future Revolution gets release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Marvel Future Revolution Release Date News" title="MARVEL Future Revolution gets release date" srcset="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/wickedly-arcane-mystery-sorcerous-has-been-released/">Wickedly arcane mystery Sorcerous has been released<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sorcerous2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sorcerous" title="Wickedly arcane mystery Sorcerous has been released" srcset="https://www.godisageek.com/wp-content/uploads/Sorcerous2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sorcerous2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sorcerous2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/warhammer-vermintide-2-gets-a-ps5-performance-update/">Warhammer Vermintide 2 gets a PS5 performance update<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer Vermintide 2 PS5" title="Warhammer Vermintide 2 gets a PS5 performance update" srcset="https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Vermintide_2_Enemy_Cover-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">Samurai Warriors 5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-24-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Samurai Warriors 5 title image" title="Samurai Warriors 5 review" srcset="https://www.godisageek.com/wp-content/uploads/hero-24-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-24-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-24-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">NEO: The World Ends With You review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEO: The World Ends With You Review" title="NEO: The World Ends With You review" srcset="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">The Great Ace Attorney Chronicles review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles title image" title="The Great Ace Attorney Chronicles review" srcset="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-23-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-23-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">Ender Lilies: Quietus of the Knights review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ender Lilies: Quietus of the Knights review" title="Ender Lilies: Quietus of the Knights review" srcset="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/cris-tales-review/">Cris Tales review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Cris Tales title image" title="Cris Tales review" srcset="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-22-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-22-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/lumberhill-review/">Lumberhill review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LUM_meta-description-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lumberhill title image" title="Lumberhill review" srcset="https://www.godisageek.com/wp-content/uploads/LUM_meta-description-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/LUM_meta-description-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/LUM_meta-description-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-453-deaths-door-skyward-sword-hd-sekiro/">Podcast 453: Death&#8217;s Door, Skyward Sword HD, Sekiro<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 453: Death&#039;s Door, Skyward Sword HD, Sekiro" title="Podcast 453: Death&#8217;s Door, Skyward Sword HD, Sekiro" srcset="https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-453-deaths-door-skyward-sword-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/space-punks-has-potential-but-isnt-as-charming-as-it-needs-to-be/">Space Punks has potential, but isn&#8217;t as charming as it needs to be | Early Access Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Space-Punks-001-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Space Punks" title="Space Punks has potential, but isn&#8217;t as charming as it needs to be | Early Access Preview" srcset="https://www.godisageek.com/wp-content/uploads/Space-Punks-001-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Space-Punks-001-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/">Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Velan Studios: &quot;We knew that if they got their hands on it, they&#039;d love it&quot; | Knockout City Interview" title="Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview" srcset="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-452-skyward-sword-hd-state-of-decay-2-kings-bounty-ii/">Podcast 452: Skyward Sword HD, State of Decay 2, King&#8217;s Bounty II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 452: Skyward Sword HD, State of Decay 2, King&#039;s Bounty II" title="Podcast 452: Skyward Sword HD, State of Decay 2, King&#8217;s Bounty II" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-452-Skyward-Sword-HD-State-of-Decay-2-Kings-Bounty-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/beedles-airshop-skyward-sword-hd-floating-shop/">Skyward Sword HD | How to find and enter Beedle’s flying air shop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Skyward Sword HD | How to find and enter Beedle’s airshop" title="Skyward Sword HD | How to find and enter Beedle’s flying air shop" srcset="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/beedles-airshop-skyward-sword-hd-floating-shop/">Skyward Sword HD | How to find and enter Beedle’s flying air shop<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Skyward Sword HD | How to find and enter Beedle’s airshop" title="Skyward Sword HD | How to find and enter Beedle’s flying air shop" srcset="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-s-rank/">Monster Hunter Stories 2 | How to get S Rank<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 S Rank" title="Monster Hunter Stories 2 | How to get S Rank" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-bottle-caps/">Monster Hunter Stories 2 | How to get Bottle Caps<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 bottle caps" title="Monster Hunter Stories 2 | How to get Bottle Caps" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-farm-monster-parts/">Monster Hunter Stories 2 | How to farm Monster Parts<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 farm parts" title="Monster Hunter Stories 2 | How to farm Monster Parts" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-rare-eggs/">Monster Hunter Stories 2 | How to get Rare Eggs<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 Rare Egg" title="Monster Hunter Stories 2 | How to get Rare Eggs" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-zenny-fast/">Monster Hunter Stories 2 | How to get Zenny fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Stories 2 Zenny" title="Monster Hunter Stories 2 | How to get Zenny fast" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/monster-hunter-stories-2-wings-of-ruin/">Monster Hunter Stories 2</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/07/what-to-expect-from-knockout-city-season-2/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/07/what-to-expect-from-knockout-city-season-2/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">MARVEL Future Revolution gets release date</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2015/02/uk-charts-the-order-1886-on-top/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Coming soon to Apple Arcade</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-253617" class="post-253617 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-previews category-video-features tag-ea-originals tag-knockout-city tag-velan-studios" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                What to expect from Knockout City Season 2                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="July 27, 2021">July 27, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='What to expect from Knockout City Season 2' data-link='https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/' data-summary='Soda balls to that!' data-app-id-name='post_above_content'></div>
<p><a href="https://www.godisageek.com/reviews/knockout-city-review/" target="_blank" rel="noopener noreferrer">Knockout City</a> season 2 is upon us, and with it, we got a new ball and a new map. We were fortunate enough to be able to see some of Season 2 ahead of time, and get a handle on it. We also got to speak to the developers and ask some questions about it.<br /><br />In the <a href="https://www.youtube.com/watch?v=jzDCtx1Zbsw" target="_blank" rel="noopener noreferrer">video</a> below, you can hear myself and Chris Hyde discussing Knockout City Season 2 in detail.<br /><br /><div class='video_frame'><iframe id='youtube_video_1' class='youtube_video' src='https://www.youtube.com/embed/jzDCtx1Zbsw?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div> <br /><br />Speaking with one of the studio founders, and the game designer, we got plenty of new info, too. You can read plenty of that in <a href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/" target="_blank" rel="noopener noreferrer">our interview</a>. Here&#8217;s a snippet:</p>
<p>“Your strategy for entering that area changes completely based on which movie preview is being displayed. There’s the Siege of Balthazar, the one with the castle, and there’s only certain entry points there, and you can mask your approach because of the high walls. But that’s totally different than say The Pyramid movie, where it’s almost a little King of the Hill as you have someone standing at the top looking down at the entire arena. They’re entirely exposed but they have a great view of everything. Each time one of these movie previews comes up, the strategy of play inside it, and the strategy of how you want to approach is totally different.”</p>
<p><a href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/" target="_blank" rel="noopener noreferrer"><strong>Read the interview, here</strong></a>.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='What to expect from Knockout City Season 2' data-link='https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/' data-summary='Soda balls to that!' data-app-id-name='post_below_content'></div><div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='What to expect from Knockout City Season 2' data-link='https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/' data-summary='Soda balls to that!' data-app-id-name='post_below_content'></div><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/previews/" title="View all posts in Previews">Previews</a>, <a href="https://www.godisageek.com/category/features/video-features/" title="View all posts in Video Features">Video Features</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/ea-originals/" title="ea originals Tag" class="ea-originals">ea originals</a><a href="https://www.godisageek.com/tag/knockout-city/" title="Knockout City Tag" class="knockout-city">Knockout City</a><a href="https://www.godisageek.com/tag/velan-studios/" title="Velan Studios Tag" class="velan-studios">Velan Studios</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief here at GodisaGeek, I organise almost every bit of content as well as running our weekly Podcast, and being the lead producer on our YouTube Channel. That means I'm very busy and sometimes grumpy. Yay!<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="16772" data-method="tags" class="info active" title="More articles tagged: ea originals">ea originals<span class="bottom-arrow"></span></a><a data-sorter="28029" data-method="tags" class="info" title="More articles tagged: Knockout City">Knockout City<span class="bottom-arrow"></span></a><a data-sorter="28273" data-method="tags" class="info" title="More articles tagged: Velan Studios">Velan Studios<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Velan Studios: &quot;We knew that if they got their hands on it, they&#039;d love it&quot; | Knockout City Interview" title="Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview" srcset="https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Velan-Studios-We-knew-that-if-they-got-their-hands-on-it-theyd-love-it-Knockout-City-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/">Velan Studios: &#8220;We knew that if they got their hands on it, they&#8217;d love it&#8221; | Knockout City Interview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/velan-studios-we-knew-that-if-they-got-their-hands-on-it-theyd-love-it-knockout-city-interview/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/knockout-city-season-2-adds-a-new-soda-ball-new-map-and-more/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Knockout-City-Season-2-c-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Knockout City Season 2 adds a new Soda Ball, new map and more" srcset="https://www.godisageek.com/wp-content/uploads/Knockout-City-Season-2-c-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Knockout-City-Season-2-c-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Knockout-City-Season-2-c-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Knockout-City-Season-2-c-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/knockout-city-season-2-adds-a-new-soda-ball-new-map-and-more/">Knockout City Season 2 adds a new Soda Ball, new map and more</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/knockout-city-season-2-adds-a-new-soda-ball-new-map-and-more/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/knockout-city-how-to-do-fake-shots-curl-shots-trick-shots-guide-tutorial/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Knockout-City-fake-shots-trick-shots-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Knockout City | How to do fake shots and trick shots" title="Knockout City | How to do fake shots and trick shots" srcset="https://www.godisageek.com/wp-content/uploads/Knockout-City-fake-shots-trick-shots-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Knockout-City-fake-shots-trick-shots-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Knockout-City-fake-shots-trick-shots-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Knockout-City-fake-shots-trick-shots-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/knockout-city-how-to-do-fake-shots-curl-shots-trick-shots-guide-tutorial/">Knockout City | How to do fake shots and trick shots</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/knockout-city-how-to-do-fake-shots-curl-shots-trick-shots-guide-tutorial/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/knockout-city-cross-play-how-to-play-with-friends-on-any-console-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-crew-area-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Knockout City | How to cross play on any console" title="Knockout City | How to cross play with friends on other consoles" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-crew-area-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-crew-area-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-crew-area-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-crew-area-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/knockout-city-cross-play-how-to-play-with-friends-on-any-console-guide/">Knockout City | How to cross play with friends on other consoles</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/knockout-city-cross-play-how-to-play-with-friends-on-any-console-guide/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/it-takes-two-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two review" title="It Takes Two review" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/it-takes-two-review/">It Takes Two review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/it-takes-two-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/05/ea-originals-title-sea-solitude-launch-worldwide-july/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="EA Originals title Sea of Solitude to launch worldwide in July." srcset="https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/sea-of-solitude-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/05/ea-originals-title-sea-solitude-launch-worldwide-july/">EA Originals title Sea of Solitude to launch worldwide in July.</a></div><a class="hover-link" href="https://www.godisageek.com/2019/05/ea-originals-title-sea-solitude-launch-worldwide-july/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/end-of-dragons-expansion-footage-for-guild-wars-2-revealed/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed" srcset="https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Guild-Wars-End-of-Dragons-news-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/end-of-dragons-expansion-footage-for-guild-wars-2-revealed/">&#8216;End of Dragons&#8217; expansion footage for Guild Wars 2 revealed</a><div class="article-meta clearfix"><a class="like-button do-like 253664 info-bottom" data-postid="253664" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/07/end-of-dragons-expansion-footage-for-guild-wars-2-revealed/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/xbox-announces-summer-spotlight-2021/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Xbox Summer Spotlight" title="Xbox announces Summer Spotlight 2021" srcset="https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Xbox-Summer-Spotlight-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/xbox-announces-summer-spotlight-2021/">Xbox announces Summer Spotlight 2021</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/xbox-announces-summer-spotlight-2021/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apple Arcade" title="Coming soon to Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apple-Arcade-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/">Coming soon to Apple Arcade</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/coming-soon-to-apple-arcade/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Marvel Future Revolution Release Date News" title="MARVEL Future Revolution gets release date" srcset="https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Marvel-Future-Revolution-Release-Date-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/">MARVEL Future Revolution gets release date</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/marvel-future-revolution-gets-release-date/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/samurai-warriors-5-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/hero-24-85x85.jpeg" class="attachment-widget-post size-widget-post wp-post-image" alt="Samurai Warriors 5 title image" title="Samurai Warriors 5 review" srcset="https://www.godisageek.com/wp-content/uploads/hero-24-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/hero-24-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-24-35x35.jpeg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">Samurai Warriors 5 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 253566 info-bottom" data-postid="253566" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEO: The World Ends With You Review" title="NEO: The World Ends With You review" srcset="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">NEO: The World Ends With You review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles title image" title="The Great Ace Attorney Chronicles review" srcset="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-23-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-23-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">The Great Ace Attorney Chronicles review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ender Lilies: Quietus of the Knights review" title="Ender Lilies: Quietus of the Knights review" srcset="https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ender-Lilies-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">Ender Lilies: Quietus of the Knights review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cris-tales-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Cris Tales title image" title="Cris Tales review" srcset="https://www.godisageek.com/wp-content/uploads/hero-22-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-22-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-22-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cris-tales-review/">Cris Tales review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cris-tales-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2</a><div class="article-meta clearfix"><a class="like-button do-like 253617 info-bottom" data-postid="253617" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/monster-hunter-stories-2-wings-of-ruin-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Main-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Monster Hunter Stories 2: Wings of Ruin" title="Monster Hunter Stories 2: Wings of Ruin review" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Main-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-hunter-stories-2-wings-of-ruin-review/">Monster Hunter Stories 2: Wings of Ruin review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 252705 info-bottom" data-postid="252705" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-hunter-stories-2-wings-of-ruin-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-legend-of-zelda-skyward-sword-hd-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Legend of Zelda: Skyward Sword HD review" title="The Legend of Zelda: Skyward Sword HD review" srcset="https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-legend-of-zelda-skyward-sword-hd-review/">The Legend of Zelda: Skyward Sword HD review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-legend-of-zelda-skyward-sword-hd-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles title image" title="The Great Ace Attorney Chronicles review" srcset="https://www.godisageek.com/wp-content/uploads/hero-23-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-23-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-23-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">The Great Ace Attorney Chronicles review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEO: The World Ends With You Review" title="NEO: The World Ends With You review" srcset="https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEO-The-World-Ends-With-You-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">NEO: The World Ends With You review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/streets-of-rage-4-mr-x-nightmare-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mr-X-Nightmare-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Streets of Rage 4: Mr. X Nightmare Review" title="Streets of Rage 4: Mr. X Nightmare review" srcset="https://www.godisageek.com/wp-content/uploads/Mr-X-Nightmare-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mr-X-Nightmare-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mr-X-Nightmare-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mr-X-Nightmare-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/streets-of-rage-4-mr-x-nightmare-review/">Streets of Rage 4: Mr. X Nightmare review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/streets-of-rage-4-mr-x-nightmare-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/skyward-sword-hd-airshop-beedle-floating-shop-guide-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/beedles-airshop-skyward-sword-hd-floating-shop/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Skyward Sword HD | How to find and enter Beedle’s flying air shop</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-S-Rank-4a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-s-rank/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Stories 2 | How to get S Rank</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-bottle-caps-1a-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-bottle-caps/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Stories 2 | How to get Bottle Caps</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-farm-parts-2a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-farm-monster-parts/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Stories 2 | How to farm Monster Parts</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Rare-Egg-3a-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-rare-eggs/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Stories 2 | How to get Rare Eggs</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Stories-2-Zenny-2a-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/07/monster-hunter-stories-2-how-to-get-zenny-fast/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Stories 2 | How to get Zenny fast</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">Samurai Warriors 5 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/samurai-warriors-5-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">NEO: The World Ends With You review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neo-the-world-ends-with-you-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">The Great Ace Attorney Chronicles review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-great-ace-attorney-chronicles-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">Ender Lilies: Quietus of the Knights review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/ender-lilies-quietus-of-the-knights-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cris-tales-review/">Cris Tales review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cris-tales-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.692307692308px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.923076923077px;" aria-label="Activision (777 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12px;" aria-label="Bandai Namco (384 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-4" style="font-size: 12.230769230769px;" aria-label="Call of Duty (394 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 18px;" aria-label="Capcom (702 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 14.076923076923px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.846153846154px;" aria-label="EA (1,143 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12.461538461538px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.692307692308px;" aria-label="Konami (562 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.769230769231px;" aria-label="Microsoft (938 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,746 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.153846153846px;" aria-label="nintendo switch (794 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.692307692308px;" aria-label="PC (1,378 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.692307692308px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 14.307692307692px;" aria-label="PlayStation 4 (491 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.384615384615px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.538461538462px;" aria-label="PS4 (1,234 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.538461538462px;" aria-label="Sega (679 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 21px;" aria-label="Sony (954 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (914 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 14.076923076923px;" aria-label="Steam (473 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.538461538462px;" aria-label="Trailer (682 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 24px;" aria-label="Ubisoft (1,284 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.538461538462px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24px;" aria-label="Xbox One (1,281 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.913705583756px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.380710659898px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.152284263959px;" aria-label="Competition (219 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.903553299492px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 19.994923857868px;" aria-label="Features (2,354 items)">Features</a>
<a href="https://www.godisageek.com/category/features/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 12px;" aria-label="Guides (208 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12.152284263959px;" aria-label="Interview (218 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.751269035533px;" aria-label="iOS (355 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,533 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.502538071066px;" aria-label="Opinion (600 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 14.208121827411px;" aria-label="Paid Placement Advertorials (409 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.53807106599px;" aria-label="PC (2,056 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.416243654822px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.548223350254px;" aria-label="PlayStation 4 (1,514 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.111675126904px;" aria-label="Podcasts (724 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.644670050761px;" aria-label="Previews (842 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.522842639594px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 21.89847715736px;" aria-label="Reviews (4,170 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.111675126904px;" aria-label="Switch (716 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.685279187817px;" aria-label="Tech (258 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.786802030457px;" aria-label="Trailers (1,193 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13.142131979695px;" aria-label="Uncategorised (296 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.253807106599px;" aria-label="Video Features (1,019 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 16.035532994924px;" aria-label="Xbox 360 (714 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 17.786802030457px;" aria-label="Xbox One (1,193 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.04px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.2px;" aria-label="Android (78 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.28px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.36px;" aria-label="Google Stadia (17 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.26px;" aria-label="HTC Vive (25 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.28px;" aria-label="iOS (119 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.04px;" aria-label="Mac (34 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (4 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.38px;" aria-label="Oculus Rift (26 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,586 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.88px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.82px;" aria-label="PlayStation 4 (1,462 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 19.74px;" aria-label="PlayStation 5 (97 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.36px;" aria-label="PlayStation VR (56 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 21px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.08px;" aria-label="Switch (760 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.6px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.92px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.16px;" aria-label="Xbox One (1,141 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 18.78px;" aria-label="Xbox Series S (67 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 19.14px;" aria-label="Xbox Series X (77 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
