<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Sci-Fi VR adventure Hubris is coming to PC VR platforms in December | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Cyborn has confirmed that Hubris will be released in December for, and it&#039;s coming to Meta Quest 2 and PlayStation VR2 in 2023, as well." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December | GodisaGeek.com" />
	<meta property="og:description" content="Cyborn has confirmed that Hubris will be released in December for, and it&#039;s coming to Meta Quest 2 and PlayStation VR2 in 2023, as well." />
	<meta property="og:url" content="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-10-25T13:00:01+00:00" />
	<meta property="article:modified_time" content="2022-10-25T11:28:39+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December.jpg","width":1920,"height":1080,"caption":"Sci-Fi VR adventure Hubris is coming to PC VR platforms in December"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#webpage","url":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/","name":"Sci-Fi VR adventure Hubris is coming to PC VR platforms in December | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#primaryimage"},"datePublished":"2022-10-25T13:00:01+00:00","dateModified":"2022-10-25T11:28:39+00:00","description":"Cyborn has confirmed that Hubris will be released in December for, and it's coming to Meta Quest 2 and PlayStation VR2 in 2023, as well.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0"},"headline":"Sci-Fi VR adventure Hubris is coming to PC VR platforms in December","datePublished":"2022-10-25T13:00:01+00:00","dateModified":"2022-10-25T11:28:39+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/#primaryimage"},"keywords":"Cyborn,Hubris,Meta Quest 2,PSVR 2,vr","articleSection":"News","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/923cf00b2377c00181ae7b2e833fadf0","name":"Adam Cook","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=96&d=mm&r=g","caption":"Adam Cook"},"description":"Editor-in-Chief.","sameAs":["jebusf","https://twitter.com/jebusf","godisageek"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"10","day":"25","hour":"14","minute":"00","second":"01","post_id":"269397","postname":"sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/' />
<meta name='shareaholic:keywords' content='tag:cyborn, tag:hubris, tag:meta quest 2, tag:psvr 2, tag:vr, cat:news, type:post' />
<meta name='shareaholic:article_published_time' content='2022-10-25T14:00:01+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-10-25T12:28:39+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Adam Cook' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=269397' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F10%2Fsci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F10%2Fsci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '7cbbb07c3e'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/"},"headline":"Sci-Fi VR adventure Hubris is coming to PC VR platforms in December","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December.jpg","width":1920,"height":1080},"datePublished":"2022-10-25T14:00:01+0000","dateModified":"2022-10-25T12:28:39+0000","author":{"@type":"Person","name":"Adam Cook","url":"https://www.godisageek.com/author/loreneholeman2/john-adams"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}},"description":"Cyborn has confirmed that Hubris will be released in December for, and it's coming to Meta Quest 2 and PlayStation VR2 in 2023, as well."}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/10\/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december\/","name":"Sci-Fi VR adventure Hubris is coming to PC VR platforms in December"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-269397 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/signalis-review/">Signalis review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Signalis-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Signalis Review" title="Signalis review" srcset="https://www.godisageek.com/wp-content/uploads/Signalis-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bayonetta-3-review/">Bayonetta 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bayonetta 3 review" title="Bayonetta 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/victoria-3-review/">Victoria 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Victoria 3" title="Victoria 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">Resident Evil Village: Winters Expansion review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Winters Expansion Review" title="Resident Evil Village: Winters Expansion review" srcset="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-valiant-review/">The Valiant review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Valiant" title="The Valiant review" srcset="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-valiant-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-valiant-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-valiant-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-40000-shootaz-blood-teef-review/">Warhammer 40,000: Shootaz, Blood &#038; Teef review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer 40,000: Shootaz, Blood &amp; Teef" title="Warhammer 40,000: Shootaz, Blood &#038; Teef review" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/the-devil-in-me-feels-new-shocking-and-creepy-as-hell-hands-on-preview/">The Devil in Me feels new, shocking, and creepy as hell | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Devil in Me" title="The Devil in Me feels new, shocking, and creepy as hell | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/aces-and-adventures-has-me-completely-hooked-hands-on-preview/">Aces and Adventures has me completely hooked | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Aces and Adventures title image" title="Aces and Adventures has me completely hooked | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/interview-with-the-devil-in-me-creative-director-tom-heaton/">Interview with The Devil in Me Creative Director Tom Heaton<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Devil in Me Interview" title="Interview with The Devil in Me Creative Director Tom Heaton" srcset="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/podcast-502-gotham-knights-mario-rabbids-sparks-of-hope-a-plague-tale-requiem/">Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem" title="Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/deadlink-is-like-ghostrunner-meets-hades-hands-on-preview/">Deadlink is like Ghostrunner meets Hades | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Deadlink-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Deadlink preview" title="Deadlink is like Ghostrunner meets Hades | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Deadlink-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/god-of-war-ragnarok-is-already-showing-signs-of-greatness-hands-on-preview/">God of War Ragnarok is already showing signs of greatness | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War Ragnarok is already showing signs of greatness | Hands-on preview" title="God of War Ragnarok is already showing signs of greatness | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/signalis-how-to-open-the-5-lock-door/">Signalis | How to open the 5 Lock Door<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Signalis 5 Lock" title="Signalis | How to open the 5 Lock Door" srcset="https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">Everything you need to know about Call of Duty: Modern Warfare II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything you need to know about Call of Duty: Modern Warfare II" title="Everything you need to know about Call of Duty: Modern Warfare II" srcset="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-co-op/">Gotham Knights | How to co-op<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights how to co-op" title="Gotham Knights | How to co-op" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-fast-travel/">Gotham Knights | How to fast travel<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights Fast Travel Guide" title="Gotham Knights | How to fast travel" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-switch-character/">Gotham Knights | How to switch character<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights | How to switch character" title="Gotham Knights | How to switch character" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/a-plague-tale-requiem-6-beginners-tips/">A Plague Tale Requiem | 6 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale: Requiem | 6 Beginner&#039;s Tips" title="A Plague Tale Requiem | 6 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/latest-legends-of-runeterra-patch-fixes-various-tumbles-bugs-and-more/">Latest Legends of Runeterra patch fixes various Tumbles bugs and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Legends of Runeterra Patch" title="Latest Legends of Runeterra patch fixes various Tumbles bugs and more" srcset="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/you-will-die-here-tonight-is-getting-six-demos-for-steam-scream-fest/">You Will Die Here Tonight is getting six demos for Steam Scream Fest<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="You Will Die Here Tonight is getting six demos for Steam Scream Fest" title="You Will Die Here Tonight is getting six demos for Steam Scream Fest" srcset="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/">Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atomicrops &quot;Deerly Beloved&quot; Halloween themed DLC out now" title="Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now" srcset="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/">Sci-Fi VR adventure Hubris is coming to PC VR platforms in December<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" title="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" srcset="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">Everything you need to know about Call of Duty: Modern Warfare II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything you need to know about Call of Duty: Modern Warfare II" title="Everything you need to know about Call of Duty: Modern Warfare II" srcset="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/first-new-disney-dreamlight-valley-content-released-scars-kingdom/">First new Disney Dreamlight Valley content released: Scar&#8217;s Kingdom<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="First new Disney Dreamlight Valley content released: Scar&#039;s Kingdom" title="First new Disney Dreamlight Valley content released: Scar&#8217;s Kingdom" srcset="https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/signalis-review/">Signalis review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Signalis-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Signalis Review" title="Signalis review" srcset="https://www.godisageek.com/wp-content/uploads/Signalis-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/bayonetta-3-review/">Bayonetta 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bayonetta 3 review" title="Bayonetta 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/victoria-3-review/">Victoria 3 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Victoria 3" title="Victoria 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">Resident Evil Village: Winters Expansion review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Winters Expansion Review" title="Resident Evil Village: Winters Expansion review" srcset="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-valiant-review/">The Valiant review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Valiant" title="The Valiant review" srcset="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-valiant-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-valiant-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-valiant-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/warhammer-40000-shootaz-blood-teef-review/">Warhammer 40,000: Shootaz, Blood &#038; Teef review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Warhammer 40,000: Shootaz, Blood &amp; Teef" title="Warhammer 40,000: Shootaz, Blood &#038; Teef review" srcset="https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Warhammer-40k-Shootaz-main-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/the-devil-in-me-feels-new-shocking-and-creepy-as-hell-hands-on-preview/">The Devil in Me feels new, shocking, and creepy as hell | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Devil in Me" title="The Devil in Me feels new, shocking, and creepy as hell | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/aces-and-adventures-has-me-completely-hooked-hands-on-preview/">Aces and Adventures has me completely hooked | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Aces and Adventures title image" title="Aces and Adventures has me completely hooked | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rsz_ss_c8541261cf1244b87c84a7a65b218f816907ab3d-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/interview-with-the-devil-in-me-creative-director-tom-heaton/">Interview with The Devil in Me Creative Director Tom Heaton<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Devil in Me Interview" title="Interview with The Devil in Me Creative Director Tom Heaton" srcset="https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Devil-in-Me-Interview-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/podcast-502-gotham-knights-mario-rabbids-sparks-of-hope-a-plague-tale-requiem/">Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem" title="Podcast 502: Gotham Knights, Mario + Rabbids Sparks of Hope, A Plague Tale Requiem" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-502-Gotham-Knights-Sparks-of-Hope-A-Plague-Tale-Requiem-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/deadlink-is-like-ghostrunner-meets-hades-hands-on-preview/">Deadlink is like Ghostrunner meets Hades | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Deadlink-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Deadlink preview" title="Deadlink is like Ghostrunner meets Hades | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Deadlink-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Deadlink-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/god-of-war-ragnarok-is-already-showing-signs-of-greatness-hands-on-preview/">God of War Ragnarok is already showing signs of greatness | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War Ragnarok is already showing signs of greatness | Hands-on preview" title="God of War Ragnarok is already showing signs of greatness | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-is-already-showing-signs-of-greatness-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/signalis-how-to-open-the-5-lock-door/">Signalis | How to open the 5 Lock Door<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Signalis 5 Lock" title="Signalis | How to open the 5 Lock Door" srcset="https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">Everything you need to know about Call of Duty: Modern Warfare II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything you need to know about Call of Duty: Modern Warfare II" title="Everything you need to know about Call of Duty: Modern Warfare II" srcset="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-co-op/">Gotham Knights | How to co-op<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights how to co-op" title="Gotham Knights | How to co-op" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-fast-travel/">Gotham Knights | How to fast travel<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights Fast Travel Guide" title="Gotham Knights | How to fast travel" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/gotham-knights-how-to-switch-character/">Gotham Knights | How to switch character<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gotham Knights | How to switch character" title="Gotham Knights | How to switch character" srcset="https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/a-plague-tale-requiem-6-beginners-tips/">A Plague Tale Requiem | 6 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale: Requiem | 6 Beginner&#039;s Tips" title="A Plague Tale Requiem | 6 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/10/latest-legends-of-runeterra-patch-fixes-various-tumbles-bugs-and-more/">Latest Legends of Runeterra patch fixes various Tumbles bugs and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Legends of Runeterra Patch" title="Latest Legends of Runeterra patch fixes various Tumbles bugs and more" srcset="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/you-will-die-here-tonight-is-getting-six-demos-for-steam-scream-fest/">You Will Die Here Tonight is getting six demos for Steam Scream Fest<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="You Will Die Here Tonight is getting six demos for Steam Scream Fest" title="You Will Die Here Tonight is getting six demos for Steam Scream Fest" srcset="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/">Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atomicrops &quot;Deerly Beloved&quot; Halloween themed DLC out now" title="Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now" srcset="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/">Sci-Fi VR adventure Hubris is coming to PC VR platforms in December<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" title="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" srcset="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">Everything you need to know about Call of Duty: Modern Warfare II<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything you need to know about Call of Duty: Modern Warfare II" title="Everything you need to know about Call of Duty: Modern Warfare II" srcset="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/first-new-disney-dreamlight-valley-content-released-scars-kingdom/">First new Disney Dreamlight Valley content released: Scar&#8217;s Kingdom<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="First new Disney Dreamlight Valley content released: Scar&#039;s Kingdom" title="First new Disney Dreamlight Valley content released: Scar&#8217;s Kingdom" srcset="https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/First-new-Disney-Dreamlight-Valley-content-released-Scars-Kingdom-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/10/the-devil-in-me-feels-new-shocking-and-creepy-as-hell-hands-on-preview/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">The Devil in Me feels new, shocking, and creepy as hell | Hands-on preview</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2019/02/red-dead-online-beta-todays-update/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Atomicrops "Deerly Beloved" Halloween themed DLC out now</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-269397" class="post-269397 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-cyborn tag-hubris tag-meta-quest-2 tag-psvr-2 tag-vr" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Sci-Fi VR adventure Hubris is coming to PC VR platforms in December                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/john-adams/"><span itemprop="author">Adam Cook </span></a></span><span class="date">on <meta itemprop="datePublished" content="October 25, 2022">October 25, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" title="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Sci-Fi VR adventure Hubris is coming to PC VR platforms in December' data-link='https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/' data-summary='PSVR2 at a later date.' data-app-id-name='post_above_content'></div>
<p>Cyborn has confirmed that Hubris will be released on Wednesday 7th December 2022 for €39.99/£39.99/$39.99, and it&#8217;s coming to <a href="https://www.oculus.com/blog/meta-quest-2-pricing-changes/?locale=en_GB" target="_blank" rel="noopener noreferrer">Meta Quest 2</a> and <a href="https://www.godisageek.com/2022/01/playstation-vr2-detailed-in-official-blog-post/">PlayStation VR2</a>, and &#8220;some other unannounced platforms&#8221; in 2023, as well.</p>
<blockquote><p>Players who take on Hubris come December will encounter a VR action-adventure game set in an absorbing and mystical Universe. Serving as a recruit of the Order of Objectivity (or OOO for short) sent to the Twin planet system to search for agent Cyana, simply staying alive in Hubris is a case of shooting, swimming, climbing, and jumping your way through a hostile world in the midst of being terraformed.</p>
<p>With Hubris delivering immersive 3D graphics and motion capture, developer Cyborn set out to use a blend of visuals, sound, and technology to produce unforgettable and engaging worlds. Hubris is a captivating adventure specifically designed from the ground up for VR platforms, allowing players to move around its environment in an all-encompassing, engaging manner.</p></blockquote>
<div class='video_frame'><iframe id='youtube_video_1' class='youtube_video' src='https://www.youtube.com/embed/oQW4k2U9YGw?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p>&nbsp;</p>
<p>“We were blown away by the response we saw at Gamescom and it’s really exciting to finally be able to lift the lid on the launch of Hubris in just over a month,&#8221; says Ives Agemans, CEO and Game Director at Cyborn. “At Cyborn we know how important is to make the most of the opportunities VR provides, and we think Hubris is going to serve as the next step for the genre, delivering an immersive experience that will push VR platforms forward&#8221;.</p>
<h3>Hubris features:</h3>
<ul>
<li>Enjoy a full VR experience in which you are able to move, climb, swim and jump freely.</li>
<li>Become part of the unique and intriguing Sci-Fi world of Hubris, the start of a new full-blown space saga.</li>
<li>Savour some of the best and most immersive graphics in VR available.</li>
<li>Fight alongside epic and colourful characters against a mix of alien wildlife, humanoids and mechanised enemies, each of them requiring unique tactics to defeat.</li>
<li>Gather and salvage resources, craft weapons and tools, control vehicles and mechanical devices.</li>
<li>Unravel the OOO’s long-forgotten secrets.</li>
<li>Earn your place as an agent of the Order of Objectivity.</li>
</ul>
<p><em>Hubris is coming to PC VR platforms on December 7th.</em></p>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Sci-Fi VR adventure Hubris is coming to PC VR platforms in December' data-link='https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/' data-summary='PSVR2 at a later date.' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Sci-Fi VR adventure Hubris is coming to PC VR platforms in December' data-link='https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/' data-summary='PSVR2 at a later date.' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/cyborn/" title="Cyborn Tag" class="cyborn">Cyborn</a><a href="https://www.godisageek.com/tag/hubris/" title="Hubris Tag" class="hubris">Hubris</a><a href="https://www.godisageek.com/tag/meta-quest-2/" title="Meta Quest 2 Tag" class="meta-quest-2">Meta Quest 2</a><a href="https://www.godisageek.com/tag/psvr-2/" title="PSVR 2 Tag" class="psvr-2">PSVR 2</a><a href="https://www.godisageek.com/tag/vr/" title="vr Tag" class="vr">vr</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><img alt='' src='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e46401da6e9e0cec783e3e3d63a61ddd?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/john-adams/"><h3>Adam Cook</h3></a>Editor-in-Chief.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/jebusf" target="_blank"></a><a class="icon-youtube info" title="Find me on YouTube" href="http://www.youtube.com/user/godisageek" target="_blank"></a><a class="icon-instagram info" title="Find me on Instagram" href="http://instagram.com/jebusf" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:adam@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com/" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="29811" data-method="tags" class="info active" title="More articles tagged: Meta Quest 2">Meta Quest 2<span class="bottom-arrow"></span></a><a data-sorter="19601" data-method="tags" class="info" title="More articles tagged: vr">vr<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/little-cities-attractions-update-is-available-now/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Cities-Attractions-update-is-available-now-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Cities Attractions update is available now" title="Little Cities Attractions update is available now" srcset="https://www.godisageek.com/wp-content/uploads/Little-Cities-Attractions-update-is-available-now-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Cities-Attractions-update-is-available-now-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Cities-Attractions-update-is-available-now-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Cities-Attractions-update-is-available-now-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/little-cities-attractions-update-is-available-now/">Little Cities Attractions update is available now</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/little-cities-attractions-update-is-available-now/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/little-cities-vr-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-Cities-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Cities VR review" title="Little Cities VR review" srcset="https://www.godisageek.com/wp-content/uploads/little-Cities-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-Cities-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-Cities-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-Cities-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/little-cities-vr-review/">Little Cities VR review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/little-cities-vr-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/10/latest-legends-of-runeterra-patch-fixes-various-tumbles-bugs-and-more/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Legends of Runeterra Patch" title="Latest Legends of Runeterra patch fixes various Tumbles bugs and more" srcset="https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Legends-of-Runeterra-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/10/latest-legends-of-runeterra-patch-fixes-various-tumbles-bugs-and-more/">Latest Legends of Runeterra patch fixes various Tumbles bugs and more</a><div class="article-meta clearfix"><a class="like-button do-like 269408 info-bottom" data-postid="269408" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/10/latest-legends-of-runeterra-patch-fixes-various-tumbles-bugs-and-more/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/10/you-will-die-here-tonight-is-getting-six-demos-for-steam-scream-fest/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="You Will Die Here Tonight is getting six demos for Steam Scream Fest" title="You Will Die Here Tonight is getting six demos for Steam Scream Fest" srcset="https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/You-Will-Die-Here-Tonight-is-getting-six-demos-for-Steam-Scream-Fest-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/10/you-will-die-here-tonight-is-getting-six-demos-for-steam-scream-fest/">You Will Die Here Tonight is getting six demos for Steam Scream Fest</a></div><a class="hover-link" href="https://www.godisageek.com/2022/10/you-will-die-here-tonight-is-getting-six-demos-for-steam-scream-fest/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atomicrops &quot;Deerly Beloved&quot; Halloween themed DLC out now" title="Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now" srcset="https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Atomicrops-Deerly-Beloved-Halloween-themed-DLC-out-now-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/">Atomicrops &#8220;Deerly Beloved&#8221; Halloween themed DLC out now</a></div><a class="hover-link" href="https://www.godisageek.com/2022/10/atomicrops-deerly-beloved-halloween-themed-dlc-out-now/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" title="Sci-Fi VR adventure Hubris is coming to PC VR platforms in December" srcset="https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sci-Fi-VR-adventure-Hubris-is-coming-to-PC-VR-platforms-in-December-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/">Sci-Fi VR adventure Hubris is coming to PC VR platforms in December</a></div><a class="hover-link" href="https://www.godisageek.com/2022/10/sci-fi-vr-adventure-hubris-is-coming-to-pc-vr-platforms-in-december/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything you need to know about Call of Duty: Modern Warfare II" title="Everything you need to know about Call of Duty: Modern Warfare II" srcset="https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">Everything you need to know about Call of Duty: Modern Warfare II</a></div><a class="hover-link" href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/signalis-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Signalis-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Signalis Review" title="Signalis review" srcset="https://www.godisageek.com/wp-content/uploads/Signalis-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Signalis-Review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/signalis-review/">Signalis review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 269310 info-bottom" data-postid="269310" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/signalis-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/bayonetta-3-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Bayonetta 3 review" title="Bayonetta 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Bayonetta-3-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bayonetta-3-review/">Bayonetta 3 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/bayonetta-3-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/victoria-3-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Victoria 3" title="Victoria 3 review" srcset="https://www.godisageek.com/wp-content/uploads/Victoria-3-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Victoria-3-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/victoria-3-review/">Victoria 3 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/victoria-3-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Resident Evil Winters Expansion Review" title="Resident Evil Village: Winters Expansion review" srcset="https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Resident-Evil-Winters-Expansion-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">Resident Evil Village: Winters Expansion review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-valiant-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Valiant" title="The Valiant review" srcset="https://www.godisageek.com/wp-content/uploads/The-valiant-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-valiant-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-valiant-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-valiant-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-valiant-review/">The Valiant review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-valiant-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far</a><div class="article-meta clearfix"><a class="like-button do-like 267467 info-bottom" data-postid="267467" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Uncharted: Legacy of Thieves Collection PC &amp; Steam Deck review" title="Uncharted: Legacy of Thieves Collection PC &#038; Steam Deck review" srcset="https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/">Uncharted: Legacy of Thieves Collection PC &#038; Steam Deck review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 268916 info-bottom" data-postid="268916" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Royal title image" title="Persona 5 Royal Steam Deck &#038; Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/">Persona 5 Royal Steam Deck &#038; Nintendo Switch review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/overwatch-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Overwatch-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Overwatch 2 review" title="Overwatch 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Overwatch-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Overwatch-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Overwatch-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Overwatch-2-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/overwatch-2-review/">Overwatch 2 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/overwatch-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/no-mans-sky-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Nintendo-Switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No Man&#039;s Sky Nintendo Switch review" title="No Man&#8217;s Sky Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Nintendo-Switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Nintendo-Switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Nintendo-Switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Nintendo-Switch-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/no-mans-sky-nintendo-switch-review/">No Man&#8217;s Sky Nintendo Switch review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/no-mans-sky-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nier-automata-the-end-of-yorha-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NieR-Automata-The-End-of-YoRHa-Edition-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NieR: Automata The End of YoRHa Edition review" title="NieR: Automata The End of YoRHa Edition review" srcset="https://www.godisageek.com/wp-content/uploads/NieR-Automata-The-End-of-YoRHa-Edition-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NieR-Automata-The-End-of-YoRHa-Edition-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NieR-Automata-The-End-of-YoRHa-Edition-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/NieR-Automata-The-End-of-YoRHa-Edition-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nier-automata-the-end-of-yorha-edition-review/">NieR: Automata The End of YoRHa Edition review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/nier-automata-the-end-of-yorha-edition-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Signalis-5-Lock-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/signalis-how-to-open-the-5-lock-door/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Signalis | How to open the 5 Lock Door</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Call-of-Duty-Modern-Warfare-II-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/everything-you-need-to-know-about-call-of-duty-modern-warfare-ii/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Everything you need to know about Call of Duty: Modern Warfare II</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Gotham-Knights-PC-featured-detailed-in-new-trailer-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/gotham-knights-how-to-co-op/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Gotham Knights | How to co-op</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Gotham-Knights-Fast-Travel-Guide-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/gotham-knights-how-to-fast-travel/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Gotham Knights | How to fast travel</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Gotham-Knights-how-to-switch-characters-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/gotham-knights-how-to-switch-character/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Gotham Knights | How to switch character</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/APTR-TIPS-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/10/a-plague-tale-requiem-6-beginners-tips/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">A Plague Tale Requiem | 6 Beginner&#8217;s Tips</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/signalis-review/">Signalis review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/signalis-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bayonetta-3-review/">Bayonetta 3 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/bayonetta-3-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/victoria-3-review/">Victoria 3 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/victoria-3-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">Resident Evil Village: Winters Expansion review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/resident-evil-village-winters-expansion-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-valiant-review/">The Valiant review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-valiant-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.230769230769px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.461538461538px;" aria-label="Activision (783 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.692307692308px;" aria-label="Bandai Namco (438 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.769230769231px;" aria-label="Capcom (731 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.615384615385px;" aria-label="DLC (481 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,184 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (410 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (574 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.307692307692px;" aria-label="Microsoft (942 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,806 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.384615384615px;" aria-label="nintendo switch (848 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,402 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.230769230769px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.846153846154px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 21.923076923077px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.307692307692px;" aria-label="PS4 (1,245 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.769230769231px;" aria-label="Sega (720 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.769230769231px;" aria-label="Sony (966 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (950 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.615384615385px;" aria-label="Steam (479 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.307692307692px;" aria-label="Trailer (685 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,320 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.076923076923px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.538461538462px;" aria-label="Xbox One (1,289 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.466321243523px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-3" style="font-size: 13.476683937824px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-4" style="font-size: 20.238341968912px;" aria-label="Features (2,744 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-5" style="font-size: 14.642487046632px;" aria-label="Guides (525 items)">Guides</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-6" style="font-size: 13.39896373057px;" aria-label="iOS (361 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-7" style="font-size: 27px;" aria-label="News (20,348 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-8" style="font-size: 15.264248704663px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-9" style="font-size: 15.341968911917px;" aria-label="Paid Placement Advertorials (639 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-10" style="font-size: 19.849740932642px;" aria-label="PC (2,430 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-11" style="font-size: 16.041450777202px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-12" style="font-size: 18.761658031088px;" aria-label="PlayStation 4 (1,767 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/reviews/playstation-5/" class="tag-cloud-link tag-link-27592 tag-link-position-13" style="font-size: 12.777202072539px;" aria-label="PlayStation 5 (301 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 15.963730569948px;" aria-label="Podcasts (778 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.740932642487px;" aria-label="Previews (985 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 13.088082901554px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 22.025906735751px;" aria-label="Reviews (4,629 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.585492227979px;" aria-label="Switch (939 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 12.544041450777px;" aria-label="Tech (279 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.829015544041px;" aria-label="Trailers (1,347 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 12.777202072539px;" aria-label="Uncategorised (300 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 16.896373056995px;" aria-label="Video Features (1,034 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-23" style="font-size: 15.652849740933px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-24" style="font-size: 18.062176165803px;" aria-label="Xbox One (1,431 items)">Xbox One</a>
<a href="https://www.godisageek.com/category/reviews/xbox-series-x/" class="tag-cloud-link tag-link-27604 tag-link-position-25" style="font-size: 12.388601036269px;" aria-label="Xbox Series S|X (271 items)">Xbox Series S|X</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.760617760618px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.123552123552px;" aria-label="Android (85 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.779922779923px;" aria-label="Apple Arcade (14 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.227799227799px;" aria-label="Google Stadia (26 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.343629343629px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.108108108108px;" aria-label="iOS (125 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 16.980694980695px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.200772200772px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.517374517375px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,958 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.571428571429px;" aria-label="PlayStation 3 (151 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.710424710425px;" aria-label="PlayStation 4 (1,717 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 22.42471042471px;" aria-label="PlayStation 5 (317 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.312741312741px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.687258687259px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.262548262548px;" aria-label="Switch (980 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.370656370656px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.702702702703px;" aria-label="Xbox 360 (107 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.131274131274px;" aria-label="Xbox One (1,371 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.382239382239px;" aria-label="Xbox Series S (207 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 22.135135135135px;" aria-label="Xbox Series S|X (282 items)">Xbox Series S|X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
