<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>F.I.S.T: Forged in Shadow Torch review | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="F.I.S.T: Forged in Shadow Torch&#039;s exciting, brutal combat, and rewarding exploration set it apart from many of its genre-mates." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="F.I.S.T: Forged in Shadow Torch review | GodisaGeek.com" />
	<meta property="og:description" content="F.I.S.T: Forged in Shadow Torch&#039;s exciting, brutal combat, and rewarding exploration set it apart from many of its genre-mates." />
	<meta property="og:url" content="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:modified_time" content="2021-09-06T18:12:27+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1.jpg","width":1280,"height":720,"caption":"F.I.S.T: Forged in Shadow Torch"},{"@type":"WebPage","@id":"https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/#webpage","url":"https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/","name":"F.I.S.T: Forged in Shadow Torch review | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/#primaryimage"},"datePublished":"2021-09-06T07:00:33+00:00","dateModified":"2021-09-06T18:12:27+00:00","description":"F.I.S.T: Forged in Shadow Torch's exciting, brutal combat, and rewarding exploration set it apart from many of its genre-mates.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/"]}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"09","day":"06","hour":"08","minute":"00","second":"33","post_id":"255190","postname":"f-i-s-t-forged-in-shadow-torch-review","category":"reviews"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/' />
<meta name='shareaholic:keywords' content='tag:bilibili, tag:f.i.s.t, tag:f.i.s.t: forged in shadow torch, tag:metroidvania, tag:ti games, cat:pc, cat:playstation 4, cat:playstation 5, cat:reviews, cat:xbox one, cat:xbox series x, type:it_reviews' />
<meta name='shareaholic:article_published_time' content='2021-09-06T08:00:33+01:00' />
<meta name='shareaholic:article_modified_time' content='2021-09-06T19:12:27+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Mick Fraser' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=255190' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Ff-i-s-t-forged-in-shadow-torch-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Ff-i-s-t-forged-in-shadow-torch-review%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="it_reviews-template-default single single-it_reviews postid-255190 it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/09/the-sims-4-reveals-spa-day-game-pack-refresh/">The Sims 4 reveals Spa Day game pack refresh<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/image002-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The Sims 4 Spa Day" title="The Sims 4 reveals Spa Day game pack refresh" srcset="https://www.godisageek.com/wp-content/uploads/image002-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/image002-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/image002-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/image002-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/pre-orders-begin-for-spacebase-startopia-on-nintendo-switch/">Pre-orders begin for Spacebase Startopia on Nintendo Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Spacebase Startopia review" title="Pre-orders begin for Spacebase Startopia on Nintendo Switch" srcset="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/first-look-at-marvels-midnight-suns-gameplay/">First look at Marvel&#8217;s Midnight Suns gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Marvel&#039;s Midnight Suns" title="First look at Marvel&#8217;s Midnight Suns gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/life-is-strange-true-colors-announces-twitch-crowd-choice/">Life is Strange: True Colors announces Twitch crowd choice<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/crowd_choice_01-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Life is Strange: True Colors" title="Life is Strange: True Colors announces Twitch crowd choice" srcset="https://www.godisageek.com/wp-content/uploads/crowd_choice_01-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/laytons-mystery-journey-lego-star-wars-more-coming-to-apple-arcade/">Layton’s Mystery Journey, Lego Star Wars &#038; more coming to Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lego Star Wars Battles" title="Layton’s Mystery Journey, Lego Star Wars &#038; more coming to Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/knockout-city-heroes-event-grants-brawlers-superpowers/">Knockout City Heroes event grants brawlers superpowers<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Knockout-City-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Knockout City event" title="Knockout City Heroes event grants brawlers superpowers" srcset="https://www.godisageek.com/wp-content/uploads/Knockout-City-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">F.I.S.T: Forged in Shadow Torch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="F.I.S.T: Forged in Shadow Torch" title="F.I.S.T: Forged in Shadow Torch review" srcset="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">Doctor Who: The Lonely Assassins Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Doctor Who: The Lonely Assassins Switch Review" title="Doctor Who: The Lonely Assassins Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-medium-ps5-review/">The Medium PS5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium PS5 Review" title="The Medium PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-700x673.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-big-con-review/">The Big Con review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Big Con Review" title="The Big Con review" srcset="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">Inked: A Tale of Love review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Inked: A Tale of Love review" srcset="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tinytopia-review/">Tinytopia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tinytopia title image" title="Tinytopia review" srcset="https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/09/podcast-459-far-cry-6-no-more-heroes-iii-lost-in-random/">Podcast 459: Far Cry 6, No More Heroes III, Lost in Random<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" title="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" srcset="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/house-of-ashes-feels-like-an-underground-until-dawn-hands-on-preview/">House of Ashes feels like an underground Until Dawn | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="House of Ashes Preview" title="House of Ashes feels like an underground Until Dawn | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/tandem-a-tale-of-shadows-has-some-interesting-ideas-puzzle-fans-will-love-hands-on-preview/">Tandem: A Tale of Shadows has some interesting ideas puzzle fans will love | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tandem A Tale of Shadows" title="Tandem: A Tale of Shadows has some interesting ideas puzzle fans will love | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/lost-in-random-is-a-smart-and-beautiful-platformer-hands-on-preview/">Lost in Random is a smart and beautiful platformer | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lost in Random Preview" title="Lost in Random is a smart and beautiful platformer | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-the-final-bosses/">No More Heroes 3 | How to beat the final bosses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 final bosses" title="No More Heroes 3 | How to beat the final bosses" srcset="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210829_102953-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210829_102953-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210829_102953-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/far-cry-6-changes-the-series-in-a-meaningful-way-6-hours-of-hands-on/">Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on" title="Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on" srcset="https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-the-final-bosses/">No More Heroes 3 | How to beat the final bosses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 final bosses" title="No More Heroes 3 | How to beat the final bosses" srcset="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210829_102953-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210829_102953-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210829_102953-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-sonic-juice/">No More Heroes 3 | How to beat Sonic Juice<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124503-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Sonic Juice" title="No More Heroes 3 | How to beat Sonic Juice" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124503-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124503-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124503-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124503-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-destroyman/">No More Heroes 3 | How to beat Destroyman<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124455-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Destroyman" title="No More Heroes 3 | How to beat Destroyman" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124455-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124455-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124455-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124455-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-kimmy-love/">No More Heroes 3 | How to beat Kimmy Love<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124437-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Kimmy Love" title="No More Heroes 3 | How to beat Kimmy Love" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124437-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124437-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124437-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124437-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-native-dancer/">No More Heroes 3 | How to beat Native Dancer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_070752-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Native Dancer" title="No More Heroes 3 | How to beat Native Dancer" srcset="https://www.godisageek.com/wp-content/uploads/20210827_070752-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_070752-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_070752-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_070752-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-golden-joe/">No More Heroes 3 | How to beat Golden Joe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_070746-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Golden Joe" title="No More Heroes 3 | How to beat Golden Joe" srcset="https://www.godisageek.com/wp-content/uploads/20210827_070746-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_070746-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_070746-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_070746-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk/">Our Merch</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/09/the-sims-4-reveals-spa-day-game-pack-refresh/">The Sims 4 reveals Spa Day game pack refresh<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/image002-min-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The Sims 4 Spa Day" title="The Sims 4 reveals Spa Day game pack refresh" srcset="https://www.godisageek.com/wp-content/uploads/image002-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/image002-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/image002-min-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/image002-min-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/pre-orders-begin-for-spacebase-startopia-on-nintendo-switch/">Pre-orders begin for Spacebase Startopia on Nintendo Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Spacebase Startopia review" title="Pre-orders begin for Spacebase Startopia on Nintendo Switch" srcset="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/first-look-at-marvels-midnight-suns-gameplay/">First look at Marvel&#8217;s Midnight Suns gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Marvel&#039;s Midnight Suns" title="First look at Marvel&#8217;s Midnight Suns gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Marvels-Midnight-Suns-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/life-is-strange-true-colors-announces-twitch-crowd-choice/">Life is Strange: True Colors announces Twitch crowd choice<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/crowd_choice_01-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Life is Strange: True Colors" title="Life is Strange: True Colors announces Twitch crowd choice" srcset="https://www.godisageek.com/wp-content/uploads/crowd_choice_01-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/crowd_choice_01-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/laytons-mystery-journey-lego-star-wars-more-coming-to-apple-arcade/">Layton’s Mystery Journey, Lego Star Wars &#038; more coming to Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lego Star Wars Battles" title="Layton’s Mystery Journey, Lego Star Wars &#038; more coming to Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Lego-Star-Wars-Battles1-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/knockout-city-heroes-event-grants-brawlers-superpowers/">Knockout City Heroes event grants brawlers superpowers<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Knockout-City-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Knockout City event" title="Knockout City Heroes event grants brawlers superpowers" srcset="https://www.godisageek.com/wp-content/uploads/Knockout-City-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Knockout-City-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">F.I.S.T: Forged in Shadow Torch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="F.I.S.T: Forged in Shadow Torch" title="F.I.S.T: Forged in Shadow Torch review" srcset="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">Doctor Who: The Lonely Assassins Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Doctor Who: The Lonely Assassins Switch Review" title="Doctor Who: The Lonely Assassins Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-medium-ps5-review/">The Medium PS5 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium PS5 Review" title="The Medium PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-700x673.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-big-con-review/">The Big Con review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Big Con Review" title="The Big Con review" srcset="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">Inked: A Tale of Love review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Inked: A Tale of Love review" srcset="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tinytopia-review/">Tinytopia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tinytopia title image" title="Tinytopia review" srcset="https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Tinytopia-Logo-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/09/podcast-459-far-cry-6-no-more-heroes-iii-lost-in-random/">Podcast 459: Far Cry 6, No More Heroes III, Lost in Random<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" title="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" srcset="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/house-of-ashes-feels-like-an-underground-until-dawn-hands-on-preview/">House of Ashes feels like an underground Until Dawn | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="House of Ashes Preview" title="House of Ashes feels like an underground Until Dawn | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/tandem-a-tale-of-shadows-has-some-interesting-ideas-puzzle-fans-will-love-hands-on-preview/">Tandem: A Tale of Shadows has some interesting ideas puzzle fans will love | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tandem A Tale of Shadows" title="Tandem: A Tale of Shadows has some interesting ideas puzzle fans will love | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tandem-A-Tale-of-Shadows-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/09/lost-in-random-is-a-smart-and-beautiful-platformer-hands-on-preview/">Lost in Random is a smart and beautiful platformer | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lost in Random Preview" title="Lost in Random is a smart and beautiful platformer | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-the-final-bosses/">No More Heroes 3 | How to beat the final bosses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 final bosses" title="No More Heroes 3 | How to beat the final bosses" srcset="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210829_102953-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210829_102953-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210829_102953-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/far-cry-6-changes-the-series-in-a-meaningful-way-6-hours-of-hands-on/">Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on" title="Far Cry 6 changes the series in a meaningful way | 6 hours of hands-on" srcset="https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/far-cry-6-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-the-final-bosses/">No More Heroes 3 | How to beat the final bosses<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 final bosses" title="No More Heroes 3 | How to beat the final bosses" srcset="https://www.godisageek.com/wp-content/uploads/20210829_102953-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210829_102953-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210829_102953-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210829_102953-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-sonic-juice/">No More Heroes 3 | How to beat Sonic Juice<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124503-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Sonic Juice" title="No More Heroes 3 | How to beat Sonic Juice" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124503-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124503-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124503-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124503-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-destroyman/">No More Heroes 3 | How to beat Destroyman<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124455-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Destroyman" title="No More Heroes 3 | How to beat Destroyman" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124455-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124455-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124455-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124455-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-kimmy-love/">No More Heroes 3 | How to beat Kimmy Love<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_124437-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Kimmy Love" title="No More Heroes 3 | How to beat Kimmy Love" srcset="https://www.godisageek.com/wp-content/uploads/20210827_124437-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_124437-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_124437-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_124437-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-native-dancer/">No More Heroes 3 | How to beat Native Dancer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_070752-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Native Dancer" title="No More Heroes 3 | How to beat Native Dancer" srcset="https://www.godisageek.com/wp-content/uploads/20210827_070752-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_070752-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_070752-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_070752-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-golden-joe/">No More Heroes 3 | How to beat Golden Joe<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20210827_070746-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No More Heroes 3 Golden Joe" title="No More Heroes 3 | How to beat Golden Joe" srcset="https://www.godisageek.com/wp-content/uploads/20210827_070746-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20210827_070746-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20210827_070746-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20210827_070746-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk/">Our Merch</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/reviews/f-i-s-t-forged-in-shadow-torch-review/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/reviews/f-i-s-t-forged-in-shadow-torch-review/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Doctor Who: The Lonely Assassins Switch review</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/reviews/horace-review/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                                                                
                                        <a class="like-button do-like 255190" data-postid="255190" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                                                            
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-255190" class="post-255190 it_reviews type-it_reviews status-publish has-post-thumbnail hentry category-pc category-ps4-reviews category-playstation-5 category-reviews category-xb1-reviews category-xbox-series-x tag-bilibili tag-f-i-s-t tag-f-i-s-t-forged-in-shadow-torch tag-metroidvania tag-ti-games reviews_platform-pc reviews_platform-playstation-4 reviews_platform-playstation-5 reviews_platform-xbox-one reviews_platform-xbox-series-s reviews_platform-xbox-series-x reviews_developer-ti-games reviews_publisher-bilibili reviews_reviewedon-playstation-5" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                F.I.S.T: Forged in Shadow Torch review                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/mick-fraser/"><span itemprop="author">Mick Fraser </span></a></span><span class="date">on <meta itemprop="datePublished" content="September 6, 2021">September 6, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                            <div class='video_frame'><iframe id='youtube_video_3' class='youtube_video' src='https://www.youtube.com/embed/zb9rFG9lSyY?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=0&amp;loop=0&amp;rel=1&amp;showinfo=0&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>                                                
                                                                                        
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"><div class="detail-item"><span class="detail-label">Platform</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-platform/pc/" rel="tag">PC</a><a href="https://www.godisageek.com/reviews-platform/playstation-4/" rel="tag">PlayStation 4</a><a href="https://www.godisageek.com/reviews-platform/playstation-5/" rel="tag">PlayStation 5</a><a href="https://www.godisageek.com/reviews-platform/xbox-one/" rel="tag">Xbox One</a><a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" rel="tag">Xbox Series S</a><a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" rel="tag">Xbox Series X</a></span></div><div class="detail-item"><span class="detail-label">Developer</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-developer/ti-games/" rel="tag">Ti Games</a></span></div><div class="detail-item"><span class="detail-label">Publisher</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-publisher/bilibili/" rel="tag">BiliBili</a></span></div><div class="detail-item"><span class="detail-label">Reviewed On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-reviewedon/playstation-5/" rel="tag">PlayStation 5</a></span></div></div><div class="details-wrapper"><div class="detail-item"><span class="detail-label">Release Date</span><span class="detail-content"><p>September 7, 2021</p>
</span></div></div></div></div>                                            
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='F.I.S.T: Forged in Shadow Torch review' data-link='https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/' data-summary='Bunny brawler' data-app-id-name='post_above_content'></div>
<p>The concept of Anthropomorphic animals is one that throws up some fairly tricky questions when you think too hard about it. Not just biologically speaking either (although Rule 34 seems to have those questions covered). It creates a very weird food chain when, say, a bunny rabbit can beat the shit out of a doberman with a giant mechanical fist. Which is the primary conceit of diesel-punk Metroidvania, F.I.S.T: Forged in Shadow Torch. Although I&#8217;m still not sure why it needed to be an acronym and they couldn&#8217;t just call it Fist. Unless of course they were really worried about Rule 34.</p>
<p>Our protagonist is Rayton, a gruff-talking rabbit, hero of a war the good guys lost. The Iron Dogs of the Machine Legion rule the city now, using violence and fear to keep the &#8220;furtizens&#8221; in check. Now a downtrodden loner who&#8217;d rather not get involved in what remains of the resistance, Rayton is drawn back into the conflict when his friend is kidnapped. All that remains of the mech he piloted in the war is one huge arm, which he straps to his back before heading off to the rescue.</p>
<p><img class="alignleft size-large wp-image-255195" src="https://www.godisageek.com/wp-content/uploads/FIST-003-1024x576.jpg" alt="F.I.S.T: Forged in Shadow Torch" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/FIST-003-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/FIST-003-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/FIST-003-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/FIST-003-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/FIST-003-2048x1152.jpg 2048w, https://www.godisageek.com/wp-content/uploads/FIST-003-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/FIST-003-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/FIST-003-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/FIST-003-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/FIST-003-640x360.jpg 640w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h3>F.I.S.T: Forged in Shadow Torch &#8211; An inventive, compelling Metroidvania</h3>
<p>As a metroidvania, F.I.S.T excels in creating a huge seamless world. You can walk into any of the main areas from the hub town, or fast travel once you&#8217;ve unlocked the teleporters. Although, they don&#8217;t actually teleport. They&#8217;re more like big pneumatic tubes that launch you around the map in steel balls. The world is an absolute highpoint in a list of highpoints, its gorgeously grimy aesthetic effortlessly setting the tone for the adventure. It&#8217;s a world of oily technology, grit and grease ingrained in every tattered surface. Neon street signs and towering buildings clutter the skyboxes, and everything looks heavy and unwieldy. It&#8217;s like Zootopia if David Twohy remade it.</p>
<p>The story is also well-written and acted. A surprising number of cutscenes tell Rayton&#8217;s tale, as he galvanises the resistance against Cicero, leader of the Machine Legion. The enemy has embraced mechanisation, and only Rayton and his band of various non-canine mammals can stop them. The cast is colourful enough, though they fill certain archetypes without much imagination. A raccoon sensei trains you to fight, for example, the rats do shady deals on street corners, and there&#8217;s a cat called Lady Q who will give a certain type of deviant artist inspiration for the next decade.</p>
<p><img class="alignleft size-large wp-image-255194" src="https://www.godisageek.com/wp-content/uploads/FIST-002-1024x576.jpg" alt="F.I.S.T: Forged in Shadow Torch" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/FIST-002-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/FIST-002-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/FIST-002-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/FIST-002-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/FIST-002-2048x1152.jpg 2048w, https://www.godisageek.com/wp-content/uploads/FIST-002-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/FIST-002-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/FIST-002-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/FIST-002-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/FIST-002-640x360.jpg 640w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h3>Rabbit run</h3>
<p>Combat is fairly standard at first, mixing light and heavy attacks with a grab and throw technique to help tackle larger groups. Finding Data Disks and scrap allows you to upgrade the Fist with more combos and special moves, and combat becomes a weighty, brutal affair. Later you&#8217;ll unlock two transformations for the Fist. The Drill allows you to open certain doors, or can become a propellor to glide or swim. The Whip lets you use swing points to reach higher areas. Both can be used in combat with a variety of attacks, which you&#8217;ll need to make it through some of F.I.S.T&#8217;s tougher encounters. Your limited block/parry skill doesn&#8217;t help, as enemies will attack through your combos now and then. There are some genuinely difficult boss fights, and even the grunt enemies are hard to deal with.</p>
<p>This is partly because F.I.S.T: Forged in Shadow Torch is quite stingy with its resources. Blue SP powers special attacks, while orange EP allows Rayton to utilise his limited-use gear like healing carrot juice, a homing rocket, and energy rods to parry attacks. The thing is, it&#8217;s very easy to run out, and the items you need to upgrade these meters are scattered far and wide, often needing special skeleton keys to access when you do find them. It&#8217;s also easy to drop directly into danger as there&#8217;s no free-look camera to check what&#8217;s below. Multiple times I&#8217;ve dropped off a ledge to land on a shock grid or whirring blade. Thankfully, the checkpointing is pretty fair, and death won&#8217;t send you back too far.</p>
<p><img class="alignleft size-large wp-image-255193" src="https://www.godisageek.com/wp-content/uploads/FIST-001-1024x576.jpg" alt="F.I.S.T: Forged in Shadow Torch" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/FIST-001-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/FIST-001-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/FIST-001-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/FIST-001-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/FIST-001-2048x1152.jpg 2048w, https://www.godisageek.com/wp-content/uploads/FIST-001-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/FIST-001-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/FIST-001-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/FIST-001-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/FIST-001-640x360.jpg 640w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h3>Bunny brawler</h3>
<p>Some of the boss fights are seriously taxing though. As you progress they get tougher and tougher, taking on characteristics reminiscent of bullet hell games. With goons firing rockets and lasers, environmental hazards, and the bosses themselves, you&#8217;ll have your work cut out trying to stay alive. Rewards are everywhere though. From comic books that reference other properties and grant new skins for your gear, to music tracks and plant seeds that you can trade with the furtizens of Torch City for more gear, there&#8217;s plenty of stuff to make the backtracking worth it. A smattering of environmental puzzles add to the charm and break up the combat nicely, and none are overly complex. They often hide secrets worth uncovering, though.</p>
<p>For a game making such little noise, F.I.S.T: Forged in Shadow Torch is an absolute blast. The world is stunning at times, the backstory deep enough to make the plot compelling, and the characters are fun and likeable if not overly original. Its exciting, brutal combat, and rewarding exploration set it apart from many of its genre-mates though, and make it utterly worth your time.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='F.I.S.T: Forged in Shadow Torch review' data-link='https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/' data-summary='Bunny brawler' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='F.I.S.T: Forged in Shadow Torch review' data-link='https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/' data-summary='Bunny brawler' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                    <div class="procon-box-wrapper"><div class="procon-box clearfix"><div class="col-wrapper"><div class="procon pro"><div class="header"><span class="icon-plus"></span>Positives</div><p>Great world and aesthetic<br />
Enjoyable combat<br />
Exploration is fun</p>
</div></div><div class="col-wrapper"><div class="procon con"><div class="header"><span class="icon-minus"></span>Negatives</div><p>Needs more of a block/parry mechanic<br />
Feels a little stingy starting out<br />
No free-look camera</p>
</div></div></div></div>                                        
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix solo"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar"><div class="rating-meter">&nbsp;</div><div class="rating-label">Our Score</div><div class="rating-value"><div class="number color5">8.5</div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-15,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar color5"><div class="rating-label">SCORE OUT OF TEN</div><meta itemprop="worstRating" content="0"><div class="rating-value" itemprop="ratingValue"><div class="number color5">8.5</div></div><meta itemprop="bestRating" content="10"><br class="clearer" /></div></div></div></div></div><br class="clearer" />                                    
                                    <div class="bottomline-wrapper"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-quote-circled"></span>In Short<div class="ribbon-separator">&nbsp;</div></div></div><div class="bottomline"><p>F.I.S.T: Forged in Shadow Torch's exciting, brutal combat, and rewarding exploration set it apart from many of its genre-mates, and make it utterly worth your time.</p>
</div></div>                                    
                                                                 
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>You may also like<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="27127" data-method="tags" class="info active" title="More articles tagged: BiliBili">BiliBili<span class="bottom-arrow"></span></a><a data-sorter="15674" data-method="tags" class="info" title="More articles tagged: metroidvania">metroidvania<span class="bottom-arrow"></span></a><a data-sorter="138" data-method="categories" class="info" title="More articles filed under: PC">PC<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/eastern-exorcist-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Eastern-Exorcist-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Eastern Exorcist" title="Eastern Exorcist review" srcset="https://www.godisageek.com/wp-content/uploads/Eastern-Exorcist-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Eastern-Exorcist-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Eastern-Exorcist-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Eastern-Exorcist-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/eastern-exorcist-review/">Eastern Exorcist review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/eastern-exorcist-review/">&nbsp;</a></div><br class="visible-desktop clearer" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/09/the-sims-4-reveals-spa-day-game-pack-refresh/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/image002-min-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="The Sims 4 Spa Day" title="The Sims 4 reveals Spa Day game pack refresh" srcset="https://www.godisageek.com/wp-content/uploads/image002-min-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/image002-min-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/image002-min-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/image002-min-700x700.png 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/09/the-sims-4-reveals-spa-day-game-pack-refresh/">The Sims 4 reveals Spa Day game pack refresh</a><div class="article-meta clearfix"><a class="like-button do-like 255248 info-bottom" data-postid="255248" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/09/the-sims-4-reveals-spa-day-game-pack-refresh/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/09/pre-orders-begin-for-spacebase-startopia-on-nintendo-switch/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Spacebase Startopia review" title="Pre-orders begin for Spacebase Startopia on Nintendo Switch" srcset="https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Spacebase-Startopia-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/09/pre-orders-begin-for-spacebase-startopia-on-nintendo-switch/">Pre-orders begin for Spacebase Startopia on Nintendo Switch</a></div><a class="hover-link" href="https://www.godisageek.com/2021/09/pre-orders-begin-for-spacebase-startopia-on-nintendo-switch/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="F.I.S.T: Forged in Shadow Torch" title="F.I.S.T: Forged in Shadow Torch review" srcset="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">F.I.S.T: Forged in Shadow Torch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/09/podcast-459-far-cry-6-no-more-heroes-iii-lost-in-random/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" title="Podcast 459: Far Cry 6, No More Heroes III, Lost in Random" srcset="https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-459-far-cry-6-no-more-heroes-3-lost-in-random-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/09/podcast-459-far-cry-6-no-more-heroes-iii-lost-in-random/">Podcast 459: Far Cry 6, No More Heroes III, Lost in Random</a></div><a class="hover-link" href="https://www.godisageek.com/2021/09/podcast-459-far-cry-6-no-more-heroes-iii-lost-in-random/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/09/house-of-ashes-feels-like-an-underground-until-dawn-hands-on-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="House of Ashes Preview" title="House of Ashes feels like an underground Until Dawn | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/House-of-Ashes-Preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/09/house-of-ashes-feels-like-an-underground-until-dawn-hands-on-preview/">House of Ashes feels like an underground Until Dawn | Hands-on preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/09/house-of-ashes-feels-like-an-underground-until-dawn-hands-on-preview/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="F.I.S.T: Forged in Shadow Torch" title="F.I.S.T: Forged in Shadow Torch review" srcset="https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EggDVHaVkAEIptI-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">F.I.S.T: Forged in Shadow Torch review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 255190 info-bottom" data-postid="255190" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Doctor Who: The Lonely Assassins Switch Review" title="Doctor Who: The Lonely Assassins Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Doctor-Who-The-Lonely-Assassins-Switch-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">Doctor Who: The Lonely Assassins Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-medium-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium PS5 Review" title="The Medium PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-700x673.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Medium-PS5-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-medium-ps5-review/">The Medium PS5 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-medium-ps5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-big-con-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Big Con Review" title="The Big Con review" srcset="https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Big-Con-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-big-con-review/">The Big Con review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-big-con-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Inked: A Tale of Love review" srcset="https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/inked-a-tale-of-love-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">Inked: A Tale of Love review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2</a><div class="article-meta clearfix"><a class="like-button do-like 253617 info-bottom" data-postid="253617" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/psychonauts-2-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Psychonauts_2_key_art_resize_7-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Psychonauts 2 title image" title="Psychonauts 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Psychonauts_2_key_art_resize_7-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Psychonauts_2_key_art_resize_7-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Psychonauts_2_key_art_resize_7-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Psychonauts_2_key_art_resize_7-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/psychonauts-2-review/">Psychonauts 2 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 254732 info-bottom" data-postid="254732" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/psychonauts-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ghost-of-tsushima-directors-cut-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-Directors-Cut-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghost of Tsushima Director&#039;s Cut PS5 Review" title="Ghost of Tsushima Director&#8217;s Cut review" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-Directors-Cut-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-Directors-Cut-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-Directors-Cut-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ghost-of-tsushima-directors-cut-review/">Ghost of Tsushima Director&#8217;s Cut review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ghost-of-tsushima-directors-cut-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/grime-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grime-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Grime review" title="GRIME review" srcset="https://www.godisageek.com/wp-content/uploads/Grime-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grime-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grime-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grime-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/grime-review/">GRIME review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/grime-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/hades-ps5-xbox-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hades-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hades PS5" title="Hades PS5 / Xbox review" srcset="https://www.godisageek.com/wp-content/uploads/Hades-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hades-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hades-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hades-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/hades-ps5-xbox-review/">Hades PS5 / Xbox review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/hades-ps5-xbox-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/road-96-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Road-96-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Road 96 Review" title="Road 96 review" srcset="https://www.godisageek.com/wp-content/uploads/Road-96-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Road-96-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Road-96-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Road-96-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/road-96-review/">Road 96 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/road-96-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210829_102953-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-the-final-bosses/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat the final bosses</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210827_124503-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-sonic-juice/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat Sonic Juice</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210827_124455-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-destroyman/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat Destroyman</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210827_124437-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-kimmy-love/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat Kimmy Love</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210827_070752-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-native-dancer/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat Native Dancer</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20210827_070746-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/08/no-more-heroes-3-how-to-beat-golden-joe/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">No More Heroes 3 | How to beat Golden Joe</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">F.I.S.T: Forged in Shadow Torch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/f-i-s-t-forged-in-shadow-torch-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">Doctor Who: The Lonely Assassins Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/doctor-who-the-lonely-assassins-switch-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-medium-ps5-review/">The Medium PS5 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-medium-ps5-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-big-con-review/">The Big Con review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-big-con-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">Inked: A Tale of Love review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/inked-a-tale-of-love-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.692307692308px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.923076923077px;" aria-label="Activision (777 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12px;" aria-label="Bandai Namco (386 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-4" style="font-size: 12.230769230769px;" aria-label="Call of Duty (395 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 18px;" aria-label="Capcom (703 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 14.076923076923px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.846153846154px;" aria-label="EA (1,143 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12.461538461538px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.692307692308px;" aria-label="Konami (564 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.769230769231px;" aria-label="Microsoft (938 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,750 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.153846153846px;" aria-label="nintendo switch (796 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.692307692308px;" aria-label="PC (1,382 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.692307692308px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 14.307692307692px;" aria-label="PlayStation 4 (491 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.384615384615px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.538461538462px;" aria-label="PS4 (1,236 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.769230769231px;" aria-label="Sega (685 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 21px;" aria-label="Sony (954 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (917 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 14.076923076923px;" aria-label="Steam (473 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.769230769231px;" aria-label="Trailer (683 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 24px;" aria-label="Ubisoft (1,286 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.538461538462px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24px;" aria-label="Xbox One (1,282 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.769230769231px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.230769230769px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12px;" aria-label="Competition (219 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.769230769231px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20px;" aria-label="Features (2,393 items)">Features</a>
<a href="https://www.godisageek.com/category/features/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 12px;" aria-label="Guides (219 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (219 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.615384615385px;" aria-label="iOS (355 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,624 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.384615384615px;" aria-label="Opinion (605 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 14.307692307692px;" aria-label="Paid Placement Advertorials (440 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.538461538462px;" aria-label="PC (2,084 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.307692307692px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.538461538462px;" aria-label="PlayStation 4 (1,534 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16px;" aria-label="Podcasts (730 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.538461538462px;" aria-label="Previews (859 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.384615384615px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 21.846153846154px;" aria-label="Reviews (4,209 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.076923076923px;" aria-label="Switch (734 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.538461538462px;" aria-label="Tech (259 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.769230769231px;" aria-label="Trailers (1,235 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13px;" aria-label="Uncategorised (297 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.153846153846px;" aria-label="Video Features (1,019 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.923076923077px;" aria-label="Xbox 360 (714 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 17.692307692308px;" aria-label="Xbox One (1,210 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.00796812749px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.171314741036px;" aria-label="Android (78 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.270916334661px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.585657370518px;" aria-label="Google Stadia (19 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.362549800797px;" aria-label="HTC Vive (26 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.247011952191px;" aria-label="iOS (119 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.139442231076px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (4 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.362549800797px;" aria-label="Oculus Rift (26 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,613 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.844621513944px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.760956175299px;" aria-label="PlayStation 4 (1,482 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 20.067729083665px;" aria-label="PlayStation 5 (110 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.394422310757px;" aria-label="PlayStation VR (58 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.964143426295px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.08764940239px;" aria-label="Switch (777 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.573705179283px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.888446215139px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.103585657371px;" aria-label="Xbox One (1,157 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 19.171314741036px;" aria-label="Xbox Series S (79 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 19.470119521912px;" aria-label="Xbox Series X (89 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
