<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Immortals Fenyx Rising review - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Immortals Fenyx Rising is an excellent adventure with excellent puzzles, wonderful combat, and a rich world ripe for exploring." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Immortals Fenyx Rising review - GodisaGeek.com" />
	<meta property="og:description" content="Immortals Fenyx Rising is an excellent adventure with excellent puzzles, wonderful combat, and a rich world ripe for exploring." />
	<meta property="og:url" content="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:author" content="http://facebook.com/christopherppwhitepoet" />
	<meta property="article:modified_time" content="2020-11-29T14:47:51+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review.jpg" />
	<meta property="og:image:width" content="1400" />
	<meta property="og:image:height" content="700" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Reviews, News, Previews, Videos, Podcasts: the one stop you need for gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/reviews/immortals-fenyx-rising-review/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review.jpg","width":1400,"height":700},{"@type":"WebPage","@id":"https://www.godisageek.com/reviews/immortals-fenyx-rising-review/#webpage","url":"https://www.godisageek.com/reviews/immortals-fenyx-rising-review/","name":"Immortals Fenyx Rising review - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/reviews/immortals-fenyx-rising-review/#primaryimage"},"datePublished":"2020-11-30T17:00:25+00:00","dateModified":"2020-11-29T14:47:51+00:00","description":"Immortals Fenyx Rising is an excellent adventure with excellent puzzles, wonderful combat, and a rich world ripe for exploring.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/reviews/immortals-fenyx-rising-review/"]}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=244447' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fimmortals-fenyx-rising-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fimmortals-fenyx-rising-review%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="it_reviews-template-default single single-it_reviews postid-244447 it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/relegend-to-launch-on-consoles-pc-in-spring-2021/">Re:Legend to launch on consoles &#038; PC in Spring 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/relegend-farming-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Re:Legend launch spring 2021" title="Re:Legend to launch on consoles &#038; PC in Spring 2021" srcset="https://www.godisageek.com/wp-content/uploads/relegend-farming-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/relegend-farming-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/relegend-farming-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/relegend-farming-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/hwang-to-be-the-final-dlc-character-for-soulcalibur-vi/">Hwang to be the final DLC character for SOULCALIBUR VI<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hwang Final DLC Character" title="Hwang to be the final DLC character for SOULCALIBUR VI" srcset="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/moonlighter-new-mutant-zero-and-more-discounted-in-gog-cyber-monday-sale/">Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOG" title="Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale" srcset="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GOG-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GOG-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GOG-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/fifa-ultimate-team-releases-new-totw-stars-for-black-friday/">FIFA Ultimate Team releases new TOTW stars for Black Friday<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="FIFA Ultimate Team releases new TOTW stars for Black Friday" title="FIFA Ultimate Team releases new TOTW stars for Black Friday" srcset="https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/epremier-league-season-3-coming-to-fifa-21/">ePremier League season 3 coming to FIFA 21<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ePremier League FIFA 21" title="ePremier League season 3 coming to FIFA 21" srcset="https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/capcom-teases-monster-hunter-world-iceborne-and-monster-hunter-film-crossover/">Capcom teases Monster Hunter World: Iceborne and Monster Hunter film crossover<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Film" title="Capcom teases Monster Hunter World: Iceborne and Monster Hunter film crossover" srcset="https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">Second Extinction Early Access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Second Extinction review" title="Second Extinction Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">Immortals Fenyx Rising review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Immortals Fenyx Rising review" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/">Chronos: Before the Ashes review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Chronos: Before the Ashes" title="Chronos: Before the Ashes review" srcset="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pistol-whip-2089-review/">Pistol Whip 2089 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pistol Whip 2089" title="Pistol Whip 2089 review" srcset="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/">Katamari Damacy REROLL review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Katamari Damacy REROLL Review" title="Katamari Damacy REROLL review" srcset="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/star-wars-tales-from-the-galaxys-edge-review/">Star Wars: Tales From the Galaxy&#8217;s Edge review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Wars: Tales from the Galaxy&#039;s Edge" title="Star Wars: Tales From the Galaxy&#8217;s Edge review" srcset="https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/back-to-the-ring-1-a-look-at-the-first-wave-of-wwe-2k-battlegrounds-new-superstars/">Back to the ring #1: A look at the first wave of WWE 2K Battlegrounds new Superstars<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K Battlegrounds Ultimate Warrior and Eddie Guerrero" title="Back to the ring #1: A look at the first wave of WWE 2K Battlegrounds new Superstars" srcset="https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/podcast-423-astros-playroom-demons-souls-sackboy-a-big-adventure-call-of-duty-black-ops-cold-war/">Podcast #423: Astro&#8217;s Playroom, Demon&#8217;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #423: Astro&#039;s Playroom, Demon&#039;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War" title="Podcast #423: Astro&#8217;s Playroom, Demon&#8217;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War" srcset="https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/puyo-puyo-tetris-2-is-great-so-far-made-better-with-the-inclusion-of-skill-battles/">Puyo Puyo Tetris 2 is great so far, made better with the inclusion of Skill Battles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Puyo Puyo Tetris 2 is great so far, made better with the inclusion of Skill Battles" srcset="https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/podcast-422-catch-that-sausage-demons-souls-sackboy-assassins-creed-valhalla-bugsnax/">Podcast #422: Demon&#8217;s Souls, Sackboy, Assassin&#8217;s Creed Valhalla, Bugsnax<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #422 NAME - Demon&#039;s Souls, Sackboy, Assassin&#039;s Creed Valhalla, Godfall" title="Podcast #422: Demon&#8217;s Souls, Sackboy, Assassin&#8217;s Creed Valhalla, Bugsnax" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-how-to-get-the-most-from-raids/">Assassin&#8217;s Creed Valhalla guide | How to get the most from raids<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla raids" title="Assassin&#8217;s Creed Valhalla guide | How to get the most from raids" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-upgrading-your-settlement/">Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla settlement" title="Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-how-to-get-the-most-from-raids/">Assassin&#8217;s Creed Valhalla guide | How to get the most from raids<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla raids" title="Assassin&#8217;s Creed Valhalla guide | How to get the most from raids" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-upgrading-your-settlement/">Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla settlement" title="Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-understanding-xp-and-the-power-system/">Assassin&#8217;s Creed Valhalla guide | Understanding XP and the power system<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla XP" title="Assassin&#8217;s Creed Valhalla guide | Understanding XP and the power system" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-700x680.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-combat/">Assassin&#8217;s Creed Valhalla guide | Getting to grips with the combat<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="assassin&#039;s creed valhalla combat" title="Assassin&#8217;s Creed Valhalla guide | Getting to grips with the combat" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/how-to-game-share-on-ps5/">How to Game Share on PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Game share PS5" title="How to Game Share on PS5" srcset="https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/how-to-find-your-game-playtime-on-ps5/">How to find your game playtime on PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="PS5 playtime" title="How to find your game playtime on PS5" srcset="https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/hyrule-warriors-age-of-calamity-preview/">Hyrule Warriors: Age of Calamity is shaping up to be a superb Musou adventure<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Hyrule Warriors: Age of Calamity is shaping up to be a superb Musou adventure" srcset="https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/apex-legends-season-7-is-flying-high/">Apex Legends Season 7 is flying high<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 7" title="Apex Legends Season 7 is flying high" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/bakugan-champions-of-vestroia-preview/">Bakugan: Champions of Vestroia could be a must play title for fans of the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Bakugan: Champions of Vestroia" title="Bakugan: Champions of Vestroia could be a must play title for fans of the series" srcset="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-nightmares-ii-is-scarier-than-ever-and-i-love-it/">Little Nightmares II is scarier than ever, and I love it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Little Nightmares II is scarier than ever, and I love it" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/relegend-to-launch-on-consoles-pc-in-spring-2021/">Re:Legend to launch on consoles &#038; PC in Spring 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/relegend-farming-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Re:Legend launch spring 2021" title="Re:Legend to launch on consoles &#038; PC in Spring 2021" srcset="https://www.godisageek.com/wp-content/uploads/relegend-farming-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/relegend-farming-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/relegend-farming-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/relegend-farming-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/hwang-to-be-the-final-dlc-character-for-soulcalibur-vi/">Hwang to be the final DLC character for SOULCALIBUR VI<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hwang Final DLC Character" title="Hwang to be the final DLC character for SOULCALIBUR VI" srcset="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/moonlighter-new-mutant-zero-and-more-discounted-in-gog-cyber-monday-sale/">Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOG" title="Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale" srcset="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GOG-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GOG-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GOG-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/fifa-ultimate-team-releases-new-totw-stars-for-black-friday/">FIFA Ultimate Team releases new TOTW stars for Black Friday<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="FIFA Ultimate Team releases new TOTW stars for Black Friday" title="FIFA Ultimate Team releases new TOTW stars for Black Friday" srcset="https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Copy-of-FUT21_BF_BestofTOTW_Social_16x9-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/epremier-league-season-3-coming-to-fifa-21/">ePremier League season 3 coming to FIFA 21<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ePremier League FIFA 21" title="ePremier League season 3 coming to FIFA 21" srcset="https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ePremier-League-FIFA-21-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/capcom-teases-monster-hunter-world-iceborne-and-monster-hunter-film-crossover/">Capcom teases Monster Hunter World: Iceborne and Monster Hunter film crossover<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Film" title="Capcom teases Monster Hunter World: Iceborne and Monster Hunter film crossover" srcset="https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHWI_Collab_2-Milla-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">Second Extinction Early Access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Second Extinction review" title="Second Extinction Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">Immortals Fenyx Rising review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Immortals Fenyx Rising review" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/">Chronos: Before the Ashes review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Chronos: Before the Ashes" title="Chronos: Before the Ashes review" srcset="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/pistol-whip-2089-review/">Pistol Whip 2089 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pistol Whip 2089" title="Pistol Whip 2089 review" srcset="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/">Katamari Damacy REROLL review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Katamari Damacy REROLL Review" title="Katamari Damacy REROLL review" srcset="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/star-wars-tales-from-the-galaxys-edge-review/">Star Wars: Tales From the Galaxy&#8217;s Edge review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Star Wars: Tales from the Galaxy&#039;s Edge" title="Star Wars: Tales From the Galaxy&#8217;s Edge review" srcset="https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/back-to-the-ring-1-a-look-at-the-first-wave-of-wwe-2k-battlegrounds-new-superstars/">Back to the ring #1: A look at the first wave of WWE 2K Battlegrounds new Superstars<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K Battlegrounds Ultimate Warrior and Eddie Guerrero" title="Back to the ring #1: A look at the first wave of WWE 2K Battlegrounds new Superstars" srcset="https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/wwe-2k-battlegrounds-feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/podcast-423-astros-playroom-demons-souls-sackboy-a-big-adventure-call-of-duty-black-ops-cold-war/">Podcast #423: Astro&#8217;s Playroom, Demon&#8217;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #423: Astro&#039;s Playroom, Demon&#039;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War" title="Podcast #423: Astro&#8217;s Playroom, Demon&#8217;s Souls, Sackboy: A Big Adventure, Call of Duty: Black Ops Cold War" srcset="https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Sackboy-A-Big-Adventure-podcast-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/puyo-puyo-tetris-2-is-great-so-far-made-better-with-the-inclusion-of-skill-battles/">Puyo Puyo Tetris 2 is great so far, made better with the inclusion of Skill Battles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Puyo Puyo Tetris 2 is great so far, made better with the inclusion of Skill Battles" srcset="https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/puyo-puyo-tetris-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/podcast-422-catch-that-sausage-demons-souls-sackboy-assassins-creed-valhalla-bugsnax/">Podcast #422: Demon&#8217;s Souls, Sackboy, Assassin&#8217;s Creed Valhalla, Bugsnax<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #422 NAME - Demon&#039;s Souls, Sackboy, Assassin&#039;s Creed Valhalla, Godfall" title="Podcast #422: Demon&#8217;s Souls, Sackboy, Assassin&#8217;s Creed Valhalla, Bugsnax" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-422-Demons-Souls-Sackboy-Assassins-Creed-Valhalla-Godfall-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-how-to-get-the-most-from-raids/">Assassin&#8217;s Creed Valhalla guide | How to get the most from raids<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla raids" title="Assassin&#8217;s Creed Valhalla guide | How to get the most from raids" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-upgrading-your-settlement/">Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla settlement" title="Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-how-to-get-the-most-from-raids/">Assassin&#8217;s Creed Valhalla guide | How to get the most from raids<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla raids" title="Assassin&#8217;s Creed Valhalla guide | How to get the most from raids" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-raids-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-upgrading-your-settlement/">Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla settlement" title="Assassin&#8217;s Creed Valhalla guide | Upgrading your settlement" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-settlement-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-understanding-xp-and-the-power-system/">Assassin&#8217;s Creed Valhalla guide | Understanding XP and the power system<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla XP" title="Assassin&#8217;s Creed Valhalla guide | Understanding XP and the power system" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-700x680.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-xp-and-power-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/assassins-creed-valhalla-guide-combat/">Assassin&#8217;s Creed Valhalla guide | Getting to grips with the combat<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="assassin&#039;s creed valhalla combat" title="Assassin&#8217;s Creed Valhalla guide | Getting to grips with the combat" srcset="https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/assassins-creed-valhalla-combat-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/how-to-game-share-on-ps5/">How to Game Share on PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Game share PS5" title="How to Game Share on PS5" srcset="https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Game-share-PS5-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/11/how-to-find-your-game-playtime-on-ps5/">How to find your game playtime on PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="PS5 playtime" title="How to find your game playtime on PS5" srcset="https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/PS5-playtime-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/11/hyrule-warriors-age-of-calamity-preview/">Hyrule Warriors: Age of Calamity is shaping up to be a superb Musou adventure<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Hyrule Warriors: Age of Calamity is shaping up to be a superb Musou adventure" srcset="https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Age-of-Calamity-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/apex-legends-season-7-is-flying-high/">Apex Legends Season 7 is flying high<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends Season 7" title="Apex Legends Season 7 is flying high" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-Season-7-a-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/bakugan-champions-of-vestroia-preview/">Bakugan: Champions of Vestroia could be a must play title for fans of the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Bakugan: Champions of Vestroia" title="Bakugan: Champions of Vestroia could be a must play title for fans of the series" srcset="https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/bakugan-champions-of-vestroia-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-nightmares-ii-is-scarier-than-ever-and-i-love-it/">Little Nightmares II is scarier than ever, and I love it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Little Nightmares II is scarier than ever, and I love it" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-II-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/reviews/immortals-fenyx-rising-review/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/reviews/immortals-fenyx-rising-review/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Chronos: Before the Ashes review</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/reviews/cook-serve-delicious-2-review/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Second Extinction Early Access review</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                                                                
                                        <a class="like-button do-like 244447" data-postid="244447" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                                                            
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-244447" class="post-244447 it_reviews type-it_reviews status-publish has-post-thumbnail hentry category-google-stadia category-pc category-ps4-reviews category-playstation-5 category-reviews category-switch-reviews category-xb1-reviews category-xbox-series-x tag-immortals-fenyx-rising tag-pc tag-ps4 tag-ps5 tag-switch tag-ubisoft tag-ubisoft-quebec tag-xbox-one tag-xbox-series-x reviews_platform-google-stadia reviews_platform-pc reviews_platform-playstation-4 reviews_platform-playstation-5 reviews_platform-switch-2 reviews_platform-xbox-one reviews_platform-xbox-series-s reviews_platform-xbox-series-x reviews_developer-ubisoft-quebec reviews_publisher-ubisoft reviews_reviewedon-xbox-series-s reviews_alsotestedon-playstation-5 reviews_alsotestedon-xbox-series-x" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                Immortals Fenyx Rising review                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-white/"><span itemprop="author">Chris White </span></a></span><span class="date">on <meta itemprop="datePublished" content="November 30, 2020">November 30, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1024x512.jpg"><img width="790" height="395" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-790x395.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="" title="Immortals Fenyx Rising review" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-790x395.jpg 790w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-300x150.jpg 300w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1024x512.jpg 1024w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-768x384.jpg 768w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-700x350.jpg 700w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-180x90.jpg 180w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-360x180.jpg 360w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1130x565.jpg 1130w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review.jpg 1400w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"><div class="detail-item"><span class="detail-label">Platform</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-platform/google-stadia/" rel="tag">Google Stadia</a><a href="https://www.godisageek.com/reviews-platform/pc/" rel="tag">PC</a><a href="https://www.godisageek.com/reviews-platform/playstation-4/" rel="tag">PlayStation 4</a><a href="https://www.godisageek.com/reviews-platform/playstation-5/" rel="tag">PlayStation 5</a><a href="https://www.godisageek.com/reviews-platform/switch-2/" rel="tag">Switch</a><a href="https://www.godisageek.com/reviews-platform/xbox-one/" rel="tag">Xbox One</a><a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" rel="tag">Xbox Series S</a><a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" rel="tag">Xbox Series X</a></span></div><div class="detail-item"><span class="detail-label">Developer</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-developer/ubisoft-quebec/" rel="tag">Ubisoft Quebec</a></span></div><div class="detail-item"><span class="detail-label">Publisher</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-publisher/ubisoft/" rel="tag">Ubisoft</a></span></div><div class="detail-item"><span class="detail-label">Reviewed On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-reviewedon/xbox-series-s/" rel="tag">Xbox Series S</a></span></div><div class="detail-item"><span class="detail-label">Also Tested On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-alsotestedon/playstation-5/" rel="tag">PlayStation 5</a><a href="https://www.godisageek.com/reviews-alsotestedon/xbox-series-x/" rel="tag">Xbox Series X</a></span></div></div><div class="details-wrapper"><div class="detail-item"><span class="detail-label">Release Date</span><span class="detail-content"><p>December 3, 2020</p>
</span></div></div></div></div>                                            
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>There&#8217;s no point ignoring the elephant in the room. You know, the one stomping its feet and blowing its trunk, craving for attention. Immortals Fenyx Rising is very similar to <a href="https://www.godisageek.com/reviews/breath-of-the-wild-review/">The Legend of Zelda: Breath of the Wild</a>. Whether that gets under your skin or not, you&#8217;ll encounter so many things in Ubisoft Quebec&#8217;s latest epic adventure that feel almost identical to the legendary masterpiece. Climbing, swimming, and running drains stamina bars which you can increase by completing Vaults (*cough* <em>not</em> Shrines). You can&#8217;t fly but you can glide after finishing one of your first main quests, and the Gods will give you Hero Blessings. You can pin locations on your map with multicoloured markers, move metal spheres with a magnetism-like ability, and tame horses whilst exploring the open world.</p>
<p>Now we&#8217;ve addressed how both games are kindred spirits, it&#8217;s time to talk about why Fenyx Rising should be a shoe-in for everybody&#8217;s game of the year lists. Whilst there are tons of similarities with BotW, Immortals Fenyx Rising is a phenomenal action-adventure game featuring loads of intricate and inspiring puzzles, superb combat, and one of the most thrilling stories of 2020. The writing is excellent, and the titular character of Fenyx is so loveable it hurts.</p>
<p>The story is centred around the re-emergence of Typhon, the most powerful Titan of all time. The Gods have been cursed, their essence lost, and their fates doomed. Greek heroes like Odysseus and Herakles have been corrupted, and almost everyone else has been turned to stone. When it seems like all hope is lost, an unlikely hero called Fenyx embarks on a quest to save Greece and destroy Typhon once and for all. You get to customise your hero to be male or female, or non-binary if you so wish. Hair colour, their voice, facial hair, and tattoos can all be chosen before you head out on your adventure.</p>
<p><img class="aligncenter size-full wp-image-244638" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4.jpg" alt="immortals fenyx rising world" width="1280" height="720" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4.jpg 1280w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-4-1130x636.jpg 1130w" sizes="(max-width: 1280px) 100vw, 1280px" /></p>
<p>Everyone is going to have their own version of Fenyx, and mine was a girl with a big heart and purple hair. Jeffrey Yohalem has written one of the finest scripts of the year, if not the decade. Throughout your adventure, Zeus and Prometheus act as narrators. They help to fill in the story, react to what Fenyx is doing, and provide some genuinely funny moments. The humour lies sweetly at the heart of Immortals Fenyx Rising. It has lighter moments, but there&#8217;s also a moving tale about a father&#8217;s realisation that he might not have been the dad of the year.</p>
<p>Your main objective is to restore the essence of the Gods you encounter. Each God is tied to a particular area, and after scaling their statue, you embark on a quest line that has you completing varied tasks that never follow a generic pattern. You might have to solve a puzzle, then fight some enemies, then dive into a Vault to recover their essence, but it always mixes it up so no two paths are the same. Each of the Gods has a unique story in the way it relates to Zeus, their father, and you learn so much about who they are and how they came to be. Ares has become a chicken, Aphrodite a tree, Hephaistos an automaton, and Athena a child. Whenever you encounter a God, you&#8217;re instantly drawn in to their history, and the voice-acting is constantly top notch.</p>
<p>Outside of the main quests, Immortals Fenyx Rising offers you so much to do. By using a skill known as Far Sight (pressing down on the right analogue stick), you can survey the land and reveal certain places of interest. You can always explore freely, but using Far Sight helps you to uncover the closest puzzles and chests far quicker. Everything on offer helps to improve Fenyx&#8217;s skills as well as bolster their weapons and armour.</p>
<p><img class="aligncenter size-full wp-image-244639" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3.jpg" alt="immortals fenyx rising hermes" width="1460" height="821" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3.jpg 1460w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-360x202.jpg 360w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-3-1130x635.jpg 1130w" sizes="(max-width: 1460px) 100vw, 1460px" /></p>
<p>By completing Mythic Challenges, you gain Coins of Charon which can be used at the Hall of the Gods (the game&#8217;s hub) to unlock new God-like abilities and improve on your standard skills. Some of these are game-changers, such as Hephaistos&#8217; Hammer. It does tons of damage, but it does consume a lot of stamina. These challenges are also excellent. You might have to find blue spheres to place into a constellation, race to the end of a course in a set time, or fire an arrow through rings until you light a pyre at the end. Whatever the challenge, I had a lot of fun trying to complete them. They can be tough, but the rewards are well worth it in the end.</p>
<p>Chests are scattered throughout the world, containing new weapons and armour sets, or cosmetic skins and upgrade materials, and each piece of armour or weapon has a particular buff that remains until you switch it out. You can also tame horses that have particular advantages, whether that be increased stamina or additional speed. Collecting enough Ambrosia will allow you to add an additional health chunk to your bar, diving into Vaults of Tartaros and solving the puzzles within grant you new gear and lightning bolts (which are needed for improving stamina), and side quests can be picked up to flesh out the overarching mythology of the story.</p>
<p>Combat in Immortals Fenyx Rising is sublime. Pressing the right shoulder button attacks with your sword whilst the right trigger lands a blow from your axe. Dodging or parrying successfully slows down time and opens up a small window of opportunity to do excess damage. When you start to incorporate all your Godly Powers, fighting plays like a dream. You can raise spears from the ground, charge fast at your enemies, use an almighty hammer to cause untold damage, and pull yourself closer to enemies to land a flurry of melee attacks. You&#8217;ll also unlock Phosphor &#8211; a Phoenix bird with a mix of powers &#8211; to aid you in battle.</p>
<p><img class="aligncenter wp-image-244637 size-full" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1.jpg" alt="immortals fenyx rising taurus" width="1200" height="675" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1.jpg 1200w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-1-1130x636.jpg 1130w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>Your bow and arrow is another great piece of gear, and tracking an Arrow of Apollo as it flies in slow motion towards an enemy&#8217;s head feels incredibly satisfying. Your bow becomes an important tool in many of the puzzles as you&#8217;ll need to fire with precision at targets that change wind direction, or hit other targets that open blocked doorways. You&#8217;ll fight a wide range of enemies straight from Greek mythology: Cerberus, Griffins, Minotaurs, Cyclops, Hecatoncheires, Harpies, and plenty more. Each one attacks differently, and you&#8217;ll always have to change tactics in battle because packs of varied monsters pop up all the time.</p>
<p>The environments in Immortals Fenyx Rising are gorgeous. From lush forests with glistening blue lakes to lands covered in dirt, ironworks, and fire, there are so many stunning places that they become a joy to explore. The mythological backbone of the game is present everywhere you look. Giant sculptures and monuments, castles with majestic architecture, and mountains that reach the heavens, the detail and design is near perfection. To add to how good this game looks, Gareth Coker&#8217;s score is incredible, using authentic Greek instrumentation and adding his own unique twist to suit the mood and area you&#8217;re in.</p>
<p>Travelling around the different regions is another part of Immortals Fenyx Rising that I adored. Using the Wings of Daedalus to glide off tall cliffs or monuments and riding around on your horse gives you chills, and climbing up mountains or golden buildings provides a sense of accomplishment due to the need to approach each one with caution; if your stamina depletes halfway, it&#8217;ll spell certain doom. At one point, you&#8217;ll face the harsh cold. If you don&#8217;t light the way with fire then death will be knocking on your door. These environmental challenges only add to the fantastical adventure you find yourself on, and as I look back after spending almost 30 hours with Fenyx, I miss it already.</p>
<div class='video_frame'><iframe id='youtube_video_1' class='youtube_video' src='https://www.youtube.com/embed/5BV5HivSXUA?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p>Perhaps Immortals&#8217; greatest achievement is the variety of its Vaults. Not only do they offer a nice break from exploring, they also offer diverse puzzles with intricate elements, and no two are the same. For example, many take the form of platforming puzzles where you&#8217;ll need to navigate wooden crates, metal pillars, and breakable stone cubes around obstacles like levitating platforms and updrafts. Trying to manage the large heavy spheres, air tunnels, corruption fields, and poisonous clouds takes up a lot of time, but the way puzzles are so intricately designed make it hard not be awed by them.</p>
<p>Immortals Fenyx Rising is an excellent adventure with challenging and inventive puzzles, a wonderful combat system, and a rich world ripe for exploring. The dialogue is funny, poignant, and thrilling, with a story that explores every facet of the human condition in a way that is relatable for everyone. It does share many similarities with BotW, almost shamelessly so at times, but this is without a doubt its own game, and the experience Ubisoft Quebec has in making open world games is on show throughout. I guess it depends how much you love Breath of the Wild, and whether you can get past many of the same ideas without feeling a little cheated. It offers a different spin on the stories of Zeus and his children, sweeping you up with its spellbinding tale and beautiful, charming world.</p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                    <div class="procon-box-wrapper"><div class="procon-box clearfix"><div class="col-wrapper"><div class="procon pro"><div class="header"><span class="icon-plus"></span>Positives</div><p>Excellent puzzles<br />
A well-written script with tons of charm<br />
Superb combat<br />
Gorgeous environments<br />
An incredible score</p>
</div></div><div class="col-wrapper"><div class="procon con"><div class="header"><span class="icon-minus"></span>Negatives</div><p>Using Far Sight is a bit finicky<br />
Borrows a lot from BotW</p>
</div></div></div></div>                                        
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix solo"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar"><div class="rating-meter">&nbsp;</div><div class="rating-label">Our Score</div><div class="rating-value"><div class="number color5">9.0</div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-10,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar color5"><div class="rating-label">SCORE OUT OF TEN</div><meta itemprop="worstRating" content="0"><div class="rating-value" itemprop="ratingValue"><div class="number color5">9.0</div></div><meta itemprop="bestRating" content="10"><br class="clearer" /></div></div></div></div></div><br class="clearer" />                                    
                                    <div class="bottomline-wrapper"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-quote-circled"></span>In Short<div class="ribbon-separator">&nbsp;</div></div></div><div class="bottomline"><p>Immortals Fenyx Rising is an excellent adventure with challenging and intricate puzzles, a wonderful combat system, and a rich world ripe for exploring. The dialogue is funny, poignant, and thrilling, with a story that explores every facet of the human condition in a way that is relatable for everyone.</p>
</div></div>                                    
                                                                 
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>You may also like<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="27496" data-method="tags" class="info active" title="More articles tagged: Immortals: Fenyx Rising">Immortals: Fenyx Rising<span class="bottom-arrow"></span></a><a data-sorter="19189" data-method="tags" class="info" title="More articles tagged: PC">PC<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-demo-returns-to-stadia/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/AnyConv.com__Immortals-Fenyx-Rising-release-date-screenshots-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fenyx Rising demo stadia" title="Immortals Fenyx Rising demo returns to Stadia" srcset="https://www.godisageek.com/wp-content/uploads/AnyConv.com__Immortals-Fenyx-Rising-release-date-screenshots-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/AnyConv.com__Immortals-Fenyx-Rising-release-date-screenshots-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/AnyConv.com__Immortals-Fenyx-Rising-release-date-screenshots-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/AnyConv.com__Immortals-Fenyx-Rising-release-date-screenshots-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-demo-returns-to-stadia/">Immortals Fenyx Rising demo returns to Stadia</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-demo-returns-to-stadia/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-gets-a-season-pass-full-of-post-launch-content/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-Season-Pass-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising Season Pass" title="Immortals Fenyx Rising gets a Season Pass full of post-launch content" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-Season-Pass-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-Season-Pass-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-Season-Pass-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-Season-Pass-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-gets-a-season-pass-full-of-post-launch-content/">Immortals Fenyx Rising gets a Season Pass full of post-launch content</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/immortals-fenyx-rising-gets-a-season-pass-full-of-post-launch-content/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/relegend-to-launch-on-consoles-pc-in-spring-2021/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/relegend-farming-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Re:Legend launch spring 2021" title="Re:Legend to launch on consoles &#038; PC in Spring 2021" srcset="https://www.godisageek.com/wp-content/uploads/relegend-farming-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/relegend-farming-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/relegend-farming-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/relegend-farming-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/relegend-to-launch-on-consoles-pc-in-spring-2021/">Re:Legend to launch on consoles &#038; PC in Spring 2021</a><div class="article-meta clearfix"><a class="like-button do-like 244692 info-bottom" data-postid="244692" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/11/relegend-to-launch-on-consoles-pc-in-spring-2021/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/hwang-to-be-the-final-dlc-character-for-soulcalibur-vi/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hwang Final DLC Character" title="Hwang to be the final DLC character for SOULCALIBUR VI" srcset="https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/soulcalibur-vi-hwang-soulcalibur-6-hwang-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/hwang-to-be-the-final-dlc-character-for-soulcalibur-vi/">Hwang to be the final DLC character for SOULCALIBUR VI</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/hwang-to-be-the-final-dlc-character-for-soulcalibur-vi/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Second Extinction review" title="Second Extinction Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">Second Extinction Early Access review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/moonlighter-new-mutant-zero-and-more-discounted-in-gog-cyber-monday-sale/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOG" title="Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale" srcset="https://www.godisageek.com/wp-content/uploads/GOG-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GOG-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GOG-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/GOG-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/moonlighter-new-mutant-zero-and-more-discounted-in-gog-cyber-monday-sale/">Moonlighter, New Mutant Zero and More Discounted in GOG Cyber Monday Sale</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/moonlighter-new-mutant-zero-and-more-discounted-in-gog-cyber-monday-sale/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Immortals Fenyx Rising review" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">Immortals Fenyx Rising review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Second Extinction review" title="Second Extinction Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">Second Extinction Early Access review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 244625 info-bottom" data-postid="244625" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Immortals Fenyx Rising review" srcset="https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">Immortals Fenyx Rising review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Chronos: Before the Ashes" title="Chronos: Before the Ashes review" srcset="https://www.godisageek.com/wp-content/uploads/Chronos-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Chronos-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/">Chronos: Before the Ashes review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/pistol-whip-2089-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pistol Whip 2089" title="Pistol Whip 2089 review" srcset="https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/pistol-whip-2089-review/">Pistol Whip 2089 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/pistol-whip-2089-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Katamari Damacy REROLL Review" title="Katamari Damacy REROLL review" srcset="https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/">Katamari Damacy REROLL review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a><div class="article-meta clearfix"><a class="like-button do-like 243566 info-bottom" data-postid="243566" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/demons-souls-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Demons-Souls-key-art-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Demon&#039;s Souls review" title="Demon&#8217;s Souls review" srcset="https://www.godisageek.com/wp-content/uploads/Demons-Souls-key-art-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Demons-Souls-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Demons-Souls-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Demons-Souls-key-art-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/demons-souls-review/">Demon&#8217;s Souls review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 244478 info-bottom" data-postid="244478" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/demons-souls-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/mortal-kombat-11-ultimate-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mortal-kombat-ultimate-ps5-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mortal Kombat 11 Ultimate review" title="Mortal Kombat 11 Ultimate PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/mortal-kombat-ultimate-ps5-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-ultimate-ps5-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-ultimate-ps5-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-ultimate-ps5-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/mortal-kombat-11-ultimate-ps5-review/">Mortal Kombat 11 Ultimate PS5 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/mortal-kombat-11-ultimate-ps5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dirt-5-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dirt-5-ps5-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DIRT 5 PS5 review" title="DIRT 5 PS5 review" srcset="https://www.godisageek.com/wp-content/uploads/dirt-5-ps5-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dirt-5-ps5-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dirt-5-ps5-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dirt-5-ps5-review/">DIRT 5 PS5 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dirt-5-ps5-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/yakuza-like-a-dragon-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Yakuza: Like a Dragon review" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/yakuza-like-a-dragon-review/">Yakuza: Like a Dragon review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/yakuza-like-a-dragon-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/fuser-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/fuser-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="fuser" title="Fuser review" srcset="https://www.godisageek.com/wp-content/uploads/fuser-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/fuser-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/fuser-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/fuser-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/fuser-review/">Fuser review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/fuser-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/2nd-Extinction-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/second-extinction-early-access-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Second Extinction Early Access review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/immortals-fenyx-rising-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/immortals-fenyx-rising-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Immortals Fenyx Rising review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Chronos-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/chronos-before-the-ashes-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Chronos: Before the Ashes review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Pistol-Whip-2089-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/pistol-whip-2089-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Pistol Whip 2089 review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/katamari-damacy-reroll-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/katamari-damacy-reroll-review-2/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Katamari Damacy REROLL review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Tales-from-the-galaxys-edge-main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/star-wars-tales-from-the-galaxys-edge-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Star Wars: Tales From the Galaxy&#8217;s Edge review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
