<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Runescape Elder God Wars: City of Senntisten is now live | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Jagex Games Studio has announced the launch of the next installment in the RuneScape Elder God Wars story arc, the City of Senntisten. " />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Runescape Elder God Wars: City of Senntisten is now live | GodisaGeek.com" />
	<meta property="og:description" content="Jagex Games Studio has announced the launch of the next installment in the RuneScape Elder God Wars story arc, the City of Senntisten. " />
	<meta property="og:url" content="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2021-06-21T14:01:24+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten.jpg","width":1920,"height":1080,"caption":"Runescape City of Senntisten"},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/#webpage","url":"https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/","name":"Runescape Elder God Wars: City of Senntisten is now live | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/#primaryimage"},"datePublished":"2021-06-21T14:01:24+00:00","dateModified":"2021-06-21T14:01:24+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/2442bf90e440fc353e369b62d31fbb2d"},"description":"Jagex Games Studio has announced the launch of the next installment in the RuneScape\u00a0Elder God Wars story arc, the City of Senntisten.\u00a0","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/2442bf90e440fc353e369b62d31fbb2d","name":"News Team","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/286e27b195400c562a644be4c076da47?s=96&d=mm&r=g","caption":"News Team"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"06","day":"21","hour":"15","minute":"01","second":"24","post_id":"252134","postname":"runescape-elder-god-wars-city-of-senntisten-is-now-live","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/' />
<meta name='shareaholic:keywords' content='tag:jagex games studio, tag:runescape, tag:runescape city of senntisten, cat:news, cat:trailers, type:post' />
<meta name='shareaholic:article_published_time' content='2021-06-21T15:01:24+01:00' />
<meta name='shareaholic:article_modified_time' content='2021-06-21T15:01:24+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='News Team' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=252134' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F06%2Frunescape-elder-god-wars-city-of-senntisten-is-now-live%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F06%2Frunescape-elder-god-wars-city-of-senntisten-is-now-live%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-252134 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-251669" class="menu-item menu-item-251669 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/e3-2021/">E3 2021</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/">Runescape Elder God Wars: City of Senntisten is now live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Runescape City of Senntisten" title="Runescape Elder God Wars: City of Senntisten is now live" srcset="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/">The O2 comes to Fortnite Creative in new interactive music experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Fortnite Creative O2" title="The O2 comes to Fortnite Creative in new interactive music experience" srcset="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/cyberpunk-2077-is-now-available-on-playstation-store/">Cyberpunk 2077 is now available on PlayStation Store<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="cyberpunk-2077-review" title="Cyberpunk 2077 is now available on PlayStation Store" srcset="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/tennocon-2021-virtual-event-schedule-has-been-revealed/">TennoCon 2021 virtual event schedule has been revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="TennoCon 2021 schedule" title="TennoCon 2021 virtual event schedule has been revealed" srcset="https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/new-lost-in-random-trailer-shows-off-gothic-fairytale-story/">New Lost in Random trailer shows off gothic fairytale story<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lost in Random trailer" title="New Lost in Random trailer shows off gothic fairytale story" srcset="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/a-plague-tale-innocence-comes-in-4k-uhd-to-xbox-series-x-and-ps5/">A Plague Tale: Innocence comes in 4K UHD to Xbox Series X and PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale: Innocence 4K" title="A Plague Tale: Innocence comes in 4K UHD to Xbox Series X and PS5" srcset="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">Dungeons &#038; Dragons: Dark Alliance review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dungeons &amp; Dragons: Dark Alliance Review" title="Dungeons &#038; Dragons: Dark Alliance review" srcset="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">Red Solstice 2: Survivors review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Solstice 2: Survivors review" title="Red Solstice 2: Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RS2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RS2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RS2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/mushihimesama-review/">Mushihimesama review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Mushihimesama title image" title="Mushihimesama review" srcset="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-16-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-16-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neptunia-reverse-review/">Neptunia ReVerse review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Neptunia ReVerse title image" title="Neptunia ReVerse review" srcset="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/main_img-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/main_img-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/main_img-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review" srcset="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/very-very-valet-nintendo-switch-review/">Very Very Valet review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Very Very Valet review" title="Very Very Valet review" srcset="https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/podcast-448-ratchet-clank-rift-apart-game-builder-garage/">Podcast #448: The Big E3 2021 Wrap-up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #448: The Big E3 2021 Wrap-up" title="Podcast #448: The Big E3 2021 Wrap-up" srcset="https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/animal-crossing-new-horizons-the-frustrations-of-being-a-long-term-fan/">Animal Crossing New Horizons | The frustrations of being a long term fan<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ACNH-Feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Animal Crossing New Horizons" title="Animal Crossing New Horizons | The frustrations of being a long term fan" srcset="https://www.godisageek.com/wp-content/uploads/ACNH-Feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/tales-of-arise-has-poetic-combat-amidst-its-layered-artes-hands-on-preview/">Tales of Arise has poetic combat amidst its layered Artes | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tales of Arise Preview" title="Tales of Arise has poetic combat amidst its layered Artes | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/all-the-nintendo-e3-announcements/">All the Nintendo E3 announcements<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct E3 2021" title="All the Nintendo E3 announcements" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/kena-bridge-of-spirits-hands-on-preview-gameplay/">Kena: Bridge of Spirits left me desperate to play more | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Kena: Bridge of Spirits left me desperate to play more | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/biomutant-out-now-gameplay-video-showcase/">Biomutant is out now, so here&#8217;s an hour of us showing the gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Biomutant is out now, so here&#039;s an hour of us showing the gameplay" title="Biomutant is out now, so here&#8217;s an hour of us showing the gameplay" srcset="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/dying-light-2-news-secret-message-twitch-gameplay-reveal/">Dying Light 2 news is coming soon according to this press pack they sent us<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light 2 news is coming soon according to this press pack they sent us" title="Dying Light 2 news is coming soon according to this press pack they sent us" srcset="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/the-first-hour-of-mass-effect-legendary-edition-gameplay-video/">The first hour of Mass Effect Legendary Edition | Gameplay video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mass Effect Legendary Edition gameplay video" title="The first hour of Mass Effect Legendary Edition | Gameplay video" srcset="https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-lorbs-guide/">Ratchet &#038; Clank: Rift Apart | How to find all the Lorbs<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ratchet &#038; Clank: Rift Apart | How to find all the Lorbs" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-tips-to-get-you-started/">Ratchet &#038; Clank: Rift Apart | 7 Tips to get you started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | tips to get you started" title="Ratchet &#038; Clank: Rift Apart | 7 Tips to get you started" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-upgrade-weapons/">Ratchet &#038; Clank: Rift Apart | How to upgrade weapons<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ratchet &#038; Clank: Rift Apart | How to upgrade weapons" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-boing-trophy/">Ratchet &#038; Clank: Rift Apart | How to unlock the &#8220;Boing!&#8221; trophy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to unlock the &quot;Boing!&quot; trophy" title="Ratchet &#038; Clank: Rift Apart | How to unlock the &#8220;Boing!&#8221; trophy" srcset="https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-ryno-weapon/">Ratchet &#038; Clank: Rift Apart | How to unlock the Ryno weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to unlock the Ryno weapon" title="Ratchet &#038; Clank: Rift Apart | How to unlock the Ryno weapon" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-zurpstones/">Ratchet &#038; Clank: Rift Apart | How to find all the Zurpstones<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to find all the Zurpstones" title="Ratchet &#038; Clank: Rift Apart | How to find all the Zurpstones" srcset="https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/ratchet-clank-rift-apart/">R&C: Rift Apart Guide</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-251669" class="menu-item menu-item-251669 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/e3-2021/">E3 2021</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/">Runescape Elder God Wars: City of Senntisten is now live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Runescape City of Senntisten" title="Runescape Elder God Wars: City of Senntisten is now live" srcset="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/">The O2 comes to Fortnite Creative in new interactive music experience<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Fortnite Creative O2" title="The O2 comes to Fortnite Creative in new interactive music experience" srcset="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/cyberpunk-2077-is-now-available-on-playstation-store/">Cyberpunk 2077 is now available on PlayStation Store<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="cyberpunk-2077-review" title="Cyberpunk 2077 is now available on PlayStation Store" srcset="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/tennocon-2021-virtual-event-schedule-has-been-revealed/">TennoCon 2021 virtual event schedule has been revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="TennoCon 2021 schedule" title="TennoCon 2021 virtual event schedule has been revealed" srcset="https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/TennoCon-2021-schedule-min-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/new-lost-in-random-trailer-shows-off-gothic-fairytale-story/">New Lost in Random trailer shows off gothic fairytale story<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Lost in Random trailer" title="New Lost in Random trailer shows off gothic fairytale story" srcset="https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Lost-in-Random-trailer-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/a-plague-tale-innocence-comes-in-4k-uhd-to-xbox-series-x-and-ps5/">A Plague Tale: Innocence comes in 4K UHD to Xbox Series X and PS5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale: Innocence 4K" title="A Plague Tale: Innocence comes in 4K UHD to Xbox Series X and PS5" srcset="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Innocence-4K-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">Dungeons &#038; Dragons: Dark Alliance review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dungeons &amp; Dragons: Dark Alliance Review" title="Dungeons &#038; Dragons: Dark Alliance review" srcset="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">Red Solstice 2: Survivors review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Solstice 2: Survivors review" title="Red Solstice 2: Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RS2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RS2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RS2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/mushihimesama-review/">Mushihimesama review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Mushihimesama title image" title="Mushihimesama review" srcset="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-16-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-16-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neptunia-reverse-review/">Neptunia ReVerse review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Neptunia ReVerse title image" title="Neptunia ReVerse review" srcset="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/main_img-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/main_img-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/main_img-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review" srcset="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/very-very-valet-nintendo-switch-review/">Very Very Valet review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Very Very Valet review" title="Very Very Valet review" srcset="https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/very-very-valet-screenshot-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/podcast-448-ratchet-clank-rift-apart-game-builder-garage/">Podcast #448: The Big E3 2021 Wrap-up<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #448: The Big E3 2021 Wrap-up" title="Podcast #448: The Big E3 2021 Wrap-up" srcset="https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/starfield-e3-podcast-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/animal-crossing-new-horizons-the-frustrations-of-being-a-long-term-fan/">Animal Crossing New Horizons | The frustrations of being a long term fan<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ACNH-Feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Animal Crossing New Horizons" title="Animal Crossing New Horizons | The frustrations of being a long term fan" srcset="https://www.godisageek.com/wp-content/uploads/ACNH-Feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ACNH-Feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/tales-of-arise-has-poetic-combat-amidst-its-layered-artes-hands-on-preview/">Tales of Arise has poetic combat amidst its layered Artes | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tales of Arise Preview" title="Tales of Arise has poetic combat amidst its layered Artes | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/all-the-nintendo-e3-announcements/">All the Nintendo E3 announcements<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct E3 2021" title="All the Nintendo E3 announcements" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-E3-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/kena-bridge-of-spirits-hands-on-preview-gameplay/">Kena: Bridge of Spirits left me desperate to play more | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Kena: Bridge of Spirits left me desperate to play more | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kena-Bridge-of-Spirits-hands-on-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/biomutant-out-now-gameplay-video-showcase/">Biomutant is out now, so here&#8217;s an hour of us showing the gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Biomutant is out now, so here&#039;s an hour of us showing the gameplay" title="Biomutant is out now, so here&#8217;s an hour of us showing the gameplay" srcset="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/dying-light-2-news-secret-message-twitch-gameplay-reveal/">Dying Light 2 news is coming soon according to this press pack they sent us<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light 2 news is coming soon according to this press pack they sent us" title="Dying Light 2 news is coming soon according to this press pack they sent us" srcset="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/05/the-first-hour-of-mass-effect-legendary-edition-gameplay-video/">The first hour of Mass Effect Legendary Edition | Gameplay video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mass Effect Legendary Edition gameplay video" title="The first hour of Mass Effect Legendary Edition | Gameplay video" srcset="https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-Legendary-Edition-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-lorbs-guide/">Ratchet &#038; Clank: Rift Apart | How to find all the Lorbs<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ratchet &#038; Clank: Rift Apart | How to find all the Lorbs" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-tips-to-get-you-started/">Ratchet &#038; Clank: Rift Apart | 7 Tips to get you started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | tips to get you started" title="Ratchet &#038; Clank: Rift Apart | 7 Tips to get you started" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-upgrade-weapons/">Ratchet &#038; Clank: Rift Apart | How to upgrade weapons<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ratchet &#038; Clank: Rift Apart | How to upgrade weapons" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-boing-trophy/">Ratchet &#038; Clank: Rift Apart | How to unlock the &#8220;Boing!&#8221; trophy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to unlock the &quot;Boing!&quot; trophy" title="Ratchet &#038; Clank: Rift Apart | How to unlock the &#8220;Boing!&#8221; trophy" srcset="https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-ryno-weapon/">Ratchet &#038; Clank: Rift Apart | How to unlock the Ryno weapon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to unlock the Ryno weapon" title="Ratchet &#038; Clank: Rift Apart | How to unlock the Ryno weapon" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-zurpstones/">Ratchet &#038; Clank: Rift Apart | How to find all the Zurpstones<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ratchet &amp; Clank: Rift Apart | How to find all the Zurpstones" title="Ratchet &#038; Clank: Rift Apart | How to find all the Zurpstones" srcset="https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/tag/ratchet-clank-rift-apart/">R&C: Rift Apart Guide</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">The O2 comes to Fortnite Creative in new interactive music experience</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2020/02/animal-crossing-brings-out-the-worst-in-me/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-252134" class="post-252134 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-trailers tag-jagex-games-studio tag-runescape" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Runescape Elder God Wars: City of Senntisten is now live                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/news-team/"><span itemprop="author">News Team </span></a></span><span class="date">on <meta itemprop="datePublished" content="June 21, 2021">June 21, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Runescape City of Senntisten" title="Runescape Elder God Wars: City of Senntisten is now live" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Runescape Elder God Wars: City of Senntisten is now live' data-link='https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/' data-summary='New Runescape quest' data-app-id-name='post_above_content'></div>
<p><a href="https://www.jagex.com/en-GB/" target="_blank" rel="noopener noreferrer">Jagex Games Studio</a> has announced the launch of the next installment in the <a href="https://www.godisageek.com/2021/01/soul-wars-arrives-in-old-school-runescape/">RuneScape</a> Elder God Wars story arc, the City of Senntisten.  The new quest is available from today.  It delivers a whole new map, providing players with a wealth of challenges and powerful rewards. The City of Senntisten also becomes RuneScape&#8217;s first new quest available to both PC and mobile players following the launch of the iconic PC MMORPG on iOS and Android last week, which brought full cross-platform play and progression to the game.</p>
<p>You can see the new Runescape City of Senntisten trailer here:</p>
<p><iframe title="Elder God Wars: City of Senntisten - Trailer" width="500" height="281" src="https://www.youtube.com/embed/j4Jmj01krWs?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<h3>The City of Senntisten</h3>
<p>The Elder God Wars is a year-long epic saga that follows Ariane’s devastating vision that “war is coming” to Gielinor.  The City of Senntisten is the final quest ahead of that foreseen war beginning. Senntisten itself is a lost city, originally home to Zaros, and gives players an entirely new location to explore.</p>
<p>Once players have recruited their allies, it’s time to put their Archaeology skill to use and gain entrance to the city.  Here they will need to fend off dark forces and begin to prepare defenses. The city has dangers lurking around every corner. Players will have to exercise caution whilst exploring the claustrophobic confines of the cathedral and its surrounding areas.  Transform the area into a fortress in preparation for oncoming waves of ferocious enemies.</p>
<p>Ryan Ward, Executive Producer, RuneScape, had this to say:</p>
<blockquote><p>“Today’s launch of the City of Senntisten sees the Elder God Wars arc really ignite as this is the prologue quest before the war truly begins. Over the coming months, the fate of Gielinor will be decided as players experience four fronts on the battlefield as the Elder Gods begin their assault.&#8221;</p></blockquote>
<p>For those who succeed, there is a cornucopia of powerful rewards, most notably new Ancient Magick spells, plus XP in Slayer and Archaeology skills, an upgrade to the Pontifex Observation Ring, and more.  The City of Senntisten is a member-exclusive quest and players will also need to have completed the previous quests in the arc; Azzanadra’s Quest and Battle of Monolith, as well as having their Slayer and Archaeology skills at 75 and 74, respectively.</p>
<p>The City of Senntisten, launches in Runescape today.  Available on PC, and Mobile on iOS and Android.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Runescape Elder God Wars: City of Senntisten is now live' data-link='https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/' data-summary='New Runescape quest' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Runescape Elder God Wars: City of Senntisten is now live' data-link='https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/' data-summary='New Runescape quest' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a>, <a href="https://www.godisageek.com/category/news/trailers/" title="View all posts in Trailers">Trailers</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/jagex-games-studio/" title="Jagex Games Studio Tag" class="jagex-games-studio">Jagex Games Studio</a><a href="https://www.godisageek.com/tag/runescape/" title="Runescape Tag" class="runescape">Runescape</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/news-team/"><img alt='' src='https://secure.gravatar.com/avatar/286e27b195400c562a644be4c076da47?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/286e27b195400c562a644be4c076da47?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/news-team/"><h3>News Team</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:news@godisageek.com"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="5841" data-method="tags" class="info active" title="More articles tagged: Runescape">Runescape<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2018/05/jagex-raised-225k-mental-health-charities-12-months/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Jagex-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Jagex has raised £225k for mental health charities in 12 months" srcset="https://www.godisageek.com/wp-content/uploads/Jagex-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Jagex-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Jagex-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Jagex-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2018/05/jagex-raised-225k-mental-health-charities-12-months/">Jagex has raised £225k for mental health charities in 12 months</a></div><a class="hover-link" href="https://www.godisageek.com/2018/05/jagex-raised-225k-mental-health-charities-12-months/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2017/07/runescape-school-runescape-coming-mobile-full-pc-cross-play/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/runescape-mobile-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="RuneScape and Old School RuneScape are coming to mobile with full PC cross play" srcset="https://www.godisageek.com/wp-content/uploads/runescape-mobile-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/runescape-mobile-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/runescape-mobile-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/runescape-mobile-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2017/07/runescape-school-runescape-coming-mobile-full-pc-cross-play/">RuneScape and Old School RuneScape are coming to mobile with full PC cross play</a></div><a class="hover-link" href="https://www.godisageek.com/2017/07/runescape-school-runescape-coming-mobile-full-pc-cross-play/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2016/01/runescape-celebrates-15th-birthday/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rune1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="RuneScape Celebrates 15th Birthday" srcset="https://www.godisageek.com/wp-content/uploads/rune1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/rune1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/rune1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/rune1-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/rune1-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2016/01/runescape-celebrates-15th-birthday/">RuneScape Celebrates 15th Birthday</a></div><a class="hover-link" href="https://www.godisageek.com/2016/01/runescape-celebrates-15th-birthday/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2015/07/runescape-joins-with-wwf/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RS_Twitter_WWF-Cats-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Jagex&#8217;s Runescape Joins with WWF to Support Endangered Animals" srcset="https://www.godisageek.com/wp-content/uploads/RS_Twitter_WWF-Cats-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RS_Twitter_WWF-Cats-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RS_Twitter_WWF-Cats-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/RS_Twitter_WWF-Cats-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2015/07/runescape-joins-with-wwf/">Jagex&#8217;s Runescape Joins with WWF to Support Endangered Animals</a></div><a class="hover-link" href="https://www.godisageek.com/2015/07/runescape-joins-with-wwf/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2013/01/runescape-celebrates-12th-year-online/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RuneScape-100x100.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="RuneScape Celebrates its 12th Year Online" srcset="https://www.godisageek.com/wp-content/uploads/RuneScape-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RuneScape-100x100-50x50.jpg 50w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2013/01/runescape-celebrates-12th-year-online/">RuneScape Celebrates its 12th Year Online</a></div><a class="hover-link" href="https://www.godisageek.com/2013/01/runescape-celebrates-12th-year-online/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2011/11/runescape-website-logo/"><img src="https://www.godisageek.com/wp-content/themes/steam/images/placeholder-35.png" alt="featured image" width="35" height="35" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2011/11/runescape-website-logo/">Runescape Gets New Website and Logo</a></div><a class="hover-link" href="https://www.godisageek.com/2011/11/runescape-website-logo/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Dungeons &amp; Dragons: Dark Alliance Review" title="Dungeons &#038; Dragons: Dark Alliance review" srcset="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">Dungeons &#038; Dragons: Dark Alliance review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 252104 info-bottom" data-postid="252104" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Runescape City of Senntisten" title="Runescape Elder God Wars: City of Senntisten is now live" srcset="https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Runescape-City-of-Senntisten-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/">Runescape Elder God Wars: City of Senntisten is now live</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/runescape-elder-god-wars-city-of-senntisten-is-now-live/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Fortnite Creative O2" title="The O2 comes to Fortnite Creative in new interactive music experience" srcset="https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Fortnite-Creative-O2-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/">The O2 comes to Fortnite Creative in new interactive music experience</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-o2-comes-to-fortnite-creative-in-new-interactive-music-experience/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/cyberpunk-2077-is-now-available-on-playstation-store/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="cyberpunk-2077-review" title="Cyberpunk 2077 is now available on PlayStation Store" srcset="https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/cyberpunk-2077-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/cyberpunk-2077-is-now-available-on-playstation-store/">Cyberpunk 2077 is now available on PlayStation Store</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/cyberpunk-2077-is-now-available-on-playstation-store/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Solstice 2: Survivors review" title="Red Solstice 2: Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RS2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RS2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RS2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">Red Solstice 2: Survivors review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Dungeons &amp; Dragons: Dark Alliance Review" title="Dungeons &#038; Dragons: Dark Alliance review" srcset="https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dungeons-and-Dragons-Dark-Alliance-Review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">Dungeons &#038; Dragons: Dark Alliance review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 252104 info-bottom" data-postid="252104" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Red Solstice 2: Survivors review" title="Red Solstice 2: Survivors review" srcset="https://www.godisageek.com/wp-content/uploads/RS2-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RS2-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RS2-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RS2-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">Red Solstice 2: Survivors review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/mushihimesama-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Mushihimesama title image" title="Mushihimesama review" srcset="https://www.godisageek.com/wp-content/uploads/hero-16-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-16-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-16-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/mushihimesama-review/">Mushihimesama review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/mushihimesama-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neptunia-reverse-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Neptunia ReVerse title image" title="Neptunia ReVerse review" srcset="https://www.godisageek.com/wp-content/uploads/main_img-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/main_img-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/main_img-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/main_img-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neptunia-reverse-review/">Neptunia ReVerse review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neptunia-reverse-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review" srcset="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="The Falconeer PS5 Preview" title="The Falconeer on PS5 just feels right | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Falconeer-PS5-preview-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">The Falconeer on PS5 just feels right | Hands-on preview</a><div class="article-meta clearfix"><a class="like-button do-like 251928 info-bottom" data-postid="251928" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/06/the-falconeer-on-ps5-just-feels-right-hands-on-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How Ratchet &amp; Clank: Rift Apart uses the PS5&#039;s DualSense and Haptics" title="How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics" srcset="https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ps5-dualsense-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">How Ratchet &#038; Clank: Rift Apart uses the PS5&#8217;s DualSense and Haptics</a></div><a class="hover-link" href="https://www.godisageek.com/2021/06/how-ratchet-clank-rift-apart-uses-the-ps5s-dualsense-and-haptics/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Final Fantasy VII Remake Intergrade Intermission gameplay preview" title="Final Fantasy VII Remake Intergrade Intermission gameplay preview" srcset="https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Final-Fantasy-VII-Remake-Intergrade-Intermission-gameplay-yuffie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">Final Fantasy VII Remake Intergrade Intermission gameplay preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/final-fantasy-vii-remake-intergrade-intermission-gameplay-preview/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/biomutant-out-now-gameplay-video-showcase/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Biomutant is out now, so here&#039;s an hour of us showing the gameplay" title="Biomutant is out now, so here&#8217;s an hour of us showing the gameplay" srcset="https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/biomutant-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/biomutant-out-now-gameplay-video-showcase/">Biomutant is out now, so here&#8217;s an hour of us showing the gameplay</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/biomutant-out-now-gameplay-video-showcase/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/05/dying-light-2-news-secret-message-twitch-gameplay-reveal/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light 2 news is coming soon according to this press pack they sent us" title="Dying Light 2 news is coming soon according to this press pack they sent us" srcset="https://www.godisageek.com/wp-content/uploads/dying-light-2-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dying-light-2-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/05/dying-light-2-news-secret-message-twitch-gameplay-reveal/">Dying Light 2 news is coming soon according to this press pack they sent us</a></div><a class="hover-link" href="https://www.godisageek.com/2021/05/dying-light-2-news-secret-message-twitch-gameplay-reveal/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ratchet-clank-rift-apart-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Ratchet &amp; Clank: Rift Apart Review" title="Ratchet &#038; Clank: Rift Apart review" srcset="https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ratchet-Clank-Rift-Apart-Review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ratchet-clank-rift-apart-review/">Ratchet &#038; Clank: Rift Apart review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 251329 info-bottom" data-postid="251329" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ratchet-clank-rift-apart-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/backbone-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Backbone-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Backbone Review" title="Backbone review" srcset="https://www.godisageek.com/wp-content/uploads/Backbone-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Backbone-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Backbone-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Backbone-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/backbone-review/">Backbone review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/backbone-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review" srcset="https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FF7-DLC-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Guilty Gear STRIVE review" title="Guilty Gear STRIVE review" srcset="https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/guilty-gear-strive-ps4-ps5-review-pc-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/">Guilty Gear STRIVE review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/guilty-gear-strive-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/game-builder-garage-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/game-maker-garage-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Game Maker Garage review" title="Game Builder Garage review" srcset="https://www.godisageek.com/wp-content/uploads/game-maker-garage-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/game-maker-garage-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/game-maker-garage-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/game-maker-garage-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/game-builder-garage-review/">Game Builder Garage review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/game-builder-garage-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-lorb-guide-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-lorbs-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | How to find all the Lorbs</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-tips-featured-image-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-tips-to-get-you-started/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | 7 Tips to get you started</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/ratchet-and-clank-rifts-apart-news-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-upgrade-weapons/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | How to upgrade weapons</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/rift-apart-boing-trophy-pocket-dimension-featured-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-boing-trophy/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | How to unlock the &#8220;Boing!&#8221; trophy</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/ratchet-clank-rift-apart-ryno-featured-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-unlock-the-ryno-weapon/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | How to unlock the Ryno weapon</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/rift-apart-zurpstones-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/06/ratchet-clank-rift-apart-how-to-find-all-the-zurpstones/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Ratchet &#038; Clank: Rift Apart | How to find all the Zurpstones</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">Dungeons &#038; Dragons: Dark Alliance review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dungeons-dragons-dark-alliance-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">Red Solstice 2: Survivors review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/red-solstice-2-survivors-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/mushihimesama-review/">Mushihimesama review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/mushihimesama-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neptunia-reverse-review/">Neptunia ReVerse review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neptunia-reverse-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">Final Fantasy 7 Remake: Intergrade &#8211; Episode: INTERmission review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/final-fantasy-7-remake-intergrade-episode-intermission-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.909090909091px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 19.045454545455px;" aria-label="Activision (776 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12px;" aria-label="Bandai Namco (380 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-4" style="font-size: 12.454545454545px;" aria-label="Call of Duty (394 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.909090909091px;" aria-label="Capcom (687 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 14.272727272727px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.909090909091px;" aria-label="EA (1,136 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12.681818181818px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.863636363636px;" aria-label="Konami (560 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.863636363636px;" aria-label="Microsoft (937 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,739 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.272727272727px;" aria-label="nintendo switch (786 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.727272727273px;" aria-label="PC (1,376 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.772727272727px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 14.5px;" aria-label="PlayStation 4 (491 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.454545454545px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.590909090909px;" aria-label="PS4 (1,230 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.681818181818px;" aria-label="Sega (669 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 21.090909090909px;" aria-label="Sony (952 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.636363636364px;" aria-label="square enix (910 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 14.045454545455px;" aria-label="Steam (472 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.681818181818px;" aria-label="Trailer (680 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 24.045454545455px;" aria-label="Ubisoft (1,283 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.545454545455px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24.045454545455px;" aria-label="Xbox One (1,281 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 13.125px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.6px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.375px;" aria-label="Competition (218 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 14.1px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.1px;" aria-label="Features (2,327 items)">Features</a>
<a href="https://www.godisageek.com/category/features/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 12px;" aria-label="Guides (195 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12.375px;" aria-label="Interview (216 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.95px;" aria-label="iOS (354 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,412 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.675px;" aria-label="Opinion (598 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 14.325px;" aria-label="Paid Placement Advertorials (397 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.65px;" aria-label="PC (2,029 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.575px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.675px;" aria-label="PlayStation 4 (1,497 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.275px;" aria-label="Podcasts (719 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.725px;" aria-label="Previews (835 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.725px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 21.975px;" aria-label="Reviews (4,133 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.125px;" aria-label="Switch (691 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.9px;" aria-label="Tech (256 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.7px;" aria-label="Trailers (1,130 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13.35px;" aria-label="Uncategorised (295 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.4px;" aria-label="Video Features (1,016 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 16.2px;" aria-label="Xbox 360 (713 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 17.85px;" aria-label="Xbox One (1,179 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.339768339768px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.471042471042px;" aria-label="Android (77 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.779922779923px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.822393822394px;" aria-label="Google Stadia (17 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.69111969112px;" aria-label="HTC Vive (25 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.571428571429px;" aria-label="iOS (118 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.444015444015px;" aria-label="Mac (34 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (3 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.69111969112px;" aria-label="Oculus Rift (25 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,558 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 21.150579150579px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.826254826255px;" aria-label="PlayStation 4 (1,444 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 19.644787644788px;" aria-label="PlayStation 5 (83 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.660231660232px;" aria-label="PlayStation VR (55 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 21.266409266409px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.146718146718px;" aria-label="Switch (735 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12.579150579151px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.949806949807px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 20.223938223938px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.189189189189px;" aria-label="Xbox One (1,126 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 18.660231660232px;" aria-label="Xbox Series S (55 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 19.065637065637px;" aria-label="Xbox Series X (65 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
<!-- WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory. -->