<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Nobody Saves the World | How to access the Frozen Hearth DLC | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="If you&#039;re looking to enjoy the Frozen Hearth DLC in Nobody Saves the World, then we show you how you can access it in the main game." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Nobody Saves the World | How to access the Frozen Hearth DLC | GodisaGeek.com" />
	<meta property="og:description" content="If you&#039;re looking to enjoy the Frozen Hearth DLC in Nobody Saves the World, then we show you how you can access it in the main game." />
	<meta property="og:url" content="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-09-14T16:00:16+00:00" />
	<meta property="article:modified_time" content="2022-09-14T12:15:11+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6.jpg","width":1280,"height":720,"caption":"Nobody Saves the World Frozen Hearth"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#webpage","url":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/","name":"Nobody Saves the World | How to access the Frozen Hearth DLC | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#primaryimage"},"datePublished":"2022-09-14T16:00:16+00:00","dateModified":"2022-09-14T12:15:11+00:00","description":"If you're looking to enjoy the Frozen Hearth DLC in Nobody Saves the World, then we show you how you can access it in the main game.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81"},"headline":"Nobody Saves the World | How to access the Frozen Hearth DLC","datePublished":"2022-09-14T16:00:16+00:00","dateModified":"2022-09-14T12:15:11+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/#primaryimage"},"keywords":"Drinkbox,Guide,Nobody Saves the World,Nobody Saves the World Frozen Hearth DLC","articleSection":"Guides","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81","name":"Chris Hyde","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=96&d=mm&r=g","caption":"Chris Hyde"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"09","day":"14","hour":"17","minute":"00","second":"16","post_id":"267370","postname":"nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc","category":"guides"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/' />
<meta name='shareaholic:keywords' content='tag:drinkbox, tag:guide, tag:nobody saves the world, tag:nobody saves the world frozen hearth dlc, tag:nobody saves the world frozen hearth, cat:guides, type:post' />
<meta name='shareaholic:article_published_time' content='2022-09-14T17:00:16+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-09-14T13:15:11+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris Hyde' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=267370' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F09%2Fnobody-saves-the-world-how-to-access-the-frozen-hearth-dlc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F09%2Fnobody-saves-the-world-how-to-access-the-frozen-hearth-dlc%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '5d5219b59e'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/"},"headline":"Nobody Saves the World | How to access the Frozen Hearth DLC","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6.jpg","width":1280,"height":720},"datePublished":"2022-09-14T17:00:16+0000","dateModified":"2022-09-14T13:15:11+0000","author":{"@type":"Person","name":"Chris Hyde","url":"https://www.godisageek.com/author/alisonsmyth05/chris-hyde"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}}}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/09\/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc\/","name":"Nobody Saves the World | How to access the Frozen Hearth DLC"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-267370 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">You Suck at Parking review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="You Suck at Parking Review" title="You Suck at Parking review" srcset="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">Nobody Saves the World Frozen Hearth DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World Frozen Hearth DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/river-city-girls-zero/">River City Girls Zero review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="River City Girls Zero title image" title="River City Girls Zero review" srcset="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/metal-hellsinger-review/">Metal: Hellsinger review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Metal Hellsinger review" title="Metal: Hellsinger review" srcset="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">NEAT King Bee II review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEAT King Bee II review" title="NEAT King Bee II review" srcset="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sunday-gold-review/">Sunday Gold review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sunday Gold" title="Sunday Gold review" srcset="https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/podcast-498-splatoon-3-circus-electrique-disney-dreamlight-valley/">Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley" title="Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/podcast-497-ooblets-the-last-of-us-part-i-destroy-all-humans-2-reprobed/">Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 &#8211; Reprobed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 - Reprobed" title="Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 &#8211; Reprobed" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/flintlock-the-siege-of-dawn-features-an-exciting-blend-of-fantasy-guns-and-chaos-hands-off-preview/">Flintlock: The Siege of Dawn features an exciting blend of fantasy, guns, and chaos | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Flintlock-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Flintlock: The Siege of Dawn Preview" title="Flintlock: The Siege of Dawn features an exciting blend of fantasy, guns, and chaos | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Flintlock-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/orx-early-access-impressions/">Orx early access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ORX title image" title="Orx early access review" srcset="https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/tchia-is-a-gorgeous-and-inspiring-adventure-hands-off-preview/">Tchia is a gorgeous and inspiring adventure | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tchia-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tchia preview" title="Tchia is a gorgeous and inspiring adventure | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Tchia-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/">Nobody Saves the World Killer Bee guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Killer Bee" title="Nobody Saves the World Killer Bee guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/">Nobody Saves the World | Frozen Hearth Complete Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nobody Saves the World | Frozen Hearth Complete Guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/">Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Killer Bee" title="Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/">Nobody Saves the World | How to access the Frozen Hearth DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World | How to access the Frozen Hearth DLC" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/">Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Mechanic" title="Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/">Nobody Saves the World Mechanic guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Mechanic" title="Nobody Saves the World Mechanic guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/like-a-dragon-8-officially-announced-and-more-during-the-rgg-summit-2022/">Like A Dragon 8 officially announced and more during the RGG Summit 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Like A Dragon 8 announcement news" title="Like A Dragon 8 officially announced and more during the RGG Summit 2022" srcset="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/xbox-discord-voice-now-live/">Xbox &#8216;Discord Voice&#8217; now live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Microsoft Discord Voice News" title="Xbox &#8216;Discord Voice&#8217; now live" srcset="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/god-of-war-ragnarok-dualsense/">The God of War Ragnarok DuelSense looks gorgeous, and so does the game.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." title="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." srcset="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/rise-of-the-ronin-is-a-team-ninja-game-coming-in-2024/">Rise of the Ronin is a Team Ninja game coming in 2024<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rise of the Ronin is a Team Ninja game coming in 2024" title="Rise of the Ronin is a Team Ninja game coming in 2024" srcset="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/pacific-drive-will-drive-you-through-hell-next-year/">Pacific Drive will drive you through hell next year.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Pacific Drive will drive you through hell next year." title="Pacific Drive will drive you through hell next year." srcset="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/goldeneye-007-coming-to-nintendo-switch-online-and-xbox-game-pass-soon/">GoldenEye 007 coming to Nintendo Switch Online and Xbox Game Pass soon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GoldenEye 007 Announcement News" title="GoldenEye 007 coming to Nintendo Switch Online and Xbox Game Pass soon" srcset="https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">You Suck at Parking review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="You Suck at Parking Review" title="You Suck at Parking review" srcset="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">Nobody Saves the World Frozen Hearth DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World Frozen Hearth DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/river-city-girls-zero/">River City Girls Zero review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="River City Girls Zero title image" title="River City Girls Zero review" srcset="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/metal-hellsinger-review/">Metal: Hellsinger review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Metal Hellsinger review" title="Metal: Hellsinger review" srcset="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">NEAT King Bee II review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEAT King Bee II review" title="NEAT King Bee II review" srcset="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sunday-gold-review/">Sunday Gold review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sunday Gold" title="Sunday Gold review" srcset="https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/sunday-gold-bande-annonce-date-de-sortie-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/podcast-498-splatoon-3-circus-electrique-disney-dreamlight-valley/">Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley" title="Podcast 498: Splatoon 3, Circus Electrique, Disney Dreamlight Valley" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-498-Splatoon-3-Circus-Electrique-Disney-Dreamlight-Valley-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/podcast-497-ooblets-the-last-of-us-part-i-destroy-all-humans-2-reprobed/">Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 &#8211; Reprobed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 - Reprobed" title="Podcast 497: Ooblets, The Last of Us Part I, Destroy All Humans! 2 &#8211; Reprobed" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-497-Ooblets-The-Last-of-Us-Part-I-Destroy-All-Humans-2-Reprobed-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/flintlock-the-siege-of-dawn-features-an-exciting-blend-of-fantasy-guns-and-chaos-hands-off-preview/">Flintlock: The Siege of Dawn features an exciting blend of fantasy, guns, and chaos | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Flintlock-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Flintlock: The Siege of Dawn Preview" title="Flintlock: The Siege of Dawn features an exciting blend of fantasy, guns, and chaos | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Flintlock-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Flintlock-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/orx-early-access-impressions/">Orx early access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ORX title image" title="Orx early access review" srcset="https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/orx-dune-reavers-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/tchia-is-a-gorgeous-and-inspiring-adventure-hands-off-preview/">Tchia is a gorgeous and inspiring adventure | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tchia-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tchia preview" title="Tchia is a gorgeous and inspiring adventure | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Tchia-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tchia-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/">Nobody Saves the World Killer Bee guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Killer Bee" title="Nobody Saves the World Killer Bee guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/">Nobody Saves the World | Frozen Hearth Complete Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nobody Saves the World | Frozen Hearth Complete Guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/">Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Killer Bee" title="Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/">Nobody Saves the World | How to access the Frozen Hearth DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World | How to access the Frozen Hearth DLC" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/">Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Mechanic" title="Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/">Nobody Saves the World Mechanic guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Mechanic" title="Nobody Saves the World Mechanic guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/like-a-dragon-8-officially-announced-and-more-during-the-rgg-summit-2022/">Like A Dragon 8 officially announced and more during the RGG Summit 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Like A Dragon 8 announcement news" title="Like A Dragon 8 officially announced and more during the RGG Summit 2022" srcset="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/xbox-discord-voice-now-live/">Xbox &#8216;Discord Voice&#8217; now live<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Microsoft Discord Voice News" title="Xbox &#8216;Discord Voice&#8217; now live" srcset="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/god-of-war-ragnarok-dualsense/">The God of War Ragnarok DuelSense looks gorgeous, and so does the game.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." title="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." srcset="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/rise-of-the-ronin-is-a-team-ninja-game-coming-in-2024/">Rise of the Ronin is a Team Ninja game coming in 2024<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rise of the Ronin is a Team Ninja game coming in 2024" title="Rise of the Ronin is a Team Ninja game coming in 2024" srcset="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/pacific-drive-will-drive-you-through-hell-next-year/">Pacific Drive will drive you through hell next year.<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Pacific Drive will drive you through hell next year." title="Pacific Drive will drive you through hell next year." srcset="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/goldeneye-007-coming-to-nintendo-switch-online-and-xbox-game-pass-soon/">GoldenEye 007 coming to Nintendo Switch Online and Xbox Game Pass soon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GoldenEye 007 Announcement News" title="GoldenEye 007 coming to Nintendo Switch Online and Xbox Game Pass soon" srcset="https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GoldenEye-007-Announcement-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2019/01/dark-souls-trilogy-collectors-edition-unveiled/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-267370" class="post-267370 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-drinkbox tag-guide tag-nobody-saves-the-world tag-nobody-saves-the-world-frozen-hearth-dlc" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Nobody Saves the World | How to access the Frozen Hearth DLC                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-hyde/"><span itemprop="author">Chris Hyde </span></a></span><span class="date">on <meta itemprop="datePublished" content="September 14, 2022">September 14, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World | How to access the Frozen Hearth DLC" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Nobody Saves the World | How to access the Frozen Hearth DLC' data-link='https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/' data-summary='Into the Frozen Hearth' data-app-id-name='post_above_content'></div>
<p>With nine months since the original launch of <a href="https://www.godisageek.com/reviews/nobody-saves-the-world-review/" target="_blank" rel="noopener noreferrer">Nobody Saves the World</a>, Drinbox Studios have now released its first DLC, called <a href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/" target="_blank" rel="noopener noreferrer">Frozen Hearth</a>. This DLC sees a whole new area to explore, and a new set of challenges to overcome in the brand-new Colosseum. Through playing Frozen Hearth, you’ll also be able to unlock two new forms, the Mechanic and the Killer Bee to add to your collection.</p>
<p>So it’s well worth exploring this new area to see what it has to offer. However, you may be wondering how you can access the Frozen Hearth DLC in <a href="https://www.youtube.com/watch?v=SdUcIppe9Ko" target="_blank" rel="noopener noreferrer">Nobody Saves the World</a>. Have no fear, we’ll explain everything you need to know so you can get on with enjoying this new content.</p>
<h3>Nobody Saves the World Frozen Hearth | Do I need to finish the main game first?</h3>
<p>You don’t actually need to finish the main game to access the DLC. Unlike most DLCs from other titles, this content is actually available relatively early on in the main game. You’ll need to beat the Castle Legendary Dungeon first, in order to open up the map enough to find the new area.</p>
<p><img class="size-large wp-image-267373" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-1024x576.jpg" alt="Nobody Saves the World Frozen Hearth" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-4.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h3>Where can I find the new area?</h3>
<p>The new area can actually be accessed from two locations. Don’t worry they both end up leading to the same place, it just means, early on in the game, when you choose to go East or West, either is OK to access the new area.</p>
<p>What you are looking for is a Portal. You’ll know when it is available as it is just after where you meet Marty Joe the hammer. Then depending on which direction you chose after the Castle Legendary Dungeon</p>
<h4>If you went West</h4>
<p>The portal is to the West of the dragon (after going through the cave)</p>
<p><img class="size-large wp-image-267372" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-5.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h4></h4>
<h4>If you went East</h4>
<p>The portal is to the East of the Castle just before the entrance to the Spooky area.</p>
<p><img class="size-large wp-image-267374" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-3.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<h3>Now what?</h3>
<p>Now, all that you need to do is enter the portal, and follow the main path through the cave. You’ll come to the Marrow Path. Follow this linear area, until you reach the Marrow Village where you will meet two flamboyant characters who will introduce you to the Tempering tournament, which forms the basis of the Frozen Hearth DLC in Nobody Saves the World.</p>
<p>Follow their dialogue and then follow them into the Colosseum to begin your adventure.</p>
<p>&nbsp;</p>
<h4><a href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/" target="_blank" rel="noopener noreferrer">CLICK HERE TO RETURN TO THE NOBODY SAVES THE WORLD FROZEN HEARTH MAIN GUIDE PAGE</a></h4>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Nobody Saves the World | How to access the Frozen Hearth DLC' data-link='https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/' data-summary='Into the Frozen Hearth' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Nobody Saves the World | How to access the Frozen Hearth DLC' data-link='https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/' data-summary='Into the Frozen Hearth' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/guides/" title="View all posts in Guides">Guides</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/drinkbox/" title="Drinkbox Tag" class="drinkbox">Drinkbox</a><a href="https://www.godisageek.com/tag/guide/" title="Guide Tag" class="guide">Guide</a><a href="https://www.godisageek.com/tag/nobody-saves-the-world/" title="Nobody Saves the World Tag" class="nobody-saves-the-world">Nobody Saves the World</a><a href="https://www.godisageek.com/tag/nobody-saves-the-world-frozen-hearth-dlc/" title="Nobody Saves the World Frozen Hearth DLC Tag" class="nobody-saves-the-world-frozen-hearth-dlc">Nobody Saves the World Frozen Hearth DLC</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><img alt='' src='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><h3>Chris Hyde</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:chrisdhyde1983@gmail.com"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="12810" data-method="tags" class="info active" title="More articles tagged: Drinkbox">Drinkbox<span class="bottom-arrow"></span></a><a data-sorter="454" data-method="tags" class="info" title="More articles tagged: Guide">Guide<span class="bottom-arrow"></span></a><a data-sorter="29327" data-method="tags" class="info" title="More articles tagged: Nobody Saves the World">Nobody Saves the World<span class="bottom-arrow"></span></a><a data-sorter="30404" data-method="tags" class="info" title="More articles tagged: Nobody Saves the World Frozen Hearth DLC">Nobody Saves the World Frozen Hearth DLC<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Killer Bee" title="Nobody Saves the World Killer Bee guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/">Nobody Saves the World Killer Bee guide</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Nobody Saves the World | Frozen Hearth Complete Guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/">Nobody Saves the World | Frozen Hearth Complete Guide</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Killer Bee" title="Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/">Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth Mechanic" title="Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/">Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Mechanic" title="Nobody Saves the World Mechanic guide" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/">Nobody Saves the World Mechanic guide</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World Frozen Hearth DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">Nobody Saves the World Frozen Hearth DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/like-a-dragon-8-officially-announced-and-more-during-the-rgg-summit-2022/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Like A Dragon 8 announcement news" title="Like A Dragon 8 officially announced and more during the RGG Summit 2022" srcset="https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Like-A-Dragon-8-announcement-news-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/like-a-dragon-8-officially-announced-and-more-during-the-rgg-summit-2022/">Like A Dragon 8 officially announced and more during the RGG Summit 2022</a><div class="article-meta clearfix"><a class="like-button do-like 267415 info-bottom" data-postid="267415" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/09/like-a-dragon-8-officially-announced-and-more-during-the-rgg-summit-2022/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/xbox-discord-voice-now-live/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Microsoft Discord Voice News" title="Xbox &#8216;Discord Voice&#8217; now live" srcset="https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Microsoft-Discord-Voice-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/xbox-discord-voice-now-live/">Xbox &#8216;Discord Voice&#8217; now live</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/xbox-discord-voice-now-live/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/god-of-war-ragnarok-dualsense/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." title="The God of War Ragnarok DuelSense looks gorgeous, and so does the game." srcset="https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-Of-War-COntroller-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/god-of-war-ragnarok-dualsense/">The God of War Ragnarok DuelSense looks gorgeous, and so does the game.</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/god-of-war-ragnarok-dualsense/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/rise-of-the-ronin-is-a-team-ninja-game-coming-in-2024/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rise of the Ronin is a Team Ninja game coming in 2024" title="Rise of the Ronin is a Team Ninja game coming in 2024" srcset="https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/52356214599_4852f8241f_h-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/rise-of-the-ronin-is-a-team-ninja-game-coming-in-2024/">Rise of the Ronin is a Team Ninja game coming in 2024</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/rise-of-the-ronin-is-a-team-ninja-game-coming-in-2024/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/pacific-drive-will-drive-you-through-hell-next-year/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Pacific Drive will drive you through hell next year." title="Pacific Drive will drive you through hell next year." srcset="https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Pacific-Drive-is-welcome-to-the-Olympics-Exclusion-Zone-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/pacific-drive-will-drive-you-through-hell-next-year/">Pacific Drive will drive you through hell next year.</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/pacific-drive-will-drive-you-through-hell-next-year/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/you-suck-at-parking-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="You Suck at Parking Review" title="You Suck at Parking review" srcset="https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/You-Suck-at-Parking-Review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">You Suck at Parking review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 267265 info-bottom" data-postid="267265" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Nobody Saves the World Frozen Hearth" title="Nobody Saves the World Frozen Hearth DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">Nobody Saves the World Frozen Hearth DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/river-city-girls-zero/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="River City Girls Zero title image" title="River City Girls Zero review" srcset="https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/H2x1_NSwitchDS_RiverCityGirlsZero_image1600w-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/river-city-girls-zero/">River City Girls Zero review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/river-city-girls-zero/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/metal-hellsinger-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Metal Hellsinger review" title="Metal: Hellsinger review" srcset="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">Metal: Hellsinger review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NEAT King Bee II review" title="NEAT King Bee II review" srcset="https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/NEAT-King-Bee-II-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">NEAT King Bee II review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?</a><div class="article-meta clearfix"><a class="like-button do-like 266996 info-bottom" data-postid="266996" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-last-of-us-part-1-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/The-Last-of-Us-Part-I-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="The Last of Us Part I review" title="The Last of Us Part 1 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Last-of-Us-Part-I-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Last-of-Us-Part-I-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Last-of-Us-Part-I-review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-last-of-us-part-1-review/">The Last of Us Part 1 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 266691 info-bottom" data-postid="266691" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-last-of-us-part-1-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/immortality-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortality-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortality Review" title="Immortality Review" srcset="https://www.godisageek.com/wp-content/uploads/Immortality-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortality-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortality-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortality-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/immortality-review/">Immortality Review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/immortality-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/rollerdrome-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome Review" title="Rollerdrome review" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/rollerdrome-review/">Rollerdrome review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/rollerdrome-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/jack-move-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Jack-Move-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Jack Move review" title="Jack Move review" srcset="https://www.godisageek.com/wp-content/uploads/Jack-Move-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Jack-Move-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Jack-Move-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Jack-Move-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/jack-move-review/">Jack Move review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/jack-move-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/metal-hellsinger-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Metal Hellsinger review" title="Metal: Hellsinger review" srcset="https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Metal-Hellsinger-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">Metal: Hellsinger review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Killer-Bee-c-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-killer-bee-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World Killer Bee guide</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-guide-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-frozen-hearth-complete-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World | Frozen Hearth Complete Guide</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Killer-Bee-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-killer-bee-in-frozen-hearth/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World | How to unlock the Killer Bee in Frozen Hearth</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-6-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-access-the-frozen-hearth-dlc/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World | How to access the Frozen Hearth DLC</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Frozen-Hearth-Mechanic-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-how-to-unlock-the-mechanic-in-frozen-hearth/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World | How to unlock the Mechanic in Frozen Hearth</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Nobody-Saves-the-World-Mechanic-b-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/09/nobody-saves-the-world-mechanic-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Nobody Saves the World Mechanic guide</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">You Suck at Parking review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/you-suck-at-parking-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">Nobody Saves the World Frozen Hearth DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/nobody-saves-the-world-frozen-hearth-dlc-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/river-city-girls-zero/">River City Girls Zero review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/river-city-girls-zero/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">Metal: Hellsinger review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/metal-hellsinger-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">NEAT King Bee II review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/neat-king-bee-ii-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.230769230769px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.461538461538px;" aria-label="Activision (782 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.692307692308px;" aria-label="Bandai Namco (434 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.769230769231px;" aria-label="Capcom (725 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.615384615385px;" aria-label="DLC (481 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,175 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (409 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (573 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.307692307692px;" aria-label="Microsoft (942 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,805 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.384615384615px;" aria-label="nintendo switch (844 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,401 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.230769230769px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.846153846154px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 21.923076923077px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.307692307692px;" aria-label="PS4 (1,245 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.538461538462px;" aria-label="Sega (714 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.538461538462px;" aria-label="Sony (963 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (946 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.615384615385px;" aria-label="Steam (477 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.307692307692px;" aria-label="Trailer (684 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,315 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.076923076923px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.538461538462px;" aria-label="Xbox One (1,289 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.466321243523px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-3" style="font-size: 13.476683937824px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-4" style="font-size: 20.160621761658px;" aria-label="Features (2,711 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-5" style="font-size: 14.40932642487px;" aria-label="Guides (488 items)">Guides</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-6" style="font-size: 13.39896373057px;" aria-label="iOS (359 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-7" style="font-size: 27px;" aria-label="News (20,234 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-8" style="font-size: 15.264248704663px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-9" style="font-size: 15.186528497409px;" aria-label="Paid Placement Advertorials (620 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-10" style="font-size: 19.772020725389px;" aria-label="PC (2,385 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-11" style="font-size: 16.041450777202px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-12" style="font-size: 18.683937823834px;" aria-label="PlayStation 4 (1,739 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/reviews/playstation-5/" class="tag-cloud-link tag-link-27592 tag-link-position-13" style="font-size: 12.388601036269px;" aria-label="PlayStation 5 (270 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 15.963730569948px;" aria-label="Podcasts (774 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.663212435233px;" aria-label="Previews (959 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 13.088082901554px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 21.948186528497px;" aria-label="Reviews (4,579 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.507772020725px;" aria-label="Switch (912 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 12.544041450777px;" aria-label="Tech (279 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.829015544041px;" aria-label="Trailers (1,339 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 12.777202072539px;" aria-label="Uncategorised (300 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 16.896373056995px;" aria-label="Video Features (1,033 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-23" style="font-size: 15.652849740933px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-24" style="font-size: 17.984455958549px;" aria-label="Xbox One (1,405 items)">Xbox One</a>
<a href="https://www.godisageek.com/category/reviews/xbox-series-x/" class="tag-cloud-link tag-link-27604 tag-link-position-25" style="font-size: 12.077720207254px;" aria-label="Xbox Series S|X (242 items)">Xbox Series S|X</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.790697674419px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.093023255814px;" aria-label="Android (83 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.616279069767px;" aria-label="Apple Arcade (13 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.244186046512px;" aria-label="Google Stadia (26 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.360465116279px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.081395348837px;" aria-label="iOS (123 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.209302325581px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.53488372093px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,914 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.604651162791px;" aria-label="PlayStation 3 (151 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.709302325581px;" aria-label="PlayStation 4 (1,689 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 22.232558139535px;" aria-label="PlayStation 5 (286 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.337209302326px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.720930232558px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.255813953488px;" aria-label="Switch (954 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.395348837209px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.732558139535px;" aria-label="Xbox 360 (107 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.127906976744px;" aria-label="Xbox One (1,345 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.418604651163px;" aria-label="Xbox Series S (207 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 21.883720930233px;" aria-label="Xbox Series S|X (253 items)">Xbox Series S|X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
