<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>The Suicide of Rachel Foster review - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/giag-favicon.png" />
    
    <link href='https://fonts.googleapis.com/css?family=PT+Sans&subset=' rel='stylesheet' type='text/css'> 
<link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-85x85.png" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    
<!-- NetworkN CMP Tool -->
<script>!function(t,n){if(function(e){"string"==typeof e&&(e=[e]);for(var a=0;a<e.length;a++)n.cookie=e[a]+
"=;max-age=-1;domain=."+n.domain+";path=/"}(["euconsent","eupubconsent","googlepersonalization"]),
!t.__cmp){t.__cmp=function(){(t.attachEvent||t.addEventListener)("message",function(e){t.__cmp.receiveMessage(e)}
,!1),function e(){if(!t.frames.__cmpLocator)if(n.body){var a=n.createElement("iframe");a.style.display="none",
a.name="__cmpLocator",n.body.appendChild(a)}else setTimeout(e,5)}();var o=[],e=function(e,a,n){"ping"===e?n&&n({
gdprAppliesGlobally:!!(t.__cmp&&t.__cmp.config&&t.__cmp.config.storeConsentGlobally),cmpLoaded:!1}):
o.push({command:e,parameter:a,callback:n})};return e.commandQueue=o,e.receiveMessage=function(e){
var a=e&&e.data&&e.data.__cmpCall;a&&o.push({callId:a.callId,command:a.command,parameter:a.parameter,
event:e})},e.config=t.cmpConfig||{},e}()}}(window,document);
</script>
<script src="//cmp.network-n.com/js/cmp.complete.bundle.js" async></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	<!-- JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@GodisaGeek">
<meta name="twitter:site" content="@GodisaGeek">
<meta name="twitter:title" content="The Suicide of Rachel Foster review">
<meta name="twitter:description" content="I’m a firm believer that any subject matter can be covered in the medium of video games. As long as the appropriate steps are taken to respect the subject matter and those who may be affected by it.">
<meta name="twitter:image" content="http://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot.jpg">
<!-- /JM Twitter Cards by Julien Maury 10.0.1 -->
<meta name='OBKey' content='58bwlG/ydjwzfnl1e4+OTg==' />

<!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="If any of the issues in The Suicide of Rachel Foster affect you, you are not alone. Call Samaritans from any phone: 116 123."/>
<link rel="canonical" href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Suicide of Rachel Foster review" />
<meta property="og:description" content="If any of the issues in this game affect you, you are not alone. Call Samaritans from any phone: 116 123" />
<meta property="og:url" content="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/" />
<meta property="og:site_name" content="GodisaGeek.com" />
<meta property="article:tag" content="Daedalic Entertainment" />
<meta property="article:tag" content="One O One Games" />
<meta property="article:tag" content="The Suicide of Rachel Foster" />
<meta property="article:section" content="Reviews" />
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" />
<meta property="og:image:secure_url" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1082" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","potentialAction":{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/#primaryimage","url":"https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png","width":1920,"height":1082,"caption":"The Suicide of Rachel Foster review"},{"@type":"WebPage","@id":"https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/#webpage","url":"https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/","inLanguage":"en-US","name":"The Suicide of Rachel Foster review - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/#primaryimage"},"datePublished":"2020-02-17T13:30:18+00:00","dateModified":"2020-02-17T13:53:18+00:00","description":"If any of the issues in The Suicide of Rachel Foster affect you, you are not alone. Call Samaritans from any phone: 116 123."}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.godisageek.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.86.2' type='text/css' media='all' />
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/10/jwplayer.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.godisageek.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"232486","token":"2fca78e4ac","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<!-- OG: 2.7.5 -->
<link rel="image_src" href="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" /><meta itemprop="image" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" /><meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" /><meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review.png" /><meta property="og:image:width" content="1920" /><meta property="og:image:height" content="1082" /><meta property="og:image:alt" content="The Suicide of Rachel Foster review" /><meta property="og:description" content="If any of the issues in this game affect you, you are not alone. Call Samaritans from any phone: 116 123" /><meta property="og:type" content="article" /><meta property="og:locale" content="en_us" /><meta property="og:site_name" content="GodisaGeek.com" /><meta property="og:title" content="The Suicide of Rachel Foster review" /><meta property="og:url" content="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/" /><meta property="og:updated_time" content="2020-02-17T13:53:18+00:00" /><meta property="article:tag" content="Daedalic Entertainment" /><meta property="article:tag" content="One O One Games" /><meta property="article:tag" content="The Suicide of Rachel Foster" /><meta property="article:published_time" content="2020-02-17T13:30:18+00:00" /><meta property="article:modified_time" content="2020-02-17T13:53:18+00:00" /><meta property="article:author" content="https://www.godisageek.com/author/chris-hyde/" /><meta property="article:section" content="PC" /><meta property="article:section" content="Reviews" /><meta property="twitter:card" content="summary_large_image" /><meta property="twitter:title" content="The Suicide of Rachel Foster review" /><meta property="twitter:description" content="If any of the issues in this game affect you, you are not alone. Call Samaritans from any phone: 116 123" /><meta property="twitter:image:width" content="1920" /><meta property="twitter:image:height" content="1082" /><meta property="twitter:image:alt" content="The Suicide of Rachel Foster review" /><meta property="twitter:url" content="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/" /><meta property="profile:first_name" content="Chris" /><meta property="profile:last_name" content="Hyde" /><meta property="profile:username" content="Chris Hyde" /><!-- /OG -->
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://www.godisageek.com/?p=232486' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fthe-suicide-of-rachel-foster-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fthe-suicide-of-rachel-foster-review%2F&#038;format=xml" />
<script type="text/javascript">jwplayer.defaults = { "ph": 2 };</script>
            <script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

            <script type="text/javascript">
	window._wp_rp_static_base_url = 'https://wprp.zemanta.com/static/';
	window._wp_rp_wp_ajax_url = "https://www.godisageek.com/wp-admin/admin-ajax.php";
	window._wp_rp_plugin_version = '3.6.4';
	window._wp_rp_post_id = '232486';
	window._wp_rp_num_rel_posts = '5';
	window._wp_rp_thumbnails = true;
	window._wp_rp_post_title = 'The+Suicide+of+Rachel+Foster+review';
	window._wp_rp_post_tags = [];
	window._wp_rp_promoted_content = true;
</script>
<link rel="stylesheet" href="https://www.godisageek.com/wp-content/plugins/wordpress-23-related-posts-plugin/static/themes/vertical-m.css?version=3.6.4" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="it_reviews-template-default single single-it_reviews postid-232486 it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/outward-dlc-the-soroboreans-coming-this-summer/">Outward DLC The Soroboreans Coming this Summer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Outward DLC The Soroboreans Coming this Summer" srcset="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/go-behind-the-scenes-of-fall-guys-in-new-documentary-series/">Go Behind the Scenes of Fall Guys in New Documentary Series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Go Behind the Scenes of Fall Guys in New Documentary Series" srcset="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/mousecraft-is-coming-to-nintendo-switch-on-february-27/">MouseCraft is coming to Nintendo Switch on February 27<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MouseCraft Switch" title="MouseCraft is coming to Nintendo Switch on February 27" srcset="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/ibb-obb-is-making-its-way-to-the-switch/">ibb &#038; obb is making its way to the Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="ibb &#038; obb is making its way to the Switch" srcset="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ibb-obb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ibb-obb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ibb-obb-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ibb-obb-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/seth-joins-the-new-champion-edition/">Seth joins the new Champion Edition of Street Fighter V<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Seth joins the new Champion Edition of Street Fighter V" srcset="https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/this-is-your-last-chance-to-join-in-with-specialeffect-gameblast20/">This is your last chance to join in with SpecialEffect&#8217;s GameBlast20<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="SpecialEffect GameBlast20" title="This is your last chance to join in with SpecialEffect&#8217;s GameBlast20" srcset="https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">Bayonetta &#038; Vanquish 10th Anniversary Bundle review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Bayonetta &#038; Vanquish 10th Anniversary Bundle review" srcset="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/">The Suicide of Rachel Foster review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The Suicide of Rachel Foster review" title="The Suicide of Rachel Foster review" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/">Darksiders Genesis Switch review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis Switch review" title="Darksiders Genesis Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/">Darksiders Genesis console review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis (PS4/Xbox One) Console review" title="Darksiders Genesis console review" srcset="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/">Snack World: The Dungeon Crawl &#8211; Gold review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Snack World: The Dungeon Crawl - Gold review" title="Snack World: The Dungeon Crawl &#8211; Gold review" srcset="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/daemon-x-machina-pc-review/">Daemon X Machina PC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/DexM-PC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Daemon X Machina PC review" title="Daemon X Machina PC review" srcset="https://www.godisageek.com/wp-content/uploads/DexM-PC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/top-3-android-gaming-emulators-for-pc-edition-2020/">Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Top 3 Android Gaming Emulators for PC: Edition 2020" title="Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020" srcset="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/LDPlayer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/LDPlayer-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/LDPlayer-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/podcast-382-dreams-kunai-patapon-2-remastered/">Podcast #382: A Singular Knacker<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #382: Dreams, Kunai, more" title="Podcast #382: A Singular Knacker" srcset="https://www.godisageek.com/wp-content/uploads/Dreams-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/is-hellpoint-more-than-just-dark-souls-in-space/">Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hellpoint_Preview" title="Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?" srcset="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/playing-dreams-is-like-surfing-imaginations/">Playing Dreams is like surfing imaginations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dreams preview" title="Playing Dreams is like surfing imaginations" srcset="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/podcast-381-kentucky-route-zero-journey-to-the-savage-planet/">Podcast #381: The Bill<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 381: Kentucky Route Zero, Journey to the Savage Planet, and more." title="Podcast #381: The Bill" srcset="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/games-of-february-2020-dreams-street-fighter-v-champion-edition-rune-factory-4-special-bayonetta-vanquish-10th-anniversary-bundle-and-more/">Games of February 2020 &#8211; Dreams, Street Fighter V: Champion Edition, Rune Factory 4 Special, Bayonetta &#038; Vanquish 10th Anniversary Bundle, and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Games of February 2020 &#8211; Dreams, Street Fighter V: Champion Edition, Rune Factory 4 Special, Bayonetta &#038; Vanquish 10th Anniversary Bundle, and more" srcset="https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/top-3-android-gaming-emulators-for-pc-edition-2020/">Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Top 3 Android Gaming Emulators for PC: Edition 2020" title="Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020" srcset="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/LDPlayer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/LDPlayer-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/LDPlayer-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-safijiiva-siege-guide/">Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-horizon-zero-dawn-event-guide-part-2-the-survivor/">Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/11/10-beginners-tips-for-reconnecting-america-in-death-stranding/">10 beginner&#8217;s tips for reconnecting America in Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="10 beginner&#039;s tips for Death Stranding" title="10 beginner&#8217;s tips for reconnecting America in Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/is-hellpoint-more-than-just-dark-souls-in-space/">Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hellpoint_Preview" title="Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?" srcset="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/playing-dreams-is-like-surfing-imaginations/">Playing Dreams is like surfing imaginations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dreams preview" title="Playing Dreams is like surfing imaginations" srcset="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/iron-danger-preview-whats-in-a-name/">Iron Danger preview | What&#8217;s in a name?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/iron-danger-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Iron Danger preview" title="Iron Danger preview | What&#8217;s in a name?" srcset="https://www.godisageek.com/wp-content/uploads/iron-danger-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/iron-danger-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/iron-danger-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/iron-danger-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/iron-danger-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/filament-is-a-clever-but-challenging-title-that-puzzle-fans-will-love/">Filament is a clever but challenging title that puzzle fans will love<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Filament-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Filament preview" title="Filament is a clever but challenging title that puzzle fans will love" srcset="https://www.godisageek.com/wp-content/uploads/Filament-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Filament-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Filament-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Filament-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Filament-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">Monster Energy Supercross 3 Shows Signs of Great Improvement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 3 Shows Signs of Great Improvement" title="Monster Energy Supercross 3 Shows Signs of Great Improvement" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/outward-dlc-the-soroboreans-coming-this-summer/">Outward DLC The Soroboreans Coming this Summer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Outward DLC The Soroboreans Coming this Summer" srcset="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/go-behind-the-scenes-of-fall-guys-in-new-documentary-series/">Go Behind the Scenes of Fall Guys in New Documentary Series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Go Behind the Scenes of Fall Guys in New Documentary Series" srcset="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/mousecraft-is-coming-to-nintendo-switch-on-february-27/">MouseCraft is coming to Nintendo Switch on February 27<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MouseCraft Switch" title="MouseCraft is coming to Nintendo Switch on February 27" srcset="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/ibb-obb-is-making-its-way-to-the-switch/">ibb &#038; obb is making its way to the Switch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="ibb &#038; obb is making its way to the Switch" srcset="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ibb-obb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ibb-obb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ibb-obb-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ibb-obb-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/seth-joins-the-new-champion-edition/">Seth joins the new Champion Edition of Street Fighter V<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Seth joins the new Champion Edition of Street Fighter V" srcset="https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/EL30zuwVUAAKp4e-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/this-is-your-last-chance-to-join-in-with-specialeffect-gameblast20/">This is your last chance to join in with SpecialEffect&#8217;s GameBlast20<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="SpecialEffect GameBlast20" title="This is your last chance to join in with SpecialEffect&#8217;s GameBlast20" srcset="https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/SpecialEffect-GameBlast20-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">Bayonetta &#038; Vanquish 10th Anniversary Bundle review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Bayonetta &#038; Vanquish 10th Anniversary Bundle review" srcset="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/">The Suicide of Rachel Foster review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The Suicide of Rachel Foster review" title="The Suicide of Rachel Foster review" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/">Darksiders Genesis Switch review | Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis Switch review" title="Darksiders Genesis Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/">Darksiders Genesis console review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis (PS4/Xbox One) Console review" title="Darksiders Genesis console review" srcset="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/">Snack World: The Dungeon Crawl &#8211; Gold review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Snack World: The Dungeon Crawl - Gold review" title="Snack World: The Dungeon Crawl &#8211; Gold review" srcset="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/daemon-x-machina-pc-review/">Daemon X Machina PC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/DexM-PC-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Daemon X Machina PC review" title="Daemon X Machina PC review" srcset="https://www.godisageek.com/wp-content/uploads/DexM-PC-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/DexM-PC-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/top-3-android-gaming-emulators-for-pc-edition-2020/">Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Top 3 Android Gaming Emulators for PC: Edition 2020" title="Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020" srcset="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/LDPlayer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/LDPlayer-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/LDPlayer-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/podcast-382-dreams-kunai-patapon-2-remastered/">Podcast #382: A Singular Knacker<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams-podcast-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast #382: Dreams, Kunai, more" title="Podcast #382: A Singular Knacker" srcset="https://www.godisageek.com/wp-content/uploads/Dreams-podcast-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams-podcast-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/is-hellpoint-more-than-just-dark-souls-in-space/">Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hellpoint_Preview" title="Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?" srcset="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/playing-dreams-is-like-surfing-imaginations/">Playing Dreams is like surfing imaginations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dreams preview" title="Playing Dreams is like surfing imaginations" srcset="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/podcast-381-kentucky-route-zero-journey-to-the-savage-planet/">Podcast #381: The Bill<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 381: Kentucky Route Zero, Journey to the Savage Planet, and more." title="Podcast #381: The Bill" srcset="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/games-of-february-2020-dreams-street-fighter-v-champion-edition-rune-factory-4-special-bayonetta-vanquish-10th-anniversary-bundle-and-more/">Games of February 2020 &#8211; Dreams, Street Fighter V: Champion Edition, Rune Factory 4 Special, Bayonetta &#038; Vanquish 10th Anniversary Bundle, and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Games of February 2020 &#8211; Dreams, Street Fighter V: Champion Edition, Rune Factory 4 Special, Bayonetta &#038; Vanquish 10th Anniversary Bundle, and more" srcset="https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/games-of-february-2020-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/top-3-android-gaming-emulators-for-pc-edition-2020/">Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Top 3 Android Gaming Emulators for PC: Edition 2020" title="Sponsored: Top 3 Android Gaming Emulators for PC: Edition 2020" srcset="https://www.godisageek.com/wp-content/uploads/LDPlayer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/LDPlayer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/LDPlayer-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/LDPlayer-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-safijiiva-siege-guide/">Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne Safi&#8217;jiiva Siege Guide" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-safijiiva-siege-main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/12/monster-hunter-world-iceborne-horizon-zero-dawn-event-guide-part-2-the-survivor/">Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Monster Hunter World: Iceborne –  Horizon Zero Dawn Event Guide Part 2 &#8211; The Survivor" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/monster-hunter-world-iceborne-horizon-zero-dawn-frozen-wilds-the-survivor-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/11/10-beginners-tips-for-reconnecting-america-in-death-stranding/">10 beginner&#8217;s tips for reconnecting America in Death Stranding<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="10 beginner&#039;s tips for Death Stranding" title="10 beginner&#8217;s tips for reconnecting America in Death Stranding" srcset="https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/death-stranding-guide-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/code-vein-boss-guide-oliver-collins/">Code Vein Boss Guide: Oliver Collins<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Code Vein Oliver Collins boss guide" title="Code Vein Boss Guide: Oliver Collins" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_1828490.7547384451277539-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/02/is-hellpoint-more-than-just-dark-souls-in-space/">Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hellpoint_Preview" title="Is Hellpoint more than just &#8216;Dark Souls in space&#8217;?" srcset="https://www.godisageek.com/wp-content/uploads/Hellpoint_003-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Hellpoint_003-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/02/playing-dreams-is-like-surfing-imaginations/">Playing Dreams is like surfing imaginations<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dreams preview" title="Playing Dreams is like surfing imaginations" srcset="https://www.godisageek.com/wp-content/uploads/Dreams_Header-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dreams_Header-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/iron-danger-preview-whats-in-a-name/">Iron Danger preview | What&#8217;s in a name?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/iron-danger-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Iron Danger preview" title="Iron Danger preview | What&#8217;s in a name?" srcset="https://www.godisageek.com/wp-content/uploads/iron-danger-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/iron-danger-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/iron-danger-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/iron-danger-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/iron-danger-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/filament-is-a-clever-but-challenging-title-that-puzzle-fans-will-love/">Filament is a clever but challenging title that puzzle fans will love<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Filament-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Filament preview" title="Filament is a clever but challenging title that puzzle fans will love" srcset="https://www.godisageek.com/wp-content/uploads/Filament-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Filament-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Filament-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Filament-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Filament-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/monster-energy-supercross-3-improvements-preview/">Monster Energy Supercross 3 Shows Signs of Great Improvement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Energy Supercross 3 Shows Signs of Great Improvement" title="Monster Energy Supercross 3 Shows Signs of Great Improvement" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Monster-Energy-Supercross-3-preview-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/reviews/the-suicide-of-rachel-foster-review/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/reviews/the-suicide-of-rachel-foster-review/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Darksiders Genesis Switch review | Switch Re:port</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/reviews/fifa-20-review/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Bayonetta & Vanquish 10th Anniversary Bundle review</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                                                                
                                        <a class="like-button do-like 232486" data-postid="232486" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                                                            
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-232486" class="post-232486 it_reviews type-it_reviews status-publish has-post-thumbnail hentry category-pc category-reviews tag-daedalic-entertainment tag-one-o-one-games tag-the-suicide-of-rachel-foster reviews_platform-pc reviews_developer-one-o-one-games reviews_publisher-daedelic-entertainment reviews_reviewedon-pc" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                The Suicide of Rachel Foster review                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-hyde/"><span itemprop="author">Chris Hyde </span></a></span><span class="date">on <meta itemprop="datePublished" content="February 17, 2020">February 17, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-1024x577.png"><img width="790" height="445" src="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-790x445.png" class="attachment-single-790 size-single-790 wp-post-image" alt="The Suicide of Rachel Foster review" title="The Suicide of Rachel Foster review" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-790x445.png 790w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-300x169.png 300w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-768x433.png 768w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-1024x577.png 1024w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-180x101.png 180w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-360x203.png 360w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-1130x637.png 1130w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"><div class="detail-item"><span class="detail-label">Platform</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-platform/pc/" rel="tag">PC</a></span></div><div class="detail-item"><span class="detail-label">Developer</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-developer/one-o-one-games/" rel="tag">One O One Games</a></span></div><div class="detail-item"><span class="detail-label">Publisher</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-publisher/daedelic-entertainment/" rel="tag">Daedelic Entertainment</a></span></div><div class="detail-item"><span class="detail-label">Reviewed On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-reviewedon/pc/" rel="tag">PC</a></span></div></div><div class="details-wrapper"><div class="detail-item"><span class="detail-label">Release Date</span><span class="detail-content"><p>February 19, 2020</p>
</span></div></div></div></div>                                            
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>I’m a firm believer that any subject matter can be covered in the medium of video games. As long as the appropriate steps are taken to respect the subject matter and those who may be affected by it. The Suicide of Rachel Foster is fairly blunt as titles go, though the approach by One O One Games is anything but. It’s clear from the outset, there is a respect here for the topic at hand, and how the raw story they wish to tell could affect people. Every time you begin a new session, there’s advice to <a href="https://www.samaritans.org/how-we-can-help/contact-samaritan/?gclid=EAIaIQobChMI4PKmrLLW5wIVx7TtCh0n2A0nEAAYASABEgIBZ_D_BwE">seek help and reach out to others for support</a> if you are struggling. It’s a message I would echo as well before we continue, given the serious nature of the plot.</p>
<p>Remember, you don’t have to go through things alone.</p>
<p>Set in the early 90s, the protagonist of this tale is Nicole, a young woman who has lost both of her parents. The death of her mother sees her become the owner of the family hotel, The Timberline, high up in the mountains. It is a place of childhood memories for Nicole, that she’d rather forget. Not because her upbringing was hard or painful, far from it, but more so the tragic events that resulted in her abrupt departure ten years ago: the suicide of Rachel Foster. As the new owner, Nicole travels to the hotel to inspect it, with a view to selling, only to get trapped alone there due to a pretty nasty snowstorm. Her only contact with the outside world is via one of the first mobile phones, which keeps her in touch with Irving, a FEMA agent tasked with helping her through the transaction.</p>
<p><img src="http://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment.jpg" alt="The Suicide of Rachel Foster review" width="1920" height="1063" class="alignnone size-full wp-image-232505" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment.jpg 1920w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-300x166.jpg 300w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-768x425.jpg 768w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-1024x567.jpg 1024w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-180x100.jpg 180w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-360x199.jpg 360w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-790x437.jpg 790w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-Daedalic-Entertainment-1130x626.jpg 1130w" sizes="(max-width: 1920px) 100vw, 1920px" /></p>
<p>Wandering around a large abandoned building alone is a pretty well-traveled narrative trope, particularly in horror games. But The Suicide of Rachel Foster feels equal parts horror and mystery to set up more of an exploration-thriller than anything else. As you search more of the hotel, the mundane tasks of securing food and lighting quickly escalate as you begin to unravel more of your family’s past and how it is interwoven with Rachel’s before her death. You begin to accidentally uncover clues that feel out of place, that confuse and challenge Nicole’s perspective of what happened in her past.</p>
<p>Undoubtedly, this is a game dripping with atmosphere, through some very well-considered design decisions. The empty hotel quite rightly feels old and full of memory, its foreboding walls, rooms, and corridors could tell a thousand stories. Narrow corridors feel suitably cramped, restricting your field of vision, but even the wider open rooms are full of furniture and knick-knacks that prevent you from ever feeling at ease in those open spaces. The relentless storm outside provides constant claustrophobia as the wind rattles the shutters, and howls through every nook and cranny. It’s a perpetual reminder, that no one is coming, and this journey of discovery is yours and yours alone.</p>
<p>The story is broken up into days, with you playing out the key moments of each. A lot of this is back and forward phone calls with Irving, and then exploring more of the hotel for a particular purpose. The pacing of the story is an interesting one, because it starts off slowly with Rachel’s suicide being mentioned, but not really tackled. Then, the breadcrumbs of intrigue begin to force Nicole into a mystery she feels compelled to solve. From there on in, the narrative ramps up quite significantly. And the hard-hitting themes and plot that the game’s title suggests definitely are addressed as the story reaches some quite hard-hitting crescendos.</p>
<p><img src="http://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot.jpg" alt="A screenshot from The Suicide of Rachel Foster" width="1920" height="1079" class="alignnone size-full wp-image-232507" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot.jpg 1920w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-1024x575.jpg 1024w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-360x202.jpg 360w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-screenshot-1130x635.jpg 1130w" sizes="(max-width: 1920px) 100vw, 1920px" /></p>
<p>Whilst dramatic and emotional, the way in which the key themes are dealt with is respectful without downplaying their impact. There’s clearly been care and consideration to how best deliver the more poignant moments the developers wanted to display. My only criticism would be that the ending felt perhaps a little rushed. So as to not reveal its hand, plenty is kept back from you until quite near the end and then laid out all at once. It’s well done, but a few more nods and clues earlier on might have made me feel more in control of the mystery. Alternatively, a few more minutes stretching out reveals would have helped slightly with the pacing. It doesn’t undo the narrative or make it feel cheap, but it just feels like its three-hour runtime ends just a little too soon.</p>
<p>In such a conversation-led story, the quality of the voice acting is critical, and it hits the mark here. The interactions between Irving and Nicole feel realistic and help immerse you as a player. It’s engaging to see Nicole go from being a confident, assertive young lady, familiar, but ultimately frustrated by her situation, into a more erratic personality. As doubt and mystery creep in, her sense of fear and unease is clear in her words and tone. Irving, meanwhile on the other end of the line provides a calming tone, but even he has a sense of passion and duty of care for Nicole, worrying for her safety. Also, despite there being decision-based dialogue, the conversations still feel fluid and natural, reinforcing the quality of the writing.</p>
<p>As usual in titles that champion atmosphere, headphones are recommended. The use of binaural audio is well-done, as sounds such as ringing phones move to each ear depending on your character&#8217;s orientation. The creaking floorboards or crunching carpet underfoot feel eerie in the hotel’s otherwise silent existence. As tensions ramp up, the use of sounds to further unease Nicole and you are well-placed, and purposeful, as you will discover by the end. The occasional music you do notice tends to juxtapose the mystery of the narrative. In the same way that safe rooms in <a href="http://www.godisageek.com/2019/12/goty-2019-best-re-release-resident-evil-2/">Resident Evil</a> have their reassuring calm music, the softer melodies that play when you’re in your bedroom or surrounding areas provide a welcome respite to the uncertainty.</p>
<p><img src="http://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot.jpg" alt="The Suicide of Rachel Foster (PC review)" width="1920" height="1069" class="alignnone size-full wp-image-232508" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot.jpg 1920w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-300x167.jpg 300w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-768x428.jpg 768w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-1024x570.jpg 1024w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-180x100.jpg 180w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-360x200.jpg 360w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-790x440.jpg 790w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-screenshot-1130x629.jpg 1130w" sizes="(max-width: 1920px) 100vw, 1920px" /></p>
<p>There are some neat visual ideas, that perhaps not unexpectedly work well because they restrict what you can see. This is a game that understands that unease comes from hinting at the unknown without showing it to you, allowing your imagination to run wild. So when the lights go out and you’re reliant on a dynamo flashlight for sight, or even worse, the flash from a Polaroid camera, fearing what you might see is an incredibly effective tool for tension. Playing the game on the highest visual setting shows it off in all its glory. However, it does expose the short draw distance and pop-in of texture detail. There were plenty of occasions I’d spot something in my peripheral vision, thinking I need to pay attention to it, when in fact it was just some detail popping in for a wall or hanging picture and nothing more. It was slightly distracting, and something I had to accept in the end due to its frequency.</p>
<p>The Suicide of Rachel Foster could have been an over-the-top, blunt take on the emotive subject of mental health. Instead, it deals with the topic head-on with finesse and respect so that it hits home, but for all of the right reasons. It’s an experience that whilst centred on a tough topic, manages to create a mysterious, engaging narrative that discusses much more than its title implies. And in the moments it does deal with the elephant in the room, the care and attention feel real and it leaves you asking the right questions of the subject matter. It doesn’t pretend to have the answers or cast judgment itself but leaves it open for unique reflection and interpretation of the player. And thanks to the brave, but equally respectful approach, this is an experience well worth undertaking.</p>
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                    <div class="procon-box-wrapper"><div class="procon-box clearfix"><div class="col-wrapper"><div class="procon pro"><div class="header"><span class="icon-plus"></span>Positives</div><p>Creates tension and mystery<br />
Sensitive to the subject matter<br />
Well-written and strong voice acting<br />
Good use of binaural audio</p>
</div></div><div class="col-wrapper"><div class="procon con"><div class="header"><span class="icon-minus"></span>Negatives</div><p>Ends a little too soon<br />
Texture pop-in can be off-putting</p>
</div></div></div></div>                                        
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix solo"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar"><div class="rating-meter">&nbsp;</div><div class="rating-label">Our Score</div><div class="rating-value"><div class="number color5">8.0</div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-20,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar color5"><div class="rating-label">SCORE OUT OF TEN</div><meta itemprop="worstRating" content="0"><div class="rating-value" itemprop="ratingValue"><div class="number color5">8.0</div></div><meta itemprop="bestRating" content="10"><br class="clearer" /></div></div></div></div></div><br class="clearer" />                                    
                                    <div class="bottomline-wrapper"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-quote-circled"></span>In Short<div class="ribbon-separator">&nbsp;</div></div></div><div class="bottomline"><p>The Suicide of Rachel Foster tackles some tough issues but in a respectful way. Surrounding it is a mystery that will intrigue and surprise right to the end.</p>
</div></div>                                    
                                                                 
                                    
                                </div>
                            
                                                    
                                                        
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank'><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/02/outward-dlc-the-soroboreans-coming-this-summer/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Outward DLC The Soroboreans Coming this Summer" srcset="https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Soroboreans-AS1-150x150.png 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/02/outward-dlc-the-soroboreans-coming-this-summer/">Outward DLC The Soroboreans Coming this Summer</a><div class="article-meta clearfix"><a class="like-button do-like 232560 info-bottom" data-postid="232560" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/02/outward-dlc-the-soroboreans-coming-this-summer/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/02/go-behind-the-scenes-of-fall-guys-in-new-documentary-series/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Go Behind the Scenes of Fall Guys in New Documentary Series" srcset="https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Fall-Guys-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/02/go-behind-the-scenes-of-fall-guys-in-new-documentary-series/">Go Behind the Scenes of Fall Guys in New Documentary Series</a></div><a class="hover-link" href="https://www.godisageek.com/2020/02/go-behind-the-scenes-of-fall-guys-in-new-documentary-series/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/02/mousecraft-is-coming-to-nintendo-switch-on-february-27/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MouseCraft Switch" title="MouseCraft is coming to Nintendo Switch on February 27" srcset="https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/MouseCraft-Switch-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/02/mousecraft-is-coming-to-nintendo-switch-on-february-27/">MouseCraft is coming to Nintendo Switch on February 27</a></div><a class="hover-link" href="https://www.godisageek.com/2020/02/mousecraft-is-coming-to-nintendo-switch-on-february-27/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/02/ibb-obb-is-making-its-way-to-the-switch/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="ibb &#038; obb is making its way to the Switch" srcset="https://www.godisageek.com/wp-content/uploads/ibb-obb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ibb-obb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ibb-obb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ibb-obb-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ibb-obb-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/02/ibb-obb-is-making-its-way-to-the-switch/">ibb &#038; obb is making its way to the Switch</a></div><a class="hover-link" href="https://www.godisageek.com/2020/02/ibb-obb-is-making-its-way-to-the-switch/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Bayonetta &#038; Vanquish 10th Anniversary Bundle review" srcset="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">Bayonetta &#038; Vanquish 10th Anniversary Bundle review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Bayonetta &#038; Vanquish 10th Anniversary Bundle review" srcset="https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">Bayonetta &#038; Vanquish 10th Anniversary Bundle review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 232495 info-bottom" data-postid="232495" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The Suicide of Rachel Foster review" title="The Suicide of Rachel Foster review" srcset="https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/">The Suicide of Rachel Foster review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis Switch review" title="Darksiders Genesis Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/">Darksiders Genesis Switch review | Switch Re:port</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Darksiders Genesis (PS4/Xbox One) Console review" title="Darksiders Genesis console review" srcset="https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/">Darksiders Genesis console review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Snack World: The Dungeon Crawl - Gold review" title="Snack World: The Dungeon Crawl &#8211; Gold review" srcset="https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/">Snack World: The Dungeon Crawl &#8211; Gold review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png" class="attachment-widget-post size-widget-post wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great</a><div class="article-meta clearfix"><a class="like-button do-like 231548 info-bottom" data-postid="231548" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Code Vein boss guide: The Butterfly of Delirium" srcset="https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Adobe_Post_20191009_2212290.052173597609875944-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">Code Vein boss guide: The Butterfly of Delirium</a></div><a class="hover-link" href="https://www.godisageek.com/2019/10/the-butterfly-of-delirium-guide/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dreams-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/dreams-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Dreams review" srcset="https://www.godisageek.com/wp-content/uploads/dreams-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/dreams-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dreams-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dreams-review-150x150.jpg 150w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dreams-review/">Dreams review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 232273 info-bottom" data-postid="232273" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dreams-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/aviary-attorney-definitive-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Aviary Attorney: Definitive Edition" title="Aviary Attorney: Definitive Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Aviary_Attorney_Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/aviary-attorney-definitive-edition-review/">Aviary Attorney: Definitive Edition review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/aviary-attorney-definitive-edition-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/kentucky-route-zero-review-tv-edition-xbox-switch-ps4/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kentucky Route Zero: TV Edition Xbox One review" title="Kentucky Route Zero: TV Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/kentucky-route-zero-review-tv-edition-xbox-switch-ps4/">Kentucky Route Zero: TV Edition review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/kentucky-route-zero-review-tv-edition-xbox-switch-ps4/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/kunai-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Kunai review" title="Kunai review" srcset="https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Kunai-featured-art-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/kunai-review/">Kunai review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/kunai-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/thronebreaker-the-witcher-tales-switch-review-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Thronebreaker: The Witcher Tales Switch review" title="Thronebreaker: The Witcher Tales Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Thronebreaker-Main-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/thronebreaker-the-witcher-tales-switch-review-switch-report/">Thronebreaker: The Witcher Tales Switch review | Switch Re:port</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/thronebreaker-the-witcher-tales-switch-review-switch-report/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/bayonetta-vanquish-10th-anniversary-bundle-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/bayonetta-vanquish-10th-anniversary-bundle-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Bayonetta &#038; Vanquish 10th Anniversary Bundle review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Suicide-of-Rachel-Foster-review-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/the-suicide-of-rachel-foster-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">The Suicide of Rachel Foster review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/6VuUuaqojKsdTRCLtXkqm4-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/darksiders-genesis-switch-review-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Darksiders Genesis Switch review | Switch Re:port</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Darksiders-Genesis-console-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/darksiders-genesis-ps4-xbox-one-console-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Darksiders Genesis console review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Snack-World-The-Dungeon-Crawl-Gold-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/snack-world-the-dungeon-crawl-gold-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Snack World: The Dungeon Crawl &#8211; Gold review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/DexM-PC-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/daemon-x-machina-pc-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Daemon X Machina PC review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/dreams-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/dreams-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div><div class="article-info">Dreams review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Skellboy-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/skellboy-review-nintendo-switch-pc/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.5</div></div></div><div class="article-info">Skellboy review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Kentucky-Route-Zero-screenshot-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/kentucky-route-zero-review-tv-edition-xbox-switch-ps4/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Kentucky Route Zero: TV Edition review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Darwin_Project-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/the-darwin-project-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">The Darwin Project review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="//www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//plus.google.com/communities/101571468730792116217" class="icon-googleplus info" title="Googleplus" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"godisageek"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.godisageek.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"stars","image_ext":"gif","max":"5","show_loading":"1","show_fading":"1","custom":"0"};
var ratings_mouseover_image=new Image();ratings_mouseover_image.src="https://www.godisageek.com/wp-content/plugins/wp-postratings/images/stars/rating_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.86.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=4.9.7'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
