<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release - GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Two puzzle games are coming together again this December, in a new trailer Puyo Puyo Tetris 2 showcases new modes playable when it releases" />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release - GodisaGeek.com" />
	<meta property="og:description" content="Two puzzle games are coming together again this December, in a new trailer Puyo Puyo Tetris 2 showcases new modes playable when it releases" />
	<meta property="og:url" content="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2020-10-22T18:51:18+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Reviews, News, Previews, Videos, Podcasts: the one stop you need for gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869.jpg","width":1280,"height":720,"caption":"Puyo Puyo Tetris 2 showcases new modes ahead of December's console release"},{"@type":"WebPage","@id":"https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/#webpage","url":"https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/","name":"Puyo Puyo Tetris 2 showcases new modes ahead of December's console release - GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/#primaryimage"},"datePublished":"2020-10-22T18:51:18+00:00","dateModified":"2020-10-22T18:51:18+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/490a0b0497964a0236cb46289f2ba8ea"},"description":"Two puzzle games are coming together again this December, in a new trailer Puyo Puyo Tetris 2 showcases new modes playable when it releases","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/490a0b0497964a0236cb46289f2ba8ea","name":"Lyle Carr","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=96&d=mm&r=g","caption":"Lyle Carr"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=243149' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F10%2Fpuyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2020%2F10%2Fpuyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-243149 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/the-new-deep-rock-galactic-update-has-new-missions-cosmetics-and-more/">The new Deep Rock Galactic update has new missions, cosmetics and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Deep Rock Galactic update" title="The new Deep Rock Galactic update has new missions, cosmetics and more" srcset="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/">New trailer for Rambo joining MK11 features the voice of Sylvester Stallone<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New trailer for Rambo joining MK11" title="New trailer for Rambo joining MK11 features the voice of Sylvester Stallone" srcset="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/">Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release" title="Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release" srcset="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/details-revealed-of-long-awaited-super-meat-boy-forever/">Details revealed of long-awaited Super Meat Boy Forever<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unnamed-14-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Details revealed of long-awaited Super Meat Boy Forever" srcset="https://www.godisageek.com/wp-content/uploads/unnamed-14-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/unnamed-14-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/unnamed-14-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/unnamed-14-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/the-final-nba-2k21-courtside-myplayer-ai/">The final NBA 2K21 Courtside Report focuses on MyPlayer and AI upgrades<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="NBA 2K21 Courtside Report" title="The final NBA 2K21 Courtside Report focuses on MyPlayer and AI upgrades" srcset="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/fallout-76-is-free-to-play-for-the-next-week/">Fallout 76 is free-to-play for the next week<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fallout 76 free to play" title="Fallout 76 is free-to-play for the next week" srcset="https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/horace-review/">Horace review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Horace review" srcset="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/">Tennis World Tour 2 Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tennis World Tour 2 Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/genshin-impact-review/">Genshin Impact review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Genshin Impact review" srcset="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/">Mario Kart Live: Home Circuit review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Kart Live: Home Circuit review" title="Mario Kart Live: Home Circuit review" srcset="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/">The Jackbox Party Pack 7 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Jackbox Party Pack 7 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/fifa-21-review/">FIFA 21 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-21-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="FIFA 21 review" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-21-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-dan-mcdonald-interview/">Interview: The Dark Pictures Anthology series Director talks scares, satisfaction, and story<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Interview: The Dark Pictures Anthology series Director talks scares, satisfaction, and story" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/top-5-launch-lineups-of-all-time/">The top five console launch lineups of all time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mario-64-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The top five console launch lineups of all time" title="The top five console launch lineups of all time" srcset="https://www.godisageek.com/wp-content/uploads/mario-64-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mario-64-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mario-64-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mario-64-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/mario-64-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/podcast-418-fifa-21-yakuza-like-a-dragon/">Podcast 418: Pound Mates &#8211; FIFA 21, Yakuza: Like A Dragon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 418: Pound Mates - FIFA 21, Yakuza: Like A Dragon" title="Podcast 418: Pound Mates &#8211; FIFA 21, Yakuza: Like A Dragon" srcset="https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/super-mario-gift-guide/">Super Mario Gift Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Gift Guides" title="Super Mario Gift Guide" srcset="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-bros-35-6-tips-to-help-you-win/">Super Mario Bros 35 | 8 Tips to help you win<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario Bros 35 tips" title="Super Mario Bros 35 | 8 Tips to help you win" srcset="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/09/ori-and-the-will-of-the-wisps-complete-boss-guide/">Ori and the Will of the Wisps | Complete Boss Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Ori and the Will of the Wisps Boss Guide" title="Ori and the Will of the Wisps | Complete Boss Guide" srcset="https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/how-to-get-resources-easily-in-a-total-war-saga-troy/">How to get resources easily in A Total War Saga: Troy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="total war saga troy resources" title="How to get resources easily in A Total War Saga: Troy" srcset="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/kingdom-hearts-melody-of-memory-is-a-refreshing-yet-unrefined-take-on-the-franchise-demo-impressions/">Kingdom Hearts: Melody of Memory is a refreshing yet unrefined take on the franchise<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Kingdom Hearts: Melody of Memory is a refreshing yet unrefined take on the franchise" srcset="https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-is-co-op-fun-in-the-garden-sun-hands-on-preview/">Pikmin 3 Deluxe is co-op fun in the garden sun | Hands on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe preview" title="Pikmin 3 Deluxe is co-op fun in the garden sun | Hands on preview" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/the-new-deep-rock-galactic-update-has-new-missions-cosmetics-and-more/">The new Deep Rock Galactic update has new missions, cosmetics and more<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Deep Rock Galactic update" title="The new Deep Rock Galactic update has new missions, cosmetics and more" srcset="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/">New trailer for Rambo joining MK11 features the voice of Sylvester Stallone<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New trailer for Rambo joining MK11" title="New trailer for Rambo joining MK11 features the voice of Sylvester Stallone" srcset="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/">Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release" title="Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release" srcset="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/details-revealed-of-long-awaited-super-meat-boy-forever/">Details revealed of long-awaited Super Meat Boy Forever<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unnamed-14-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Details revealed of long-awaited Super Meat Boy Forever" srcset="https://www.godisageek.com/wp-content/uploads/unnamed-14-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/unnamed-14-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/unnamed-14-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/unnamed-14-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/the-final-nba-2k21-courtside-myplayer-ai/">The final NBA 2K21 Courtside Report focuses on MyPlayer and AI upgrades<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="NBA 2K21 Courtside Report" title="The final NBA 2K21 Courtside Report focuses on MyPlayer and AI upgrades" srcset="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Courtside-Report-C4-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/fallout-76-is-free-to-play-for-the-next-week/">Fallout 76 is free-to-play for the next week<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fallout 76 free to play" title="Fallout 76 is free-to-play for the next week" srcset="https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/fallout-76-1200x675-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/horace-review/">Horace review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Horace review" srcset="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/">Tennis World Tour 2 Switch Re:port<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tennis World Tour 2 Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/genshin-impact-review/">Genshin Impact review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Genshin Impact review" srcset="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/">Mario Kart Live: Home Circuit review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Kart Live: Home Circuit review" title="Mario Kart Live: Home Circuit review" srcset="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/">The Jackbox Party Pack 7 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Jackbox Party Pack 7 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/fifa-21-review/">FIFA 21 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-21-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="FIFA 21 review" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-21-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-21-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/little-hope-dan-mcdonald-interview/">Interview: The Dark Pictures Anthology series Director talks scares, satisfaction, and story<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Interview: The Dark Pictures Anthology series Director talks scares, satisfaction, and story" srcset="https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Little-Hope-Dan-McDonald-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/top-5-launch-lineups-of-all-time/">The top five console launch lineups of all time<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mario-64-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The top five console launch lineups of all time" title="The top five console launch lineups of all time" srcset="https://www.godisageek.com/wp-content/uploads/mario-64-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mario-64-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mario-64-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mario-64-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/mario-64-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/podcast-418-fifa-21-yakuza-like-a-dragon/">Podcast 418: Pound Mates &#8211; FIFA 21, Yakuza: Like A Dragon<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 418: Pound Mates - FIFA 21, Yakuza: Like A Dragon" title="Podcast 418: Pound Mates &#8211; FIFA 21, Yakuza: Like A Dragon" srcset="https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/YAKUZA-like-a-dragon-babies-quest-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2019/10/best-apple-arcade-games-so-far/">The 5 Apple Arcade games you need to try right now: Part One<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="The 5 Apple Arcade games you need to try right now" title="The 5 Apple Arcade games you need to try right now: Part One" srcset="https://www.godisageek.com/wp-content/uploads/apple-arcade-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/apple-arcade-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/apple-arcade-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/apple-arcade-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/apple-arcade-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/super-mario-gift-guide/">Super Mario Gift Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Gift Guides" title="Super Mario Gift Guide" srcset="https://www.godisageek.com/wp-content/uploads/Mario-moneybox-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-moneybox-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/super-mario-bros-35-6-tips-to-help-you-win/">Super Mario Bros 35 | 8 Tips to help you win<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario Bros 35 tips" title="Super Mario Bros 35 | 8 Tips to help you win" srcset="https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Mario-Bros-35-tips-8-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/09/ori-and-the-will-of-the-wisps-complete-boss-guide/">Ori and the Will of the Wisps | Complete Boss Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Ori and the Will of the Wisps Boss Guide" title="Ori and the Will of the Wisps | Complete Boss Guide" srcset="https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Ori-Will-Wisps-Boss-Guide-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/marvels-avengers-10-beginners-tips/">Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Marvel&#8217;s Avengers | 10 Beginner&#8217;s Tips" srcset="https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/marvels-avengers-beta-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/08/how-to-get-resources-easily-in-a-total-war-saga-troy/">How to get resources easily in A Total War Saga: Troy<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="total war saga troy resources" title="How to get resources easily in A Total War Saga: Troy" srcset="https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/total-war-saga-troy-resources-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/07/ghost-of-tsushima-11-tips-to-help-you-become-a-fearsome-and-unstoppable-warrior/">Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ghost of Tsushima | 11 tips to help you become a fearsome and unstoppable warrior" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Ghost-of-Tsushima-tips-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/whats-new-in-nhl-21-a-primer-for-this-years-game/">What&#8217;s new in NHL 21? A primer for this year&#8217;s game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="What&#8217;s new in NHL 21? A primer for this year&#8217;s game" srcset="https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/nhl-21-feature-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/kingdom-hearts-melody-of-memory-is-a-refreshing-yet-unrefined-take-on-the-franchise-demo-impressions/">Kingdom Hearts: Melody of Memory is a refreshing yet unrefined take on the franchise<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Kingdom Hearts: Melody of Memory is a refreshing yet unrefined take on the franchise" srcset="https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Kingdom-Hearts-Melody-of-Memory-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/pikmin-3-deluxe-is-co-op-fun-in-the-garden-sun-hands-on-preview/">Pikmin 3 Deluxe is co-op fun in the garden sun | Hands on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Pikmin 3 Deluxe preview" title="Pikmin 3 Deluxe is co-op fun in the garden sun | Hands on preview" srcset="https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Pikmin-3-Deluxe-preview-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2015/03/shovel-knight-free-update-detailed/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">New trailer for Rambo joining MK11 features the voice of Sylvester Stallone</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-243149" class="post-243149 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-next-gen tag-online-modes tag-online-play tag-puyo-puyo tag-puyo-puyo-tetris-2 tag-puzzle-game tag-sega tag-skill-mode tag-tetris tag-trailer" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/lyle-carr/"><span itemprop="author">Lyle Carr </span></a></span><span class="date">on <meta itemprop="datePublished" content="October 22, 2020">October 22, 2020</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release" title="Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><p>Two of the greatest puzzle games are coming together again this December, and in a new trailer Puyo Puyo Tetris 2 showcases new modes playable when it releases. With multiple ways to play online and locally, Sega are promising a ton of features for the upcoming crossover.</p>
<p>&#8220;In Skill Battle mode, players will create teams of three from selectable characters in either Puyo Puyo or Tetris gameplay settings and use their unique skills to create the ultimate lineup.</p>
<div class='video_frame'><iframe id='youtube_video_2' class='youtube_video' src='https://www.youtube.com/embed/WxE_DE1pZ9M?autohide=0&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=0&amp;hd=0&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<p>Each character starts out with a single specialty and learns more powerful skills as you play with them. Selecting characters with complementary skills becomes a key strategy for winning a Skill Battle match. As you play, you’ll pop Puyos and clear Lines, sending Garbage Puyos and Blocks to the other player’s board. When the Garbage falls, your opponent loses HP. If their HP hits 0, you win!!</p>
<p>Puyo Puyo™ Tetris® 2 offers fun for all types of players, including Leagues for experienced gamers and a Free Play mode for fun and casual gameplay.</p>
<p>Building onto Puzzle League from the previous game, three additional Leagues have been added: Tetris League, Puyo Puyo League, and Skill Battle League. These Leagues provide a competitive space where you can match your strategy and talents against other pros and see how you rank amongst the world’s best. Free Play, brought over from Puyo Puyo™ Tetris®, lets you play at a more casual pace with any ruleset and without the pressure of rankings.&#8221;</p>
<p>As someone who thinks both <a href="https://en.m.wikipedia.org/wiki/Puyo_Puyo">Puyo Puyo</a> and <a href="https://www.godisageek.com/reviews/tetris-effect-review/">Tetris</a> are great, I should make sure to play the crossover game this time. Sega will be releasing on next gen and current consoles on December 8th, with the PC launch coming early next year. I think it might be a perfect game for Switch, but maybe it&#8217;ll be worth getting on a next gen console too.</p>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/next-gen/" title="next gen Tag" class="next-gen">next gen</a><a href="https://www.godisageek.com/tag/online-modes/" title="Online modes Tag" class="online-modes">Online modes</a><a href="https://www.godisageek.com/tag/online-play/" title="Online Play Tag" class="online-play">Online Play</a><a href="https://www.godisageek.com/tag/puyo-puyo/" title="puyo puyo Tag" class="puyo-puyo">puyo puyo</a><a href="https://www.godisageek.com/tag/puyo-puyo-tetris-2/" title="Puyo Puyo Tetris 2 Tag" class="puyo-puyo-tetris-2">Puyo Puyo Tetris 2</a><a href="https://www.godisageek.com/tag/puzzle-game/" title="Puzzle game Tag" class="puzzle-game">Puzzle game</a><a href="https://www.godisageek.com/tag/sega/" title="Sega Tag" class="sega">Sega</a><a href="https://www.godisageek.com/tag/skill-mode/" title="Skill Mode Tag" class="skill-mode">Skill Mode</a><a href="https://www.godisageek.com/tag/tetris/" title="Tetris Tag" class="tetris">Tetris</a><a href="https://www.godisageek.com/tag/trailer/" title="Trailer Tag" class="trailer">Trailer</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/lyle-carr/"><img alt='' src='https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/9dff0ec46443d5cbf6b9fedd7e59cec2?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/lyle-carr/"><h3>Lyle Carr</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:fishchipswhips@gmail.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="1585" data-method="tags" class="info active" title="More articles tagged: next gen">next gen<span class="bottom-arrow"></span></a><a data-sorter="18169" data-method="tags" class="info" title="More articles tagged: puyo puyo">puyo puyo<span class="bottom-arrow"></span></a><a data-sorter="27188" data-method="tags" class="info" title="More articles tagged: Puyo Puyo Tetris 2">Puyo Puyo Tetris 2<span class="bottom-arrow"></span></a><a data-sorter="6296" data-method="tags" class="info" title="More articles tagged: Puzzle game">Puzzle game<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/new-dirt-5-trailer-shows-series-x-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dirt-5-screenshot-94d21844-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New DIRT 5 trailer shows Series X Gameplay" title="New DIRT 5 trailer shows Series X gameplay" srcset="https://www.godisageek.com/wp-content/uploads/dirt-5-screenshot-94d21844-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dirt-5-screenshot-94d21844-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dirt-5-screenshot-94d21844-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dirt-5-screenshot-94d21844-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/new-dirt-5-trailer-shows-series-x-gameplay/">New DIRT 5 trailer shows Series X gameplay</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/new-dirt-5-trailer-shows-series-x-gameplay/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/planet-coaster-console-edition-is-coming-november-10th/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/PlanetCoaster_Anniversary_02-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Planet Coaster: Console Edition is coming November 10th" srcset="https://www.godisageek.com/wp-content/uploads/PlanetCoaster_Anniversary_02-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/PlanetCoaster_Anniversary_02-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/PlanetCoaster_Anniversary_02-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/PlanetCoaster_Anniversary_02-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/planet-coaster-console-edition-is-coming-november-10th/">Planet Coaster: Console Edition is coming November 10th</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/planet-coaster-console-edition-is-coming-november-10th/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/2k-reveal-first-look-at-next-gen-gameplay-for-nba-2k21/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Next-Gen-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="2K reveal first look at Next-Gen gameplay for NBA 2K21" srcset="https://www.godisageek.com/wp-content/uploads/NBA-2K21-Next-Gen-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Next-Gen-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Next-Gen-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/NBA-2K21-Next-Gen-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/2k-reveal-first-look-at-next-gen-gameplay-for-nba-2k21/">2K reveal first look at Next-Gen gameplay for NBA 2K21</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/2k-reveal-first-look-at-next-gen-gameplay-for-nba-2k21/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/09/yakuza-like-a-dragon-launches-everywhere-but-ps5-on-november-10th/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/890c1410-cc33-11ea-bbff-d6f3ac0450b8-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="An image of Yakuza: Like a Dragon which launches in November" title="Yakuza: Like a Dragon launches everywhere but PS5 on November 10th" srcset="https://www.godisageek.com/wp-content/uploads/890c1410-cc33-11ea-bbff-d6f3ac0450b8-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/890c1410-cc33-11ea-bbff-d6f3ac0450b8-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/890c1410-cc33-11ea-bbff-d6f3ac0450b8-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/890c1410-cc33-11ea-bbff-d6f3ac0450b8-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/09/yakuza-like-a-dragon-launches-everywhere-but-ps5-on-november-10th/">Yakuza: Like a Dragon launches everywhere but PS5 on November 10th</a></div><a class="hover-link" href="https://www.godisageek.com/2020/09/yakuza-like-a-dragon-launches-everywhere-but-ps5-on-november-10th/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/09/xbox-series-s-console-and-pricing-revealed/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20200908_092326-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Xbox Series S console and pricing revealed" srcset="https://www.godisageek.com/wp-content/uploads/20200908_092326-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20200908_092326-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20200908_092326-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20200908_092326-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/09/xbox-series-s-console-and-pricing-revealed/">Xbox Series S console and pricing revealed</a></div><a class="hover-link" href="https://www.godisageek.com/2020/09/xbox-series-s-console-and-pricing-revealed/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/turtle-beach-stealth-700-gen-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/STEALTH-700-PS-GEN2_LIFESTYLE2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Stealth 700 Gen 2 Turtle Beach coming this month" srcset="https://www.godisageek.com/wp-content/uploads/STEALTH-700-PS-GEN2_LIFESTYLE2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/STEALTH-700-PS-GEN2_LIFESTYLE2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/STEALTH-700-PS-GEN2_LIFESTYLE2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/STEALTH-700-PS-GEN2_LIFESTYLE2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/turtle-beach-stealth-700-gen-2/">Stealth 700 Gen 2 Turtle Beach coming this month</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/turtle-beach-stealth-700-gen-2/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="search-3" class="widget clearfix widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.godisageek.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="media_image-5" class="widget clearfix widget_media_image"><div class="header clearfix">Support us on Patreon for exclusive content</div><a href="https://www.patreon.com/GodisaGeek"><img width="662" height="320" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg" class="image wp-image-210374  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2.jpg 662w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg 300w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-180x87.jpg 180w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-360x174.jpg 360w, https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-280x135.jpg 280w" sizes="(max-width: 662px) 100vw, 662px" /></a></div><div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><br />
<input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /><br />
<input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /><br />
<img src="https://www.paypal.com/en_GB/i/scr/pixel.gif" alt="" width="1" height="1" border="0" /></form>
<p><a href='https://ko-fi.com/L3L31F4XP' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0px;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p>
</div>
		</div><div id="it_social_tabs-8" class="widget clearfix Social Tabs"><div class="it-widget-tabs it-social-tabs section-buttons"><ul class="sort-buttons"><li><a href="#twitter-social-tab" class="info icon-twitter" title="Twitter"><span class="selector-arrow"></span></a></li></ul><div id="twitter-social-tab"><a href="https://twitter.com/GodisaGeek?ref_src=twsrc%5Etfw" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @GodisaGeek</a><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></div></div>		
		
	<div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/the-new-deep-rock-galactic-update-has-new-missions-cosmetics-and-more/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Deep Rock Galactic update" title="The new Deep Rock Galactic update has new missions, cosmetics and more" srcset="https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Deep-Rock-Galactic-update-3-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/the-new-deep-rock-galactic-update-has-new-missions-cosmetics-and-more/">The new Deep Rock Galactic update has new missions, cosmetics and more</a><div class="article-meta clearfix"><a class="like-button do-like 243155 info-bottom" data-postid="243155" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/10/the-new-deep-rock-galactic-update-has-new-missions-cosmetics-and-more/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New trailer for Rambo joining MK11" title="New trailer for Rambo joining MK11 features the voice of Sylvester Stallone" srcset="https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/mortal-kombat-11-rambo-mk11-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/">New trailer for Rambo joining MK11 features the voice of Sylvester Stallone</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/new-trailer-for-rambo-joining-mk11-features-the-voice-of-sylvester-stallone/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Puyo Puyo Tetris 2 showcases new modes ahead of December&#039;s console release" title="Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release" srcset="https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Puyo-Puyo-Tetris-2-Big-Bang-Mode-502515f43fa3006aad5.64511869-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/">Puyo Puyo Tetris 2 showcases new modes ahead of December&#8217;s console release</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/puyo-puyo-tetris-2-showcases-new-modes-ahead-of-decembers-console-release/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/horace-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Horace review" srcset="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/horace-review/">Horace review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/horace-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" title="Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild" srcset="https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Immortals-Fenyx-Rising-preview-key-art-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">Immortals Fenyx Rising is more than just Ubisoft’s Breath of the Wild</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/immortals-fenyx-rising-is-more-than-just-ubisofts-botw/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/horace-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Horace review" srcset="https://www.godisageek.com/wp-content/uploads/horace-switch-hero-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/horace-switch-hero-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/horace-review/">Horace review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 243066 info-bottom" data-postid="243066" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/horace-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tennis World Tour 2 Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/">Tennis World Tour 2 Switch Re:port</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/genshin-impact-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Genshin Impact review" srcset="https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/genshin-impact-review/">Genshin Impact review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/genshin-impact-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Mario Kart Live: Home Circuit review" title="Mario Kart Live: Home Circuit review" srcset="https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/">Mario Kart Live: Home Circuit review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The Jackbox Party Pack 7 review" srcset="https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/">The Jackbox Party Pack 7 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/">&nbsp;</a></div></div></div>		
		
	<div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series</a><div class="article-meta clearfix"><a class="like-button do-like 242662 info-bottom" data-postid="242662" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Tainted Grail PC Preview" title="Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/Grail-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Grail-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Grail-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Grail-85x85.png 85w, https://www.godisageek.com/wp-content/uploads/Grail-150x150.png 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">Tainted Grail is grimdark Baldur&#8217;s Gate with deck-building &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/tainted-grail-is-grimdark-baldurs-gate-with-deck-building-and-its-great/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Our Top 5 Most Anticipated Games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/ff7Remake2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/ff7Remake2-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">Our Top 5 Most Anticipated Games of 2020</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/godisageek-top-5-most-anticipated-games-of-2020/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What is The Cycle?" title="The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great" srcset="https://www.godisageek.com/wp-content/uploads/The-Cycle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Cycle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Cycle-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Cycle-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/The-Cycle-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">The Cycle is like Fortnite and Borderlands had a baby &#8211; and it&#8217;s great</a></div><a class="hover-link" href="https://www.godisageek.com/2020/01/the-cycle-is-like-fortnite-and-borderlands-had-a-baby-and-its-great/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/spelunky-2-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/1200px-Spelunky_2_logo-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Spelunky 2 review" srcset="https://www.godisageek.com/wp-content/uploads/1200px-Spelunky_2_logo-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/1200px-Spelunky_2_logo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/1200px-Spelunky_2_logo-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/spelunky-2-review/">Spelunky 2 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 241997 info-bottom" data-postid="241997" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/spelunky-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/oculus-quest-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Oculus Quest 2 review" title="Oculus Quest 2 review" srcset="https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/oculus-quest-2-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/oculus-quest-2-review/">Oculus Quest 2 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/oculus-quest-2-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/i-am-dead-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/i-am-dead-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="I Am Dead review" srcset="https://www.godisageek.com/wp-content/uploads/i-am-dead-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/i-am-dead-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/i-am-dead-review/">I Am Dead review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/i-am-dead-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ikenfell-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ikenfell-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ikenfell review" srcset="https://www.godisageek.com/wp-content/uploads/Ikenfell-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ikenfell-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ikenfell-review/">Ikenfell review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ikenfell-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ori-and-the-will-of-the-wisps-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ori-switch-report-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Ori and the Will of the Wisps Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/ori-switch-report-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ori-switch-report-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ori-switch-report-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ori-switch-report-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ori-and-the-will-of-the-wisps-switch-report/">Ori and the Will of the Wisps Switch Re:port</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ori-and-the-will-of-the-wisps-switch-report/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/horace-switch-hero-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/horace-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Horace review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/tennis-world-tour-2-switch-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/tennis-world-tour-2-switch-report/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.5</div></div></div><div class="article-info">Tennis World Tour 2 Switch Re:port</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/uthypjdkesxhmxlf_1601384107-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/genshin-impact-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Genshin Impact review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Mario-Kart-Live-Home-Circuit-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/mario-kart-live-home-circuit-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Mario Kart Live: Home Circuit review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Jackbox-Party-Pack-7-review-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/the-jackbox-party-pack-7-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">The Jackbox Party Pack 7 review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/FIFA-21-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/fifa-21-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">FIFA 21 review</div></div></div></div><div class="box-panel box-7"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Scourgebringer-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/reviews/scourgebringer-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">ScourgeBringer Nintendo Switch review</div></div></div></div><div class="box-panel box-8"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/LittleBigWorkshopMain-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/little-big-workshop-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Little Big Workshop Nintendo Switch review</div></div></div></div><div class="box-panel box-0"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Aquanox-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/aquanox-deep-descent-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Aquanox: Deep Descent review</div></div></div></div><div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/monster-truck-championship-review-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/monster-truck-championship-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.5</div></div></div><div class="article-info">Monster Truck Championship review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
