<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Persona 5 Strikers has the best combat in the series | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Persona 5 Strikers is shaping up nicely, with a refreshing combat pattern filled with plenty of options to wipe out the Shadows." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Persona 5 Strikers has the best combat in the series | Hands-on Preview" />
	<meta property="og:description" content="Persona 5 Strikers is shaping up nicely, with a refreshing combat pattern filled with plenty of options to wipe out the Shadows." />
	<meta property="og:url" content="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:author" content="http://facebook.com/christopherppwhitepoet" />
	<meta property="article:published_time" content="2021-01-15T15:00:53+00:00" />
	<meta property="article:modified_time" content="2021-01-14T09:01:33+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview.jpg","width":1280,"height":720,"caption":"Persona 5 Strikers Preview"},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/#webpage","url":"https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/","name":"Persona 5 Strikers has the best combat in the series | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/#primaryimage"},"datePublished":"2021-01-15T15:00:53+00:00","dateModified":"2021-01-14T09:01:33+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646"},"description":"Persona 5 Strikers is shaping up nicely, with a refreshing combat pattern filled with plenty of options to wipe out the Shadows.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646","name":"Chris White","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=96&d=mm&r=g","caption":"Chris White"},"description":"Video games are cool. Don't let anybody tell you any different.","sameAs":["http://facebook.com/christopherppwhitepoet","https://twitter.com/http://twitter.com/firstavenger83"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"01","day":"15","hour":"15","minute":"00","second":"53","post_id":"245973","postname":"persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc","category":"features"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/' />
<meta name='shareaholic:keywords' content='tag:atlus, tag:koei tecmo, tag:persona 5, tag:persona 5 strikers, cat:features, cat:previews, type:post' />
<meta name='shareaholic:article_published_time' content='2021-01-15T15:00:53+00:00' />
<meta name='shareaholic:article_modified_time' content='2021-01-14T09:01:33+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris White' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=245973' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F01%2Fpersona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F01%2Fpersona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-245973 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/">PC specs for Outriders detailed in new video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders PC Specs" title="PC specs for Outriders detailed in new video" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/new-pokemon-snap-will-launch-on-april-30/">New Pokémon Snap will launch on April 30<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokémon Snap" title="New Pokémon Snap will launch on April 30" srcset="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/captain-tsubasa-demo/">New Captain Tsubasa demo is available to download now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Captain Tsubasa demo" title="New Captain Tsubasa demo is available to download now" srcset="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/release-date-announced-for-first-a-total-war-saga-troy-dlc/">Release date announced for first A Total War Saga: Troy DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Total War Saga: Troy DLC" title="Release date announced for first A Total War Saga: Troy DLC" srcset="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/bloober-team-release-live-action-trailer-for-the-medium/">Bloober Team release live action trailer for The Medium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Live Action Trailer News" title="Bloober Team release live action trailer for The Medium" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/ubisoft-announces-new-open-world-star-wars-game/">Ubisoft announces new open world Star Wars game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ubisoft announces new open world Star Wars game" title="Ubisoft announces new open world Star Wars game" srcset="https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/mxgp-2020-review/">MXGP 2020 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MXGP 2020 review" title="MXGP 2020 review" srcset="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/">Scott Pilgrim vs the World: The Game &#8211; Complete Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Scott Pilgrim vs the World: The Game - Complete Edition Review" title="Scott Pilgrim vs the World: The Game &#8211; Complete Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/">The Hong Kong Massacre review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Hong Kong Massacre Review" title="The Hong Kong Massacre review" srcset="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">Turtle Beach Stealth 700 Gen 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turtle Beach Stealth 700 Gen 2 review" title="Turtle Beach Stealth 700 Gen 2 review" srcset="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/grindstone-review/">Grindstone review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Grindstone title image" title="Grindstone review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tears-of-avia-review/">Tears of Avia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tears of Avia review" srcset="https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">Persona 5 Strikers has the best combat in the series | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/little-nightmares-ii-is-better-than-the-first-in-every-way-hands-on-preview/">Little Nightmares II is better than the first in every way | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II is better than the first in every way" title="Little Nightmares II is better than the first in every way | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/everything-we-know-about-hitman-3/">Everything we know about Hitman 3<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything we know about Hitman 3" title="Everything we know about Hitman 3" srcset="https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/podcast-426-super-mario-3d-world-horizon-forbidden-west-the-medium-the-witcher-3-wild-hunt/">Podcast #426: Super Mario 3D World, Horizon Forbidden West, The Medium, The Witcher 3: Wild Hunt<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario 3D World" title="Podcast #426: Super Mario 3D World, Horizon Forbidden West, The Medium, The Witcher 3: Wild Hunt" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/cyberpunk-2077-guide-how-to-romance-panam/">Cyberpunk 2077 guide | How to romance Panam<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk 2077 Romance Panam Sandstorm" title="Cyberpunk 2077 guide | How to romance Panam" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/christmas-gift-guide-2020/">Christmas Gift Guide 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Gift Guide 2020" title="Christmas Gift Guide 2020" srcset="https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/temtem-guide-understanding-the-basics-of-combat-and-exploration/">Temtem guide | Understanding the basics of combat and exploration<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/temtem-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Temtem Guide" title="Temtem guide | Understanding the basics of combat and exploration" srcset="https://www.godisageek.com/wp-content/uploads/temtem-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/temtem-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/temtem-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/temtem-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/cyberpunk-2077-easiest-ways-to-make-money/">Cyberpunk 2077 &#8211; Easiest ways to make money<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk2077 Money guide" title="Cyberpunk 2077 &#8211; Easiest ways to make money" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">Persona 5 Strikers has the best combat in the series | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/little-nightmares-ii-is-better-than-the-first-in-every-way-hands-on-preview/">Little Nightmares II is better than the first in every way | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II is better than the first in every way" title="Little Nightmares II is better than the first in every way | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/what-to-expect-from-the-ys-ix-monstrum-nox-demo/">What to expect from the Ys IX: Monstrum Nox demo<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ys IX: Monstrum Nox Demo" title="What to expect from the Ys IX: Monstrum Nox demo" srcset="https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/back-4-blood-is-a-left-4-dead-threequel-in-every-way-that-matters/">Back 4 Blood is a Left 4 Dead threequel in every way that matters<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Back 4 Blood closed alpha impressions" title="Back 4 Blood is a Left 4 Dead threequel in every way that matters" srcset="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/king-of-seas-is-a-procedurally-generated-pirate-adventure-with-great-potential/">King of Seas is a procedurally generated pirate adventure with great potential<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="king of seas preview" title="King of Seas is a procedurally generated pirate adventure with great potential" srcset="https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/atelier-ryza-2-lost-legends-and-the-secret-fairy-is-an-alchemists-dream/">Atelier Ryza 2: Lost Legends and the Secret Fairy is an alchemist&#8217;s dream<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Atelier Ryza 2: Lost Legends and the Secret Fairy is an alchemist&#8217;s dream" srcset="https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/">PC specs for Outriders detailed in new video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders PC Specs" title="PC specs for Outriders detailed in new video" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/new-pokemon-snap-will-launch-on-april-30/">New Pokémon Snap will launch on April 30<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokémon Snap" title="New Pokémon Snap will launch on April 30" srcset="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/captain-tsubasa-demo/">New Captain Tsubasa demo is available to download now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Captain Tsubasa demo" title="New Captain Tsubasa demo is available to download now" srcset="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/release-date-announced-for-first-a-total-war-saga-troy-dlc/">Release date announced for first A Total War Saga: Troy DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Total War Saga: Troy DLC" title="Release date announced for first A Total War Saga: Troy DLC" srcset="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/bloober-team-release-live-action-trailer-for-the-medium/">Bloober Team release live action trailer for The Medium<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Live Action Trailer News" title="Bloober Team release live action trailer for The Medium" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Live-action-trailer-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/ubisoft-announces-new-open-world-star-wars-game/">Ubisoft announces new open world Star Wars game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ubisoft announces new open world Star Wars game" title="Ubisoft announces new open world Star Wars game" srcset="https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ubisoft_new_2017_logo_2400.0-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/mxgp-2020-review/">MXGP 2020 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MXGP 2020 review" title="MXGP 2020 review" srcset="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/">Scott Pilgrim vs the World: The Game &#8211; Complete Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Scott Pilgrim vs the World: The Game - Complete Edition Review" title="Scott Pilgrim vs the World: The Game &#8211; Complete Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/">The Hong Kong Massacre review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Hong Kong Massacre Review" title="The Hong Kong Massacre review" srcset="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">Turtle Beach Stealth 700 Gen 2 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turtle Beach Stealth 700 Gen 2 review" title="Turtle Beach Stealth 700 Gen 2 review" srcset="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/grindstone-review/">Grindstone review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Grindstone title image" title="Grindstone review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/tears-of-avia-review/">Tears of Avia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Tears of Avia review" srcset="https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">Persona 5 Strikers has the best combat in the series | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/little-nightmares-ii-is-better-than-the-first-in-every-way-hands-on-preview/">Little Nightmares II is better than the first in every way | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II is better than the first in every way" title="Little Nightmares II is better than the first in every way | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/everything-we-know-about-hitman-3/">Everything we know about Hitman 3<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Everything we know about Hitman 3" title="Everything we know about Hitman 3" srcset="https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Everything-we-know-about-Hitman-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/podcast-426-super-mario-3d-world-horizon-forbidden-west-the-medium-the-witcher-3-wild-hunt/">Podcast #426: Super Mario 3D World, Horizon Forbidden West, The Medium, The Witcher 3: Wild Hunt<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario 3D World" title="Podcast #426: Super Mario 3D World, Horizon Forbidden West, The Medium, The Witcher 3: Wild Hunt" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-426-Super-Mario-3D-World-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/yakuza-like-a-dragon-is-one-of-the-best-games-of-2020/">Yakuza: Like a Dragon is comfortably one of the best games of 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Yakuza: Like a Dragon preview | Comfortably one of the best games of 2020" title="Yakuza: Like a Dragon is comfortably one of the best games of 2020" srcset="https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/yakuza-like-a-dragon-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-endemic-life-guide/">Monster Hunter Rise | Endemic Life Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise endemic life" title="Monster Hunter Rise | Endemic Life Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHR-Antidobra-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/monster-hunter-rise-monster-guide/">Monster Hunter Rise | Monster Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | Monster Guide" title="Monster Hunter Rise | Monster Guide" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-Guide-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/cyberpunk-2077-guide-how-to-romance-panam/">Cyberpunk 2077 guide | How to romance Panam<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk 2077 Romance Panam Sandstorm" title="Cyberpunk 2077 guide | How to romance Panam" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk-2077-Romance-Panam-Feature-Image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/christmas-gift-guide-2020/">Christmas Gift Guide 2020<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Gift Guide 2020" title="Christmas Gift Guide 2020" srcset="https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/christmas-gift-guide-2020-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/temtem-guide-understanding-the-basics-of-combat-and-exploration/">Temtem guide | Understanding the basics of combat and exploration<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/temtem-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Temtem Guide" title="Temtem guide | Understanding the basics of combat and exploration" srcset="https://www.godisageek.com/wp-content/uploads/temtem-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/temtem-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/temtem-guide-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/temtem-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/cyberpunk-2077-easiest-ways-to-make-money/">Cyberpunk 2077 &#8211; Easiest ways to make money<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cyberpunk2077 Money guide" title="Cyberpunk 2077 &#8211; Easiest ways to make money" srcset="https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cyberpunk2077_My_name_is_Evelyn_RGB-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">Persona 5 Strikers has the best combat in the series | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/little-nightmares-ii-is-better-than-the-first-in-every-way-hands-on-preview/">Little Nightmares II is better than the first in every way | Hands-on Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Little Nightmares II is better than the first in every way" title="Little Nightmares II is better than the first in every way | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/little-nightmares-2-preview-better-than-the-original-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/what-to-expect-from-the-ys-ix-monstrum-nox-demo/">What to expect from the Ys IX: Monstrum Nox demo<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ys IX: Monstrum Nox Demo" title="What to expect from the Ys IX: Monstrum Nox demo" srcset="https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2021010417100507_Moment3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/back-4-blood-is-a-left-4-dead-threequel-in-every-way-that-matters/">Back 4 Blood is a Left 4 Dead threequel in every way that matters<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Back 4 Blood closed alpha impressions" title="Back 4 Blood is a Left 4 Dead threequel in every way that matters" srcset="https://www.godisageek.com/wp-content/uploads/Back-4-Blood-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Back-4-Blood-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/king-of-seas-is-a-procedurally-generated-pirate-adventure-with-great-potential/">King of Seas is a procedurally generated pirate adventure with great potential<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="king of seas preview" title="King of Seas is a procedurally generated pirate adventure with great potential" srcset="https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/king-of-seas-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/atelier-ryza-2-lost-legends-and-the-secret-fairy-is-an-alchemists-dream/">Atelier Ryza 2: Lost Legends and the Secret Fairy is an alchemist&#8217;s dream<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Atelier Ryza 2: Lost Legends and the Secret Fairy is an alchemist&#8217;s dream" srcset="https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/atelier-ryza-2-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">PC specs for Outriders detailed in new video</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2019/03/gaming-news-roundup-08-march/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-245973" class="post-245973 post type-post status-publish format-standard has-post-thumbnail hentry category-features category-previews tag-atlus tag-koei-tecmo tag-persona-5 tag-persona-5-strikers" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Persona 5 Strikers has the best combat in the series | Hands-on Preview                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-white/"><span itemprop="author">Chris White </span></a></span><span class="date">on <meta itemprop="datePublished" content="January 15, 2021">January 15, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Persona 5 Strikers has the best combat in the series | Hands-on Preview' data-link='https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/' data-summary='The Phantom Thieves are back!' data-app-id-name='post_above_content'></div>
<p>I have to admit, <a href="https://en.wikipedia.org/wiki/Musou">Musou games</a> aren&#8217;t really my thing. I&#8217;ve given them plenty of attention over the years, but they tend to bore me rather quickly. I never feel like the combat evolves over time, or does enough differently the more hours you spend playing, leaving you in a repetitive loop of hammering the buttons without a worthwhile reward. When I heard Atlus and Koei Tecmo were taking this approach with the Persona series, I certainly had my doubts, but after spending five hours playing the opening to Persona 5 Strikers (know as Persona 5 Scramble: The Phantom Strikers in Japan in 2020), the genre has been smashed wide open.</p>
<p>Six months after the events of <a href="https://www.godisageek.com/reviews/persona-5-review/">Persona 5</a>, Joker, Ryuji, Ann, and Morgana find themselves back in Yongen-Jaya to reunite with their old friends before heading out on a summer vacation. Unfortunately, things don&#8217;t quite go as planned. Before they can enjoy their time together, the Phantom Thieves have to team up to save the heart of pop idol Alice Hiragi, who has been corrupting men in the real world, turning them into lovesick puppies who are acting incredibly suspiciously. At first, it feels like a natural sequel to Persona 5, with many of the same features available to you, but once it opens up and you start fighting Shadows, you&#8217;re in for a different battle altogether.</p>
<p><img class="aligncenter size-full wp-image-245975" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2.jpg" alt="Persona 5 Strikers Combat" width="1872" height="1053" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2.jpg 1872w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-2-640x360.jpg 640w" sizes="(max-width: 1872px) 100vw, 1872px" /></p>
<p>Much like <a href="https://www.godisageek.com/reviews/yakuza-like-a-dragon-review/">Yakuza: Like a Dragon</a>, exploring Shibuya, visiting the Velvet Room, and travelling through Jails (Palaces in P5) feels similar to previous entries in the series, but the combat is different in many ways. Instead of turn-based action, you&#8217;re now involved in frantic-yet controlled Musou battles that are layered with many fighting choices at your disposal. There&#8217;s the standard hack-and-slash approach where you&#8217;ll fight hundreds of shadows at any one time. On top of this, however, is the implementation of Personas, using the environment to gain an advantage, and more.</p>
<p>To use your Personas in battle, you can press R1 to brings them all up and momentarily pauses the action. From here, you can select who you want to use as well as the desired attack, then send them into battle and unfreezing the action. All Shadows have weaknesses much like before, so using the correct move can help to drastically reduce their health. You can also use vantage points scattered around the Jails to attack from higher up. Pressing Circle when prompted can see you jump on top of a lamp post or building ledge, and from their you can attack by pressing Triangle to unleash a spinning strike. There are other places where the environment can be used to your advantage, such as confetti canons and skateboard-type attacks.</p>
<p><img class="aligncenter size-full wp-image-245976" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1.jpg" alt="Persona 5 Strikers Dialogue" width="1872" height="1053" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1.jpg 1872w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-1-640x360.jpg 640w" sizes="(max-width: 1872px) 100vw, 1872px" /></p>
<p>Showtime returns from <a href="https://www.godisageek.com/reviews/persona-5-royal-review/">Persona 5 Royal</a>. These are highly efficient attacks where all members of your party unite to do significant damage to your enemies. You can also initiate All-Out Attacks after weakening an enemy enough (after connecting with 1More, also returning from P5), but this time they happen within the flow of a battle. You can usually unlock and All-Out Attack if you manage to ambush Shadows by approaching them without detection as well, meaning it&#8217;s still worthwhile to be stealthy when traversing the Metaverse.</p>
<p>Every character from Persona 5 can be used in your party of four by selecting them before entering a Jail, or at one of the many checkpoints found whilst exploring. Yusuke, Makoto, Futaba, and Haru are all playable so far, each with their own unique skill in battle. New playable character Sophia becomes vastly important early on. She&#8217;s an AI that appears as a human in the Jail, using yoyos to attack from a distance. Having the option to switch in and out pretty frequently helps you to mix up combat options, and hey, who doesn&#8217;t love Matt Mercer&#8217;s snobby representation of Yusuke, right?</p>
<p>Although I&#8217;ve only played a small part of Persona 5 Strikers, I think the combat is excellent, but on top of that, the story has hooked me as well. It&#8217;s hard to think that after hundreds of hours of narrative in P5 there would be much left to say, but the inclusion of shady police officer Zenkichi Hasegawa, and the mystery of these new Shadows appearing across Japan has left me more than excited to find out what&#8217;s going on. It&#8217;s also a gorgeous game, oozing that same slick style as seen in P5, with additional animations and short and sweet anime cutscenes that look great.</p>
<p><img class="aligncenter size-full wp-image-245974" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3.jpg" alt="Persona 5 Strikers All-Out Attack" width="1872" height="1053" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3.jpg 1872w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-3-640x360.jpg 640w" sizes="(max-width: 1872px) 100vw, 1872px" /></p>
<p>As mentioned, Alice&#8217;s reasons for being the way she is tug at the heartstrings, reminding you of the darker undertones Persona stories have. After the Shibuya Jail, my time with the preview had to come to an end, leaving me impatiently waiting to see what happens next. Persona 5 Strikers doesn&#8217;t feel like an unnecessary sequel, rather a fresh way to take what made P5 special and expand upon it. I&#8217;ve yet to see Requests, how Bonds properly help within battle, or what travelling across Japan feels like, but these are all things I&#8217;m looking forward to discovering.</p>
<p>Persona 5 Strikers is shaping up to be a worthy sequel to P5, with a refreshing combat pattern filled with plenty of options to wipe out the Shadows. I&#8217;m happy to spend time with my friends once again, even if it means Japan is once again in trouble. Whilst you don&#8217;t have the same level of freedom as in Persona 5, I quite enjoy the fact Strikers has been streamlined somewhat. It is the combat that makes this a must play, and a storyline that feels different in a good way. If you&#8217;re sleeping on Strikers, I encourage you to wake up, don your mask, and get ready to jump back into the world of the Phantom Thieves.</p>
<p><iframe width="560" height="315" src="https://www.youtube.com/embed/bR6hFabpp9M" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p><em>Persona 5 Strikers is out on February 23, 2021 on PC, Switch and PS4.</em></p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Persona 5 Strikers has the best combat in the series | Hands-on Preview' data-link='https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/' data-summary='The Phantom Thieves are back!' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Persona 5 Strikers has the best combat in the series | Hands-on Preview' data-link='https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/' data-summary='The Phantom Thieves are back!' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/previews/" title="View all posts in Previews">Previews</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/atlus/" title="Atlus Tag" class="atlus">Atlus</a><a href="https://www.godisageek.com/tag/koei-tecmo/" title="Koei Tecmo Tag" class="koei-tecmo">Koei Tecmo</a><a href="https://www.godisageek.com/tag/persona-5/" title="Persona 5 Tag" class="persona-5">Persona 5</a><a href="https://www.godisageek.com/tag/persona-5-strikers/" title="Persona 5 Strikers Tag" class="persona-5-strikers">Persona 5 Strikers</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><img alt='' src='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><h3>Chris White</h3></a>Video games are cool. Don't let anybody tell you any different.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/http://twitter.com/firstavenger83" target="_blank"></a><a class="icon-facebook info" title="Find me on Facebook" href="http://www.facebook.com/http://facebook.com/christopherppwhitepoet" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:chris@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="3330" data-method="tags" class="info active" title="More articles tagged: Atlus">Atlus<span class="bottom-arrow"></span></a><a data-sorter="12616" data-method="tags" class="info" title="More articles tagged: Koei Tecmo">Koei Tecmo<span class="bottom-arrow"></span></a><a data-sorter="8228" data-method="tags" class="info" title="More articles tagged: Persona 5">Persona 5<span class="bottom-arrow"></span></a><a data-sorter="27776" data-method="tags" class="info" title="More articles tagged: Persona 5 Strikers">Persona 5 Strikers<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/13-sentinels-aegis-rim-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2020-06-16_00022-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="13 Sentinels: Aegis Rim" title="13 Sentinels: Aegis Rim review" srcset="https://www.godisageek.com/wp-content/uploads/2020-06-16_00022-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2020-06-16_00022-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2020-06-16_00022-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2020-06-16_00022-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/13-sentinels-aegis-rim-review/">13 Sentinels: Aegis Rim review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/13-sentinels-aegis-rim-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Catherine: Full Body Switch review | Switch Re:port" srcset="https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/catherine-full-body-switch-review-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/">Catherine: Full Body Switch review | Switch Re:port</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/catherine-full-body-switch-review-switch-report/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/06/13-sentinels-aegis-rim-is-heading-to-ps4/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sentinels-Aegis-Rim-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="13 Sentinels: Aegis Rim" title="13 Sentinels: Aegis Rim is heading to PS4" srcset="https://www.godisageek.com/wp-content/uploads/Sentinels-Aegis-Rim-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sentinels-Aegis-Rim-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sentinels-Aegis-Rim-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Sentinels-Aegis-Rim-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/06/13-sentinels-aegis-rim-is-heading-to-ps4/">13 Sentinels: Aegis Rim is heading to PS4</a></div><a class="hover-link" href="https://www.godisageek.com/2020/06/13-sentinels-aegis-rim-is-heading-to-ps4/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/persona-4-golden-pc-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona-4-Golden-PC-review" title="Persona 4 Golden PC review" srcset="https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Persona-4-Golden-feature-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-4-golden-pc-review/">Persona 4 Golden PC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-4-golden-pc-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/05/catherine-full-body-is-available-to-pre-order-on-the-eshop/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Catherine - Full Body" title="Catherine: Full Body is available to pre-order on the eShop" srcset="https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Catherine-Full-Body-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/05/catherine-full-body-is-available-to-pre-order-on-the-eshop/">Catherine: Full Body is available to pre-order on the eShop</a></div><a class="hover-link" href="https://www.godisageek.com/2020/05/catherine-full-body-is-available-to-pre-order-on-the-eshop/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/03/catherine-full-body-coming-to-nintendo-switch-this-july/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Catherine: Full Body coming to Nintendo Switch this July" srcset="https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Catherine-full-body-switch-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/03/catherine-full-body-coming-to-nintendo-switch-this-july/">Catherine: Full Body coming to Nintendo Switch this July</a></div><a class="hover-link" href="https://www.godisageek.com/2020/03/catherine-full-body-coming-to-nintendo-switch-this-july/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Persona 5 Strikers Preview" title="Persona 5 Strikers has the best combat in the series | Hands-on Preview" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-preview-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">Persona 5 Strikers has the best combat in the series | Hands-on Preview</a><div class="article-meta clearfix"><a class="like-button do-like 245973 info-bottom" data-postid="245973" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/01/persona-5-strikers-scramble-english-language-gameplay-ps4-ps5-switch-pc/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders PC Specs" title="PC specs for Outriders detailed in new video" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-PC-Specs-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/">PC specs for Outriders detailed in new video</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/pc-specs-for-outriders-detailed-in-new-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/new-pokemon-snap-will-launch-on-april-30/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokémon Snap" title="New Pokémon Snap will launch on April 30" srcset="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/new-pokemon-snap-will-launch-on-april-30/">New Pokémon Snap will launch on April 30</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/new-pokemon-snap-will-launch-on-april-30/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/captain-tsubasa-demo/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Captain Tsubasa demo" title="New Captain Tsubasa demo is available to download now" srcset="https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/CAPTAIN_TSUBASA_RONC__Screenshot_05-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/captain-tsubasa-demo/">New Captain Tsubasa demo is available to download now</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/captain-tsubasa-demo/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/release-date-announced-for-first-a-total-war-saga-troy-dlc/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Total War Saga: Troy DLC" title="Release date announced for first A Total War Saga: Troy DLC" srcset="https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Total-War-Saga-Troy-DLC-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/release-date-announced-for-first-a-total-war-saga-troy-dlc/">Release date announced for first A Total War Saga: Troy DLC</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/release-date-announced-for-first-a-total-war-saga-troy-dlc/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/mxgp-2020-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="MXGP 2020 review" title="MXGP 2020 review" srcset="https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/mxgp-2020-review/">MXGP 2020 review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 245905 info-bottom" data-postid="245905" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/mxgp-2020-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Scott Pilgrim vs the World: The Game - Complete Edition Review" title="Scott Pilgrim vs the World: The Game &#8211; Complete Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/">Scott Pilgrim vs the World: The Game &#8211; Complete Edition review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Hong Kong Massacre Review" title="The Hong Kong Massacre review" srcset="https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/">The Hong Kong Massacre review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turtle Beach Stealth 700 Gen 2 review" title="Turtle Beach Stealth 700 Gen 2 review" srcset="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">Turtle Beach Stealth 700 Gen 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/grindstone-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Grindstone title image" title="Grindstone review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/grindstone-review/">Grindstone review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/grindstone-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video</a><div class="article-meta clearfix"><a class="like-button do-like 245444 info-bottom" data-postid="245444" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Assassin&#039;s Creed Valhalla could be the best in the series" title="Assassin&#8217;s Creed Valhalla could be the best in the series" srcset="https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Assassins-Creed-Valhalla-could-be-the-best-in-the-series-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">Assassin&#8217;s Creed Valhalla could be the best in the series</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/assassins-creed-valhalla-could-be-the-best-in-the-series/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/grindstone-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Grindstone title image" title="Grindstone review" srcset="https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/grindstone-review/">Grindstone review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 245575 info-bottom" data-postid="245575" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/grindstone-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/exit-the-gungeon-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/exit-the-gungeon-switch-hero-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Exit the Gungeon Hello to Arms" title="Exit the Gungeon review" srcset="https://www.godisageek.com/wp-content/uploads/exit-the-gungeon-switch-hero-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/exit-the-gungeon-switch-hero-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/exit-the-gungeon-switch-hero-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/exit-the-gungeon-switch-hero-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/exit-the-gungeon-review/">Exit the Gungeon review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/exit-the-gungeon-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turtle Beach Stealth 700 Gen 2 review" title="Turtle Beach Stealth 700 Gen 2 review" srcset="https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">Turtle Beach Stealth 700 Gen 2 review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/doom-eternal-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Doom-Eternal-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Doom Eternal Nintendo Switch review" title="Doom Eternal Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Doom-Eternal-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Doom-Eternal-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Doom-Eternal-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Doom-Eternal-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/doom-eternal-nintendo-switch-review/">Doom Eternal Nintendo Switch review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/doom-eternal-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/alba-a-wildlife-adventure-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/f0be91e4-a770-4c95-862c-89dcefb40017_ss_7327afc8ad6742758acf8574df5330fdabf016b7.1920x1080-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Alba: A Wildlife Adventure" title="Alba: A Wildlife Adventure review" srcset="https://www.godisageek.com/wp-content/uploads/f0be91e4-a770-4c95-862c-89dcefb40017_ss_7327afc8ad6742758acf8574df5330fdabf016b7.1920x1080-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/f0be91e4-a770-4c95-862c-89dcefb40017_ss_7327afc8ad6742758acf8574df5330fdabf016b7.1920x1080-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/f0be91e4-a770-4c95-862c-89dcefb40017_ss_7327afc8ad6742758acf8574df5330fdabf016b7.1920x1080-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/f0be91e4-a770-4c95-862c-89dcefb40017_ss_7327afc8ad6742758acf8574df5330fdabf016b7.1920x1080-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/alba-a-wildlife-adventure-review/">Alba: A Wildlife Adventure review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/alba-a-wildlife-adventure-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MGXP-2020-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/mxgp-2020-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">MXGP 2020 review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Scott-Pilgrim-vs-the-World-The-Game-Complete-Edition-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/scott-pilgrim-vs-the-world-the-game-complete-edition-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Scott Pilgrim vs the World: The Game &#8211; Complete Edition review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Hong-Kong-Massacre-1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/the-hong-kong-massacre-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.0</div></div></div><div class="article-info">The Hong Kong Massacre review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/turtle-beach-stealth-700-gen-2-xbox-series-x-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/turtle-beach-stealth-700-gen-2-xbox-series-x-s-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Turtle Beach Stealth 700 Gen 2 review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Switch_Grindstone_Hero-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/grindstone-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div><div class="article-info">Grindstone review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/apps.45122.13543559389560526.b9ad9e77-e97a-4533-863a-996226cb2eac-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/tears-of-avia-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">4.0</div></div></div><div class="article-info">Tears of Avia review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-19179" class="widget clearfix widget_links"><div class="header clearfix">Reviews</div>
	<ul class='xoxo blogroll'>
<li><a href="http://www.godisageek.com/category/reviews/" title="Latest Reviews">Latest Reviews</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PC Game reviews">PC</a></li>
<li><a href="http://www.godisageek.com/category/reviews/ps4-reviews/" title="PS4 Reviews">PS4</a></li>
<li><a href="http://www.godisageek.com/category/reviews/wiiu/" title="Wii U Reviews">Wii U</a></li>
<li><a href="http://www.godisageek.com/category/reviews/xb1-reviews/" title="Xbox One reviews">Xbox One</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="linkcat-15983" class="widget clearfix widget_links"><div class="header clearfix">Video Shows</div>
	<ul class='xoxo blogroll'>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCv3fPEF6jsb-vrSa9_nj_k">Blindfold Gaming</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDshNxUq0Oxtn9AJ5nsX_7x">Debatable</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCm9pvpA9PZMCoflKNC7wAs">Family Gamer</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJBy9G4Pf3O-lZ5wHdbeWydG">For Your Amusement</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAYKXagyVxNsvE_GWSHLfJv">NewsRound</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJDOscOwQGihsQavELpjmIa9">Reasons to be Cheerful</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJCenkgHTFCRtkJQKb_A63XO">Score Attack</a></li>
<li><a href="https://www.youtube.com/playlist?list=PLQ4rnAy-GwJAdtnxg1rfgjui13eHqm1hn">The Retrocast</a></li>

	</ul>
</div>
<div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
<!-- WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory. -->