<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>GeForce NOW adds eight new titles, including Genshin Impact | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="GeForce NOW has extended its library to feature eight new games for Mac users, including Genshin Impact and Car Mechanic Simulator 2018." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="GeForce NOW adds eight new titles, including Genshin Impact | GodisaGeek.com" />
	<meta property="og:description" content="GeForce NOW has extended its library to feature eight new games for Mac users, including Genshin Impact and Car Mechanic Simulator 2018." />
	<meta property="og:url" content="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:author" content="http://facebook.com/christopherppwhitepoet" />
	<meta property="article:published_time" content="2022-06-24T12:55:10+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg" />
	<meta property="og:image:width" content="740" />
	<meta property="og:image:height" content="416" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg","width":740,"height":416,"caption":"GeForce NOW new games news"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#webpage","url":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/","name":"GeForce NOW adds eight new titles, including Genshin Impact | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#primaryimage"},"datePublished":"2022-06-24T12:55:10+00:00","dateModified":"2022-06-24T12:55:10+00:00","description":"GeForce NOW has extended its library to feature eight new games for Mac users, including Genshin Impact and Car Mechanic Simulator 2018.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646"},"headline":"GeForce NOW adds eight new titles, including Genshin Impact","datePublished":"2022-06-24T12:55:10+00:00","dateModified":"2022-06-24T12:55:10+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/#primaryimage"},"keywords":"geforce now,Genshin Impact,nvidia","articleSection":"News","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/2787838b81bac62608c748f9a1e47646","name":"Chris White","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=96&d=mm&r=g","caption":"Chris White"},"description":"Video games are cool. Don't let anybody tell you any different.","sameAs":["http://facebook.com/christopherppwhitepoet","https://twitter.com/http://twitter.com/firstavenger83"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"06","day":"24","hour":"13","minute":"55","second":"10","post_id":"264565","postname":"geforce-now-adds-eight-new-titles-including-genshin-impact","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/' />
<meta name='shareaholic:keywords' content='tag:geforce now, tag:genshin impact, tag:nvidia, cat:news, type:post' />
<meta name='shareaholic:article_published_time' content='2022-06-24T13:55:10+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-06-24T13:55:10+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris White' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=264565' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F06%2Fgeforce-now-adds-eight-new-titles-including-genshin-impact%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F06%2Fgeforce-now-adds-eight-new-titles-including-genshin-impact%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '396984a9f7'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/"},"headline":"GeForce NOW adds eight new titles, including Genshin Impact","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg","width":740,"height":416},"datePublished":"2022-06-24T13:55:10+0000","dateModified":"2022-06-24T13:55:10+0000","author":{"@type":"Person","name":"Chris White","url":"https://www.godisageek.com/author/antonettamccarty/chris-white"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}}}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/06\/geforce-now-adds-eight-new-titles-including-genshin-impact\/","name":"GeForce NOW adds eight new titles, including Genshin Impact"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-264565 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/cloud-gardens-review/">Cloud Gardens review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cloud Gardens title image" title="Cloud Gardens review" srcset="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">Shadowrun Trilogy: Console Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shadowrun Trilogy Console Edition" title="Shadowrun Trilogy: Console Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">Capcom Fighting Collection review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Capcom Fighting Collection review" title="Capcom Fighting Collection review" srcset="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">Fire Emblem Warriors: Three Hopes review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes review" title="Fire Emblem Warriors: Three Hopes review" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">Disgaea 6 Complete review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Disgaea 6 Complete review" srcset="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dead-by-daylight-roots-of-dread/">Dead by Daylight: Roots of Dread review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dead by Daylight Roots of Dread" title="Dead by Daylight: Roots of Dread review" srcset="https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/tinykin-is-one-of-the-highlists-of-the-idxbox-2022-demo-event/">Tinykin is one of the highlights of the ID@Xbox 2022 demo event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tinykin title image" title="Tinykin is one of the highlights of the ID@Xbox 2022 demo event" srcset="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-has-made-huge-changes-for-its-xbox-launch/">Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Naraka: Bladepoint" title="Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview" srcset="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/podcast-490-the-quarry-tmnt-shredders-revenge-freezer-pops/">Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 490: The Quarry, TMNT: Shredder&#039;s Revenge, Freezer Pops" title="Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/final-fight-and-streets-of-rage-1-and-2-were-pretty-much-the-benchmark-an-interview-with-mike-tucker-of-bitmap-bureau-on-final-vendetta/">&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="&quot;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&quot;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" title="&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" srcset="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/gerda-a-flame-in-winter-interview-we-put-a-lot-of-ourselves-in-the-game/">Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda Interview" title="Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/lightyear-frontier-combines-mech-piloting-with-farming/">Lightyear Frontier combines mech-piloting with farming, and we&#8217;re here for it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lightyear Frontier title image" title="Lightyear Frontier combines mech-piloting with farming, and we&#8217;re here for it" srcset="https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/">Naraka Bladepoint | Characters Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naraka Bladepoint Characters" title="Naraka Bladepoint | Characters Guide" srcset="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-evidence-guide/">The Quarry | Evidence guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Evidence" title="The Quarry | Evidence guide" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-keep-everyone-alive/">The Quarry | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Keep Everyone Alive" title="The Quarry | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-get-the-bizarre-yet-bonafide-achievement/">The Quarry | How to get the Bizarre yet Bonafide achievement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Bizarre yet Bonafide" title="The Quarry | How to get the Bizarre yet Bonafide achievement" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-kill-everyone/">The Quarry | How to kill everyone<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry kill everyone" title="The Quarry | How to kill everyone" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/evil-dead-the-game-beginners-tips/">Evil Dead: The Game | Beginners Tips to get you started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Dead: The Game | Beginners Tips to get you started" title="Evil Dead: The Game | Beginners Tips to get you started" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/five-nights-at-freddys-security-breach-coming-to-xbox-this-year/">Five Nights at Freddy’s: Security Breach coming to Xbox this year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Five Nights at Freddy&#039;s Security Breach Xbox news" title="Five Nights at Freddy’s: Security Breach coming to Xbox this year" srcset="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/air-twister-launches-today-on-apple-arcade/">Air Twister launches today on Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Air Twister" title="Air Twister launches today on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/sonic-origins-is-out-now-on-pc-and-consoles/">Sonic Origins is out now on PC and consoles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Origins" title="Sonic Origins is out now on PC and consoles" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/">A Plague Tale: Requiem gets an October release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale Requiem release date news" title="A Plague Tale: Requiem gets an October release date" srcset="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/">GeForce NOW adds eight new titles, including Genshin Impact<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GeForce NOW new games news" title="GeForce NOW adds eight new titles, including Genshin Impact" srcset="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/no-mans-sky-nintendo-switch-version-coming-october/">No Man&#8217;s Sky Nintendo Switch version coming October<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No Man&#039;s Sky Switch News" title="No Man&#8217;s Sky Nintendo Switch version coming October" srcset="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/cloud-gardens-review/">Cloud Gardens review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cloud Gardens title image" title="Cloud Gardens review" srcset="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">Shadowrun Trilogy: Console Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shadowrun Trilogy Console Edition" title="Shadowrun Trilogy: Console Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">Capcom Fighting Collection review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Capcom Fighting Collection review" title="Capcom Fighting Collection review" srcset="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">Fire Emblem Warriors: Three Hopes review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes review" title="Fire Emblem Warriors: Three Hopes review" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">Disgaea 6 Complete review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Disgaea 6 Complete review" srcset="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dead-by-daylight-roots-of-dread/">Dead by Daylight: Roots of Dread review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dead by Daylight Roots of Dread" title="Dead by Daylight: Roots of Dread review" srcset="https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ezgif-4-b8809d63a5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/tinykin-is-one-of-the-highlists-of-the-idxbox-2022-demo-event/">Tinykin is one of the highlights of the ID@Xbox 2022 demo event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tinykin title image" title="Tinykin is one of the highlights of the ID@Xbox 2022 demo event" srcset="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-has-made-huge-changes-for-its-xbox-launch/">Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Naraka: Bladepoint" title="Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview" srcset="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/podcast-490-the-quarry-tmnt-shredders-revenge-freezer-pops/">Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 490: The Quarry, TMNT: Shredder&#039;s Revenge, Freezer Pops" title="Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/final-fight-and-streets-of-rage-1-and-2-were-pretty-much-the-benchmark-an-interview-with-mike-tucker-of-bitmap-bureau-on-final-vendetta/">&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="&quot;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&quot;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" title="&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" srcset="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/gerda-a-flame-in-winter-interview-we-put-a-lot-of-ourselves-in-the-game/">Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda Interview" title="Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/lightyear-frontier-combines-mech-piloting-with-farming/">Lightyear Frontier combines mech-piloting with farming, and we&#8217;re here for it<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Lightyear Frontier title image" title="Lightyear Frontier combines mech-piloting with farming, and we&#8217;re here for it" srcset="https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/lightyear-frontier-release-date-trailers-gameplay-everything-we-know-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/">Naraka Bladepoint | Characters Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naraka Bladepoint Characters" title="Naraka Bladepoint | Characters Guide" srcset="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-evidence-guide/">The Quarry | Evidence guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Evidence" title="The Quarry | Evidence guide" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-keep-everyone-alive/">The Quarry | How to keep everyone alive<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Keep Everyone Alive" title="The Quarry | How to keep everyone alive" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-get-the-bizarre-yet-bonafide-achievement/">The Quarry | How to get the Bizarre yet Bonafide achievement<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry Bizarre yet Bonafide" title="The Quarry | How to get the Bizarre yet Bonafide achievement" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/the-quarry-how-to-kill-everyone/">The Quarry | How to kill everyone<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry kill everyone" title="The Quarry | How to kill everyone" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/evil-dead-the-game-beginners-tips/">Evil Dead: The Game | Beginners Tips to get you started<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Dead: The Game | Beginners Tips to get you started" title="Evil Dead: The Game | Beginners Tips to get you started" srcset="https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/five-nights-at-freddys-security-breach-coming-to-xbox-this-year/">Five Nights at Freddy’s: Security Breach coming to Xbox this year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Five Nights at Freddy&#039;s Security Breach Xbox news" title="Five Nights at Freddy’s: Security Breach coming to Xbox this year" srcset="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/air-twister-launches-today-on-apple-arcade/">Air Twister launches today on Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Air Twister" title="Air Twister launches today on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/sonic-origins-is-out-now-on-pc-and-consoles/">Sonic Origins is out now on PC and consoles<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Origins" title="Sonic Origins is out now on PC and consoles" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/">A Plague Tale: Requiem gets an October release date<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale Requiem release date news" title="A Plague Tale: Requiem gets an October release date" srcset="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/">GeForce NOW adds eight new titles, including Genshin Impact<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GeForce NOW new games news" title="GeForce NOW adds eight new titles, including Genshin Impact" srcset="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/no-mans-sky-nintendo-switch-version-coming-october/">No Man&#8217;s Sky Nintendo Switch version coming October<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="No Man&#039;s Sky Switch News" title="No Man&#8217;s Sky Nintendo Switch version coming October" srcset="https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/No-Mans-Sky-Switch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/06/no-mans-sky-nintendo-switch-version-coming-october/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">No Man's Sky Nintendo Switch version coming October</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2021/09/tales-of-arise-how-to-redeem-dlc-content/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">A Plague Tale: Requiem gets an October release date</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-264565" class="post-264565 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-geforce-now tag-genshin-impact tag-nvidia" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                GeForce NOW adds eight new titles, including Genshin Impact                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-white/"><span itemprop="author">Chris White </span></a></span><span class="date">on <meta itemprop="datePublished" content="June 24, 2022">June 24, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg"><img width="740" height="416" src="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="GeForce NOW new games news" title="GeForce NOW adds eight new titles, including Genshin Impact" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news.jpg 740w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-360x202.jpg 360w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-640x360.jpg 640w" sizes="(max-width: 740px) 100vw, 740px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='GeForce NOW adds eight new titles, including Genshin Impact' data-link='https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/' data-summary='New games coming to the Mac streaming service' data-app-id-name='post_above_content'></div>
<p><a href="https://blogs.nvidia.com/blog/2022/06/16/geforce-now-thursday-june-16/" target="_blank" rel="noopener noreferrer">GeForce NOW</a> has extended its library to feature eight new games for Mac users, including <a href="https://www.godisageek.com/2022/05/new-genshin-impact-version-2-7-update-brings-a-new-quest-characters-and-a-drumming-game/" target="_blank" rel="noopener noreferrer">Genshin Impact</a> and Car Mechanic Simulator 2018. For those that might not be familiar with the service, it allows Mac users to stream PC versions of games straight from the cloud.</p>
<p>GeForce NOW RTX 3080 members can play on M1 Mac laptops at up to 1600p or 4K resolution on supported displays, for sessions up to eight hours. Along with the Priority plan, players can play with RTX ON for certain supported games like Cyberpunk 2077 and control with real-time ray tracing.</p>
<p>Game saves are synced across each digital store, so those playing on Macs can carry progression across any supported devices. It also means games remain updated with the latest DLC, patches, and expansions. With the addition of Genshin Impact, players can earn rewards through GeForce NOW, such as a starter kit for anyone who opted in to receive rewards by visiting the NVIDIA Rewards redemption portal.</p>
<p>The starter kit comes with 10,000 Mora, five Fine Enhancement Ores, three Squirrel Fish and Northern Apple Stews, along with 10 Adventurer&#8217;s Experience points to level up their characters. All players need to do is log into their NVIDIA account and select &#8216;GEFORCE NOW&#8217; from the header, scroll down to &#8216;REWARDS.&#8217; and click &#8216;UPDATE REWARD SETTINGS.&#8217; Then, check the box in the dialogue window to start receiving all the goodies.</p>
<p>The complete list of all eight games added to GeForce NOW are as follows:</p>
<p>● Car Mechanic Simulator 2018 (Free on Epic Games Store, June 23-30)<br />
● Airborne Kingdom (Steam)<br />
● Fishing: North Atlantic (Steam)<br />
● Genshin Impact (Native Launcher)<br />
● Immortal Life (Steam)<br />
● King Arthur: Knight&#8217;s Tale (Steam)<br />
● SimAirport (Steam)<br />
● Skeleton Crew (Steam)</p>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='GeForce NOW adds eight new titles, including Genshin Impact' data-link='https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/' data-summary='New games coming to the Mac streaming service' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='GeForce NOW adds eight new titles, including Genshin Impact' data-link='https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/' data-summary='New games coming to the Mac streaming service' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/geforce-now/" title="geforce now Tag" class="geforce-now">geforce now</a><a href="https://www.godisageek.com/tag/genshin-impact/" title="Genshin Impact Tag" class="genshin-impact">Genshin Impact</a><a href="https://www.godisageek.com/tag/nvidia/" title="nvidia Tag" class="nvidia">nvidia</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><img alt='' src='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/81109e5c951eba4ecb54e1a4f84c097d?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-white/"><h3>Chris White</h3></a>Video games are cool. Don't let anybody tell you any different.<div class="author-profile-fields"><a class="icon-twitter info" title="Find me on Twitter" href="http://twitter.com/http://twitter.com/firstavenger83" target="_blank"></a><a class="icon-facebook info" title="Find me on Facebook" href="http://www.facebook.com/http://facebook.com/christopherppwhitepoet" target="_blank"></a><a class="icon-email info" title="E-mail Me" href="mailto:chris@godisageek.com"></a><a class="icon-globe info" title="My Website" href="http://godisageek.com" target="_blank"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="20862" data-method="tags" class="info active" title="More articles tagged: geforce now">geforce now<span class="bottom-arrow"></span></a><a data-sorter="27516" data-method="tags" class="info" title="More articles tagged: Genshin Impact">Genshin Impact<span class="bottom-arrow"></span></a><a data-sorter="973" data-method="tags" class="info" title="More articles tagged: nvidia">nvidia<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/12/gog-version-of-cyberpunk-2077-to-be-supported-via-geforce-now/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/cyberpunk2077-credit-cdprojektred@2000x1270-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOG Cyberpunk GeForce NOWW" title="GOG version of Cyberpunk 2077 to be supported via GeForce NOW" srcset="https://www.godisageek.com/wp-content/uploads/cyberpunk2077-credit-cdprojektred@2000x1270-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/cyberpunk2077-credit-cdprojektred@2000x1270-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/cyberpunk2077-credit-cdprojektred@2000x1270-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/cyberpunk2077-credit-cdprojektred@2000x1270-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/12/gog-version-of-cyberpunk-2077-to-be-supported-via-geforce-now/">GOG version of Cyberpunk 2077 to be supported via GeForce NOW</a></div><a class="hover-link" href="https://www.godisageek.com/2020/12/gog-version-of-cyberpunk-2077-to-be-supported-via-geforce-now/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2017/10/geforce-mac-beta-europe/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/geforce-now-pubg-mac-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="The GeForce NOW Mac Beta is now available in Europe" srcset="https://www.godisageek.com/wp-content/uploads/geforce-now-pubg-mac-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/geforce-now-pubg-mac-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/geforce-now-pubg-mac-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/geforce-now-pubg-mac-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2017/10/geforce-mac-beta-europe/">The GeForce NOW Mac Beta is now available in Europe</a></div><a class="hover-link" href="https://www.godisageek.com/2017/10/geforce-mac-beta-europe/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/five-nights-at-freddys-security-breach-coming-to-xbox-this-year/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Five Nights at Freddy&#039;s Security Breach Xbox news" title="Five Nights at Freddy’s: Security Breach coming to Xbox this year" srcset="https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Five-Nights-at-Freddys-Security-Breach-Xbox-news-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/five-nights-at-freddys-security-breach-coming-to-xbox-this-year/">Five Nights at Freddy’s: Security Breach coming to Xbox this year</a><div class="article-meta clearfix"><a class="like-button do-like 264585 info-bottom" data-postid="264585" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/06/five-nights-at-freddys-security-breach-coming-to-xbox-this-year/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/air-twister-launches-today-on-apple-arcade/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Air Twister" title="Air Twister launches today on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Air-Twister-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Air-Twister-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/air-twister-launches-today-on-apple-arcade/">Air Twister launches today on Apple Arcade</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/air-twister-launches-today-on-apple-arcade/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/sonic-origins-is-out-now-on-pc-and-consoles/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Origins" title="Sonic Origins is out now on PC and consoles" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/sonic-origins-is-out-now-on-pc-and-consoles/">Sonic Origins is out now on PC and consoles</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/sonic-origins-is-out-now-on-pc-and-consoles/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale Requiem release date news" title="A Plague Tale: Requiem gets an October release date" srcset="https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/A-Plague-Tale-Requiem-release-date-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/">A Plague Tale: Requiem gets an October release date</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/a-plague-tale-requiem-gets-an-october-release-date/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GeForce NOW new games news" title="GeForce NOW adds eight new titles, including Genshin Impact" srcset="https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/GeForce-NOW-new-games-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/">GeForce NOW adds eight new titles, including Genshin Impact</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/geforce-now-adds-eight-new-titles-including-genshin-impact/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cloud-gardens-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Cloud Gardens title image" title="Cloud Gardens review" srcset="https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cloud-Gardens-Switch_05-26-22-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cloud-gardens-review/">Cloud Gardens review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">6.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 264472 info-bottom" data-postid="264472" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/cloud-gardens-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shadowrun Trilogy Console Edition" title="Shadowrun Trilogy: Console Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shadowrun-main-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">Shadowrun Trilogy: Console Edition review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Capcom Fighting Collection review" title="Capcom Fighting Collection review" srcset="https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Capcom-Fighting-Collection-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">Capcom Fighting Collection review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes review" title="Fire Emblem Warriors: Three Hopes review" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">Fire Emblem Warriors: Three Hopes review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/disgaea-6-complete-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Disgaea 6 Complete review" srcset="https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/D6C-Ann_02-10-22-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">Disgaea 6 Complete review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares</a><div class="article-meta clearfix"><a class="like-button do-like 264061 info-bottom" data-postid="264061" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage</a></div><a class="hover-link" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/arcade-spirits-the-new-challengers-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_ArcadeSpiritsTheNewChallengers-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Arcade Spirits: The New Challengers title image" title="Arcade Spirits: The New Challengers review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_ArcadeSpiritsTheNewChallengers-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_ArcadeSpiritsTheNewChallengers-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_ArcadeSpiritsTheNewChallengers-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_ArcadeSpiritsTheNewChallengers-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/arcade-spirits-the-new-challengers-review/">Arcade Spirits: The New Challengers review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 263700 info-bottom" data-postid="263700" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/arcade-spirits-the-new-challengers-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/card-shark-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-8-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Card Shark title image" title="Card Shark review" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-8-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-8-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-8-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-8-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/card-shark-review/">Card Shark review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/card-shark-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/teenage-mutant-ninja-turtles-shredders-revenge-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Teenage-Mutant-Ninja-Turtles-Shredders-Revenge-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Teenage Mutant Ninja Turtles: Shredder&#039;s Revenge review" title="Teenage Mutant Ninja Turtles: Shredder&#8217;s Revenge review" srcset="https://www.godisageek.com/wp-content/uploads/Teenage-Mutant-Ninja-Turtles-Shredders-Revenge-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Teenage-Mutant-Ninja-Turtles-Shredders-Revenge-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Teenage-Mutant-Ninja-Turtles-Shredders-Revenge-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Teenage-Mutant-Ninja-Turtles-Shredders-Revenge-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/teenage-mutant-ninja-turtles-shredders-revenge-review/">Teenage Mutant Ninja Turtles: Shredder&#8217;s Revenge review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/teenage-mutant-ninja-turtles-shredders-revenge-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neon-white-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Neon-White-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Neon White Review" title="Neon White review" srcset="https://www.godisageek.com/wp-content/uploads/Neon-White-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neon-white-review/">Neon White review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/neon-white-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-quarry-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry review" title="The Quarry review" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-quarry-review/">The Quarry review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-quarry-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Naraka Bladepoint | Characters Guide</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Quarry-Evidence-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/the-quarry-evidence-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">The Quarry | Evidence guide</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Quarry-Keep-Everyone-Alive-24-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/the-quarry-how-to-keep-everyone-alive/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">The Quarry | How to keep everyone alive</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Quarry-Bizarre-yet-Bonafide-6-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/the-quarry-how-to-get-the-bizarre-yet-bonafide-achievement/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">The Quarry | How to get the Bizarre yet Bonafide achievement</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/The-Quarry-kill-everyone-12-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/the-quarry-how-to-kill-everyone/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">The Quarry | How to kill everyone</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Evil-Dead-The-Game-beginners-tips-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/05/evil-dead-the-game-beginners-tips/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Evil Dead: The Game | Beginners Tips to get you started</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cloud-gardens-review/">Cloud Gardens review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cloud-gardens-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">Shadowrun Trilogy: Console Edition review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/shadowrun-trilogy-console-edition-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">Capcom Fighting Collection review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/capcom-fighting-collection-switch-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">Fire Emblem Warriors: Three Hopes review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/fire-emblem-warriors-three-hopes-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">Disgaea 6 Complete review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/disgaea-6-complete-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.234375px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.5625px;" aria-label="Activision (780 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.46875px;" aria-label="Bandai Namco (428 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.859375px;" aria-label="Capcom (717 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.640625px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.78125px;" aria-label="EA (1,169 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (409 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.515625px;" aria-label="Konami (569 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.4375px;" aria-label="Microsoft (940 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,789 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.265625px;" aria-label="nintendo switch (823 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.421875px;" aria-label="PC (1,394 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.375px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.875px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.078125px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.25px;" aria-label="PS4 (1,239 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.625px;" aria-label="Sega (700 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.671875px;" aria-label="Sony (961 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.4375px;" aria-label="square enix (937 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.640625px;" aria-label="Steam (477 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.390625px;" aria-label="Trailer (684 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.953125px;" aria-label="Ubisoft (1,311 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.296875px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.71875px;" aria-label="Xbox One (1,287 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.692307692308px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.230769230769px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12px;" aria-label="Competition (223 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.692307692308px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.307692307692px;" aria-label="Features (2,684 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 14.076923076923px;" aria-label="Guides (412 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (222 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.615384615385px;" aria-label="iOS (358 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (20,029 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.461538461538px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 15.230769230769px;" aria-label="Paid Placement Advertorials (584 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.769230769231px;" aria-label="PC (2,306 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.230769230769px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.769230769231px;" aria-label="PlayStation 4 (1,690 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.076923076923px;" aria-label="Podcasts (766 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.769230769231px;" aria-label="Previews (940 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.307692307692px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 22px;" aria-label="Reviews (4,489 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.538461538462px;" aria-label="Switch (867 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.692307692308px;" aria-label="Tech (273 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.923076923077px;" aria-label="Trailers (1,309 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13px;" aria-label="Uncategorised (298 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.076923076923px;" aria-label="Video Features (1,028 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.846153846154px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18px;" aria-label="Xbox One (1,361 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.8515625px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.1484375px;" aria-label="Android (83 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.2265625px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.16015625px;" aria-label="Google Stadia (25 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.39453125px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.14453125px;" aria-label="iOS (122 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.0390625px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.2265625px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.5703125px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,837 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.671875px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.765625px;" aria-label="PlayStation 4 (1,641 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 21.78515625px;" aria-label="PlayStation 5 (236 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.38671875px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.7890625px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.2421875px;" aria-label="Switch (910 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.4453125px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.79296875px;" aria-label="Xbox 360 (106 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.1796875px;" aria-label="Xbox One (1,303 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.375px;" aria-label="Xbox Series S (198 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 21.4921875px;" aria-label="Xbox Series X (208 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
