<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Crash Bandicoot 4: It&#039;s About Time on Switch is just as fun as it is on Sony&#039;s consoles, but it&#039;s just a little less glorious to look at." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review | GodisaGeek.com" />
	<meta property="og:description" content="Crash Bandicoot 4: It&#039;s About Time on Switch is just as fun as it is on Sony&#039;s consoles, but it&#039;s just a little less glorious to look at." />
	<meta property="og:url" content="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch.jpg","width":1920,"height":1080,"caption":"Crash Bandicoot 4: It's About Time Nintendo Switch review"},{"@type":"WebPage","@id":"https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/#webpage","url":"https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/","name":"Crash Bandicoot 4: It's About Time Nintendo Switch review | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/#primaryimage"},"datePublished":"2021-03-13T12:11:30+00:00","dateModified":"2021-03-13T12:11:30+00:00","description":"Crash Bandicoot 4: It's About Time on Switch is just as fun as it is on Sony's consoles, but it's just a little less glorious to look at.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/"]}]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//go.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"03","day":"13","hour":"12","minute":"11","second":"30","post_id":"247586","postname":"crash-bandicoot-4-its-about-time-nintendo-switch-review","category":"reviews"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/' />
<meta name='shareaholic:keywords' content='tag:activision, tag:crash bandicoot 4, tag:crash bandicoot 4: it&amp;#039;s about time, tag:naughty dog, tag:nintendo, tag:sony, tag:toys for bob, tag:crash bandicoot 4 it&amp;#039;s about time, cat:playstation 4, cat:playstation 5, cat:reviews, cat:switch, type:it_reviews' />
<meta name='shareaholic:article_published_time' content='2021-03-13T12:11:30+00:00' />
<meta name='shareaholic:article_modified_time' content='2021-03-13T12:11:30+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Mick Fraser' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.6.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=247586' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fcrash-bandicoot-4-its-about-time-nintendo-switch-review%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2Freviews%2Fcrash-bandicoot-4-its-about-time-nintendo-switch-review%2F&#038;format=xml" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="it_reviews-template-default single single-it_reviews postid-247586 it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/rust-set-to-arrive-on-ps4-and-xbox-one-this-spring/">Rust set to arrive on PS4 and Xbox One this Spring<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rust console release date news" title="Rust set to arrive on PS4 and Xbox One this Spring" srcset="https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/zynga-partners-with-girls-who-code-to-help-support-women-in-technology/">Zynga partners with Girls Who Code to help support women in technology<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Zynga Girls Who Code News" title="Zynga partners with Girls Who Code to help support women in technology" srcset="https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-genshin-impact-windblume-festival-is-coming-on-march-17/">The Genshin Impact Windblume Festival is coming on March 17<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Genshin Impact Windblume Festival" title="The Genshin Impact Windblume Festival is coming on March 17" srcset="https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/a-new-tales-of-arise-trailer-has-landed/">A new Tales of Arise trailer has landed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tales of Arise trailer" title="A new Tales of Arise trailer has landed" srcset="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/hoa-has-a-new-gameplay-trailer/">Hoa has a new gameplay trailer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hoa-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hoa trailer" title="Hoa has a new gameplay trailer" srcset="https://www.godisageek.com/wp-content/uploads/Hoa-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/heroic-expedition-coming-to-mobile-in-april/">Heroic Expedition coming to mobile in April<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Heroic Expedition" title="Heroic Expedition coming to mobile in April" srcset="https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/gnosia-review/">Gnosia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Gnosia title image" title="Gnosia review" srcset="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sir-lovalot-review/">Sir Lovalot review<img src="https://www.godisageek.com/wp-content/themes/steam/images/placeholder-35.png" alt="featured image" width="35" height="35" /></a><a href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">Monster Truck Championship next-gen review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Truck Championship next-gen review" title="Monster Truck Championship next-gen review" srcset="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">WRC 9 Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WRC 8 Switch review" title="WRC 9 Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sword-of-the-necromancer-review/">Sword of the Necromancer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/sword-cover-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sword of the Necromancer" title="Sword of the Necromancer review" srcset="https://www.godisageek.com/wp-content/uploads/sword-cover-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/sword-cover-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/sword-cover-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/sword-cover-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MHR Magnamalo demo" title="Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/why-one-particular-new-wyvern-in-monster-hunter-rise-has-me-excited/">Why one particular new wyvern in Monster Hunter Rise has me excited<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radna-Kadaki" title="Why one particular new wyvern in Monster Hunter Rise has me excited" srcset="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/me-myself-and-mario-how-one-plumber-saved-my-life/">Me, Myself, and Mario: How one plumber saved my life<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mario-feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario" title="Me, Myself, and Mario: How one plumber saved my life" srcset="https://www.godisageek.com/wp-content/uploads/mario-feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mario-feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mario-feature-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/mario-feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/podcast-434-it-takes-two-satisfactory-outriders/">Podcast #434: It Takes Two, Satisfactory, Outriders<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-434-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 434 It Takes Two" title="Podcast #434: It Takes Two, Satisfactory, Outriders" srcset="https://www.godisageek.com/wp-content/uploads/podcast-434-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-434-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-434-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-434-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-eternal-cylinder-is-both-horrifying-and-beautiful-hand-on-preview/">The Eternal Cylinder is both horrifying and beautiful | Hand-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Eternal Cylinder Preview" title="The Eternal Cylinder is both horrifying and beautiful | Hand-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/why-i-cant-stop-thinking-about-satisfactory/">Satisfactory could be your next gaming addiction<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Satisfactory-1-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Satisfactory" title="Satisfactory could be your next gaming addiction" srcset="https://www.godisageek.com/wp-content/uploads/Satisfactory-1-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Satisfactory-1-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Satisfactory-1-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Let&#039;s Play part one" title="It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-how-to-get-the-best-personas/">Persona 5 Strikers guide | How to get the best Personas<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Persona guide" title="Persona 5 Strikers guide | How to get the best Personas" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-how-to-make-money-fast/">Persona 5 Strikers guide | How to make money fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Money guide" title="Persona 5 Strikers guide | How to make money fast" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-unlock-the-best-bond-skills/">Persona 5 Strikers guide | Unlock the best Bond skills<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Bond guide" title="Persona 5 Strikers guide | Unlock the best Bond skills" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-master-the-combat-of-the-phantom-thieves/">Persona 5 Strikers guide | Master the combat of the Phantom Thieves<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Combat guide" title="Persona 5 Strikers guide | Master the combat of the Phantom Thieves" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/how-to-win-at-project-winter-the-ultimate-survival-guide/">How to win at Project Winter | The Ultimate Survival Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project Winter | How to win as a survivor" title="How to win at Project Winter | The Ultimate Survival Guide" srcset="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/the-medium-guide-how-to-solve-clock-puzzle/">The Medium guide | How to solve the clock puzzle<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Guide how to solve the clock puzzle" title="The Medium guide | How to solve the clock puzzle" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MHR Magnamalo demo" title="Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-eternal-cylinder-is-both-horrifying-and-beautiful-hand-on-preview/">The Eternal Cylinder is both horrifying and beautiful | Hand-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Eternal Cylinder Preview" title="The Eternal Cylinder is both horrifying and beautiful | Hand-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/it-takes-two-is-a-delightful-co-op-filled-with-magical-gameplay-and-plenty-of-heart-hands-on-preview/">It Takes Two is a delightful co-op filled with magical gameplay and plenty of heart | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Hands-on Preview" title="It Takes Two is a delightful co-op filled with magical gameplay and plenty of heart | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Let&#039;s Play part one" title="It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/no-shiny-shit-it-takes-two-could-be-hazelight-and-josef-fares-breakout-moment/">&#8220;No Shiny Shit!&#8221;: It Takes Two could be Hazelight and Josef Fares&#8217; breakout moment<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/it-takes-two-game-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two, Josef Fares, and how this could be Hazelight&#039;s breakout moment" title="&#8220;No Shiny Shit!&#8221;: It Takes Two could be Hazelight and Josef Fares&#8217; breakout moment" srcset="https://www.godisageek.com/wp-content/uploads/it-takes-two-game-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/narita-boy-is-a-techno-themed-metroidvania-that-refuses-to-hold-your-hand-hands-on-preview/">Narita Boy is a techno-themed Metroidvania that refuses to hold your hand | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Narita Boy" title="Narita Boy is a techno-themed Metroidvania that refuses to hold your hand | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/rust-set-to-arrive-on-ps4-and-xbox-one-this-spring/">Rust set to arrive on PS4 and Xbox One this Spring<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rust console release date news" title="Rust set to arrive on PS4 and Xbox One this Spring" srcset="https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rust-console-release-date-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/zynga-partners-with-girls-who-code-to-help-support-women-in-technology/">Zynga partners with Girls Who Code to help support women in technology<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Zynga Girls Who Code News" title="Zynga partners with Girls Who Code to help support women in technology" srcset="https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Zynga-Girls-Who-Code-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-genshin-impact-windblume-festival-is-coming-on-march-17/">The Genshin Impact Windblume Festival is coming on March 17<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Genshin Impact Windblume Festival" title="The Genshin Impact Windblume Festival is coming on March 17" srcset="https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Genshin-Impact-Windblume-Festival-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/a-new-tales-of-arise-trailer-has-landed/">A new Tales of Arise trailer has landed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tales of Arise trailer" title="A new Tales of Arise trailer has landed" srcset="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/hoa-has-a-new-gameplay-trailer/">Hoa has a new gameplay trailer<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Hoa-trailer-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Hoa trailer" title="Hoa has a new gameplay trailer" srcset="https://www.godisageek.com/wp-content/uploads/Hoa-trailer-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Hoa-trailer-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/heroic-expedition-coming-to-mobile-in-april/">Heroic Expedition coming to mobile in April<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Heroic Expedition" title="Heroic Expedition coming to mobile in April" srcset="https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Heroic-Expedition-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/gnosia-review/">Gnosia review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Gnosia title image" title="Gnosia review" srcset="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sir-lovalot-review/">Sir Lovalot review<img src="https://www.godisageek.com/wp-content/themes/steam/images/placeholder-35.png" alt="featured image" width="35" height="35" /></a><a href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">Monster Truck Championship next-gen review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Truck Championship next-gen review" title="Monster Truck Championship next-gen review" srcset="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">WRC 9 Nintendo Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WRC 8 Switch review" title="WRC 9 Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sword-of-the-necromancer-review/">Sword of the Necromancer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/sword-cover-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sword of the Necromancer" title="Sword of the Necromancer review" srcset="https://www.godisageek.com/wp-content/uploads/sword-cover-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/sword-cover-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/sword-cover-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/sword-cover-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MHR Magnamalo demo" title="Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/why-one-particular-new-wyvern-in-monster-hunter-rise-has-me-excited/">Why one particular new wyvern in Monster Hunter Rise has me excited<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radna-Kadaki" title="Why one particular new wyvern in Monster Hunter Rise has me excited" srcset="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/me-myself-and-mario-how-one-plumber-saved-my-life/">Me, Myself, and Mario: How one plumber saved my life<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/mario-feature-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Mario" title="Me, Myself, and Mario: How one plumber saved my life" srcset="https://www.godisageek.com/wp-content/uploads/mario-feature-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/mario-feature-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/mario-feature-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/mario-feature-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/podcast-434-it-takes-two-satisfactory-outriders/">Podcast #434: It Takes Two, Satisfactory, Outriders<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-434-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 434 It Takes Two" title="Podcast #434: It Takes Two, Satisfactory, Outriders" srcset="https://www.godisageek.com/wp-content/uploads/podcast-434-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-434-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-434-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-434-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-eternal-cylinder-is-both-horrifying-and-beautiful-hand-on-preview/">The Eternal Cylinder is both horrifying and beautiful | Hand-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Eternal Cylinder Preview" title="The Eternal Cylinder is both horrifying and beautiful | Hand-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/why-i-cant-stop-thinking-about-satisfactory/">Satisfactory could be your next gaming addiction<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Satisfactory-1-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Satisfactory" title="Satisfactory could be your next gaming addiction" srcset="https://www.godisageek.com/wp-content/uploads/Satisfactory-1-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Satisfactory-1-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Satisfactory-1-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Let&#039;s Play part one" title="It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2020/10/unboxing-the-xbox-series-x/">Unboxing the Xbox Series X<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Unboxing the Xbox Series X" title="Unboxing the Xbox Series X" srcset="https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Nph8dPTYz5DB8czhnwQpc9-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-how-to-get-the-best-personas/">Persona 5 Strikers guide | How to get the best Personas<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Persona guide" title="Persona 5 Strikers guide | How to get the best Personas" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Persona-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-how-to-make-money-fast/">Persona 5 Strikers guide | How to make money fast<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Money guide" title="Persona 5 Strikers guide | How to make money fast" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Money-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-unlock-the-best-bond-skills/">Persona 5 Strikers guide | Unlock the best Bond skills<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Bond guide" title="Persona 5 Strikers guide | Unlock the best Bond skills" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Bond-guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/persona-5-strikers-guide-master-the-combat-of-the-phantom-thieves/">Persona 5 Strikers guide | Master the combat of the Phantom Thieves<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Strikers Combat guide" title="Persona 5 Strikers guide | Master the combat of the Phantom Thieves" srcset="https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Persona-5-Strikers-Combat-Guide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/02/how-to-win-at-project-winter-the-ultimate-survival-guide/">How to win at Project Winter | The Ultimate Survival Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Project Winter | How to win as a survivor" title="How to win at Project Winter | The Ultimate Survival Guide" srcset="https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/how-to-win-at-project-winter-team-guide-tips-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/01/the-medium-guide-how-to-solve-clock-puzzle/">The Medium guide | How to solve the clock puzzle<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Medium Guide how to solve the clock puzzle" title="The Medium guide | How to solve the clock puzzle" srcset="https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Medium-Guide-clock-puzzle-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-67" class="menu-item menu-item-67 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="previews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/previews/">Previews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MHR Magnamalo demo" title="Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/the-eternal-cylinder-is-both-horrifying-and-beautiful-hand-on-preview/">The Eternal Cylinder is both horrifying and beautiful | Hand-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Eternal Cylinder Preview" title="The Eternal Cylinder is both horrifying and beautiful | Hand-on preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Eternal-Cylinder-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/it-takes-two-is-a-delightful-co-op-filled-with-magical-gameplay-and-plenty-of-heart-hands-on-preview/">It Takes Two is a delightful co-op filled with magical gameplay and plenty of heart | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Hands-on Preview" title="It Takes Two is a delightful co-op filled with magical gameplay and plenty of heart | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two Let&#039;s Play part one" title="It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/no-shiny-shit-it-takes-two-could-be-hazelight-and-josef-fares-breakout-moment/">&#8220;No Shiny Shit!&#8221;: It Takes Two could be Hazelight and Josef Fares&#8217; breakout moment<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/it-takes-two-game-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two, Josef Fares, and how this could be Hazelight&#039;s breakout moment" title="&#8220;No Shiny Shit!&#8221;: It Takes Two could be Hazelight and Josef Fares&#8217; breakout moment" srcset="https://www.godisageek.com/wp-content/uploads/it-takes-two-game-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/it-takes-two-game-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/03/narita-boy-is-a-techno-themed-metroidvania-that-refuses-to-hold-your-hand-hands-on-preview/">Narita Boy is a techno-themed Metroidvania that refuses to hold your hand | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Narita Boy" title="Narita Boy is a techno-themed Metroidvania that refuses to hold your hand | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Narita-Boy-Main1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/previews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-165623" class="menu-item menu-item-165623 post_type 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="page" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/patreon/">Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page minisite-page full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/reviews/gnosia-review/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Gnosia review</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/reviews/the-long-dark-review/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                        
                                                <div class="award-grid"></div>                                                
                                                                                    
                                                                                
                                                                                
                                        <a class="like-button do-like 247586" data-postid="247586" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">0 likes</span></a>                                        
                                                                            
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-247586" class="post-247586 it_reviews type-it_reviews status-publish has-post-thumbnail hentry category-ps4-reviews category-playstation-5 category-reviews category-switch-reviews tag-activision tag-crash-bandicoot-4 tag-crash-bandicoot-4-its-about-time tag-naughty-dog tag-nintendo tag-sony tag-toys-for-bob reviews_platform-playstation-4 reviews_platform-playstation-5 reviews_platform-switch-2 reviews_developer-toys-for-bob-2 reviews_publisher-activision reviews_reviewedon-switch-3 reviews_alsotestedon-playstation-4 reviews_alsotestedon-playstation-5" itemscope itemtype="http://schema.org/Review">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1 itemprop="itemReviewed">								
                                                Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/mick-fraser/"><span itemprop="author">Mick Fraser </span></a></span><span class="date">on <meta itemprop="datePublished" content="March 13, 2021">March 13, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                    <div class="details-box-wrapper"><div class="ribbon-wrapper"><div class="ribbon">Details<div class="ribbon-separator">&nbsp;</div></div></div><div class="details-box"><div class="taxonomies-wrapper"><div class="detail-item"><span class="detail-label">Platform</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-platform/playstation-4/" rel="tag">PlayStation 4</a><a href="https://www.godisageek.com/reviews-platform/playstation-5/" rel="tag">PlayStation 5</a><a href="https://www.godisageek.com/reviews-platform/switch-2/" rel="tag">Switch</a></span></div><div class="detail-item"><span class="detail-label">Developer</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-developer/toys-for-bob-2/" rel="tag">Toys for Bob</a></span></div><div class="detail-item"><span class="detail-label">Publisher</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-publisher/activision/" rel="tag">Activision</a></span></div><div class="detail-item"><span class="detail-label">Reviewed On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-reviewedon/switch-3/" rel="tag">Switch</a></span></div><div class="detail-item"><span class="detail-label">Also Tested On</span><span class="detail-content"><a href="https://www.godisageek.com/reviews-alsotestedon/playstation-4/" rel="tag">PlayStation 4</a><a href="https://www.godisageek.com/reviews-alsotestedon/playstation-5/" rel="tag">PlayStation 5</a></span></div></div><div class="details-wrapper"><div class="detail-item"><span class="detail-label">Release Date</span><span class="detail-content"><p>March 12 2021</p>
</span></div></div></div></div>                                            
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review' data-link='https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/' data-app-id-name='post_above_content'></div>
<p>Despite my penchant for slaying dragons, gods and giants in videogames, occasionally I just want to play something colourful and charming – although, crucially, these games are not necessarily easier than the other ones. But as with the case of Crash Bandicoot 4: It’s About Time, which hit PS4 last year, sometimes they land right when you need them to.</p>
<p><a href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-review/">I had a ball with Crash’s fourth outing</a>. It consistently won me over with its bright colours and likeable characters, even if some of the new mechanics weren’t quite as worthy as we hoped they’d be. The time travel element, for example, was really just an excuse to have you run sections of certain levels multiple times and added very little to the game – but the platforming was on point throughout.</p>
<p>Now playing on both Switch and PS5 pretty much side-by-side, I can see the benefits to both versions and it’s actually difficult to strongly recommend one over the other – but I’ll focus on the Switch version primarily here as it’s the one with the most differences to the original release. On the Switch, though, things are more noticeable. Obviously it lacks the graphical clout of PS5 or PS4, and so even in handheld mode It’s About Time is not as nice to look at. It runs slower too, although I never suffered any actual slow-down; it just isn’t consistently hitting the same framerate as the PS5 version.</p>
<p><img class="alignleft size-large wp-image-247591" src="https://www.godisageek.com/wp-content/uploads/Crash-3-1024x576.jpg" alt="Crash Bandicoot 4: It's About Time Nintendo Switch review" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Crash-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Crash-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Crash-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Crash-3-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Crash-3-2048x1152.jpg 2048w, https://www.godisageek.com/wp-content/uploads/Crash-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Crash-3-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Crash-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Crash-3-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Crash-3-640x360.jpg 640w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>Crucially, it plays well enough that lounging on my couch with the Switch in handheld mode has become my preferable way to play. I mean, lounging on the couch is my preferable way to live in most situations so that’s not a stretch, but Crash Bandicoot 4: It’s About Time is just one of those instant-fun games that the Switch is kind of made for.</p>
<p>There are no exclusive skins or DLC packs on the Switch version, so you’ll be doing the exact same things as you were on PS4, to the point where if you played it on that platform I wouldn’t advise bothering again unless you really loved it, or hanker after it for a morning commute. If you haven’t played it yet, well, you’re in for a treat.</p>
<p>The story is kind of throwaway, and sees a trio of previous villains including series stalwart Dr. Neo Cortex coming together to escape their interdimensional prison and wreak the usual havoc purely because it’s their job, I guess. As Crash or Coco, you’ll race through various locales, aided at times by other playable characters who only step in for limited sections of previously played levels.</p>
<p><img class="alignleft size-large wp-image-247589" src="https://www.godisageek.com/wp-content/uploads/Crash-4-001-1024x576.jpg" alt="Crash Bandicoot 4: It's About Time Nintendo Switch review" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-001-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Crash-4-001-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Crash-4-001.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>It’s a shame in many ways, as these alternate characters present some fun moments but feel underused. Tawna, for example, is great to play as with her grappling hook ability, but you don’t spend enough time with her to fully appreciate the different moveset, and the same goes with all of them.</p>
<p>Ultimately, Crash Bandicoot 4: It’s About Time on Nintendo Switch is a slightly less polished version of a very good platformer, and the trade-off is the ability to kick back and thrash it out on the couch, bus or khazi. Seems like a pretty fair trade to me – particularly if you skipped it on PS4 for whatever reason. Either way it&#8217;s a thoroughly good game that comes highly recomended.</p>
<div class='video_frame'><iframe id='youtube_video_1' class='youtube_video' src='https://www.youtube.com/embed/FardxFNIsVs?autohide=2&amp;autoplay=0&amp;controls=1&amp;disablekb=0&amp;fs=1&amp;hd=1&amp;loop=0&amp;rel=1&amp;showinfo=1&amp;showsearch=1&amp;wmode=transparent&amp;enablejsapi=1' width='' height=''></iframe></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review' data-link='https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review' data-link='https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                    <div class="procon-box-wrapper"><div class="procon-box clearfix"><div class="col-wrapper"><div class="procon pro"><div class="header"><span class="icon-plus"></span>Positives</div><p>Still just as much fun<br />
Great platforming<br />
Fun characters</p>
</div></div><div class="col-wrapper"><div class="procon con"><div class="header"><span class="icon-minus"></span>Negatives</div><p>No Switch-exclusive feratures<br />
Looks a little rougher than the other versions</p>
</div></div></div></div>                                        
                                    <div class="ratings clearfix"><div class="ratings-panel-wrapper clearfix solo"><div class="ratings-panel editor-rating"><div class="header"><span class="icon-reviewed"></span>Editor Rating</div><div class="rating-wrapper" id="editor_rating_0"><div class="rating-bar"><div class="rating-meter">&nbsp;</div><div class="rating-label">Our Score</div><div class="rating-value"><div class="number color5">8.5</div></div><br class="clearer" /></div></div><script type="text/javascript">jQuery(window).load(function() {animateRating(-15,1000,"editor_rating_0")});</script><div class="rating-wrapper total" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><div class="rating-bar color5"><div class="rating-label">SCORE OUT OF TEN</div><meta itemprop="worstRating" content="0"><div class="rating-value" itemprop="ratingValue"><div class="number color5">8.5</div></div><meta itemprop="bestRating" content="10"><br class="clearer" /></div></div></div></div></div><br class="clearer" />                                    
                                    <div class="bottomline-wrapper"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-quote-circled"></span>In Short<div class="ribbon-separator">&nbsp;</div></div></div><div class="bottomline"><p>Crash Bandicoot 4: It's About Time on Switch is just as fun and frantic as it is on Sony's consoles, but it's just that little bit less glorious to look at. </p>
</div></div>                                    
                                                                 
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>You may also like<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="236" data-method="tags" class="info active" title="More articles tagged: Activision">Activision<span class="bottom-arrow"></span></a><a data-sorter="27399" data-method="tags" class="info" title="More articles tagged: Crash Bandicoot 4">Crash Bandicoot 4<span class="bottom-arrow"></span></a><a data-sorter="11296" data-method="categories" class="info" title="More articles filed under: PlayStation 4">PlayStation 4<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/call-of-duty-black-ops-cold-war-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-review-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Call of Duty: Black Ops Cold War review" title="Call of Duty: Black Ops Cold War review" srcset="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-review-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-review-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-review-5-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-review-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/call-of-duty-black-ops-cold-war-review/">Call of Duty: Black Ops Cold War review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/call-of-duty-black-ops-cold-war-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/11/activision-announces-worldwide-launch-of-call-of-duty-black-ops-cold-war/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-launched-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Activision announces worldwide launch of Call of Duty: Black Ops Cold War" title="Activision announces worldwide launch of Call of Duty: Black Ops Cold War" srcset="https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-launched-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-launched-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/call-of-duty-black-ops-cold-war-launched-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/11/activision-announces-worldwide-launch-of-call-of-duty-black-ops-cold-war/">Activision announces worldwide launch of Call of Duty: Black Ops Cold War</a></div><a class="hover-link" href="https://www.godisageek.com/2020/11/activision-announces-worldwide-launch-of-call-of-duty-black-ops-cold-war/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Crash-4-main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time" title="Crash Bandicoot 4: It&#8217;s About Time review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Crash-4-main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-review/">Crash Bandicoot 4: It&#8217;s About Time review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/tony-hawks-pro-skater-1-2-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tony-Hawks-Pro-Skater-1-2-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tony Hawk&#039;s Pro Skater 1 + 2 review" title="Tony Hawk&#8217;s Pro Skater 1 + 2 review" srcset="https://www.godisageek.com/wp-content/uploads/Tony-Hawks-Pro-Skater-1-2-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tony-Hawks-Pro-Skater-1-2-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tony-Hawks-Pro-Skater-1-2-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tony-Hawks-Pro-Skater-1-2-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tony-hawks-pro-skater-1-2-review/">Tony Hawk&#8217;s Pro Skater 1 + 2 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/tony-hawks-pro-skater-1-2-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Games of Summer" title="Games of Summer is coming to Call of Duty Modern Warfare" srcset="https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Games-of-Summer-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">Games of Summer is coming to Call of Duty Modern Warfare</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/games-of-summer-is-coming-to-call-of-duty-modern-warfare/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/06/current-pro-skaters-set-to-join-the-ogs-in-tony-hawks-pro-skater-1-and-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Current pro skaters set to join the OGs in Tony Hawk&#8217;s Pro Skater 1 and 2" srcset="https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/tony-hawks-new-skaters-news-150x150.jpg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/06/current-pro-skaters-set-to-join-the-ogs-in-tony-hawks-pro-skater-1-and-2/">Current pro skaters set to join the OGs in Tony Hawk&#8217;s Pro Skater 1 and 2</a></div><a class="hover-link" href="https://www.godisageek.com/2020/06/current-pro-skaters-set-to-join-the-ogs-in-tony-hawks-pro-skater-1-and-2/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Newly Added</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 247586 info-bottom" data-postid="247586" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="MHR Magnamalo demo" title="Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around" srcset="https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-hunter-rise-magnamalo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">Monster Hunter Rise &#8211; New Magnamalo Demo isn&#8217;t messing around</a></div><a class="hover-link" href="https://www.godisageek.com/2021/03/monster-hunter-rise-new-magnamalo-demo-isnt-messing-around/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/03/why-one-particular-new-wyvern-in-monster-hunter-rise-has-me-excited/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Radna-Kadaki" title="Why one particular new wyvern in Monster Hunter Rise has me excited" srcset="https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/RADNA-MAIN-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/03/why-one-particular-new-wyvern-in-monster-hunter-rise-has-me-excited/">Why one particular new wyvern in Monster Hunter Rise has me excited</a></div><a class="hover-link" href="https://www.godisageek.com/2021/03/why-one-particular-new-wyvern-in-monster-hunter-rise-has-me-excited/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/gnosia-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Gnosia title image" title="Gnosia review" srcset="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/gnosia-review/">Gnosia review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/gnosia-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/sir-lovalot-review/"><img src="https://www.godisageek.com/wp-content/themes/steam/images/placeholder-35.png" alt="featured image" width="35" height="35" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sir-lovalot-review/">Sir Lovalot review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sir-lovalot-review/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 247586 info-bottom" data-postid="247586" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/gnosia-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Gnosia title image" title="Gnosia review" srcset="https://www.godisageek.com/wp-content/uploads/hero-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/hero-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/hero-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/gnosia-review/">Gnosia review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/gnosia-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/sir-lovalot-review/"><img src="https://www.godisageek.com/wp-content/themes/steam/images/placeholder-35.png" alt="featured image" width="35" height="35" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sir-lovalot-review/">Sir Lovalot review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sir-lovalot-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Truck Championship next-gen review" title="Monster Truck Championship next-gen review" srcset="https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">Monster Truck Championship next-gen review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WRC 8 Switch review" title="WRC 9 Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">WRC 9 Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="It Takes Two Let&#039;s Play part one" title="It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-Lets-Play-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">It Takes Two | Let&#8217;s Play Part 1 &#8211; &#8220;It plays brilliantly&#8221;</a><div class="article-meta clearfix"><a class="like-button do-like 247367 info-bottom" data-postid="247367" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/03/it-takes-two-lets-play-part-1-it-plays-brilliantly/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Balan Wonderworld&#039;s demo gives us a view at life after Sonic for Yuji Naka | Hands-on Preview" title="The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/balan-wonderworld-demo-impressions-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">The Balan Wonderworld demo gives us a glimpse of life after Sonic for Yuji Naka | Hands-on preview</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/balan-wonderworlds-demo-gameplay-hands-on-life-after-sonic/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Super Meat Boy Forever" title="Super Meat Boy Forever | First Impressions video" srcset="https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Super-Meat-Boy-Forever-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">Super Meat Boy Forever | First Impressions video</a></div><a class="hover-link" href="https://www.godisageek.com/2020/12/super-meat-boy-forever-30-minutes-of-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible" srcset="https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/astros-playroom-ps5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">Astro&#8217;s Playroom PS5 preview | The Dualsense seems incredible</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/astros-playroom-ps5-preview-the-dualsense-seems-incredible/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Unboxing the PlayStation 5" srcset="https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/unboxing-the-playstation-5-video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">Unboxing the PlayStation 5</a></div><a class="hover-link" href="https://www.godisageek.com/2020/10/unboxing-the-playstation-5/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/loop-hero-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Loop-Hero-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Loop Hero review" title="Loop Hero review" srcset="https://www.godisageek.com/wp-content/uploads/Loop-Hero-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Loop-Hero-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Loop-Hero-review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/loop-hero-review/">Loop Hero review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 247406 info-bottom" data-postid="247406" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/loop-hero-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/curse-of-the-dead-gods-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Curseofthedeadgods-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Curse of the Dead Gods" title="Curse of the Dead Gods review" srcset="https://www.godisageek.com/wp-content/uploads/Curseofthedeadgods-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Curseofthedeadgods-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Curseofthedeadgods-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Curseofthedeadgods-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/curse-of-the-dead-gods-review/">Curse of the Dead Gods review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/curse-of-the-dead-gods-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/natsuki-chronicles-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Natsuki-Chronicles-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Natsuki Chronicles review" title="Natsuki Chronicles review" srcset="https://www.godisageek.com/wp-content/uploads/Natsuki-Chronicles-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Natsuki-Chronicles-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Natsuki-Chronicles-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Natsuki-Chronicles-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/natsuki-chronicles-review/">Natsuki Chronicles review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/natsuki-chronicles-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Crash Bandicoot 4: It&#039;s About Time Nintendo Switch review" title="Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/main-assembly-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Main-Assembly-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Main Assembly review" title="Main Assembly review" srcset="https://www.godisageek.com/wp-content/uploads/Main-Assembly-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Main-Assembly-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Main-Assembly-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Main-Assembly-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/main-assembly-review/">Main Assembly review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/main-assembly-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Crash-4-review-switch-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div><div class="article-info">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/hero-272x188.jpeg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/gnosia-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Gnosia review</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url();"></div><a class="box-link" href="https://www.godisageek.com/reviews/sir-lovalot-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div><div class="article-info">Sir Lovalot review</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/monster-truck-championship-xbox-series-s-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div><div class="article-info">Monster Truck Championship next-gen review</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/WRC-9-Switch-review-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.0</div></div></div><div class="article-info">WRC 9 Nintendo Switch review</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/sword-cover-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/reviews/sword-of-the-necromancer-review/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color3">5.5</div></div></div><div class="article-info">Sword of the Necromancer review</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">Crash Bandicoot 4: It&#8217;s About Time Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/crash-bandicoot-4-its-about-time-nintendo-switch-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/gnosia-review/">Gnosia review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/gnosia-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sir-lovalot-review/">Sir Lovalot review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sir-lovalot-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">Monster Truck Championship next-gen review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-truck-championship-next-gen-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">WRC 9 Nintendo Switch review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/wrc-9-nintendo-switch-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 13.119402985075px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 19.164179104478px;" aria-label="Activision (774 items)">Activision</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-3" style="font-size: 12.671641791045px;" aria-label="Call of Duty (393 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-4" style="font-size: 17.373134328358px;" aria-label="Capcom (650 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-5" style="font-size: 14.462686567164px;" aria-label="DLC (478 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-6" style="font-size: 22.746268656716px;" aria-label="EA (1,123 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-7" style="font-size: 12.89552238806px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-8" style="font-size: 16.029850746269px;" aria-label="Konami (559 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-9" style="font-size: 20.955223880597px;" aria-label="Microsoft (936 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-10" style="font-size: 27px;" aria-label="nintendo (1,726 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-11" style="font-size: 19.164179104478px;" aria-label="nintendo switch (769 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-12" style="font-size: 24.537313432836px;" aria-label="PC (1,363 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-13" style="font-size: 21.850746268657px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-14" style="font-size: 14.686567164179px;" aria-label="PlayStation 4 (490 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-15" style="font-size: 22.522388059701px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-16" style="font-size: 23.641791044776px;" aria-label="PS4 (1,226 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-17" style="font-size: 17.597014925373px;" aria-label="Sega (663 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-18" style="font-size: 20.955223880597px;" aria-label="Sony (943 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-19" style="font-size: 20.507462686567px;" aria-label="square enix (889 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-20" style="font-size: 14.238805970149px;" aria-label="Steam (467 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-21" style="font-size: 17.820895522388px;" aria-label="Trailer (680 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-22" style="font-size: 23.865671641791px;" aria-label="Ubisoft (1,270 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/wii-u/" class="tag-cloud-link tag-link-4747 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (370 items)">Wii U</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.55223880597px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 24.089552238806px;" aria-label="Xbox One (1,278 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 13.470588235294px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.955882352941px;" aria-label="Articles (235 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.661764705882px;" aria-label="Competition (214 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 14.426470588235px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.088235294118px;" aria-label="Features (2,195 items)">Features</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-6" style="font-size: 12.661764705882px;" aria-label="Interview (215 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-7" style="font-size: 14.279411764706px;" aria-label="iOS (351 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-8" style="font-size: 27px;" aria-label="News (19,187 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-9" style="font-size: 15.897058823529px;" aria-label="Opinion (591 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-10" style="font-size: 14.205882352941px;" aria-label="Paid Placement Advertorials (345 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-11" style="font-size: 19.794117647059px;" aria-label="PC (1,973 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-12" style="font-size: 16.852941176471px;" aria-label="PlayStation 3 (791 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-13" style="font-size: 18.764705882353px;" aria-label="PlayStation 4 (1,460 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 16.485294117647px;" aria-label="Podcasts (704 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.926470588235px;" aria-label="Previews (805 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 14.058823529412px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 22.073529411765px;" aria-label="Reviews (4,055 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.264705882353px;" aria-label="Switch (655 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 13.25px;" aria-label="Tech (255 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.661764705882px;" aria-label="Trailers (1,016 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 13.691176470588px;" aria-label="Uncategorised (292 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 17.588235294118px;" aria-label="Video Features (1,003 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/wiiu/" class="tag-cloud-link tag-link-9285 tag-link-position-23" style="font-size: 12px;" aria-label="Wii U (171 items)">Wii U</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 16.485294117647px;" aria-label="Xbox 360 (713 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.029411764706px;" aria-label="Xbox One (1,150 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 20.372093023256px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.441860465116px;" aria-label="Android (75 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.558139534884px;" aria-label="Apple Arcade (10 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 15.372093023256px;" aria-label="Google Stadia (14 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.709302325581px;" aria-label="HTC Vive (25 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.546511627907px;" aria-label="iOS (116 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.406976744186px;" aria-label="Mac (33 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 12px;" aria-label="Oculus Quest 2 (3 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.709302325581px;" aria-label="Oculus Rift (25 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,500 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 21.186046511628px;" aria-label="PlayStation 3 (149 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.825581395349px;" aria-label="PlayStation 4 (1,405 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 18.395348837209px;" aria-label="PlayStation 5 (49 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.686046511628px;" aria-label="PlayStation VR (55 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 21.302325581395px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.023255813953px;" aria-label="Switch (695 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12.581395348837px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.976744186047px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 20.255813953488px;" aria-label="Xbox 360 (104 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.186046511628px;" aria-label="Xbox One (1,098 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 17.116279069767px;" aria-label="Xbox Series S (29 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 17.813953488372px;" aria-label="Xbox Series X (39 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
