<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>Escape Academy Take to the Skies Walkthrough | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Here&#039;s our walkthrough for the Take to the Skies level in the Escape Academy DLC Escape from Anti-Escape Island. Read it for all the answers." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Escape Academy Take to the Skies Walkthrough | GodisaGeek.com" />
	<meta property="og:description" content="Here&#039;s our walkthrough for the Take to the Skies level in the Escape Academy DLC Escape from Anti-Escape Island. Read it for all the answers." />
	<meta property="og:url" content="https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-11-10T08:00:41+00:00" />
	<meta property="article:modified_time" content="2022-11-09T22:44:49+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies.jpg","width":1280,"height":720,"caption":"Escape Academy Take to the Skies"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#webpage","url":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/","name":"Escape Academy Take to the Skies Walkthrough | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#primaryimage"},"datePublished":"2022-11-10T08:00:41+00:00","dateModified":"2022-11-09T22:44:49+00:00","description":"Here's our walkthrough for the Take to the Skies level in the Escape Academy DLC Escape from Anti-Escape Island. Read it for all the answers.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81"},"headline":"Escape Academy Take to the Skies Walkthrough","datePublished":"2022-11-10T08:00:41+00:00","dateModified":"2022-11-09T22:44:49+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/#primaryimage"},"keywords":"Coin Crew Games,Escape Academy,Escape Academy: Escape From Anti-Escape Island,Guide,iam8bit","articleSection":"Guides","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81","name":"Chris Hyde","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=96&d=mm&r=g","caption":"Chris Hyde"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"11","day":"10","hour":"08","minute":"00","second":"41","post_id":"269782","postname":"escape-academy-take-to-the-skies-walkthrough","category":"guides"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/' />
<meta name='shareaholic:keywords' content='tag:coin crew games, tag:escape academy, tag:escape academy: escape from anti-escape island, tag:guide, tag:iam8bit, tag:escape academy take to the skies walkthrough, cat:guides, type:post' />
<meta name='shareaholic:article_published_time' content='2022-11-10T08:00:41+00:00' />
<meta name='shareaholic:article_modified_time' content='2022-11-09T22:44:49+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris Hyde' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=269782' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F11%2Fescape-academy-take-to-the-skies-walkthrough%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F11%2Fescape-academy-take-to-the-skies-walkthrough%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '212bc1e00d'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/"},"headline":"Escape Academy Take to the Skies Walkthrough","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies.jpg","width":1280,"height":720},"datePublished":"2022-11-10T08:00:41+0000","dateModified":"2022-11-09T22:44:49+0000","author":{"@type":"Person","name":"Chris Hyde","url":"https://www.godisageek.com/author/glorylininger48/chris-hyde"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}}}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/11\/escape-academy-take-to-the-skies-walkthrough\/","name":"Escape Academy Take to the Skies Walkthrough"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-269782 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">Tactics Ogre Reborn review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tactics Ogre Reborn review" title="Tactics Ogre Reborn review" srcset="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/harvestella-review/">Harvestella review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Harvestella Review" title="Harvestella review" srcset="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">Buddy Simulator 1984 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Buddy Simulator 1984 Review" title="Buddy Simulator 1984 review" srcset="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">Escape Academy: Escape from Anti-Escape Island DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy: Escape from Anti-Escape Island" title="Escape Academy: Escape from Anti-Escape Island DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sonic-frontiers-review/">Sonic Frontiers review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Frontiers review" title="Sonic Frontiers review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/prodeus-switch-review/">Prodeus Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Prodeus Switch review" title="Prodeus Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/turbo-overkill-gives-you-a-chainsaw-leg-any-further-questions-early-access-review/">Turbo Overkill gives you a chainsaw leg &#8211; any further questions? | Early Access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Turbo-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turbo Overkill" title="Turbo Overkill gives you a chainsaw leg &#8211; any further questions? | Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/Turbo-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/blacktail-is-a-creepy-mix-of-first-person-combat-and-witchcraft-hands-on-preview/">Blacktail is a creepy mix of first-person combat and witchcraft | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Blacktail-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Blacktail preview" title="Blacktail is a creepy mix of first-person combat and witchcraft | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Blacktail-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/togges-is-a-unique-3d-platformer-with-a-focus-on-exploration-hands-on-preview/">Togges is a unique 3D platformer with a focus on exploration | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Togges title image" title="Togges is a unique 3D platformer with a focus on exploration | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/orx-interview/">Interview with ORX game designer Ivan Suhin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ORX-with-logo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ORX interview title image" title="Interview with ORX game designer Ivan Suhin" srcset="https://www.godisageek.com/wp-content/uploads/ORX-with-logo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ORX-with-logo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ORX-with-logo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/podcast-503-bayonetta-3-the-devil-in-me-resident-evil-village-dlc/">Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC" title="Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/apex-legends-season-15-new-legend-changes-maps/">Apex Legends season 15 is shaping up very nicely | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends season 15 is shaping up very nicely" title="Apex Legends season 15 is shaping up very nicely | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/">Escape Academy: Escape from Anti-Escape Island Complete Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Escape from Anti-Escape Island Walkthrough" title="Escape Academy: Escape from Anti-Escape Island Complete Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/">Escape Academy Take to the Skies Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Take to the Skies" title="Escape Academy Take to the Skies Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/">Escape Academy Into the Capture Dimension Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Into the Capture Dimension Walkthrough" title="Escape Academy Into the Capture Dimension Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/">Escape Academy The Experiment Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy The Experiment Walkthrough" title="Escape Academy The Experiment Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/">Escape Academy A Juicy Discovery Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy A Juicy Discovery Walkthrough" title="Escape Academy A Juicy Discovery Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/">Escape Academy Ventilation Infiltration Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Ventilation Infiltration Walkthrough" title="Escape Academy Ventilation Infiltration Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/football-manager-2023-touch-now-available-on-apple-arcade/">Football Manager 2023 Touch now available on Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Football Manager 2023 Touch News" title="Football Manager 2023 Touch now available on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/cities-skylines-world-tour-announced-starting-on-november-15th/">Cities: Skylines World Tour announced, starting on November 15th<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cities: Skylines World Tour announced, starting on November 15th" title="Cities: Skylines World Tour announced, starting on November 15th" srcset="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/a-new-monster-hunter-game-is-coming-from-tencents-timi-studio-group/">A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="First Monster Hunter Rise: Sunbreak update coming tomorrow" title="A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group" srcset="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/bioware-and-ea-celebrate-nearly-15-years-of-mass-effect-on-n7-day/">BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day" srcset="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/arcade-paradise-is-getting-3-new-dlc-cabinets/">Arcade Paradise is getting 3 new DLC cabinets<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Arcade Paradise is getting 3 new DLC cabinets" title="Arcade Paradise is getting 3 new DLC cabinets" srcset="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/nhl-23-receives-the-mighty-ducks-in-game-content/">NHL 23 receives The Mighty Ducks in-game content<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NHL 23 Mighty Ducks News" title="NHL 23 receives The Mighty Ducks in-game content" srcset="https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">Tactics Ogre Reborn review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tactics Ogre Reborn review" title="Tactics Ogre Reborn review" srcset="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/harvestella-review/">Harvestella review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Harvestella Review" title="Harvestella review" srcset="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">Buddy Simulator 1984 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Buddy Simulator 1984 Review" title="Buddy Simulator 1984 review" srcset="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">Escape Academy: Escape from Anti-Escape Island DLC review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy: Escape from Anti-Escape Island" title="Escape Academy: Escape from Anti-Escape Island DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/sonic-frontiers-review/">Sonic Frontiers review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Frontiers review" title="Sonic Frontiers review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/prodeus-switch-review/">Prodeus Switch review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Prodeus Switch review" title="Prodeus Switch review" srcset="https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Prodeus-Switch-MAin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/turbo-overkill-gives-you-a-chainsaw-leg-any-further-questions-early-access-review/">Turbo Overkill gives you a chainsaw leg &#8211; any further questions? | Early Access review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Turbo-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Turbo Overkill" title="Turbo Overkill gives you a chainsaw leg &#8211; any further questions? | Early Access review" srcset="https://www.godisageek.com/wp-content/uploads/Turbo-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Turbo-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/blacktail-is-a-creepy-mix-of-first-person-combat-and-witchcraft-hands-on-preview/">Blacktail is a creepy mix of first-person combat and witchcraft | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Blacktail-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Blacktail preview" title="Blacktail is a creepy mix of first-person combat and witchcraft | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/Blacktail-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Blacktail-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/togges-is-a-unique-3d-platformer-with-a-focus-on-exploration-hands-on-preview/">Togges is a unique 3D platformer with a focus on exploration | Hands-on preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Togges title image" title="Togges is a unique 3D platformer with a focus on exploration | Hands-on preview" srcset="https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/maxresdefault-17-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/orx-interview/">Interview with ORX game designer Ivan Suhin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ORX-with-logo-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="ORX interview title image" title="Interview with ORX game designer Ivan Suhin" srcset="https://www.godisageek.com/wp-content/uploads/ORX-with-logo-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ORX-with-logo-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ORX-with-logo-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/podcast-503-bayonetta-3-the-devil-in-me-resident-evil-village-dlc/">Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC" title="Podcast 503: Bayonetta 3, The Devil in Me, Resident Evil Village DLC" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-503-Bayonetta-3-The-Devil-in-Me-Resident-Evil-Village-DLC-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/10/apex-legends-season-15-new-legend-changes-maps/">Apex Legends season 15 is shaping up very nicely | Hands-off preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Apex Legends season 15 is shaping up very nicely" title="Apex Legends season 15 is shaping up very nicely | Hands-off preview" srcset="https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Apex-Legends-season-15-is-shaping-up-very-nicely-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/">Escape Academy: Escape from Anti-Escape Island Complete Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Escape from Anti-Escape Island Walkthrough" title="Escape Academy: Escape from Anti-Escape Island Complete Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/">Escape Academy Take to the Skies Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Take to the Skies" title="Escape Academy Take to the Skies Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/">Escape Academy Into the Capture Dimension Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Into the Capture Dimension Walkthrough" title="Escape Academy Into the Capture Dimension Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/">Escape Academy The Experiment Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy The Experiment Walkthrough" title="Escape Academy The Experiment Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/">Escape Academy A Juicy Discovery Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy A Juicy Discovery Walkthrough" title="Escape Academy A Juicy Discovery Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/">Escape Academy Ventilation Infiltration Walkthrough<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Ventilation Infiltration Walkthrough" title="Escape Academy Ventilation Infiltration Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/11/football-manager-2023-touch-now-available-on-apple-arcade/">Football Manager 2023 Touch now available on Apple Arcade<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Football Manager 2023 Touch News" title="Football Manager 2023 Touch now available on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/cities-skylines-world-tour-announced-starting-on-november-15th/">Cities: Skylines World Tour announced, starting on November 15th<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cities: Skylines World Tour announced, starting on November 15th" title="Cities: Skylines World Tour announced, starting on November 15th" srcset="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/a-new-monster-hunter-game-is-coming-from-tencents-timi-studio-group/">A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="First Monster Hunter Rise: Sunbreak update coming tomorrow" title="A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group" srcset="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/bioware-and-ea-celebrate-nearly-15-years-of-mass-effect-on-n7-day/">BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day" srcset="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/arcade-paradise-is-getting-3-new-dlc-cabinets/">Arcade Paradise is getting 3 new DLC cabinets<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Arcade Paradise is getting 3 new DLC cabinets" title="Arcade Paradise is getting 3 new DLC cabinets" srcset="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/11/nhl-23-receives-the-mighty-ducks-in-game-content/">NHL 23 receives The Mighty Ducks in-game content<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="NHL 23 Mighty Ducks News" title="NHL 23 receives The Mighty Ducks in-game content" srcset="https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/NHL-23-Mighty-Ducks-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/08/how-does-marvels-spider-man-remastered-run-on-steam-deck/">How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Marvel&#039;s Spider-Man Remastered run on Steam Deck?" title="How does Marvel&#8217;s Spider-Man Remastered run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/How-does-Marvels-Spider-Man-Remastered-run-on-Steam-Deck-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/11/escape-academy-take-to-the-skies-walkthrough/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/11/escape-academy-take-to-the-skies-walkthrough/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Escape Academy Into the Capture Dimension Walkthrough</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2010/09/ps3-firmware-version-3-42-now/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class="" href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item ">next<span class="icon-next"></span></div><div class="article-title ">Escape Academy: Escape from Anti-Escape Island Complete Walkthrough</div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-269782" class="post-269782 post type-post status-publish format-standard has-post-thumbnail hentry category-guides tag-coin-crew-games tag-escape-academy tag-escape-academy-escape-from-anti-escape-island tag-guide tag-iam8bit" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                Escape Academy Take to the Skies Walkthrough                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-hyde/"><span itemprop="author">Chris Hyde </span></a></span><span class="date">on <meta itemprop="datePublished" content="November 10, 2022">November 10, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="Escape Academy Take to the Skies" title="Escape Academy Take to the Skies Walkthrough" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies.jpg 1280w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Escape Academy Take to the Skies Walkthrough' data-link='https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/' data-summary='Puzzle Plane' data-app-id-name='post_above_content'></div>
<p>Take to the Skies is the first escape room in the <a href="https://www.godisageek.com/reviews/escape-academy-review/" target="_blank" rel="noopener noreferrer">Escape Academy</a> DLC <a href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/" target="_blank" rel="noopener noreferrer">Escape from Anti-Escape Island</a> by <a href="https://www.coincrew.games/" target="_blank" rel="noopener noreferrer">Coin Crew Games</a>, and here is our walkthrough to help you through every step:</p>
<h3>Escape Academy Take to the Skies Walkthrough Details</h3>
<h4><span style="font-weight: 400;">Time to complete: 25 Minutes</span></h4>
<h4><span style="font-weight: 400;">Difficulty Rating: 3/5</span></h4>
<h3>Walkthrough</h3>
<h4>Decode the Skypher</h4>
<p>Your first port of call should be the jet bathroom. Handily on the toilet is the <strong>Skypher Magazine</strong>. Pick it up. Pin it up in front of you to start decoding it. You&#8217;ll notice the first clue is done for you:</p>
<p style="text-align: center;"><strong>GHHU = DEER</strong></p>
<p>What this means is:</p>
<p style="text-align: center;"><strong>G=D</strong><br />
<strong>H=E</strong><br />
<strong>U=R</strong></p>
<p>Now we need to solve the other puzzles using their pictures. The next picture is an <strong>ICE CREAM</strong>, which means:</p>
<p style="text-align: center;"><strong>LFH FUHDP = ICE CREAM</strong></p>
<p>This gives us four more letters for our Skypher:</p>
<p style="text-align: center;"><strong>L=I</strong><br />
<strong>F=C</strong><br />
<strong>D=A</strong><br />
<strong>P=M</strong></p>
<p>Now onto our last clue which we can see is a pair of <strong>SHOES</strong>, which means:</p>
<p style="text-align: center;"><strong>VKRHV = SHOES</strong></p>
<p>Which gives us these final three letters for our Skypher:</p>
<p style="text-align: center;"><strong>V=S</strong><br />
<strong>K=H</strong><br />
<strong>R=O</strong></p>
<p>With all these letters we can now solve the riddle on the left-hand page of the Magazine:</p>
<blockquote><p>Fun Tip: Check the UHG FKDLUV</p></blockquote>
<p>We can translate <strong>UHG FKDLUV</strong> using our Skypher letters to reveal:</p>
<p style="text-align: center;"><strong>RED CHAIRS</strong></p>
<p>Now if you explore the cabin, you&#8217;ll notice some of the rows are indeed made up of Red Chairs. What you might not know is what to do with that information.</p>
<p>The answer is to interact with the Window Covers on each row with Red Chairs. Each Window Cover has a letter on it. Once you have done this with all the Red Chair rows, you should have the following letters:</p>
<p style="text-align: center;"><strong>AHAIRED</strong></p>
<p>If you rearrange these to form a reasonably relevant word right now, you&#8217;d get:</p>
<p style="text-align: center;"><strong>AIRHEAD</strong></p>
<p>Head to the Cockpit door and use the keypad to enter the code. So for AIRHEAD, you&#8217;d need to enter:</p>
<p style="text-align: center;"><strong>[abc], [ghi], [pqr], [ghi], [def], [abc], [def]</strong></p>
<p>And the cockpit will open.</p>
<p>&nbsp;</p>
<h4>Turn on Autopilot</h4>
<p>Firstly you&#8217;ll want to go over to Jeb and give him a satisfying slap to wake him up. He&#8217;ll then tell you that the engines are on fire and that you need to put them out.</p>
<p>The machine to do this is to the right of Jeb, behind the co-pilot seat. This machine reads:</p>
<blockquote><p>In case of fire: Pull from left to right</p></blockquote>
<p>All you now need to do is figure out which engines are where. To do this you&#8217;ll need to go back into the main cabin and look at the engines on the wings.</p>
<p>Begin by looking out the left window, to see the <strong>LIMA</strong> and <strong>OSCAR</strong> engines. Look out the right window to see the <strong>CHARLIE </strong>and<strong> KILO</strong> engines. So going from left to right, the engines would be:</p>
<p style="text-align: center;"><strong>LIMA, OSCAR, CHARLIE, KILO</strong></p>
<p>The keen-eyed amongst you will notice this spells LOCK &#8211; just another Escape Academy easter egg. Pull the levers in this order, and the engine fires will be extinguished.</p>
<p>Jeb will comment however that the plane is imbalanced, and he could do with you rebalancing the luggage in the overhead compartments.</p>
<p>Before you start, you&#8217;ll want to grab the <strong>Luggage Infographic</strong> which can be found on a trolley, to the right of the Cargo Hold door at the other end of the plane. Pin this to your inventory. It details the following:</p>
<p style="text-align: center;"><strong>Blue Luggage = 10kg</strong><br />
<strong>Green Luggage = 20kg</strong><br />
<strong>Yellow Luggage = 30kg</strong><br />
<strong>Orange Luggage = 40kg</strong><br />
<strong>Red Luggage = 50kg</strong></p>
<p>Now go and investigate the overhead luggage compartments. As you look down the plan at the cockpit, you&#8217;ll notice the right-hand side of the aircraft has the following luggage</p>
<p style="text-align: center;"><strong>Blue, Blue, Red, Blue, Blue, Space, Blue</strong></p>
<p>And the left-hand side has:</p>
<p style="text-align: center;"><strong>Yellow, Yellow, Yellow, Yellow, Blue, Orange, Red</strong></p>
<p>&nbsp;</p>
<p>A quick conversion of the weights of the suitcases using the Luggage Infographic reveals that the total weight of each suitcase listed above is <strong>320kg</strong>. However currently, there is 100kg on the right-hand side and 220kg on the left-hand side, and we need <strong>both sides to be 160kg</strong><strong> to balance.</strong></p>
<p>The simplest way to do this is to do the following:</p>
<ol>
<li style="text-align: left;"><strong>Take the Orange Luggage from the Left side and place it in the Space on the Right side</strong></li>
<li><strong>Pick up a Blue Luggage from the Right side and place it in the Space on the Left side</strong></li>
<li><strong>Pick up a Yellow Luggage from the Left side and place it in the Space on the Right side</strong></li>
</ol>
<p>You&#8217;ll know you&#8217;ve done it right because you&#8217;ll hear the familiar Escape Academy tune, and the overhead compartments will close automatically.</p>
<p>Now head back to the cockpit and press the Autopilot button in the centre to finally turn it on.</p>
<p>&nbsp;</p>
<h4>Try to Eject</h4>
<p>Now you need to eject from the plan. head to the ejector seats where the Headmaster and Gillian are already seated. Pick a seat opposite and sit down. Then interact with the stick in from of you. Gillian and the Headmaster will eject successfully but Jeb will tell you we&#8217;re out of Ejector Fuel and you need to find some.</p>
<p>&nbsp;</p>
<h4>Crack the Cases</h4>
<p>What you&#8217;re looking for here is access to the Cargo Hold, but to do that you&#8217;re going to need to get deep inside the Headmaster&#8217;s luggage. We&#8217;re going to need to get into some cases and find some keys.</p>
<p>The first case you come across is a red case with stickers all over it. You&#8217;ll notice the case combination is a 5-digit code where each digit is a shape. If you look closely, you&#8217;ll notice that each shape is the same shape as a sticker on the case.</p>
<p>To crack the code you need to put the shapes in the order they were put on the suitcase in. So the sticker most underneath will be first and so on. This means the correct code for this case is:</p>
<p style="text-align: center;"><strong>Rectangle, Hexagon, Triangle, Octagon, Circle</strong></p>
<p>Input this code to unlock the suitcase. Inside you will find a <strong>Small Key</strong>.</p>
<p>Now move on to the case just to the right of the sticker case. Here you&#8217;ll find a case with four luggage tags on it that you need to line up. You can pull the tag and it will be pulled down to its marker at the bottom. Winding the key moves all labels back up a spot (unless they&#8217;re already at the top). The idea is to get each label to match with the label marker on the case.</p>
<p>You can do this through trial and error or you can follow the solution below:</p>
<ol>
<li style="text-align: left;"><strong>Pull the third label</strong></li>
<li style="text-align: left;"><strong>Spin wheel</strong></li>
<li style="text-align: left;"><strong>Pull the fourth label (the third and fourth should now be level)</strong></li>
<li style="text-align: left;"><strong>Spin wheel</strong></li>
<li style="text-align: left;"><strong>Pull the first label (the first, third, and fourth labels should now be level)</strong></li>
<li style="text-align: left;"><strong>Spin wheel</strong></li>
<li style="text-align: left;"><strong>Pull the second label</strong></li>
</ol>
<p>The case will open, and inside you will find another <strong>Small Key</strong>.</p>
<p>Now onto the third case, which is in a floor compartment to the left of where you are. In that compartment, you&#8217;ll want the one to the right, with a handle and wheels. When you inspect it, you&#8217;ll see you can raise the handle between the numbers 1 to 5. And the key is to find the correct order to raise the handle to unlock it.</p>
<p>The solution is actually right in front of you. Pay attention to the markings on the suitcase below the handle, and you&#8217;ll see inside the little flower motifs, you have different numbers of dots each time. This is the code for the suitcase. It is:</p>
<p style="text-align: center;"><strong>1, 4, 2, 5, 3</strong></p>
<p>Raise and lower the suitcase handle to these numbers and you will unlock it. Inside is the third and final <strong>Small Key</strong>.</p>
<p>Now pay attention to the other case in this compartment &#8211; the one with two keys on it. Use <strong>Small Keys</strong> on it to keep opening each smaller and smaller case, until finally you retrieve the <strong>ID Card</strong>.</p>
<p>&nbsp;</p>
<h4>Blast off to Safety!</h4>
<p>With the<strong> ID Card</strong> in hand, head to the Cargo Bay, and use the ID Card on the scanner to open the door, and head inside.</p>
<p>In front of you will be a wheel to turn, which will open a hatch. Inspect it to see the Ejector Fuel in the Cargo Hold with a lot of other luggage. You&#8217;ll need to move luggage around to get it out. You&#8217;ll likely be able to get this by playing around, but if you want the solution, then see below:</p>
<ol>
<li><strong>Move the bottom-left green crate up</strong></li>
<li><strong>Move the bottom grey crate left</strong></li>
<li><strong>Move the orange crate down</strong></li>
<li><strong>Move the Ejector Fuel down</strong></li>
<li><strong>Move the left purple crate right</strong></li>
<li><strong>Move the top-left yellow crate down</strong></li>
<li><strong>Move the top grey crate left</strong></li>
<li><strong>Move the orange crate up</strong></li>
<li><strong>Move the Ejector Fuel up</strong></li>
<li><strong>Move the right purple crate left</strong></li>
<li><strong>Move the bottom-right yellow crate up</strong></li>
<li><strong>Move the bottom-right green crate up</strong></li>
<li><strong>Move the bottom grey crate right</strong></li>
<li><strong>Move the central purple crate right</strong></li>
<li><strong>Move the Ejector Fuel down and out of the hatch</strong></li>
</ol>
<p>Interact with the crate to pick up the <strong>Ejector Fuel</strong>. Head back to the Ejector Seats and use the Ejector Fuel on them. Jeb will sit down, and you should too. Interact with the stick again to eject properly this time and escape. Congratulations, thanks to our walkthrough you&#8217;ve finished Take to the Skies in the Escape Academy DLC.</p>
<p>&nbsp;</p>
<h4><a href="https://www.godisageek.com/2022/07/escape-academy-complete-walkthrough/" target="_blank" rel="noopener noreferrer">CLICK HERE TO GO BACK TO THE MAIN ESCAPE ACADEMY GUIDE</a></h4>
<h4><a href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/" target="_blank" rel="noopener noreferrer"><strong>CLICK HERE TO GO BACK TO THE MAIN ESCAPE FROM ANTI ESCAPE ISLAND GUIDE</strong></a></h4>
<h4>NEXT: <a href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/" target="_blank" rel="noopener noreferrer">A JUICY DISCOVERY</a></h4>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='Escape Academy Take to the Skies Walkthrough' data-link='https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/' data-summary='Puzzle Plane' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='Escape Academy Take to the Skies Walkthrough' data-link='https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/' data-summary='Puzzle Plane' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/guides/" title="View all posts in Guides">Guides</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/coin-crew-games/" title="Coin Crew Games Tag" class="coin-crew-games">Coin Crew Games</a><a href="https://www.godisageek.com/tag/escape-academy/" title="Escape Academy Tag" class="escape-academy">Escape Academy</a><a href="https://www.godisageek.com/tag/escape-academy-escape-from-anti-escape-island/" title="Escape Academy: Escape From Anti-Escape Island Tag" class="escape-academy-escape-from-anti-escape-island">Escape Academy: Escape From Anti-Escape Island</a><a href="https://www.godisageek.com/tag/guide/" title="Guide Tag" class="guide">Guide</a><a href="https://www.godisageek.com/tag/iam8bit/" title="iam8bit Tag" class="iam8bit">iam8bit</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><img alt='' src='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><h3>Chris Hyde</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:chrisdhyde1983@gmail.com"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="30098" data-method="tags" class="info active" title="More articles tagged: Coin Crew Games">Coin Crew Games<span class="bottom-arrow"></span></a><a data-sorter="30097" data-method="tags" class="info" title="More articles tagged: Escape Academy">Escape Academy<span class="bottom-arrow"></span></a><a data-sorter="30696" data-method="tags" class="info" title="More articles tagged: Escape Academy: Escape From Anti-Escape Island">Escape Academy: Escape From Anti-Escape Island<span class="bottom-arrow"></span></a><a data-sorter="454" data-method="tags" class="info" title="More articles tagged: Guide">Guide<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Escape from Anti-Escape Island Walkthrough" title="Escape Academy: Escape from Anti-Escape Island Complete Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/">Escape Academy: Escape from Anti-Escape Island Complete Walkthrough</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy The Experiment Walkthrough" title="Escape Academy The Experiment Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/">Escape Academy The Experiment Walkthrough</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Into the Capture Dimension Walkthrough" title="Escape Academy Into the Capture Dimension Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/">Escape Academy Into the Capture Dimension Walkthrough</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy A Juicy Discovery Walkthrough" title="Escape Academy A Juicy Discovery Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/">Escape Academy A Juicy Discovery Walkthrough</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy Ventilation Infiltration Walkthrough" title="Escape Academy Ventilation Infiltration Walkthrough" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/">Escape Academy Ventilation Infiltration Walkthrough</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy: Escape from Anti-Escape Island" title="Escape Academy: Escape from Anti-Escape Island DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">Escape Academy: Escape from Anti-Escape Island DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/football-manager-2023-touch-now-available-on-apple-arcade/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Football Manager 2023 Touch News" title="Football Manager 2023 Touch now available on Apple Arcade" srcset="https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Football-Manager-2023-Touch-News-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/football-manager-2023-touch-now-available-on-apple-arcade/">Football Manager 2023 Touch now available on Apple Arcade</a><div class="article-meta clearfix"><a class="like-button do-like 269866 info-bottom" data-postid="269866" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/11/football-manager-2023-touch-now-available-on-apple-arcade/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/cities-skylines-world-tour-announced-starting-on-november-15th/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cities: Skylines World Tour announced, starting on November 15th" title="Cities: Skylines World Tour announced, starting on November 15th" srcset="https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cities-Skylines-World-Tour-announced-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/cities-skylines-world-tour-announced-starting-on-november-15th/">Cities: Skylines World Tour announced, starting on November 15th</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/cities-skylines-world-tour-announced-starting-on-november-15th/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/a-new-monster-hunter-game-is-coming-from-tencents-timi-studio-group/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="First Monster Hunter Rise: Sunbreak update coming tomorrow" title="A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group" srcset="https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/First-Monster-Hunter-Rise-Sunbreak-update-coming-tomorrow-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/a-new-monster-hunter-game-is-coming-from-tencents-timi-studio-group/">A new Monster Hunter game is coming from Tencent&#8217;s Timi Studio Group</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/a-new-monster-hunter-game-is-coming-from-tencents-timi-studio-group/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/bioware-and-ea-celebrate-nearly-15-years-of-mass-effect-on-n7-day/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day" srcset="https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mass-Effect-N7-Day-2022-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/bioware-and-ea-celebrate-nearly-15-years-of-mass-effect-on-n7-day/">BioWare and EA celebrate nearly 15 years of Mass Effect on N7 Day</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/bioware-and-ea-celebrate-nearly-15-years-of-mass-effect-on-n7-day/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/11/arcade-paradise-is-getting-3-new-dlc-cabinets/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Arcade Paradise is getting 3 new DLC cabinets" title="Arcade Paradise is getting 3 new DLC cabinets" srcset="https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Arcade-Paradise-is-getting-3-new-DLC-cabinets-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/11/arcade-paradise-is-getting-3-new-dlc-cabinets/">Arcade Paradise is getting 3 new DLC cabinets</a></div><a class="hover-link" href="https://www.godisageek.com/2022/11/arcade-paradise-is-getting-3-new-dlc-cabinets/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Tactics Ogre Reborn review" title="Tactics Ogre Reborn review" srcset="https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Tactics-Ogre-Reborn-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">Tactics Ogre Reborn review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 269940 info-bottom" data-postid="269940" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/harvestella-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Harvestella Review" title="Harvestella review" srcset="https://www.godisageek.com/wp-content/uploads/Harvestella-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Harvestella-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/harvestella-review/">Harvestella review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/harvestella-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Buddy Simulator 1984 Review" title="Buddy Simulator 1984 review" srcset="https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Buddy-Simulator-1984-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">Buddy Simulator 1984 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Escape Academy: Escape from Anti-Escape Island" title="Escape Academy: Escape from Anti-Escape Island DLC review" srcset="https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">Escape Academy: Escape from Anti-Escape Island DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/sonic-frontiers-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Frontiers review" title="Sonic Frontiers review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Frontiers-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sonic-frontiers-review/">Sonic Frontiers review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sonic-frontiers-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Street Fighter 6 gameplay preview | Video of all the fighters so far" title="Street Fighter 6 gameplay preview | Video of all the fighters so far" srcset="https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Street-Fighter-6-gameplay-preview-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">Street Fighter 6 gameplay preview | Video of all the fighters so far</a><div class="article-meta clearfix"><a class="like-button do-like 267467 info-bottom" data-postid="267467" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/09/street-fighter-6-gameplay-preview-video-of-all-the-fighters-so-far/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disney Dreamlight Valley Steam Deck: how does it run?" title="Disney Dreamlight Valley Steam Deck: how does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Disney-Dreamlight-Valley-Steam-Deck-how-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">Disney Dreamlight Valley Steam Deck: how does it run?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/09/disney-dreamlight-valley-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 496: Saints Row, Splatoon 3, Tinykin" title="Podcast 496: Saints Row, Splatoon 3, Tinykin" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-496-Saints-Row-Splatoon-3-Tinykin-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">Podcast 496: Saints Row, Splatoon 3, Tinykin</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/podcast-496-saints-row-splatoon-3-tinykin/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rollerdrome on Steam Deck: How does it run?" title="Rollerdrome Steam Deck: How does it run?" srcset="https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rollerdrome-on-Steam-Deck-How-does-it-run-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">Rollerdrome Steam Deck: How does it run?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/rollerdrome-steam-deck-how-does-it-run/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="How does Cult of the Lamb run on Steam Deck?" title="How does Cult of the Lamb run on Steam Deck?" srcset="https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cult-of-the-Lamb-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">How does Cult of the Lamb run on Steam Deck?</a></div><a class="hover-link" href="https://www.godisageek.com/2022/08/how-does-cult-of-the-lamb-run-on-steam-deck/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Uncharted: Legacy of Thieves Collection PC &amp; Steam Deck review" title="Uncharted: Legacy of Thieves Collection PC &#038; Steam Deck review" srcset="https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Uncharted-Legacy-of-Thieves-Collection-PC-Steam-Deck-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/">Uncharted: Legacy of Thieves Collection PC &#038; Steam Deck review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 268916 info-bottom" data-postid="268916" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/uncharted-legacy-of-thieves-collection-steam-deck-and-pc-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/god-of-war-ragnarok-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War Ragnarok Review" title="God of War Ragnarok review" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-Ragnarok-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/god-of-war-ragnarok-review/">God of War Ragnarok review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/god-of-war-ragnarok-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Persona 5 Royal title image" title="Persona 5 Royal Steam Deck &#038; Nintendo Switch review" srcset="https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/rsz_persona-5-royal-best-ps4-games2000x1270-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/">Persona 5 Royal Steam Deck &#038; Nintendo Switch review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/persona-5-royal-steam-deck-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/ghost-song-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Ghost-Song-Key-Art-1920x1080-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Ghost Song title image" title="Ghost Song review" srcset="https://www.godisageek.com/wp-content/uploads/Ghost-Song-Key-Art-1920x1080-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Ghost-Song-Key-Art-1920x1080-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Ghost-Song-Key-Art-1920x1080-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Ghost-Song-Key-Art-1920x1080-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/ghost-song-review/">Ghost Song review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/ghost-song-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/a-plague-tale-requiem-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/APTR-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A Plague Tale: Requiem review" title="A Plague Tale: Requiem review" srcset="https://www.godisageek.com/wp-content/uploads/APTR-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/APTR-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/APTR-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/APTR-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/a-plague-tale-requiem-review/">A Plague Tale: Requiem review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/a-plague-tale-requiem-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-Escape-from-Anti-Escape-Island-Walkthrough-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-escape-from-anti-escape-island-complete-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy: Escape from Anti-Escape Island Complete Walkthrough</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-Take-to-the-Skies-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-take-to-the-skies-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy Take to the Skies Walkthrough</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-Into-the-Capture-Dimension-Walkthrough--272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-into-the-capture-dimension-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy Into the Capture Dimension Walkthrough</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-The-Experiment-Walkthrough-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-the-experiment-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy The Experiment Walkthrough</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-A-Juicy-Discovery-Walkthrough-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-a-juicy-discovery-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy A Juicy Discovery Walkthrough</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Escape-Academy-Ventilation-Infiltration-Walkthrough-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/11/escape-academy-ventilation-infiltration-walkthrough/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Escape Academy Ventilation Infiltration Walkthrough</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">Tactics Ogre Reborn review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/tactics-ogre-reborn-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/harvestella-review/">Harvestella review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/harvestella-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">Buddy Simulator 1984 review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/buddy-simulator-1984-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">Escape Academy: Escape from Anti-Escape Island DLC review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/escape-academy-escape-from-anti-escape-island-dlc-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sonic-frontiers-review/">Sonic Frontiers review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sonic-frontiers-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.230769230769px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.461538461538px;" aria-label="Activision (783 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.692307692308px;" aria-label="Bandai Namco (438 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 18px;" aria-label="Capcom (732 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.615384615385px;" aria-label="DLC (481 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,185 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (410 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (574 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.307692307692px;" aria-label="Microsoft (942 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,806 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.384615384615px;" aria-label="nintendo switch (848 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,402 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.230769230769px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.846153846154px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 21.923076923077px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.307692307692px;" aria-label="PS4 (1,245 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.769230769231px;" aria-label="Sega (724 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.769230769231px;" aria-label="Sony (967 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (954 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.615384615385px;" aria-label="Steam (479 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.307692307692px;" aria-label="Trailer (685 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,320 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.076923076923px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.538461538462px;" aria-label="Xbox One (1,290 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.466321243523px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-3" style="font-size: 13.476683937824px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-4" style="font-size: 20.238341968912px;" aria-label="Features (2,752 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-5" style="font-size: 14.720207253886px;" aria-label="Guides (530 items)">Guides</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-6" style="font-size: 13.39896373057px;" aria-label="iOS (361 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-7" style="font-size: 27px;" aria-label="News (20,372 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-8" style="font-size: 15.264248704663px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-9" style="font-size: 15.341968911917px;" aria-label="Paid Placement Advertorials (644 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-10" style="font-size: 19.849740932642px;" aria-label="PC (2,450 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-11" style="font-size: 16.041450777202px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-12" style="font-size: 18.761658031088px;" aria-label="PlayStation 4 (1,777 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/reviews/playstation-5/" class="tag-cloud-link tag-link-27592 tag-link-position-13" style="font-size: 12.932642487047px;" aria-label="PlayStation 5 (312 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-14" style="font-size: 15.963730569948px;" aria-label="Podcasts (779 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-15" style="font-size: 16.818652849741px;" aria-label="Previews (991 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-16" style="font-size: 13.088082901554px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-17" style="font-size: 22.025906735751px;" aria-label="Reviews (4,655 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-18" style="font-size: 16.663212435233px;" aria-label="Switch (950 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-19" style="font-size: 12.544041450777px;" aria-label="Tech (284 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-20" style="font-size: 17.829015544041px;" aria-label="Trailers (1,347 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-21" style="font-size: 12.777202072539px;" aria-label="Uncategorised (300 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-22" style="font-size: 16.896373056995px;" aria-label="Video Features (1,034 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-23" style="font-size: 15.652849740933px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-24" style="font-size: 18.062176165803px;" aria-label="Xbox One (1,440 items)">Xbox One</a>
<a href="https://www.godisageek.com/category/reviews/xbox-series-x/" class="tag-cloud-link tag-link-27604 tag-link-position-25" style="font-size: 12.544041450777px;" aria-label="Xbox Series S|X (282 items)">Xbox Series S|X</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.730769230769px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.153846153846px;" aria-label="Android (86 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.769230769231px;" aria-label="Apple Arcade (14 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.211538461538px;" aria-label="Google Stadia (26 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.326923076923px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.076923076923px;" aria-label="iOS (126 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 16.961538461538px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.192307692308px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.5px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,978 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.538461538462px;" aria-label="PlayStation 3 (151 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.653846153846px;" aria-label="PlayStation 4 (1,728 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 22.5px;" aria-label="PlayStation 5 (329 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.288461538462px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.653846153846px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.269230769231px;" aria-label="Switch (991 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.346153846154px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.673076923077px;" aria-label="Xbox 360 (107 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.076923076923px;" aria-label="Xbox One (1,381 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.346153846154px;" aria-label="Xbox Series S (207 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 22.211538461538px;" aria-label="Xbox Series S|X (294 items)">Xbox Series S|X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
