<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>EFootball to have Inter Milan exclusivity from July 2024 | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://kumo.network-n.com/dist/app.js" site="god-is-a-geek"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="Konami has today announced an exclusive partnership with Inter Milan, meaning the Italian giants will feature solely eFootball moving forward." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="EFootball to have Inter Milan exclusivity from July 2024 | GodisaGeek.com" />
	<meta property="og:description" content="Konami has today announced an exclusive partnership with Inter Milan, meaning the Italian giants will feature solely eFootball moving forward." />
	<meta property="og:url" content="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2022-07-01T11:14:24+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan.jpg" />
	<meta property="og:image:width" content="1236" />
	<meta property="og:image:height" content="720" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.godisageek.com/#organization","name":"GodisaGeek.com","url":"https://www.godisageek.com/","sameAs":["http://youtube.com/godisageek","https://twitter.com/GodisaGeek"],"logo":{"@type":"ImageObject","@id":"https://www.godisageek.com/#logo","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png","width":400,"height":400,"caption":"GodisaGeek.com"},"image":{"@id":"https://www.godisageek.com/#logo"}},{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","publisher":{"@id":"https://www.godisageek.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan.jpg","width":1236,"height":720,"caption":"FIFA 23 Inter Milan"},{"@type":"WebPage","@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#webpage","url":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/","name":"EFootball to have Inter Milan exclusivity from July 2024 | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#primaryimage"},"datePublished":"2022-07-01T11:14:24+00:00","dateModified":"2022-07-01T11:14:24+00:00","description":"Konami has today announced an exclusive partnership with Inter Milan, meaning the Italian giants will feature solely eFootball moving forward.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/"]}]},{"@type":"Article","@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#article","isPartOf":{"@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#webpage"},"author":{"@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81"},"headline":"EFootball will have Inter Milan as an exclusive from July 2024","datePublished":"2022-07-01T11:14:24+00:00","dateModified":"2022-07-01T11:14:24+00:00","mainEntityOfPage":{"@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#webpage"},"publisher":{"@id":"https://www.godisageek.com/#organization"},"image":{"@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/#primaryimage"},"keywords":"eFootball,Konami","articleSection":"News","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81","name":"Chris Hyde","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=96&d=mm&r=g","caption":"Chris Hyde"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2022","monthnum":"07","day":"01","hour":"12","minute":"14","second":"24","post_id":"264732","postname":"efootball-will-have-inter-milan-as-an-exclusive-from-july-2024","category":"news"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/' />
<meta name='shareaholic:keywords' content='tag:efootball, tag:konami, tag:efootball inter milan, cat:news, type:post' />
<meta name='shareaholic:article_published_time' content='2022-07-01T12:14:24+01:00' />
<meta name='shareaholic:article_modified_time' content='2022-07-01T12:14:24+01:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris Hyde' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-640x373.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-1024x597.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='patreon-wordpress-css-css'  href='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/css/app.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.godisageek.com/wp-includes/css/dashicons.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='cb_p6-css-main-css'  href='https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/plugin/templates/default/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=264732' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F07%2Fefootball-will-have-inter-milan-as-an-exclusive-from-july-2024%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2022%2F07%2Fefootball-will-have-inter-milan-as-an-exclusive-from-july-2024%2F&#038;format=xml" />
<style>@font-face {
			font-family: 'Libre Franklin Extra Bold';
			src: url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff2') format('woff2'),
				 url('https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/fonts/librefranklin-extrabold-webfont.woff') format('woff');
			font-weight: bold;
			}</style>    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '9b09840bb8'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><!-- Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/"},"headline":"EFootball will have Inter Milan as an exclusive from July 2024","image":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan.jpg","width":1236,"height":720},"datePublished":"2022-07-01T12:14:24+0000","dateModified":"2022-07-01T12:14:24+0000","author":{"@type":"Person","name":"Chris Hyde","url":"https://www.godisageek.com/author/morgancapra3/chris-hyde"},"publisher":{"@type":"Organization","name":"GodisaGeek.com","logo":{"@type":"ImageObject","url":"https://www.godisageek.com/wp-content/uploads/2020-social-logo-2.png"}}}</script><!-- / Schema optimized by Schema Pro --><!-- site-navigation-element Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@graph":[{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Reviews","url":"https:\/\/www.godisageek.com\/category\/reviews\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Features","url":"https:\/\/www.godisageek.com\/category\/features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Guides","url":"https:\/\/www.godisageek.com\/category\/guides\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"News","url":"https:\/\/www.godisageek.com\/category\/news\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Videos","url":"https:\/\/www.godisageek.com\/category\/features\/video-features\/"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"Our Patreon","url":"http:\/\/patreon.com\/godisageek"},{"@context":"https:\/\/schema.org","@type":"SiteNavigationElement","id":"site-navigation","name":"MERCH","url":"https:\/\/godisageek.myspreadshop.co.uk"}]}</script><!-- / site-navigation-element Schema optimized by Schema Pro --><!-- breadcrumb Schema optimized by Schema Pro --><script type="application/ld+json">{"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.godisageek.com\/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.godisageek.com\/2022\/07\/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024\/","name":"EFootball will have Inter Milan as an exclusive from July 2024"}}]}</script><!-- / breadcrumb Schema optimized by Schema Pro -->			<style id="wpsp-style-frontend"></style>
			<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
		<style type="text/css" id="wp-custom-css">
			post p{line-height: 6em;}
	
		</style>
		<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-264732 single-format-standard it-background woocommerce wp-schema-pro-2.7.2">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/sonic-origins-review/">Sonic Origins review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Origins Review" title="Sonic Origins review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">Cuphead: The Delicious Last Course review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cuphead The Delicious Last Course Review" title="Cuphead: The Delicious Last Course review" srcset="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">Monster Hunter Rise: Sunbreak review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise Sunbreak" title="Monster Hunter Rise: Sunbreak review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DNF Duel title image" title="DNF Duel review" srcset="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">Outriders: Worldslayer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders: Worldslayer" title="Outriders: Worldslayer review" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/ea-sports-f1-2022-review/">EA Sports F1 2022 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/F1-2022-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="F1 2022 Review" title="EA Sports F1 2022 review" srcset="https://www.godisageek.com/wp-content/uploads/F1-2022-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/podcast-491-fire-emblem-warriors-three-hopes-tmnt-shredders-revenge/">Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#8217;s Revenge<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#039;s Revenge" title="Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#8217;s Revenge" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/tinykin-is-one-of-the-highlists-of-the-idxbox-2022-demo-event/">Tinykin is one of the highlights of the ID@Xbox 2022 demo event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tinykin title image" title="Tinykin is one of the highlights of the ID@Xbox 2022 demo event" srcset="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-has-made-huge-changes-for-its-xbox-launch/">Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Naraka: Bladepoint" title="Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview" srcset="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/podcast-490-the-quarry-tmnt-shredders-revenge-freezer-pops/">Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 490: The Quarry, TMNT: Shredder&#039;s Revenge, Freezer Pops" title="Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/final-fight-and-streets-of-rage-1-and-2-were-pretty-much-the-benchmark-an-interview-with-mike-tucker-of-bitmap-bureau-on-final-vendetta/">&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="&quot;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&quot;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" title="&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" srcset="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/gerda-a-flame-in-winter-interview-we-put-a-lot-of-ourselves-in-the-game/">Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda Interview" title="Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-jungle-sub-camp/">Monster Hunter Rise: Sunbreak | How to unlock the Jungle Sub-camp<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise sunbreak jungle camp" title="Monster Hunter Rise: Sunbreak | How to unlock the Jungle Sub-camp" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-heavy-knight-armor/">Monster Hunter Rise: Sunbreak | How to unlock the Heavy Knight Armor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Montster Hunter Rise Sunbreak Arlow Armor" title="Monster Hunter Rise: Sunbreak | How to unlock the Heavy Knight Armor" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-follower-collaboration-quest-guide/">Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20220615220506_1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide" title="Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide" srcset="https://www.godisageek.com/wp-content/uploads/20220615220506_1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-citadel-sub-camp/">Monster Hunter Rise: Sunbreak | How to unlock the Citadel Sub-camp<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise sunbreak citadel sub-camp" title="Monster Hunter Rise: Sunbreak | How to unlock the Citadel Sub-camp" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-buddy-recon-guide/">Monster Hunter Rise: Sunbreak | Buddy Recon Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Sunbreak | Buddy Recon Guide" title="Monster Hunter Rise: Sunbreak | Buddy Recon Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/">Naraka Bladepoint | Characters Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naraka Bladepoint Characters" title="Naraka Bladepoint | Characters Guide" srcset="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/">EFootball will have Inter Milan as an exclusive from July 2024<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="FIFA 23 Inter Milan" title="EFootball will have Inter Milan as an exclusive from July 2024" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/">Disco Elysium adds dyslexia friendly fonts<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium adds dyslexia friendly fonts" title="Disco Elysium adds dyslexia friendly fonts" srcset="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/atlus-celebrates-the-persona-25th-anniversary-with-a-load-of-stylish-merch/">Atlus celebrates the Persona 25th anniversary with a load of stylish merch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" title="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" srcset="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/ufc-4-adds-paddy-the-baddy-and-more-uk-fighters/">UFC 4 adds paddy the baddy and more UK fighters<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="UFC 4 adds paddy the baddy and more UK fighters" srcset="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/nintendo-direct-mini-partner-showcase-everything-announced/">Nintendo Direct Mini: Partner Showcase: Everything announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct Mini Partner Showcase June 2022" title="Nintendo Direct Mini: Partner Showcase: Everything announced" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/wwe-2k22-clowning-around-pack-out-now/">WWE 2K22 &#8216;Clowning Around Pack&#8217; out now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K22 Clowning Around Pack DLC" title="WWE 2K22 &#8216;Clowning Around Pack&#8217; out now" srcset="https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/sonic-origins-review/">Sonic Origins review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Sonic Origins Review" title="Sonic Origins review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">Cuphead: The Delicious Last Course review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cuphead The Delicious Last Course Review" title="Cuphead: The Delicious Last Course review" srcset="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">Monster Hunter Rise: Sunbreak review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise Sunbreak" title="Monster Hunter Rise: Sunbreak review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DNF Duel title image" title="DNF Duel review" srcset="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">Outriders: Worldslayer review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders: Worldslayer" title="Outriders: Worldslayer review" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/ea-sports-f1-2022-review/">EA Sports F1 2022 review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/F1-2022-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="F1 2022 Review" title="EA Sports F1 2022 review" srcset="https://www.godisageek.com/wp-content/uploads/F1-2022-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/F1-2022-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/podcast-491-fire-emblem-warriors-three-hopes-tmnt-shredders-revenge/">Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#8217;s Revenge<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#039;s Revenge" title="Podcast 491: Fire Emblem Warriors: Three Hopes, TMNT: Shredder&#8217;s Revenge" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-491-Fire-Emblem-Warriors-Three-Hopes-TMNT-Shredders-Revenge-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/tinykin-is-one-of-the-highlists-of-the-idxbox-2022-demo-event/">Tinykin is one of the highlights of the ID@Xbox 2022 demo event<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Tinykin title image" title="Tinykin is one of the highlights of the ID@Xbox 2022 demo event" srcset="https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/6b3605_4e4971f2518a4d60bbf8a4ae12dc8d16_mv2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-has-made-huge-changes-for-its-xbox-launch/">Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="A screenshot of Naraka: Bladepoint" title="Naraka: Bladepoint has made some big changes ahead of its Xbox release | Preview" srcset="https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/ss_1c634e9a7b36580315d9665b185a6cf1090bffef-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/podcast-490-the-quarry-tmnt-shredders-revenge-freezer-pops/">Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 490: The Quarry, TMNT: Shredder&#039;s Revenge, Freezer Pops" title="Podcast 490: The Quarry, TMNT: Shredder&#8217;s Revenge, Freezer Pops" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-490-The-Quarry-TMNT-Shredders-Revenge-Freezer-Pops-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/final-fight-and-streets-of-rage-1-and-2-were-pretty-much-the-benchmark-an-interview-with-mike-tucker-of-bitmap-bureau-on-final-vendetta/">&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="&quot;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&quot;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" title="&#8220;Final Fight and Streets of Rage 1 and 2 were pretty much the benchmark&#8221;: An interview with Mike Tucker of Bitmap Bureau on Final Vendetta" srcset="https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Mike-Tucker-Final-Vendetta-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/gerda-a-flame-in-winter-interview-we-put-a-lot-of-ourselves-in-the-game/">Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda Interview" title="Gerda: A Flame in Winter interview: &#8220;We put a lot of ourselves in the game&#8221;" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-Interview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-Interview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-jungle-sub-camp/">Monster Hunter Rise: Sunbreak | How to unlock the Jungle Sub-camp<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise sunbreak jungle camp" title="Monster Hunter Rise: Sunbreak | How to unlock the Jungle Sub-camp" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-heavy-knight-armor/">Monster Hunter Rise: Sunbreak | How to unlock the Heavy Knight Armor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Montster Hunter Rise Sunbreak Arlow Armor" title="Monster Hunter Rise: Sunbreak | How to unlock the Heavy Knight Armor" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-follower-collaboration-quest-guide/">Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/20220615220506_1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide" title="Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide" srcset="https://www.godisageek.com/wp-content/uploads/20220615220506_1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/20220615220506_1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-citadel-sub-camp/">Monster Hunter Rise: Sunbreak | How to unlock the Citadel Sub-camp<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="monster hunter rise sunbreak citadel sub-camp" title="Monster Hunter Rise: Sunbreak | How to unlock the Citadel Sub-camp" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-buddy-recon-guide/">Monster Hunter Rise: Sunbreak | Buddy Recon Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise: Sunbreak | Buddy Recon Guide" title="Monster Hunter Rise: Sunbreak | Buddy Recon Guide" srcset="https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/">Naraka Bladepoint | Characters Guide<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Naraka Bladepoint Characters" title="Naraka Bladepoint | Characters Guide" srcset="https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/">EFootball will have Inter Milan as an exclusive from July 2024<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="FIFA 23 Inter Milan" title="EFootball will have Inter Milan as an exclusive from July 2024" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/">Disco Elysium adds dyslexia friendly fonts<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium adds dyslexia friendly fonts" title="Disco Elysium adds dyslexia friendly fonts" srcset="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/07/atlus-celebrates-the-persona-25th-anniversary-with-a-load-of-stylish-merch/">Atlus celebrates the Persona 25th anniversary with a load of stylish merch<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" title="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" srcset="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/ufc-4-adds-paddy-the-baddy-and-more-uk-fighters/">UFC 4 adds paddy the baddy and more UK fighters<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="UFC 4 adds paddy the baddy and more UK fighters" srcset="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/nintendo-direct-mini-partner-showcase-everything-announced/">Nintendo Direct Mini: Partner Showcase: Everything announced<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct Mini Partner Showcase June 2022" title="Nintendo Direct Mini: Partner Showcase: Everything announced" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/wwe-2k22-clowning-around-pack-out-now/">WWE 2K22 &#8216;Clowning Around Pack&#8217; out now<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="WWE 2K22 Clowning Around Pack DLC" title="WWE 2K22 &#8216;Clowning Around Pack&#8217; out now" srcset="https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/WWE-2K22-Clowning-Around-Pack-DLC-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2022/01/rainbow-six-extraction-gameplay/">Rainbow Six Extraction gameplay: check out 15 minutes of new footage<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" title="Rainbow Six Extraction gameplay: check out 15 minutes of new footage" srcset="https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Rainbox-Six-Extraction-gunplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-263406" class="menu-item menu-item-263406 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://godisageek.myspreadshop.co.uk">MERCH</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">Disco Elysium adds dyslexia friendly fonts</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2019/01/brand-chernobyl-themed-raid-update-console-warface/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-264732" class="post-264732 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-efootball tag-konami" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                EFootball will have Inter Milan as an exclusive from July 2024                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-hyde/"><span itemprop="author">Chris Hyde </span></a></span><span class="date">on <meta itemprop="datePublished" content="July 1, 2022">July 1, 2022</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-1024x597.jpg"><img width="790" height="460" src="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-790x460.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="FIFA 23 Inter Milan" title="EFootball will have Inter Milan as an exclusive from July 2024" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-790x460.jpg 790w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-300x175.jpg 300w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-1024x597.jpg 1024w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-768x447.jpg 768w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-180x105.jpg 180w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-360x210.jpg 360w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-1130x658.jpg 1130w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-640x373.jpg 640w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan.jpg 1236w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='EFootball will have Inter Milan as an exclusive from July 2024' data-link='https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/' data-summary='Benvenuto Nerazzurri' data-app-id-name='post_above_content'></div>
<p><a href="https://www.konami.com/en/" target="_blank" rel="noopener noreferrer">Konami</a> has today announced an exclusive partnership with Inter Milan, meaning the Italian giants will feature solely <a href="https://www.godisageek.com/reviews/efootball-pes-2020-review/" target="_blank" rel="noopener noreferrer">eFootball</a> moving forward. The deal is a multi-year partnership that will incorporate a range of elements in and out of the <a href="https://www.godisageek.com/2022/06/efootball-2022-season-2-sees-mobile-version-updated/" target="_blank" rel="noopener noreferrer">eFootball</a> series. The partnership itself will incorporate many different commercial, imagery, and activation rights.</p>
<p>These will include:</p>
<ul>
<li>Global Football Video Game Partner status</li>
<li>Training Kit Back Partner status (which will feature the eFootball branding)</li>
<li>Youth Development Centre Partner status – with the facility set to be known as “KONAMI Youth Development Centre in memory of Giacinto Facchetti”</li>
</ul>
<p>The partnership will also see the club feature within the eFootball™ series from version 2.0.0 onwards. This will see the featuring of authentic kits, the newly branded training kit, and the infamous San Siro stadium in-game. The partnership will see Inter Milan feature exclusively within eFootball and no other video game from July 2024. This means Inter Milan is now almost certain to not feature in future EA Football titles once the FIFA license expires after FIFA 23, given the July 2024 deadline. It&#8217;s not clear how long this exclusivity deal will run and therefore how many seasons of football titles it will impact.</p>
<p>Alongside a host of branding and commercial rights, Inter Milan will also integrate themselves within the array of eSports tournaments and activations that Konami runs, including the <a href="https://www.godisageek.com/2022/05/eight-clubs-announced-for-efootball-championship-pro-2022/" target="_blank" rel="noopener noreferrer">eFootball Championship Pro</a>, the most recent edition of which concluded last weekend.</p>
<p>Naoki Morita, Konami Digital Entertainment B.V.’s European President had this to say regarding the deal:</p>
<blockquote><p>Adding a club the stature of Inter Milan to our cohort of partner clubs is very exciting for Konami With the naming rights to the Youth Development Centre, the eFootball branding on the team’s training kit, and their involvement in our ever-expanding portfolio of eSports activations, we at Konami know that this partnership will bring us many successes now and for the long-term.</p></blockquote>
<p><em>eFootball 2022 is out now on PC, PS4, PS5, Xbox One, Xbox Series X|S, iOS and Android devices.</em></p>
<div class="cb_p6_patreon_button" style="text-align:center !important;margin-top:15px;margin-bottom:15px;">
<div class="cb_p6_message_over_post_button" style="font-size:24px;margin-top:10px;margin-bottom:10px;">Liked it? Take a second to support GodisaGeek.com on Patreon!</div>
<p><a rel="nofollow" target="_blank" href="https://www.patreon.com/GodisaGeek?utm_content=post_button&utm_medium=patron_button_and_widgets_plugin&utm_campaign=185319&utm_term=&utm_source=https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/"><img style="margin-top: 10px;margin-bottom: 10px;max-width:200px;width:100%;height:auto;" src="https://www.godisageek.com/wp-content/plugins/patron-button-and-widgets-by-codebard/images/become_a_patron_button.png"></a></div>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='EFootball will have Inter Milan as an exclusive from July 2024' data-link='https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/' data-summary='Benvenuto Nerazzurri' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='EFootball will have Inter Milan as an exclusive from July 2024' data-link='https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/' data-summary='Benvenuto Nerazzurri' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/news/" title="View all posts in News">News</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/efootball/" title="eFootball Tag" class="efootball">eFootball</a><a href="https://www.godisageek.com/tag/konami/" title="Konami Tag" class="konami">Konami</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><img alt='' src='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><h3>Chris Hyde</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:chrisdhyde1983@gmail.com"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="25757" data-method="tags" class="info active" title="More articles tagged: eFootball">eFootball<span class="bottom-arrow"></span></a><a data-sorter="162" data-method="tags" class="info" title="More articles tagged: Konami">Konami<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/eight-clubs-announced-for-efootball-championship-pro-2022/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Podcast-484-eFootball-2022-LEGO-Star-Wars-The-Skywalker-Saga-Astral-Ascent-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Eight clubs announced for eFootball Championship Pro 2022" title="Eight clubs announced for eFootball Championship Pro 2022" srcset="https://www.godisageek.com/wp-content/uploads/Podcast-484-eFootball-2022-LEGO-Star-Wars-The-Skywalker-Saga-Astral-Ascent-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Podcast-484-eFootball-2022-LEGO-Star-Wars-The-Skywalker-Saga-Astral-Ascent-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Podcast-484-eFootball-2022-LEGO-Star-Wars-The-Skywalker-Saga-Astral-Ascent-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Podcast-484-eFootball-2022-LEGO-Star-Wars-The-Skywalker-Saga-Astral-Ascent-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/eight-clubs-announced-for-efootball-championship-pro-2022/">Eight clubs announced for eFootball Championship Pro 2022</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/eight-clubs-announced-for-efootball-championship-pro-2022/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/04/efootball-championship-2022-will-take-place-in-june/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/eFootball-Championship-2022-will-take-place-in-June-image-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="eFootball Championship 2022 will take place in June" title="eFootball Championship 2022 will take place in June" srcset="https://www.godisageek.com/wp-content/uploads/eFootball-Championship-2022-will-take-place-in-June-image-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/eFootball-Championship-2022-will-take-place-in-June-image-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/eFootball-Championship-2022-will-take-place-in-June-image-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/eFootball-Championship-2022-will-take-place-in-June-image-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/04/efootball-championship-2022-will-take-place-in-june/">eFootball Championship 2022 will take place in June</a></div><a class="hover-link" href="https://www.godisageek.com/2022/04/efootball-championship-2022-will-take-place-in-june/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/04/efootball-2022-version-1-0-is-now-available-worldwide/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/eFootball-2022-version-1-is-now-available-worldwide-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="eFootball 2022 version 1.0 is now available worldwide" title="eFootball 2022 version 1.0 is now available worldwide" srcset="https://www.godisageek.com/wp-content/uploads/eFootball-2022-version-1-is-now-available-worldwide-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/eFootball-2022-version-1-is-now-available-worldwide-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/eFootball-2022-version-1-is-now-available-worldwide-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/eFootball-2022-version-1-is-now-available-worldwide-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/04/efootball-2022-version-1-0-is-now-available-worldwide/">eFootball 2022 version 1.0 is now available worldwide</a></div><a class="hover-link" href="https://www.godisageek.com/2022/04/efootball-2022-version-1-0-is-now-available-worldwide/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer three-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/konami-announces-efootball-a-free-to-play-football-simulation-experience/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Konami-eFootball-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Konami eFootball" title="Konami announces eFootball, a free-to-play football simulation experience" srcset="https://www.godisageek.com/wp-content/uploads/Konami-eFootball-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Konami-eFootball-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Konami-eFootball-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Konami-eFootball-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/konami-announces-efootball-a-free-to-play-football-simulation-experience/">Konami announces eFootball, a free-to-play football simulation experience</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/konami-announces-efootball-a-free-to-play-football-simulation-experience/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/08/efootball-pes-2021-season-update/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/eFootball-PES-2021-Season-Update-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="eFootball PES 2021 Season Update" title="eFootball PES 2021 Season Update cover revealed" srcset="https://www.godisageek.com/wp-content/uploads/eFootball-PES-2021-Season-Update-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/eFootball-PES-2021-Season-Update-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/eFootball-PES-2021-Season-Update-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/eFootball-PES-2021-Season-Update-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/08/efootball-pes-2021-season-update/">eFootball PES 2021 Season Update cover revealed</a></div><a class="hover-link" href="https://www.godisageek.com/2020/08/efootball-pes-2021-season-update/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2020/07/konami-announces-the-efootball-pro-cup/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/eFootball.Pro-Cup-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="eFootball.Pro Cup" title="Konami announces the eFootball.Pro Cup" srcset="https://www.godisageek.com/wp-content/uploads/eFootball.Pro-Cup-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/eFootball.Pro-Cup-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/eFootball.Pro-Cup-85x85.jpeg 85w, https://www.godisageek.com/wp-content/uploads/eFootball.Pro-Cup-150x150.jpeg 150w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2020/07/konami-announces-the-efootball-pro-cup/">Konami announces the eFootball.Pro Cup</a></div><a class="hover-link" href="https://www.godisageek.com/2020/07/konami-announces-the-efootball-pro-cup/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /><br class="hidden-desktop clearer three-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="FIFA 23 Inter Milan" title="EFootball will have Inter Milan as an exclusive from July 2024" srcset="https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/FIFA-23-Inter-Milan-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/">EFootball will have Inter Milan as an exclusive from July 2024</a><div class="article-meta clearfix"><a class="like-button do-like 264732 info-bottom" data-postid="264732" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/07/efootball-will-have-inter-milan-as-an-exclusive-from-july-2024/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Disco Elysium adds dyslexia friendly fonts" title="Disco Elysium adds dyslexia friendly fonts" srcset="https://www.godisageek.com/wp-content/uploads/disco-elysium-4-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/disco-elysium-4-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/">Disco Elysium adds dyslexia friendly fonts</a></div><a class="hover-link" href="https://www.godisageek.com/2022/07/disco-elysium-adds-dyslexia-friendly-fonts/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/07/atlus-celebrates-the-persona-25th-anniversary-with-a-load-of-stylish-merch/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" title="Atlus celebrates the Persona 25th anniversary with a load of stylish merch" srcset="https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/thumb-1920-418376-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/07/atlus-celebrates-the-persona-25th-anniversary-with-a-load-of-stylish-merch/">Atlus celebrates the Persona 25th anniversary with a load of stylish merch</a></div><a class="hover-link" href="https://www.godisageek.com/2022/07/atlus-celebrates-the-persona-25th-anniversary-with-a-load-of-stylish-merch/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/ufc-4-adds-paddy-the-baddy-and-more-uk-fighters/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="UFC 4 adds paddy the baddy and more UK fighters" srcset="https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Paddy-UFC-4-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/ufc-4-adds-paddy-the-baddy-and-more-uk-fighters/">UFC 4 adds paddy the baddy and more UK fighters</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/ufc-4-adds-paddy-the-baddy-and-more-uk-fighters/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/nintendo-direct-mini-partner-showcase-everything-announced/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="Nintendo Direct Mini Partner Showcase June 2022" title="Nintendo Direct Mini: Partner Showcase: Everything announced" srcset="https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Nintendo-Direct-Mini-Partner-Showcase-June-2022-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/nintendo-direct-mini-partner-showcase-everything-announced/">Nintendo Direct Mini: Partner Showcase: Everything announced</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/nintendo-direct-mini-partner-showcase-everything-announced/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/sonic-origins-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Sonic Origins Review" title="Sonic Origins review" srcset="https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Sonic-Origins-Review-35x35.jpg 35w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sonic-origins-review/">Sonic Origins review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">8.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 264710 info-bottom" data-postid="264710" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/sonic-origins-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cuphead The Delicious Last Course Review" title="Cuphead: The Delicious Last Course review" srcset="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">Cuphead: The Delicious Last Course review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise Sunbreak" title="Monster Hunter Rise: Sunbreak review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">Monster Hunter Rise: Sunbreak review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dnf-duel-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DNF Duel title image" title="DNF Duel review" srcset="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dnf-duel-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/outriders-worldslayer-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Outriders: Worldslayer" title="Outriders: Worldslayer review" srcset="https://www.godisageek.com/wp-content/uploads/Outriders-Main-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Outriders-Main-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">Outriders: Worldslayer review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Saints Row Boss Factory" title="Saints Row Boss Factory lets you create the boss of your dreams, or nightmares" srcset="https://www.godisageek.com/wp-content/uploads/Saints-Row-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Saints-Row-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">Saints Row Boss Factory lets you create the boss of your dreams, or nightmares</a><div class="article-meta clearfix"><a class="like-button do-like 264061 info-bottom" data-postid="264061" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2022/06/saints-row-boss-factory-lets-you-create-the-boss-of-your-dreams-or-nightmares/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Fire Emblem Warriors: Three Hopes trailer shows new and returning characters" title="Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay" srcset="https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Fire-Emblem-Warriors-Three-Hopes-trailer-shows-new-and-returning-characters-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">Watch ten minutes of new Fire Emblem Warriors: Three Hopes gameplay</a></div><a class="hover-link" href="https://www.godisageek.com/2022/06/watch-ten-minutes-of-new-fire-emblem-warriors-three-hopes-gameplay/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Source of Madness | First Look Video" title="Source of Madness | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Source-of-Madness-First-Look-Video-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">Source of Madness | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/source-of-madness-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Wildcat Gun Machine | First Look Video" title="Wildcat Gun Machine | First Look Video" srcset="https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Wildcat-Gun-Machine-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">Wildcat Gun Machine | First Look Video</a></div><a class="hover-link" href="https://www.godisageek.com/2022/05/wildcat-gun-machine-first-look-video/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" title="God of War PC gameplay: check out ten minutes of 4K/60FPS footage" srcset="https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/God-of-War-video-featured-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">God of War PC gameplay: check out ten minutes of 4K/60FPS footage</a></div><a class="hover-link" href="https://www.godisageek.com/2022/01/god-of-war-pc-gameplay-4k-60fps-footage/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Monster Hunter Rise Sunbreak" title="Monster Hunter Rise: Sunbreak review" srcset="https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2x1_NSwitch_MonsterHunterRiseSunbreak-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">Monster Hunter Rise: Sunbreak review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">10</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 264553 info-bottom" data-postid="264553" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dnf-duel-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DNF Duel title image" title="DNF Duel review" srcset="https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dnfduel_inquisitor-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dnf-duel-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/neon-white-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Neon-White-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Neon White Review" title="Neon White review" srcset="https://www.godisageek.com/wp-content/uploads/Neon-White-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Neon-White-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/neon-white-review/">Neon White review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/neon-white-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Cuphead The Delicious Last Course Review" title="Cuphead: The Delicious Last Course review" srcset="https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Cuphead-The-Delicious-Last-Course-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">Cuphead: The Delicious Last Course review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-quarry-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Quarry-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Quarry review" title="The Quarry review" srcset="https://www.godisageek.com/wp-content/uploads/The-Quarry-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Quarry-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-quarry-review/">The Quarry review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-quarry-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MHRS-Jungle-Camp-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-jungle-sub-camp/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Rise: Sunbreak | How to unlock the Jungle Sub-camp</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MHRS-Arlow-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-heavy-knight-armor/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Rise: Sunbreak | How to unlock the Heavy Knight Armor</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/20220615220506_1-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-follower-collaboration-quest-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Rise: Sunbreak | Follower Collaboration Quest Guide</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MHRS-Citadel-Camp-Main-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-how-to-unlock-the-citadel-sub-camp/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Rise: Sunbreak | How to unlock the Citadel Sub-camp</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/MHRS-Buddy-Recon-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/monster-hunter-rise-sunbreak-buddy-recon-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Monster Hunter Rise: Sunbreak | Buddy Recon Guide</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Naraka-Bladepoint-Characters-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2022/06/naraka-bladepoint-characters-guide/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Naraka Bladepoint | Characters Guide</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/sonic-origins-review/">Sonic Origins review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/sonic-origins-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">Cuphead: The Delicious Last Course review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/cuphead-the-delicious-last-course-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">Monster Hunter Rise: Sunbreak review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/monster-hunter-rise-sunbreak-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dnf-duel-review/">DNF Duel review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dnf-duel-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">Outriders: Worldslayer review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/outriders-worldslayer-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.234375px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.5625px;" aria-label="Activision (781 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.46875px;" aria-label="Bandai Namco (428 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/bethesda/" class="tag-cloud-link tag-link-1020 tag-link-position-4" style="font-size: 12px;" aria-label="bethesda (411 items)">bethesda</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.859375px;" aria-label="Capcom (721 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.640625px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.78125px;" aria-label="EA (1,169 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12px;" aria-label="iOS (409 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.515625px;" aria-label="Konami (570 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.4375px;" aria-label="Microsoft (940 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,791 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.265625px;" aria-label="nintendo switch (823 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.421875px;" aria-label="PC (1,394 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.375px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 13.875px;" aria-label="PlayStation 4 (493 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.078125px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.25px;" aria-label="PS4 (1,239 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.625px;" aria-label="Sega (701 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.671875px;" aria-label="Sony (961 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.4375px;" aria-label="square enix (937 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.640625px;" aria-label="Steam (477 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.390625px;" aria-label="Trailer (684 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.953125px;" aria-label="Ubisoft (1,311 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.296875px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.71875px;" aria-label="Xbox One (1,287 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.692307692308px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.230769230769px;" aria-label="Articles (238 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12px;" aria-label="Competition (223 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.692307692308px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.307692307692px;" aria-label="Features (2,685 items)">Features</a>
<a href="https://www.godisageek.com/category/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 14.076923076923px;" aria-label="Guides (417 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (222 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.615384615385px;" aria-label="iOS (358 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (20,042 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.461538461538px;" aria-label="Opinion (625 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 15.230769230769px;" aria-label="Paid Placement Advertorials (584 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.769230769231px;" aria-label="PC (2,312 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.230769230769px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.769230769231px;" aria-label="PlayStation 4 (1,695 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.153846153846px;" aria-label="Podcasts (767 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.769230769231px;" aria-label="Previews (940 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.307692307692px;" aria-label="PS Vita (330 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 22px;" aria-label="Reviews (4,495 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.538461538462px;" aria-label="Switch (870 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.692307692308px;" aria-label="Tech (273 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.923076923077px;" aria-label="Trailers (1,311 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 13px;" aria-label="Uncategorised (300 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.076923076923px;" aria-label="Video Features (1,028 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.846153846154px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 18.076923076923px;" aria-label="Xbox One (1,365 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.821011673152px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.120622568093px;" aria-label="Android (83 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.217898832685px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.143968871595px;" aria-label="Google Stadia (25 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.377431906615px;" aria-label="HTC Vive (27 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.112840466926px;" aria-label="iOS (122 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.019455252918px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 14.217898832685px;" aria-label="Oculus Quest 2 (11 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.552529182879px;" aria-label="Oculus Rift (29 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,843 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.63813229572px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.708171206226px;" aria-label="PlayStation 4 (1,646 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 21.805447470817px;" aria-label="PlayStation 5 (240 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.36186770428px;" aria-label="PlayStation VR (61 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.75486381323px;" aria-label="PS Vita (159 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.190661478599px;" aria-label="Switch (913 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.420233463035px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.762645914397px;" aria-label="Xbox 360 (106 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.124513618677px;" aria-label="Xbox One (1,307 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 21.396887159533px;" aria-label="Xbox Series S (201 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 21.513618677043px;" aria-label="Xbox Series X (211 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/patreon-connect/assets/js/app.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
			<script type="text/javascript" id="wpsp-script-frontend"></script>
			<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
