<!DOCTYPE HTML>

<html lang="en-US">

<head>

	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
        	<meta name="viewport" content="width=device-width, initial-scale=1.0">
    	
	
	<title>GOTY 2021: Chris Hyde | GodisaGeek.com</title>
    
    
	 
     
	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap.css" type="text/css" />
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/bootstrap-responsive.css" type="text/css" />
    	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/style.css" type="text/css" /> 
        	<link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/responsive.css" type="text/css" />
        <link media="screen, projection" rel="stylesheet" href="https://www.godisageek.com/wp-content/themes/steam/css/retina.css" type="text/css" />
    
    <style type="text/css">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</style>    
        
    	
	<link rel="shortcut icon" href="http://www.godisageek.com/wp-content/uploads/2020-social-logo-1.png" />
    
    <link href="https://fonts.googleapis.com/css?family=Dosis:400,600|Oswald:300,400|Roboto+Slab:400,100,300,700|Source+Sans+Pro:300,400,700&amp;subset=" rel="stylesheet" type="text/css">	
<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-85x85.jpg" />    
    	
	<link rel="pingback" href="https://www.godisageek.com/xmlrpc.php" />

	    
     
    

<script async src="https://os1.network-n.com/dist/godisageek.min.js"></script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-55V8VHH');</script>
<!-- End Google Tag Manager -->
	<!-- End NetworkN Stuff -->
	
	
	<!-- This site is optimized with the Yoast SEO plugin v14.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="It&#039;s been quite a year for games, with plenty to play and enjoy, and here Chris Hyde has pulled together his GOTY list for 2021." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.godisageek.com/2021/12/goty-2021-chris-hyde/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="GOTY 2021: Chris Hyde | GodisaGeek.com" />
	<meta property="og:description" content="It&#039;s been quite a year for games, with plenty to play and enjoy, and here Chris Hyde has pulled together his GOTY list for 2021." />
	<meta property="og:url" content="https://www.godisageek.com/2021/12/goty-2021-chris-hyde/" />
	<meta property="og:site_name" content="GodisaGeek.com" />
	<meta property="article:published_time" content="2021-12-29T14:00:06+00:00" />
	<meta property="article:modified_time" content="2021-12-21T16:13:50+00:00" />
	<meta property="og:image" content="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2.jpg" />
	<meta property="og:image:width" content="1920" />
	<meta property="og:image:height" content="1080" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.godisageek.com/#website","url":"https://www.godisageek.com/","name":"GodisaGeek.com","description":"Game Reviews, Gaming News, Podcasts: PS5 | Xbox | Nintendo Switch | PC Gaming","potentialAction":[{"@type":"SearchAction","target":"https://www.godisageek.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.godisageek.com/2021/12/goty-2021-chris-hyde/#primaryimage","inLanguage":"en-US","url":"https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2.jpg","width":1920,"height":1080},{"@type":"WebPage","@id":"https://www.godisageek.com/2021/12/goty-2021-chris-hyde/#webpage","url":"https://www.godisageek.com/2021/12/goty-2021-chris-hyde/","name":"GOTY 2021: Chris Hyde | GodisaGeek.com","isPartOf":{"@id":"https://www.godisageek.com/#website"},"primaryImageOfPage":{"@id":"https://www.godisageek.com/2021/12/goty-2021-chris-hyde/#primaryimage"},"datePublished":"2021-12-29T14:00:06+00:00","dateModified":"2021-12-21T16:13:50+00:00","author":{"@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81"},"description":"It's been quite a year for games, with plenty to play and enjoy, and here Chris Hyde has pulled together his GOTY list for 2021.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.godisageek.com/2021/12/goty-2021-chris-hyde/"]}]},{"@type":"Person","@id":"https://www.godisageek.com/#/schema/person/546460bc38b6bd9fc348a7ba4aa6ee81","name":"Chris Hyde","image":{"@type":"ImageObject","@id":"https://www.godisageek.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=96&d=mm&r=g","caption":"Chris Hyde"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//embedtweet.com' />
<link rel='dns-prefetch' href='//www.godisageek.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//m9m6e2w5.stackpathcdn.com' />
<link rel='dns-prefetch' href='//cdn.shareaholic.net' />
<link rel='dns-prefetch' href='//www.shareaholic.net' />
<link rel='dns-prefetch' href='//analytics.shareaholic.com' />
<link rel='dns-prefetch' href='//recs.shareaholic.com' />
<link rel='dns-prefetch' href='//partner.shareaholic.com' />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Feed" href="https://www.godisageek.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="GodisaGeek.com &raquo; Comments Feed" href="https://www.godisageek.com/comments/feed/" />
<!-- Shareaholic - https://www.shareaholic.com -->
<link rel='preload' href='//cdn.shareaholic.net/assets/pub/shareaholic.js' as='script'/>
<script data-no-minify='1' data-cfasync='false'>
_SHR_SETTINGS = {"endpoints":{"local_recs_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php?action=shareaholic_permalink_related","ajax_url":"https:\/\/www.godisageek.com\/wp-admin\/admin-ajax.php"},"site_id":"aad10e6a1fd66b6a486324e528805232","url_components":{"year":"2021","monthnum":"12","day":"29","hour":"14","minute":"00","second":"06","post_id":"258447","postname":"goty-2021-chris-hyde","category":"features"}};
</script>
<script data-no-minify='1' data-cfasync='false' src='//cdn.shareaholic.net/assets/pub/shareaholic.js' data-shr-siteid='aad10e6a1fd66b6a486324e528805232' async ></script>

<!-- Shareaholic Content Tags -->
<meta name='shareaholic:site_name' content='GodisaGeek.com' />
<meta name='shareaholic:language' content='en-US' />
<meta name='shareaholic:url' content='https://www.godisageek.com/2021/12/goty-2021-chris-hyde/' />
<meta name='shareaholic:keywords' content='tag:control ultimate edition, tag:death&amp;#039;s door, tag:deathloop, tag:feat, tag:forza horizon 5, tag:game of the year, tag:game of the year 2021, tag:it takes two, tag:knockout city, tag:metroid dread, tag:monster hunter rise, tag:new world, tag:nier replicant, tag:psychonauts 2, tag:ratchet &amp; clank: rift apart, tag:scarlet nexus, tag:super mario 3d world + bowser&amp;#039;s fury, tag:tales of arise, tag:goty 2021 chris hyde, cat:editorials, cat:features, cat:game of the year 2021, cat:opinion, type:post' />
<meta name='shareaholic:article_published_time' content='2021-12-29T14:00:06+00:00' />
<meta name='shareaholic:article_modified_time' content='2021-12-21T16:13:50+00:00' />
<meta name='shareaholic:shareable_page' content='true' />
<meta name='shareaholic:article_author_name' content='Chris Hyde' />
<meta name='shareaholic:site_id' content='aad10e6a1fd66b6a486324e528805232' />
<meta name='shareaholic:wp_version' content='9.7.1' />
<meta name='shareaholic:image' content='https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-640x360.jpg' />
<!-- Shareaholic Content Tags End -->

<!-- Shareaholic Open Graph Tags -->
<meta property='og:image' content='https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-1024x576.jpg' />
<!-- Shareaholic Open Graph Tags End -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.godisageek.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='EmbedTweet-css'  href='http://embedtweet.com/stylesheets/embed_v2.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.godisageek.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='promoslider_main-css'  href='https://www.godisageek.com/wp-content/plugins/promotion-slider/css/slider.css?ver=5.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://embedtweet.com/javascripts/embed_v2.js?via=WP&#038;ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var promoslider_options = {"version":"3.3.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/promotion-slider/js/promoslider.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://www.godisageek.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.godisageek.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.godisageek.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.godisageek.com/?p=258447' />
<link rel="alternate" type="application/json+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F12%2Fgoty-2021-chris-hyde%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.godisageek.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.godisageek.com%2F2021%2F12%2Fgoty-2021-chris-hyde%2F&#038;format=xml" />
    <script type="text/javascript">
        function nxsPostToFav(obj){ obj.preventDefault;
            var k = obj.target.split("-"); var nt = k[0]; var ii = k[1];  var pid = k[2];
            var data = {  action:'nxs_snap_aj', nxsact: 'manPost', nt:nt, id: pid, nid: ii, et_load_builder_modules:1, _wpnonce: '2f8ed5f175'};
            jQuery('#nxsFavNoticeCnt').html('<p> Posting... </p>'); jQuery('#nxsFavNotice').modal({ fadeDuration: 50 });
            jQuery.post('https://www.godisageek.com/wp-admin/admin-ajax.php', data, function(response) { if (response=='') response = 'Message Posted';
                jQuery('#nxsFavNoticeCnt').html('<p> ' + response + '</p>' +'<input type="button"  onclick="jQuery.modal.close();" class="bClose" value="Close" />');
            });
        }
    </script><link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.godisageek.com/wp-content/uploads/cropped-2020-social-logo-1-270x270.png" />
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-7235323-4']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>
<!-- ## NXS/OG ## --><!-- ## NXSOGTAGS ## --><!-- ## NXS/OG ## -->
	
</head>


<body class="post-template-default single single-post postid-258447 single-format-standard it-background woocommerce">



<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-55V8VHH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
    <div id="nn_skinl"></div>
    <div id="nn_skinr"></div>


	    
    <div id="fb-root"></div>
    
    <div id="ajax-error"></div>
    
    


	<div class="container-fluid no-padding">
   
        <div id="sticky-bar">
            
            <div class="row-fluid"> 
            
                <div class="span12"> 
                
                	<div class="container">
                    
                    	                        
                        	<div class="logo">
        
								                                    <a class="info-bottom" href="https://www.godisageek.com/" title="Home">
                                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                                    </a>
                                                                
                            </div>
                        
                                                
                                                
                                                
                        <div id="section-menu" class="menu-container">
                    
                            <div id="section-menu-full">
                                            
                                <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/scarf-review/">Scarf review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Scarf-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Scarf review" srcset="https://www.godisageek.com/wp-content/uploads/Scarf-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scarf-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scarf-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Scarf-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-gunk-review/">The Gunk review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Gunk" title="The Gunk review" srcset="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">DoDonPachi Resurrection review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DonDonPachi Resurrection" title="DoDonPachi Resurrection review" srcset="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">Shovel Knight Pocket Dungeon review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shovel Knight Pocket Dungeon review" title="Shovel Knight Pocket Dungeon review" srcset="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">Grim Dawn: Definitive Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Grim Dawn: Definitive Edition" title="Grim Dawn: Definitive Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/evil-genius-2-world-domination-console-review/">Evil Genius 2: World Domination console review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination console" title="Evil Genius 2: World Domination console review" srcset="https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/goty-2021-chris-hyde/">GOTY 2021: Chris Hyde<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="GOTY 2021: Chris Hyde" srcset="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-mick-fraser/">GOTY 2021: Mick Fraser<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOTY 2021: Mick Fraser" title="GOTY 2021: Mick Fraser" srcset="https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-lyle-carr/">GOTY 2021: Lyle Carr<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokémon Snap" title="GOTY 2021: Lyle Carr" srcset="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/game-of-the-year-2021-it-takes-two/">Game of the Year 2021: It Takes Two<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two review" title="Game of the Year 2021: It Takes Two" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/game-of-the-year-the-top-ten-games-of-2021/">Game of the Year: The Top Ten Games of 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Game of the Year: The Top Ten Games of 2021" title="Game of the Year: The Top Ten Games of 2021" srcset="https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-most-anticipated-games-of-2022/">GOTY 2021: Most Anticipated Games of 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOTY 2021: Most Anticipated Games of 2022" title="GOTY 2021: Most Anticipated Games of 2022" srcset="https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/christmas-gaming-gift-guide-2021/">Christmas Gaming Gift Guide 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Gaming Gift Guide 2021" title="Christmas Gaming Gift Guide 2021" srcset="https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/christmas-tech-gift-guide-2021/">Christmas Tech Gift Guide 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Tech Gift Guide 2021" title="Christmas Tech Gift Guide 2021" srcset="https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/shovel-knight-pocket-dungeon-how-to-get-the-true-ending/">Shovel Knight Pocket Dungeon: How to get the True Ending<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Shovel Knight Pocket Dungeon: How to get the True Ending" srcset="https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-fob-upgrades-and-how-to-unlock-them-with-valor/">Halo Infinite | FOB Upgrades and how to unlock them with Valor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite | How to upgrade your FOB with Valor" title="Halo Infinite | FOB Upgrades and how to unlock them with Valor" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-best-upgrades-for-master-chiefs-abilities/">Halo Infinite | Best upgrades for Master Chief&#8217;s abilities<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The right tools for the job" title="Halo Infinite | Best upgrades for Master Chief&#8217;s abilities" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-tips-to-get-started-on-zeta-halo/">Halo Infinite | Tips to get started on Zeta Halo<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite: Master Chief goes open world" title="Halo Infinite | Tips to get started on Zeta Halo" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/dying-light-2-stay-human-pc-system-requirements-revealed/">Dying Light 2 Stay Human PC system requirements revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light 2 PC system requirements" title="Dying Light 2 Stay Human PC system requirements revealed" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/gerda-a-flame-in-winter-announced-by-dontnod/">Gerda: A Flame in Winter announced by DONTNOD<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda A Flame in Winter Announcement" title="Gerda: A Flame in Winter announced by DONTNOD" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/new-patch-for-diablo-ii-resurrected-coming-next-year/">New patch for Diablo II: Resurrected coming next year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Diablo II Resurrected Patch 2.4" title="New patch for Diablo II: Resurrected coming next year" srcset="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/olliolli-world-release-date-announced-for-next-year/">OlliOlli World release date announced for next year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="OlliOlli World Release Date" title="OlliOlli World release date announced for next year" srcset="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/the-new-war-the-latest-expansion-for-warframe-launches-today/">The New War, the latest expansion for Warframe, launches today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warframe: The New War" title="The New War, the latest expansion for Warframe, launches today" srcset="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warframe-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warframe-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warframe-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/the-dawning-returns-to-destiny-2/">The Dawning returns to Destiny 2 with new gear, gifts and snowball fights!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Dawning returns to Destiny 2" title="The Dawning returns to Destiny 2 with new gear, gifts and snowball fights!" srcset="https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/2022-game-release-dates-ps5-xbox-nintendo-switch-pc/">Release Dates</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                
                            </div>
                            
                            <div id="section-menu-compact">
                            
                                <ul>
                            
                                    <li>
                            
                                        <a id="section-menu-selector">
                                        
                                            <span class="icon-grid"></span>
                                    
                                            SECTIONS                                            
                                            <span class="icon-down-bold selector"></span> 
                                            
                                        </a> 
                                        
                                        <ul id="menu-section-menu" class="menu"><li id="menu-item-68" class="menu-item menu-item-68 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="reviews"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/reviews/">Reviews<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/reviews/scarf-review/">Scarf review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Scarf-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="Scarf review" srcset="https://www.godisageek.com/wp-content/uploads/Scarf-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scarf-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scarf-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Scarf-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/the-gunk-review/">The Gunk review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Gunk" title="The Gunk review" srcset="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">DoDonPachi Resurrection review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DonDonPachi Resurrection" title="DoDonPachi Resurrection review" srcset="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">Shovel Knight Pocket Dungeon review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shovel Knight Pocket Dungeon review" title="Shovel Knight Pocket Dungeon review" srcset="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">Grim Dawn: Definitive Edition review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Grim Dawn: Definitive Edition" title="Grim Dawn: Definitive Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/reviews/evil-genius-2-world-domination-console-review/">Evil Genius 2: World Domination console review<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Evil Genius 2: World Domination console" title="Evil Genius 2: World Domination console review" srcset="https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/EG2_MaxCenter_1080p-b803-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/reviews/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-19" class="menu-item menu-item-19 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/">Features<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/goty-2021-chris-hyde/">GOTY 2021: Chris Hyde<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="" title="GOTY 2021: Chris Hyde" srcset="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-mick-fraser/">GOTY 2021: Mick Fraser<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOTY 2021: Mick Fraser" title="GOTY 2021: Mick Fraser" srcset="https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/haloinfinite-singleplayerreview-blogroll-1638561548039-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-lyle-carr/">GOTY 2021: Lyle Carr<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="New Pokémon Snap" title="GOTY 2021: Lyle Carr" srcset="https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/New-Pokémon-Snap-5-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/game-of-the-year-2021-it-takes-two/">Game of the Year 2021: It Takes Two<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="It Takes Two review" title="Game of the Year 2021: It Takes Two" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/game-of-the-year-the-top-ten-games-of-2021/">Game of the Year: The Top Ten Games of 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Game of the Year: The Top Ten Games of 2021" title="Game of the Year: The Top Ten Games of 2021" srcset="https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Game-of-the-Year-2021-The-Ten-Best-Games-of-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/goty-2021-most-anticipated-games-of-2022/">GOTY 2021: Most Anticipated Games of 2022<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GOTY 2021: Most Anticipated Games of 2022" title="GOTY 2021: Most Anticipated Games of 2022" srcset="https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Most-Anticipated-of-2022-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-8815" class="menu-item menu-item-8815 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="guides"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/guides/">Guides<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/christmas-gaming-gift-guide-2021/">Christmas Gaming Gift Guide 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Gaming Gift Guide 2021" title="Christmas Gaming Gift Guide 2021" srcset="https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/christmas-tech-gift-guide-2021/">Christmas Tech Gift Guide 2021<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Christmas Tech Gift Guide 2021" title="Christmas Tech Gift Guide 2021" srcset="https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/shovel-knight-pocket-dungeon-how-to-get-the-true-ending/">Shovel Knight Pocket Dungeon: How to get the True Ending<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-35x35.png" class="attachment-tiny size-tiny wp-post-image" alt="" title="Shovel Knight Pocket Dungeon: How to get the True Ending" srcset="https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-35x35.png 35w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-100x100.png 100w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-700x700.png 700w, https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-85x85.png 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-fob-upgrades-and-how-to-unlock-them-with-valor/">Halo Infinite | FOB Upgrades and how to unlock them with Valor<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite | How to upgrade your FOB with Valor" title="Halo Infinite | FOB Upgrades and how to unlock them with Valor" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-best-upgrades-for-master-chiefs-abilities/">Halo Infinite | Best upgrades for Master Chief&#8217;s abilities<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The right tools for the job" title="Halo Infinite | Best upgrades for Master Chief&#8217;s abilities" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/halo-infinite-tips-to-get-started-on-zeta-halo/">Halo Infinite | Tips to get started on Zeta Halo<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite: Master Chief goes open world" title="Halo Infinite | Tips to get started on Zeta Halo" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/guides/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-66" class="menu-item menu-item-66 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="news"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/news/">News<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/dying-light-2-stay-human-pc-system-requirements-revealed/">Dying Light 2 Stay Human PC system requirements revealed<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Dying Light 2 PC system requirements" title="Dying Light 2 Stay Human PC system requirements revealed" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/gerda-a-flame-in-winter-announced-by-dontnod/">Gerda: A Flame in Winter announced by DONTNOD<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda A Flame in Winter Announcement" title="Gerda: A Flame in Winter announced by DONTNOD" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/new-patch-for-diablo-ii-resurrected-coming-next-year/">New patch for Diablo II: Resurrected coming next year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Diablo II Resurrected Patch 2.4" title="New patch for Diablo II: Resurrected coming next year" srcset="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/olliolli-world-release-date-announced-for-next-year/">OlliOlli World release date announced for next year<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="OlliOlli World Release Date" title="OlliOlli World release date announced for next year" srcset="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/the-new-war-the-latest-expansion-for-warframe-launches-today/">The New War, the latest expansion for Warframe, launches today<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warframe: The New War" title="The New War, the latest expansion for Warframe, launches today" srcset="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warframe-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warframe-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warframe-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/12/the-dawning-returns-to-destiny-2/">The Dawning returns to Destiny 2 with new gear, gifts and snowball fights!<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Dawning returns to Destiny 2" title="The Dawning returns to Destiny 2 with new gear, gifts and snowball fights!" srcset="https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/2021_Dawning_Press_Kit_Compressed_Tower_13-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/news/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-4894" class="menu-item menu-item-4894 taxonomy 0  loaded" data-loop="menu" data-method="category" data-minisite="0" data-numarticles="6" data-object_name="category_name" data-object="category" data-thumbnail="1" data-type="mega" data-sorter="video-features"><a class="parent-item arrow-right" href="https://www.godisageek.com/category/features/video-features/">Videos<span class="icon-down-bold"></span><span class="icon-right"></span></a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"><ul class="term-list solo"><li class="post-list"><div class="loading"><div>&nbsp;</div></div><a href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a href="https://www.godisageek.com/2021/06/the-great-ace-attorney-chronicles-video-gameplay-preview/">The Great Ace Attorney Chronicles | Video Gameplay Preview<img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Great Ace Attorney Chronicles | Video Gameplay Preview" title="The Great Ace Attorney Chronicles | Video Gameplay Preview" srcset="https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Great-Ace-Attorney-Chronicles-Video-Gameplay-Preview-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a><a class="view-all" href="https://www.godisageek.com/category/features/video-features/">VIEW ALL<span class="icon-right"></span></a></li></ul></div></li><li id="menu-item-249856" class="menu-item menu-item-249856 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="https://www.godisageek.com/2022-game-release-dates-ps5-xbox-nintendo-switch-pc/">Release Dates</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li><li id="menu-item-249859" class="menu-item menu-item-249859 custom 0  loaded" data-loop="menu" data-method="" data-minisite="0" data-numarticles="6" data-object_name="" data-object="custom" data-thumbnail="1" data-type="standard" data-sorter=""><a class="parent-item" href="http://patreon.com/godisageek">Our Patreon</a><ul class="loading-placeholder"><li><div class="loading"><div>&nbsp;</div></div></li></ul><div class="dropdown-placeholder"></div></li></ul>                                        
                                    </li>
                                    
                                </ul>
                                
                            </div>  
                            
                        </div>
                        
                                            
                        <div id="sticky-controls">
                        
                        	                        
                                <div id="menu-search-button">
                                
                                    <span class="icon-search info-bottom" title="Search"></span>
                                    
                                </div>
                            
                                <div id="menu-search" class="info-bottom" title="Type and hit Enter">
                                
                                    <form method="get" id="searchformtop" action="https://www.godisageek.com/">                             
                                        <input type="text" placeholder="search" name="s" id="s" />          
                                    </form>
                                    
                                </div>
                                
                                                                        
                            <a id="back-to-top" href="#top" class="info icon-up-open" title="Top" data-placement="bottom"></a>
                            
                                              
                            
								                                
                                    <div class="register-wrapper">
                                    
                                        <a id="sticky-register" class="info-bottom icon-register sticky-button" title="Register"></a>
                                    
                                        <div class="sticky-form" id="sticky-register-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php?action=register" class="sticky-register-form"><div id="sticky-register-submit" class="sticky-submit register"><span class="icon-check"></span>REGISTER</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="user_login" value="" id="user_register" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on at-symbol">@</span><input type="text" name="user_email" value="" id="user_email" tabindex="12" placeholder="email" /></div><input type="hidden" name="redirect_to" value="/2021/12/goty-2021-chris-hyde/?register=true" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>
                                    
                                    <div class="login-wrapper">
                                    
                                        <a id="sticky-login" class="info-bottom icon-login sticky-button" title="Login"></a>
                                        
                                        <div class="sticky-form" id="sticky-login-form">
                                    
                                            <div class="loading"><div>&nbsp;</div></div>
                                        
                                            <form method="post" action="https://www.godisageek.com/wp-login.php" class="sticky-login-form"><div id="sticky-login-submit" class="sticky-submit login"><span class="icon-check"></span>LOGIN</div><div class="input-prepend"><span class="add-on icon-username"></span><input type="text" name="log" value="" id="user_login" tabindex="11" placeholder="username" /></div><br class="clearer" /><div class="input-prepend"><span class="add-on icon-password"></span><input type="password" name="pwd" value="" id="user_pass" tabindex="12" placeholder="password" /></div><input type="hidden" name="redirect_to" value="/2021/12/goty-2021-chris-hyde/" /><input type="hidden" name="user-cookie" value="1" /> </form>                                        
                                        </div>
                                    
                                    </div>                               
                                
                                                                
                                                                
                                                        
                        </div>
                        
                    </div>
                    
                </div>
                
            </div>
    
        </div>
        
    </div>
    
        
    <div id="sticky-logo-mobile" class="container">
    
		                            
            <div class="logo info-bottom" title="Home">
    
                                    <a href="https://www.godisageek.com/">
                        <img id="site-logo" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/GIAG-2020-Logo-for-Site-no-text.png" width="120" height="50" />   
                        <img id="site-logo-hd" alt="GodisaGeek.com" src="http://www.godisageek.com/wp-content/uploads/Black-2020-GIAG-LOGO-no-text.png" width="120" height="50" />  
                    </a>
                                
            </div>
        
            
    </div>

    
    <div class="after-top-menu">
        
        

    <div class="container" id="logo-bar">
    
        <div class="row">
    
            <div class="span12">
            
                <div id="logo-inner">
                
                	                    
                            
                        <div class="ad" id="ad-header">
                            
                            <div id="nn_lb1"></div> 
                              
                        </div>
                    
                     
                    
                    <br class="clearer" /> 
                    
                </div>    
                
            </div> 
        
        </div>
        
    </div>
    




<div class="container">

    <div id="content-wrapper" class="single-page  full-image">
    
        <div class="row">
    
            <div class="span12">
                
                <div id="postnav-wrapper" class="clearfix"><div id="postnav"><div class="previous-wrapper"><a class="" href="https://www.godisageek.com/2021/12/goty-2021-mick-fraser/">&nbsp;</a><div class="previous-inner inner-content"><div class="nav-item "><span class="icon-previous"></span>previous</div><div class="article-title ">GOTY 2021: Mick Fraser</div>&nbsp;</div></div><div class="random-wrapper"><a href="https://www.godisageek.com/2015/12/modding-tools-war/">&nbsp;</a><div class="random-inner inner-content"><div class="nav-item">random<br /><span class="icon-random"></span></div></div></div><div class="next-wrapper"><a class=" hidden" href="">&nbsp;</a><div class="next-inner inner-content"><div class="nav-item  hidden">next<span class="icon-next"></span></div><div class="article-title  hidden"></div>&nbsp;</div></div></div></div>                    
                                
                <div id="content" class="main-content sidebar-right" data-location="single-page">
                              
                                        
                                                
                            <div class="main-sortbar">
                        
                                <div class="sortbar-wrapper">
                                
                                    <div class="sortbar clearfix">
                                    
                                        <span></span>
                        
                                                                                
                                                                                        
                                                                                
                                                                                
                                                                                
                                        <span class="metric" title="Comments"><span class="icon icon-commented"></span><span class="numcount">0 comments</span></span>                                    
                                    </div>
                                    
                                </div>
                                
                            </div>
                            
                                                
                        <div class="content-inner">
                        
                                                
                                                        
                                                            
                                <div id="post-258447" class="post-258447 post type-post status-publish format-standard has-post-thumbnail hentry category-editorial category-features category-game-of-the-year-2021 category-opinion tag-control-ultimate-edition tag-deaths-door tag-deathloop tag-feat tag-forza-horizon-5 tag-game-of-the-year tag-game-of-the-year-2021 tag-it-takes-two tag-knockout-city tag-metroid-dread tag-monster-hunter-rise tag-new-world tag-nier-replicant tag-psychonauts-2 tag-ratchet-clank-rift-apart tag-scarlet-nexus tag-super-mario-3d-world-bowsers-fury tag-tales-of-arise" itemscope itemtype="http://schema.org/Article">
                                
                                    <div class="content-panel image-container">
                        
                                                                                
										                                            <h1>								
                                                GOTY 2021: Chris Hyde                                    
                                            </h1>
                                                                                
                                        <div class="authorship"><span class="author">by <a href="https://www.godisageek.com/author/chris-hyde/"><span itemprop="author">Chris Hyde </span></a></span><span class="date">on <meta itemprop="datePublished" content="December 29, 2021">December 29, 2021</span></div>                                        
                                                                                
                                                                                
                                                                                    
                                                                                            
                                            <div class="featured-image-wrapper"><div class="featured-image-inner"><a class="featured-image darken" href="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-1024x576.jpg"><img width="790" height="444" src="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-790x444.jpg" class="attachment-single-790 size-single-790 wp-post-image" alt="" title="GOTY 2021: Chris Hyde" itemprop="image" srcset="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-2.jpg 1920w" sizes="(max-width: 790px) 100vw, 790px" /></a></div></div>                                            
                                                                                
                                                                                
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="content-panel content-container">
                                        
                                        <div class="the-content clearfix">
                                        
                                              
                                            
                                            <div class="safari-text-fix">&nbsp;</div>
                            
                                            <div class="clearfix"><div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='GOTY 2021: Chris Hyde' data-link='https://www.godisageek.com/2021/12/goty-2021-chris-hyde/' data-summary='What a year!' data-app-id-name='post_above_content'></div>
<p>“All the games are being delayed” they said. “There’ll be fewer big games to enjoy” they said. And whilst it’s true that a cursory glance at the releases coming up in 2022 does make many fans salivate, that certainly hasn’t made 2021 a barren year. Far from it. There have been plenty of incredibly good games to sink your teeth into this year.</p>
<p>For me personally, I’ve enjoyed quite a mixture of experiences. And ultimately 2021 has surprised me. There are a couple of games on this list I knew would be there back in January, but mostly it’s filled with titles that have caught me a bit off guard. There are franchises or genres I’ve not experienced until this year. As well as a few titles which have been far better than I could have hoped them to be. And then there are the unknown quantities which have delighted me too.</p>
<p>And so for me, 2021 has been about gaming joy and discovery, and I can’t really ask for much more than that. So here are those games, my best of the year. Enjoy!</p>
<h3>Honourable Mentions</h3>
<p><img class="alignnone size-full wp-image-253422" src="https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview.jpg" alt="The EA relationship" width="1454" height="818" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview.jpg 1454w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/knockout-city-velan-studios-interview-640x360.jpg 640w" sizes="(max-width: 1454px) 100vw, 1454px" /></p>
<p><a href="https://www.godisageek.com/reviews/knockout-city-review/" target="_blank" rel="noopener noreferrer"><strong>Knockout City:</strong></a> On the face of it looks like another street sports game, but its simple yet superb design, gameplay variety, and accessible learning curve make this a great game to play with mates and is really different from everything else out there.</p>
<p><a href="https://www.godisageek.com/reviews/super-mario-3d-world-bowsers-fury-review/" target="_blank" rel="noopener noreferrer"><strong>Super Mario 3D World &amp; Bowser’s Fury:</strong></a> Take what is already a great multiplayer Mario platformer. Add online multiplayer functionality. And then add a unique experience in Bowser’s Fury that manages to feel fresh but grounded in Mario’s 3D roots and you’re on to a winner.</p>
<p><a href="https://www.godisageek.com/reviews/ratchet-clank-rift-apart-review/" target="_blank" rel="noopener noreferrer"><strong>Ratchet &amp; Clank: Rift Apart:</strong></a> An absolutely stunning-looking game showcasing the PS5 grunt. Sprinkle over some good platforming, shooting, level design, and overall fun and you’ve got a really enjoyable package.</p>
<p><a href="https://www.godisageek.com/reviews/control-review/" target="_blank" rel="noopener noreferrer"><strong>Control: Ultimate Edition:</strong></a> Bringing together the main Control experience and the DLC is one thing, but next-gen hardware frees Control’s frame rate issues and allows it to blossom into the awesome mind-bending experience that Remedy intended.</p>
<p><a href="https://www.godisageek.com/reviews/nier-replicant-review/" target="_blank" rel="noopener noreferrer"><strong>NieR Replicant:</strong></a> I’ve wanted to scratch the NieR itch ever since Automata blew me away. Replicant brings a fresh experience to us in the West, that’s full of great characters, action, and a twisting story that leaves you guessing until the end.</p>
<h3><a href="https://www.godisageek.com/reviews/deaths-door-review/" target="_blank" rel="noopener noreferrer">10. Death’s Door</a></h3>
<p><a href="https://www.youtube.com/watch?v=sKnl-84f0EQ"><img class="alignnone wp-image-253286 size-large" src="https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Deaths-Door-review-3.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>Who’d want the job of a Crow eh? Working all day reaping souls with not even a moment’s thanks from your boss upstairs. Good thing then that things properly kick off when someone steals your next assignment. Things unravel and require you to go on a glorious isometric adventure. With smooth fluid movement attached to decent combat, set in a charming, if slightly disturbing world, Death’s Door really is a bit of a gem. It looks and sounds nice too and offers just enough of a challenge to keep you engaged without ever feeling unfair. It’s not the longest game, but there’s plenty to do whilst you’re playing, and proof that good things do indeed come in small packages.</p>
<h3><a href="https://www.godisageek.com/reviews/new-world-review/" target="_blank" rel="noopener noreferrer">9. New World</a></h3>
<p><a href="https://www.youtube.com/watch?v=gbo_xW2wGSU"><img class="alignnone wp-image-256263 size-large" src="https://www.godisageek.com/wp-content/uploads/New-World-001-1-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/New-World-001-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/New-World-001-1-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/New-World-001-1.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>I’ve never dared step foot into an MMO before and if you’d told me that not only would 2021 would be the year that I did, but also that it’d make my top 10 I’d have laughed in your face. But New World sucked me in, sucked me in good. And despite my fifty hours or so with the game, had I not forced myself to play other games as the year came to a close, I’d have happily surrendered many more. The world always feels full and alive, with plenty to see and do, be that simple grinding or wandering off to complete a quest. It’s also an incredibly zen game where you just exist in your own bubble or with friends and enjoy the time together. The next quest or milestone is always achievable and pretty much everything you do contributes to something making the draw to keep going even greater. Well played Amazon, well played.</p>
<h3><a href="https://www.godisageek.com/reviews/deathloop-review/" target="_blank" rel="noopener noreferrer">8. Deathloop</a></h3>
<p><a href="https://www.youtube.com/watch?v=5foClUBdTHA"><img class="alignnone wp-image-255541 size-large" src="https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-1024x576.jpg" alt="Deathloop Gunplay" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Deathloop-Review-1-1.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>It’s hardly surprising coming from Arkane Studios, but Deathloop oozes class. The overt orange and black aesthetic, and intentional musical tones are only drowned out thematically by the superb main characters of Colt and Julianna. Their interactions always land and add a layer of entertainment to a title that already refuses to take itself too seriously. Deathloop manages to nail its loop mechanic by making repetition different and interesting. And it also has the bravado to offer you the option of solving Deathloop’s mystery in any order you wish, which keeps things fresh and unique to the player. Throw in a tactical element with varied weaponry, loadouts, and Slabs with crazy fun abilities to humourously torture the denizens of Blackreef, and you’ll find yourself smiling loop after loop.</p>
<h3><a href="https://www.godisageek.com/reviews/psychonauts-2-review/" target="_blank" rel="noopener noreferrer">7. Psychonauts 2</a></h3>
<p><a href="https://www.youtube.com/watch?v=anb996XPR1c"><img class="alignnone wp-image-188220 size-large" src="https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-1024x576.png" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-1024x576.png 1024w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-300x168.png 300w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-180x101.png 180w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-360x202.png 360w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-790x444.png 790w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001-1130x635.png 1130w, https://www.godisageek.com/wp-content/uploads/Psychonauts-ROR-E32016-001.png 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>Not for the last time on this list, I find myself coming to a series for the first time. I hadn’t played the original Psychonauts game, but I was still intrigued to see how a sequel to a fifteen-year-old game would land. The answer is: incredibly well. Psychonauts 2 offers a bit of everything, there’s decent platforming, upgrade trees, collectibles, a hint of Metroidvania. But all that revolves around a story that was quite interesting even for me as a newcomer and characters that despite looking ridiculous, keep you engaged. It also deals with facets of mental health, emotions, and respect in a really sensible way, without ever letting its zany style stop or clash with it. It’s a delicate balance that somehow sticks the landing, creating an enjoyable, endearing experience. Well worth the 15-year wait!</p>
<h3><a href="https://www.godisageek.com/reviews/scarlet-nexus-review/" target="_blank" rel="noopener noreferrer">6. Scarlet Nexus</a></h3>
<p><a href="https://www.youtube.com/watch?v=4R6hPC8SS1o"><img class="alignnone wp-image-251933 size-large" src="https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Scarlet-Nexus-Interview-3.jpg 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>Scarlet Nexus is one of those games that when you try to explain it to someone you’d be met with weird looks, and people shuffling away from you quite quickly. Set in a pseudo-futuristic world where the entire civilisation revolves around people’s brains is weird enough. Then there are the enemies known as Others, which are a hideous amalgamation of the natural and the synthetic. But it’s so fun to play, as the combat feels incredibly satisfying. The combination of traditional melee attacks, with psychokinesis, means you’re always surveying the landscape for bits and pieces to launch at enemies, comboing up for more damage. And when you land a powerful special attack courtesy of a QTE, you feel like a badass.</p>
<p>It’s Devil May Cry type endorphins when it lands, and the great thing is Scarlet Nexus knows how to build it up over time. You’ll keep unlocking more combo or ways to tackle foes as you progress, giving you more options to take down these weird-looking enemies. It’s incredibly cathartic and hugely rewarding. Well worth anyone’s time who’s not yet jumped into this one.</p>
<h3><a href="https://www.godisageek.com/reviews/monster-hunter-rise-review/" target="_blank" rel="noopener noreferrer">5. Monster Hunter Rise</a></h3>
<p><a href="https://www.youtube.com/watch?v=Tu8cNlW2AqE"><img class="alignnone wp-image-247869 size-large" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-capture-1.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>Yes it’s not Monster Hunter World 2. Yes it launched without a satisfying single-player ending. But Monster Hunter Rise was such an enjoyable experience for me this year, I just couldn’t put it down for weeks. True enough a lot of the core gameplay remains the same &#8211; which is fine by me &#8211; but the new additions to this title in the franchise were a lot of fun. The Wirebug, once I got to grips with it, helped me out of the pinch of battle, and became a mainstay for general traversal. And the environments themselves suddenly opened up in more ways than ever as you went off hunting for long-lost treasures, almost forgetting your behemoth prey for a moment.</p>
<p>But, perhaps unsurprisingly, it&#8217;s the hunting of monsters where Monster Hunter Rise really shines. Taking down new and familiar creatures either alone or with a group of mates, continues to be as fun as ever. New ways to use weapons and combo them keeps things fresh, and the feeling of success after 45 minutes of chipping away when that Monster finally falls is glorious. I await the Sunbreak expansion with baited breath.</p>
<h3><a href="https://www.godisageek.com/reviews/metroid-dread-review/" target="_blank" rel="noopener noreferrer">4. Metroid Dread</a></h3>
<p><a href="https://www.youtube.com/watch?v=cNP4gV8tTow"><img class="alignnone wp-image-254213 size-large" src="https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/metroid-dread-attack.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>A game that no one knew existed until May this year, ends up careering its way towards the top of the list. Metroid Dread from Mercury Steam who after cutting their teeth in the franchise with Samus Returns, are back with a whole new entry in the franchise. And it’s clear they’re hitting their stride in this area. They clearly understand what makes a brilliant 2D Metroid experience: superb movement and dexterity, fluid, well-designed, interconnected levels, and combat that feels responsive and satisfying. All present and correct in Metroid Dread, but the experience goes beyond that.</p>
<p>The EMMI sections provide the titular Dread to perfection as you try to escape these relentless foes before ultimately finding the weaponry to take them down. It offers superb light and shade from relaxed exploration to frenetic scampering through the specific zones. And a special mention to the detail Mercury Steam put in this game, from different situational effects that remind you of Breath of the Wild to the additional scenes added in for those speedrunners who sequence break the game. It’s a superb package and gets everyone playing and talking about Metroid again, which can only be a good thing.</p>
<h3><a href="https://www.godisageek.com/reviews/forza-horizon-5-review/" target="_blank" rel="noopener noreferrer">3. Forza Horizon 5</a></h3>
<p><a href="https://www.youtube.com/watch?v=_MvJGfd3QvI"><img class="alignnone wp-image-257064 size-large" src="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Forza-Horizon-5-Review-4.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>Put down those pitchforks people, and just embrace the fact I’ve never played a Forza Horizon game before. Yes I know I missed 4 which was set in the UK, and that was great. But here I am, a Horizon virgin, losing my plates with Forza Horizon 5. And wow, what an experience it has been. In many ways for me, Mexico feels like the perfect setting for a Horizon game. The carnival party atmosphere and aesthetic that oozes throughout is perfectly synonymous with what Forza Horizon 5 is all about. It’s a game that just wants you to enjoy yourself, to have unashamed fun, no matter what that looks like. If you want to race into the night, you can do that, if you fancy scouting the area for hidden boards and barns, then you go right ahead. Even if you just want to experience every single road in the game, Horizon 5 lets you and rewards you for your effort.</p>
<p>Everything is so seamless and, frankly, allowed. There are no rules on how to play, when or what. You find your own fun, and options are literally around every turn. The car variety is superb, giving you plenty of options to mess around in, and you may have noticed but it’s bloody beautiful to look at too. Mexico is an awesome sandbox playground to explore with intense variety and diversity from lush jungles areas, to mountains, sand dunes or city streets. It’s been my go-to “chill out” game when I just want to relax and enjoy myself this year. So whilst this is my first Forza Horizon game, if they make more, it certainly won’t be my last.</p>
<h3><a href="https://www.godisageek.com/reviews/it-takes-two-review/" target="_blank" rel="noopener noreferrer">2. It Takes Two</a></h3>
<p><img class="alignnone size-large wp-image-247717" src="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/It-Takes-Two-review-4.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p>It’s difficult to know where to start with It Takes Two, really. A co-op-only experience created by a team led by the sometimes Marmite Josef Fares could be enough to have some people tuning out. But what they’d be missing out on is one of the most enjoyable experiences of the year. It’s a compendium of superb individual moments that end up delighting and resonating with you long after they’re over. The attention to detail here is frankly staggering, often bordering on the unnecessary. Hazelight Studios demonstrate not only a high level of competency with It Takes Two, but a level of understanding and awareness of what games can and should be.</p>
<p>Seemingly traditional or predictable mechanics like a hammer and nail provide the perfect case study as two why this game is so special. It starts with just hammering switches and nailing platforms in place. Then it’s about using the hammer to swing on nails that are shot in the wall, as extra platforms. It culminates in a boss battle using all these mechanics and more. Oh and obviously Mae can also hammer Cody into the floor, for no other reason than it’s funny. In many ways, it’s reminiscent of Super Mario Odyssey in what it does, but for me, It Takes Two “out-Odyssey’s” Odyssey, in that it takes unique ideas, but their multi-functional execution makes them more wonderful than ideas in Mario’s epic.</p>
<p>And It Takes Two keeps doing this throughout its entire runtime. It’s chock-full of special, memorable moments that delight you. It’s got wacky random minigames or ways to randomly kill each other. There’s even a section where you can construct a photo scene just to see the polaroid outcome and nothing else. That and the myriad gaming references and homages throughout and the subtle humour in the writing and character interactions, it truly is a treat. It’s a game that you can’t help but enjoy and appreciate for all that’s inside it. A game for gamers made by gamers that just brings joy to everyone who plays it.</p>
<h3><a href="https://www.godisageek.com/reviews/tales-of-arise-review/" target="_blank" rel="noopener noreferrer">1. Tales of Arise</a></h3>
<p><a href="https://www.youtube.com/watch?v=HYG6takSO2c"><img class="alignnone wp-image-253759 size-large" src="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-1024x576.jpg" alt="Tales of Arise New Trailer" width="1024" height="576" srcset="https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-1024x576.jpg 1024w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-300x169.jpg 300w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-768x432.jpg 768w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-1536x864.jpg 1536w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-180x101.jpg 180w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-360x203.jpg 360w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-790x444.jpg 790w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-1130x636.jpg 1130w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News-640x360.jpg 640w, https://www.godisageek.com/wp-content/uploads/Tales-of-Arise-New-Trailer-News.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></a></p>
<p>It was a tough, close fight between Tales of Arise and It Takes Two for the top spot, but for me, Arise just edges it. The Tales series for me has been one of mild disappointment over the years. Not because they’ve been bad games, but because entries in the series have failed to live up to my first foray into the franchise, Tales of Symphonia on the GameCube. I thought at that point I’d found a new series I’d fall in love with. I consumed so much of Symphonia, the characters, the lore, the world, even the original video animation, and I loved everything about it. Nothing has come close since, and in all honesty, I wasn’t expecting Tales of Arise to buck that trend, but I was so pleasantly surprised.</p>
<p>What elevates Tales of Arise is that it excels in so many areas. The combat is the first area to mention in that it feels so fluid, satisfying, and a real upgrade from what has come before in Tales games. What starts as a simple, ground and aerial combo mechanic, quickly becomes about identifying enemy weaknesses, and building separate meters to unleash powerful solo or coop attacks. All of which in the roaring heat of battle (supplemented by superb rousing music) are so satisfying to land, before you quickly, and seamlessly divert your attention to the next unlucky foe. In many ways, it’s reminiscent of Scarlet Nexus in its combat, but the way you can tailor and combine your experience across six unique characters makes Tales of Arise just that little bit more satisfying.</p>
<p>The world is interesting and diverse, as is the lore of the warring Dahnans and Renans, and the 300-year history that has led to the here and now. The main characters themselves though, and their arcs, interactions, and main story beats, are where I really fell in love with this game. Shionne, and her isolated past, unable to physically feel human companionship, or Alphen with his unique abilities, unable to help those around him he cares about most. Even Dohalim, born with a silver spoon in his mouth, fights with a dark past, and an overbearing burden of responsibility that doesn’t even end when the credits roll. It’s a cast that really feels like they grow together, in an organic way. But also it&#8217;s refreshing that whilst there are payoffs, the end is not just a happy ever after. Reminiscent of Tolkien’s “Scouring of the Shire”, there’s a realisation here that long-fought wars and differences aren’t resolved the instant the big bad is defeated, and it’s nice to see a game approach the realism of this head-on.</p>
<p>It’s an experience that I enjoyed from start to finish. My GOTY. The Tales series is back to its best, and this fan couldn’t be happier.</p>
<div style='display:none;' class='shareaholic-canvas' data-app='share_buttons' data-title='GOTY 2021: Chris Hyde' data-link='https://www.godisageek.com/2021/12/goty-2021-chris-hyde/' data-summary='What a year!' data-app-id-name='post_below_content'></div>
<div style='display:none;' class='shareaholic-canvas' data-app='recommendations' data-title='GOTY 2021: Chris Hyde' data-link='https://www.godisageek.com/2021/12/goty-2021-chris-hyde/' data-summary='What a year!' data-app-id-name='post_below_content'></div>
<div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_player"></div></div>
<!-- AI CONTENT END 1 -->
</div>
                                    
                                                                                                
                                        </div> 
                                        
                                    </div>
                                    
                                                                                
                                                                            
                                                                        
                                                                        
                                    <div class="postinfo-box-wrapper"><div class="postinfo-box"><div class="category-list"><span class="icon-category"></span><a href="https://www.godisageek.com/category/features/editorial/" title="View all posts in Editorials">Editorials</a>, <a href="https://www.godisageek.com/category/features/" title="View all posts in Features">Features</a>, <a href="https://www.godisageek.com/category/features/game-of-the-year-2021/" title="View all posts in Game of the Year 2021">Game of the Year 2021</a>, <a href="https://www.godisageek.com/category/features/opinion/" title="View all posts in Opinion">Opinion</a></div><br class="clearer" /><div class="post-tags-wrapper"><span class="icon-tag"></span><div class="post-tags"><a href="https://www.godisageek.com/tag/control-ultimate-edition/" title="Control Ultimate Edition Tag" class="control-ultimate-edition">Control Ultimate Edition</a><a href="https://www.godisageek.com/tag/deaths-door/" title="Death's Door Tag" class="deaths-door">Death's Door</a><a href="https://www.godisageek.com/tag/deathloop/" title="deathloop Tag" class="deathloop">deathloop</a><a href="https://www.godisageek.com/tag/feat/" title="feat Tag" class="feat">feat</a><a href="https://www.godisageek.com/tag/forza-horizon-5/" title="Forza Horizon 5 Tag" class="forza-horizon-5">Forza Horizon 5</a><a href="https://www.godisageek.com/tag/game-of-the-year/" title="game of the year Tag" class="game-of-the-year">game of the year</a><a href="https://www.godisageek.com/tag/game-of-the-year-2021/" title="Game of the Year 2021 Tag" class="game-of-the-year-2021">Game of the Year 2021</a><a href="https://www.godisageek.com/tag/it-takes-two/" title="It Takes Two Tag" class="it-takes-two">It Takes Two</a><a href="https://www.godisageek.com/tag/knockout-city/" title="Knockout City Tag" class="knockout-city">Knockout City</a><a href="https://www.godisageek.com/tag/metroid-dread/" title="Metroid Dread Tag" class="metroid-dread">Metroid Dread</a><a href="https://www.godisageek.com/tag/monster-hunter-rise/" title="Monster Hunter Rise Tag" class="monster-hunter-rise">Monster Hunter Rise</a><a href="https://www.godisageek.com/tag/new-world/" title="New World Tag" class="new-world">New World</a><a href="https://www.godisageek.com/tag/nier-replicant/" title="NieR Replicant Tag" class="nier-replicant">NieR Replicant</a><a href="https://www.godisageek.com/tag/psychonauts-2/" title="psychonauts 2 Tag" class="psychonauts-2">psychonauts 2</a><a href="https://www.godisageek.com/tag/ratchet-clank-rift-apart/" title="Ratchet &amp; Clank: Rift Apart Tag" class="ratchet-clank-rift-apart">Ratchet &amp; Clank: Rift Apart</a><a href="https://www.godisageek.com/tag/scarlet-nexus/" title="Scarlet Nexus Tag" class="scarlet-nexus">Scarlet Nexus</a><a href="https://www.godisageek.com/tag/super-mario-3d-world-bowsers-fury/" title="Super Mario 3D World + Bowser's Fury Tag" class="super-mario-3d-world-bowsers-fury">Super Mario 3D World + Bowser's Fury</a><a href="https://www.godisageek.com/tag/tales-of-arise/" title="Tales of Arise Tag" class="tales-of-arise">Tales of Arise</a><br class="clearer" /></div></div><br class="clearer" /><div class="author-info"><div class="author-image thumbnail"><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><img alt='' src='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7e47477df584e14fe2fabec6989cf360?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></a></div><a class="info" title="See all posts from this author" href="https://www.godisageek.com/author/chris-hyde/"><h3>Chris Hyde</h3></a><div class="author-profile-fields"><a class="icon-email info" title="E-mail Me" href="mailto:chrisdhyde1983@gmail.com"></a></div><br class="clearer" /></div></div></div>                             
                                    
                                </div>
                            
                                                    
                            <div id="recommended" class="clearfix"><div class="filterbar"><div class="sort-buttons" data-loop="recommended" data-location="widget" data-thumbnail="1" data-rating="1" data-numarticles="6" data-icon="1" data-targeted="" data-container="#recommended" data-columns="1"><div class="ribbon-wrapper"><div class="ribbon"><span class="icon-thumbs-up"></span>MORE LIKE THIS<div class="ribbon-separator">&nbsp;</div></div></div><a data-sorter="27938" data-method="tags" class="info active" title="More articles tagged: Control Ultimate Edition">Control Ultimate Edition<span class="bottom-arrow"></span></a><a data-sorter="28692" data-method="tags" class="info" title="More articles tagged: Death's Door">Death's Door<span class="bottom-arrow"></span></a><a data-sorter="24092" data-method="tags" class="info" title="More articles tagged: deathloop">deathloop<span class="bottom-arrow"></span></a><a data-sorter="13083" data-method="tags" class="info" title="More articles tagged: feat">feat<span class="bottom-arrow"></span></a></div><br class="clearer" /></div><div class="loading"><div>&nbsp;</div></div><div class="post-list-wrapper"><div class="post-list"><div class="list-item clearfix small first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/control-ultimate-edition-ps5-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Control-ultimate-edition-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Control ultimate edition review" title="Control Ultimate Edition (PS5) review" srcset="https://www.godisageek.com/wp-content/uploads/Control-ultimate-edition-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Control-ultimate-edition-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Control-ultimate-edition-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Control-ultimate-edition-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/control-ultimate-edition-ps5-review/">Control Ultimate Edition (PS5) review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/control-ultimate-edition-ps5-review/">&nbsp;</a></div><br class="visible-desktop clearer" /><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/01/february-ps-plus-games-revealed-with-destruction-allstars-leading-the-charge/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/destruction-allstars-february-ps-plus-news-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Destruction AllStars PS Plus February" title="February PS Plus games revealed, with Destruction AllStars leading the charge" srcset="https://www.godisageek.com/wp-content/uploads/destruction-allstars-february-ps-plus-news-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/destruction-allstars-february-ps-plus-news-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/destruction-allstars-february-ps-plus-news-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/01/february-ps-plus-games-revealed-with-destruction-allstars-leading-the-charge/">February PS Plus games revealed, with Destruction AllStars leading the charge</a></div><a class="hover-link" href="https://www.godisageek.com/2021/01/february-ps-plus-games-revealed-with-destruction-allstars-leading-the-charge/">&nbsp;</a></div><br class="visible-desktop clearer" /><br class="hidden-desktop clearer two-panel" /></div><br class="clearer" /></div></div>                            
                                                                                    
                                                        
                        </div>
                    
                     
                    
                                            
                </div>          
             
                <div class="widgets-wrapper"><div class="widgets sidebar-right"><div id="it_latest_articles-8" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest News</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/dying-light-2-stay-human-pc-system-requirements-revealed/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Dying Light 2 PC system requirements" title="Dying Light 2 Stay Human PC system requirements revealed" srcset="https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Dying-Light-2-PC-system-requirements-1-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/dying-light-2-stay-human-pc-system-requirements-revealed/">Dying Light 2 Stay Human PC system requirements revealed</a><div class="article-meta clearfix"><a class="like-button do-like 258415 info-bottom" data-postid="258415" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/12/dying-light-2-stay-human-pc-system-requirements-revealed/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/gerda-a-flame-in-winter-announced-by-dontnod/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Gerda A Flame in Winter Announcement" title="Gerda: A Flame in Winter announced by DONTNOD" srcset="https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Gerda-A-Flame-in-Winter-Announcement-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/gerda-a-flame-in-winter-announced-by-dontnod/">Gerda: A Flame in Winter announced by DONTNOD</a></div><a class="hover-link" href="https://www.godisageek.com/2021/12/gerda-a-flame-in-winter-announced-by-dontnod/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/new-patch-for-diablo-ii-resurrected-coming-next-year/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Diablo II Resurrected Patch 2.4" title="New patch for Diablo II: Resurrected coming next year" srcset="https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Diablo-II-Resurrected-Patch-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/new-patch-for-diablo-ii-resurrected-coming-next-year/">New patch for Diablo II: Resurrected coming next year</a></div><a class="hover-link" href="https://www.godisageek.com/2021/12/new-patch-for-diablo-ii-resurrected-coming-next-year/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/olliolli-world-release-date-announced-for-next-year/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="OlliOlli World Release Date" title="OlliOlli World release date announced for next year" srcset="https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-700x675.jpg 700w, https://www.godisageek.com/wp-content/uploads/OlliOlli-World-News-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/olliolli-world-release-date-announced-for-next-year/">OlliOlli World release date announced for next year</a></div><a class="hover-link" href="https://www.godisageek.com/2021/12/olliolli-world-release-date-announced-for-next-year/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/the-new-war-the-latest-expansion-for-warframe-launches-today/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Warframe: The New War" title="The New War, the latest expansion for Warframe, launches today" srcset="https://www.godisageek.com/wp-content/uploads/Warframe-3-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Warframe-3-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Warframe-3-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Warframe-3-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/the-new-war-the-latest-expansion-for-warframe-launches-today/">The New War, the latest expansion for Warframe, launches today</a></div><a class="hover-link" href="https://www.godisageek.com/2021/12/the-new-war-the-latest-expansion-for-warframe-launches-today/">&nbsp;</a></div></div></div>		
		
	<div id="text-18" class="widget clearfix widget_text"><div class="header clearfix">Support us</div>			<div class="textwidget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top"><input name="cmd" type="hidden" value="_s-xclick" /><a href="https://www.patreon.com/GodisaGeek"><img class="size-medium wp-image-210374 aligncenter" src="https://www.godisageek.com/wp-content/uploads/downloads_wordmark_white_on_coral@2x-2-300x145.jpg" alt="" width="300" height="145" /></a><input name="hosted_button_id" type="hidden" value="FG86V8YQ688BA" /></p>
<p><input title="PayPal - The safer, easier way to pay online!" alt="Donate with PayPal button" name="submit" src="https://www.paypalobjects.com/en_US/GB/i/btn/btn_donateCC_LG.gif" type="image" /> <a href="https://ko-fi.com/L3L31F4XP" target="_blank" rel="noopener noreferrer"><img style="border: 0px; height: 36px;" src="https://az743702.vo.msecnd.net/cdn/kofi1.png?v=2" alt="Buy Me a Coffee at ko-fi.com" height="36" border="0" /></a></p>
</form>
</div>
		</div><div id="text-11" class="widget clearfix widget_text">			<div class="textwidget"><div id="nn_mpu1"></div></div>
		</div><div id="it_latest_articles-24" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Reviews</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/scarf-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Scarf-2-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="" title="Scarf review" srcset="https://www.godisageek.com/wp-content/uploads/Scarf-2-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Scarf-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Scarf-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Scarf-2-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/scarf-review/">Scarf review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color4">7.0</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 258453 info-bottom" data-postid="258453" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">2</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/scarf-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/the-gunk-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="The Gunk" title="The Gunk review" srcset="https://www.godisageek.com/wp-content/uploads/The-Gunk-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/The-Gunk-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-gunk-review/">The Gunk review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-gunk-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DonDonPachi Resurrection" title="DoDonPachi Resurrection review" srcset="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">DoDonPachi Resurrection review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Shovel Knight Pocket Dungeon review" title="Shovel Knight Pocket Dungeon review" srcset="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">Shovel Knight Pocket Dungeon review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg" class="attachment-tiny size-tiny wp-post-image" alt="Grim Dawn: Definitive Edition" title="Grim Dawn: Definitive Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-35x35.jpeg 35w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-100x100.jpeg 100w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-700x700.jpeg 700w, https://www.godisageek.com/wp-content/uploads/Grim-Dawn-Main-85x85.jpeg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">Grim Dawn: Definitive Edition review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">&nbsp;</a></div></div></div>		
		
	<div id="custom_html-4" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-86506"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=86506';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div></div><div id="it_latest_articles-41" class="widget clearfix Latest Articles">                	
            <div class="header clearfix">
                <h3><span class="icon-recent header-icon"></span>Latest Videos</h3>
                
                                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="GRID Legends gameplay preview video" title="GRID Legends gameplay preview video" srcset="https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Grid-Legends-video-preview-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">GRID Legends gameplay preview video</a><div class="article-meta clearfix"><a class="like-button do-like 258106 info-bottom" data-postid="258106" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount">1</span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/2021/12/grid-legends-gameplay-preview-video/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="There’s combat when riding the horse in Elden Ring network test" title="Elden Ring gameplay footage | 17 minutes of us playing the game" srcset="https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Elden-Ring-network-test-mounted-horse-combat-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">Elden Ring gameplay footage | 17 minutes of us playing the game</a></div><a class="hover-link" href="https://www.godisageek.com/2021/11/elden-ring-gameplay-17-minutes-of-us-playing-the-game/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Monster Hunter Rise | PC versus Switch Comparison" title="Monster Hunter Rise PC versus Switch Comparison" srcset="https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Monster-Hunter-Rise-pc-demo-gameplay-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">Monster Hunter Rise PC versus Switch Comparison</a></div><a class="hover-link" href="https://www.godisageek.com/2021/10/monster-hunter-rise-pc-versus-switch-comparison/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="What to expect from Knockout City Season 2" title="What to expect from Knockout City Season 2" srcset="https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/knockout-city-season-2-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">What to expect from Knockout City Season 2</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/what-to-expect-from-knockout-city-season-2/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" title="Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf" srcset="https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/podcast-450-rift-apart-scarlet-nexus-mario-golf-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">Podcast 450: Rift Apart, Scarlet Nexus, Mario Golf</a></div><a class="hover-link" href="https://www.godisageek.com/2021/07/podcast-450-rift-apart-mario-golf-scarlet-nexus/">&nbsp;</a></div></div></div>		
		
	<div id="it_top_reviewed-15" class="widget clearfix Top Reviewed">                	
            <div class="header clearfix"> 	
                <h3><span class="icon-reviewed header-icon"></span>Highest rated games this month</h3>
                
            </div>        <div class="post-list list clearfix"><div class="list-item clearfix large first"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/"><img width="85" height="85" src="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-85x85.jpg" class="attachment-widget-post size-widget-post wp-post-image" alt="Shovel Knight Pocket Dungeon review" title="Shovel Knight Pocket Dungeon review" srcset="https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-85x85.jpg 85w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Shovel-Knight-Pocket-Dungeon-review-700x700.jpg 700w" sizes="(max-width: 85px) 100vw, 85px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">Shovel Knight Pocket Dungeon review</a><div class="clearfix"><div class="rating  number_wrapper"><div class="editor_rating solo"><div class="number color5">9.5</div></div></div></div><div class="article-meta clearfix"><a class="like-button do-like 258236 info-bottom" data-postid="258236" data-likeaction="like" title="Likes"><span class="icon icon-liked like"></span><span class="numcount"></span></a><span class="metric info-bottom" title="Comments"></span></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="DonDonPachi Resurrection" title="DoDonPachi Resurrection review" srcset="https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/dodonpachi-daifukkatsu-official-artwork-1-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">DoDonPachi Resurrection review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/halo-infinite-multiplayer-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Multiplayer-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite Multiplayer Review" title="Halo Infinite multiplayer review" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Multiplayer-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Multiplayer-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Multiplayer-Review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Multiplayer-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/halo-infinite-multiplayer-review/">Halo Infinite multiplayer review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/halo-infinite-multiplayer-review/">&nbsp;</a></div><div class="list-item clearfix small"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/halo-infinite-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-campaign-review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Halo Infinite review" title="Halo Infinite review" srcset="https://www.godisageek.com/wp-content/uploads/Halo-Infinite-campaign-review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-campaign-review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-campaign-review-700x700.jpg 700w, https://www.godisageek.com/wp-content/uploads/Halo-Infinite-campaign-review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/halo-infinite-review/">Halo Infinite review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">9.0</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/halo-infinite-review/">&nbsp;</a></div><div class="list-item clearfix small last"><div class="article-image"><a class="thumbnail darken" href="https://www.godisageek.com/reviews/oddworld-soulstorm-enhanced-edition-review/"><img width="35" height="35" src="https://www.godisageek.com/wp-content/uploads/Oddworld-Soulstorm-Enhanced-Edition-Review-35x35.jpg" class="attachment-tiny size-tiny wp-post-image" alt="Oddworld Soulstorm Enhanced Edition Review" title="Oddworld: Soulstorm Enhanced Edition review" srcset="https://www.godisageek.com/wp-content/uploads/Oddworld-Soulstorm-Enhanced-Edition-Review-35x35.jpg 35w, https://www.godisageek.com/wp-content/uploads/Oddworld-Soulstorm-Enhanced-Edition-Review-100x100.jpg 100w, https://www.godisageek.com/wp-content/uploads/Oddworld-Soulstorm-Enhanced-Edition-Review-85x85.jpg 85w" sizes="(max-width: 35px) 100vw, 35px" /></a></div><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/oddworld-soulstorm-enhanced-edition-review/">Oddworld: Soulstorm Enhanced Edition review</a><div class="clearfix"><div class="rating small number_wrapper"><div class="editor_rating solo"><div class="number color5">8.5</div></div></div></div></div><a class="hover-link" href="https://www.godisageek.com/reviews/oddworld-soulstorm-enhanced-edition-review/">&nbsp;</a></div></div></div>		
		
	</div></div>            
            </div>
        
        </div>
        
    </div>
    
</div>



	    
    <div class="container">
        
        <div class="row" id="steam">
        
            <div class="span12">
            
                <div class="steam-content">
                
                    <div class="box-panel box-1"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Christmas-Gaming-Gift-Guide-2021-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/christmas-gaming-gift-guide-2021/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Christmas Gaming Gift Guide 2021</div></div></div></div><div class="box-panel box-2"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Christmas-Tech-Gift-Guide-2021-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/christmas-tech-gift-guide-2021/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Christmas Tech Gift Guide 2021</div></div></div></div><div class="box-panel box-3"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Screenshot-2021-12-10-192146-272x188.png);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/shovel-knight-pocket-dungeon-how-to-get-the-true-ending/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Shovel Knight Pocket Dungeon: How to get the True Ending</div></div></div></div><div class="box-panel box-4"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Halo-Infinite-FOB-vehicles-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/halo-infinite-fob-upgrades-and-how-to-unlock-them-with-valor/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Halo Infinite | FOB Upgrades and how to unlock them with Valor</div></div></div></div><div class="box-panel box-5"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Halo-Infinite-upgrades-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/halo-infinite-best-upgrades-for-master-chiefs-abilities/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Halo Infinite | Best upgrades for Master Chief&#8217;s abilities</div></div></div></div><div class="box-panel box-6"><div class="box-image" style="background-image:url(https://www.godisageek.com/wp-content/uploads/Halo-Infinite-Open-World-272x188.jpg);"></div><a class="box-link" href="https://www.godisageek.com/2021/12/halo-infinite-tips-to-get-started-on-zeta-halo/"></a><div class="box-layer black"></div><div class="box-info"><div class="box-inner"><div class="article-info">Halo Infinite | Tips to get started on Zeta Halo</div></div></div></div>                
                </div>
                
            </div>
            
        </div>
        
    </div>
    
    	



<div class="container">
    
    <div class="row" id="connect">
    
        <div class="span12">
        
            <div class="bar-wrapper clearfix">
            
                <div class="bar-label">
                
                    <div class="label-text">Social Media</div>
                    
                    <div class="timeperiod-text">SUBSCRIBE</div>
                    
                </div>
                
                                
                                
                                
                    <div class="connect-social">
                        
                        <div class="social-badges"><a href="http://www.facebook.com/GodisaGeek" class="icon-facebook info" title="Facebook" target="_blank"></a><a href="//www.youtube.com/godisageek" class="icon-youtube info" title="Youtube" target="_blank"></a><a href="//twitter.com/godisageek" class="icon-twitter info" title="Twitter" target="_blank"></a><a href="https://www.instagram.com/godisageek/" class="icon-instagram info" title="Instagram" target="_blank"></a></div>                    
                    </div>
                    
                                
            </div>
            
        </div>
    
    </div>
    
</div>




	
</div> 

    <div id="footer-wrapper">
    
        <div class="container">
    
            <div id="footer" class="widgets">
            
                <div class="row">
                
                	                
                        <div class="span3">
                        
                            <div id="it_sections-14" class="widget clearfix Sections"><div class='sections-wrapper section-buttons'><div class="header clearfix">
            <h3><span class="icon-grid header-icon"></span>Reviews</h3>            
            <div class="sort-buttons" data-loop="minisite tabs" data-location="widget" data-thumbnail="" data-numarticles="5" data-rating="" data-rating-small="" data-meta="" data-award="" data-article-format="small" data-width="349" data-height="240" data-size="grid-post"><a data-sorter="it_reviews" class="info active" title="Latest from Reviews"><span class="selector-arrow"></span></a></div>            
        </div><div class="loading"><div>&nbsp;</div></div><div class="post-list list clearfix"><div class="list-item clearfix small first full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/scarf-review/">Scarf review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/scarf-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/the-gunk-review/">The Gunk review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/the-gunk-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">DoDonPachi Resurrection review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/dodonpachi-resurrection-review/">&nbsp;</a></div><div class="list-item clearfix small full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">Shovel Knight Pocket Dungeon review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/shovel-knight-pocket-dungeon-review/">&nbsp;</a></div><div class="list-item clearfix small last full"><div class="article-excerpt clearfix hover-text"><a class="title" href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">Grim Dawn: Definitive Edition review</a></div><a class="hover-link" href="https://www.godisageek.com/reviews/grim-dawn-definitive-edition-review/">&nbsp;</a></div></div></div></div>		
		
	<div id="custom_html-3" class="widget_text widget clearfix widget_custom_html"><div class="textwidget custom-html-widget"><a style="cursor:pointer" onclick="window.__cmp('showConsentModal')">Manage Cookie Settings</a></div></div>                        
                        </div>
                        
                                        
                                        
                        <div class="span3">
                        
                            <div id="linkcat-15982" class="widget clearfix widget_links"><div class="header clearfix">Community</div>
	<ul class='xoxo blogroll'>
<li><a href="http://facebook.com/godisageek">Facebook</a></li>
<li><a href="http://www.godisageek.com/category/features/podcasts/">Podcast</a></li>
<li><a href="http://feeds.feedburner.com/godisageek/site">RSS</a></li>
<li><a href="http://twitter.com/godisageek">Twitter</a></li>
<li><a href="http://youtube.com/godisageek">YouTube</a></li>

	</ul>
</div>
                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="it_clouds-7" class="widget clearfix Clouds"><div class="it-widget-tabs it-clouds section-buttons"><ul class="sort-buttons clearfix"><li><a href="#tag-cloud" class="info active icon-tag" title="Tag Cloud"><span class="selector-arrow"></span></a></li><li><a href="#category-cloud" class="info icon-category" title="Category Cloud"><span class="selector-arrow"></span></a></li><li><a href="#reviews_platform-cloud" class="info minisite-icon" title="Platform Cloud"><span class="selector-arrow"></span></a></li></ul><div id="tag-cloud"><a href="https://www.godisageek.com/tag/3ds/" class="tag-cloud-link tag-link-1223 tag-link-position-1" style="font-size: 12.461538461538px;" aria-label="3ds (412 items)">3ds</a>
<a href="https://www.godisageek.com/tag/activision/" class="tag-cloud-link tag-link-236 tag-link-position-2" style="font-size: 18.692307692308px;" aria-label="Activision (780 items)">Activision</a>
<a href="https://www.godisageek.com/tag/bandai-namco/" class="tag-cloud-link tag-link-6186 tag-link-position-3" style="font-size: 12.230769230769px;" aria-label="Bandai Namco (409 items)">Bandai Namco</a>
<a href="https://www.godisageek.com/tag/call-of-duty/" class="tag-cloud-link tag-link-71 tag-link-position-4" style="font-size: 12px;" aria-label="Call of Duty (399 items)">Call of Duty</a>
<a href="https://www.godisageek.com/tag/capcom/" class="tag-cloud-link tag-link-80 tag-link-position-5" style="font-size: 17.769230769231px;" aria-label="Capcom (707 items)">Capcom</a>
<a href="https://www.godisageek.com/tag/dlc/" class="tag-cloud-link tag-link-87 tag-link-position-6" style="font-size: 13.846153846154px;" aria-label="DLC (480 items)">DLC</a>
<a href="https://www.godisageek.com/tag/ea/" class="tag-cloud-link tag-link-111 tag-link-position-7" style="font-size: 22.615384615385px;" aria-label="EA (1,157 items)">EA</a>
<a href="https://www.godisageek.com/tag/ios/" class="tag-cloud-link tag-link-19247 tag-link-position-8" style="font-size: 12.230769230769px;" aria-label="iOS (408 items)">iOS</a>
<a href="https://www.godisageek.com/tag/konami/" class="tag-cloud-link tag-link-162 tag-link-position-9" style="font-size: 15.461538461538px;" aria-label="Konami (565 items)">Konami</a>
<a href="https://www.godisageek.com/tag/microsoft/" class="tag-cloud-link tag-link-144 tag-link-position-10" style="font-size: 20.538461538462px;" aria-label="Microsoft (938 items)">Microsoft</a>
<a href="https://www.godisageek.com/tag/nintendo/" class="tag-cloud-link tag-link-20 tag-link-position-11" style="font-size: 27px;" aria-label="nintendo (1,767 items)">nintendo</a>
<a href="https://www.godisageek.com/tag/nintendo-switch/" class="tag-cloud-link tag-link-17513 tag-link-position-12" style="font-size: 19.153846153846px;" aria-label="nintendo switch (806 items)">nintendo switch</a>
<a href="https://www.godisageek.com/tag/pc/" class="tag-cloud-link tag-link-19189 tag-link-position-13" style="font-size: 24.461538461538px;" aria-label="PC (1,384 items)">PC</a>
<a href="https://www.godisageek.com/tag/playstation-3/" class="tag-cloud-link tag-link-384 tag-link-position-14" style="font-size: 21.461538461538px;" aria-label="playstation 3 (1,032 items)">playstation 3</a>
<a href="https://www.godisageek.com/tag/playstation-4/" class="tag-cloud-link tag-link-6816 tag-link-position-15" style="font-size: 14.076923076923px;" aria-label="PlayStation 4 (492 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/tag/ps3/" class="tag-cloud-link tag-link-6 tag-link-position-16" style="font-size: 22.153846153846px;" aria-label="PS3 (1,104 items)">PS3</a>
<a href="https://www.godisageek.com/tag/ps4/" class="tag-cloud-link tag-link-889 tag-link-position-17" style="font-size: 23.307692307692px;" aria-label="PS4 (1,238 items)">PS4</a>
<a href="https://www.godisageek.com/tag/sega/" class="tag-cloud-link tag-link-116 tag-link-position-18" style="font-size: 17.538461538462px;" aria-label="Sega (691 items)">Sega</a>
<a href="https://www.godisageek.com/tag/sony/" class="tag-cloud-link tag-link-91 tag-link-position-19" style="font-size: 20.769230769231px;" aria-label="Sony (955 items)">Sony</a>
<a href="https://www.godisageek.com/tag/square-enix/" class="tag-cloud-link tag-link-557 tag-link-position-20" style="font-size: 20.538461538462px;" aria-label="square enix (924 items)">square enix</a>
<a href="https://www.godisageek.com/tag/steam/" class="tag-cloud-link tag-link-326 tag-link-position-21" style="font-size: 13.846153846154px;" aria-label="Steam (473 items)">Steam</a>
<a href="https://www.godisageek.com/tag/trailer/" class="tag-cloud-link tag-link-73 tag-link-position-22" style="font-size: 17.538461538462px;" aria-label="Trailer (683 items)">Trailer</a>
<a href="https://www.godisageek.com/tag/ubisoft/" class="tag-cloud-link tag-link-159 tag-link-position-23" style="font-size: 23.769230769231px;" aria-label="Ubisoft (1,295 items)">Ubisoft</a>
<a href="https://www.godisageek.com/tag/xbox-360/" class="tag-cloud-link tag-link-274 tag-link-position-24" style="font-size: 26.307692307692px;" aria-label="Xbox 360 (1,643 items)">Xbox 360</a>
<a href="https://www.godisageek.com/tag/xbox-one/" class="tag-cloud-link tag-link-10518 tag-link-position-25" style="font-size: 23.769230769231px;" aria-label="Xbox One (1,285 items)">Xbox One</a></div><div id="category-cloud"><a href="https://www.godisageek.com/category/reviews/3ds-reviews/" class="tag-cloud-link tag-link-4930 tag-link-position-1" style="font-size: 12.765306122449px;" aria-label="3DS (277 items)">3DS</a>
<a href="https://www.godisageek.com/category/articles/" class="tag-cloud-link tag-link-4925 tag-link-position-2" style="font-size: 12.229591836735px;" aria-label="Articles (236 items)">Articles</a>
<a href="https://www.godisageek.com/category/competition-2/" class="tag-cloud-link tag-link-2904 tag-link-position-3" style="font-size: 12.076530612245px;" aria-label="Competition (222 items)">Competition</a>
<a href="https://www.godisageek.com/category/esports-2/" class="tag-cloud-link tag-link-13446 tag-link-position-4" style="font-size: 13.760204081633px;" aria-label="eSports (374 items)">eSports</a>
<a href="https://www.godisageek.com/category/features/" class="tag-cloud-link tag-link-19 tag-link-position-5" style="font-size: 20.112244897959px;" aria-label="Features (2,492 items)">Features</a>
<a href="https://www.godisageek.com/category/features/guides/" class="tag-cloud-link tag-link-8815 tag-link-position-6" style="font-size: 12.612244897959px;" aria-label="Guides (263 items)">Guides</a>
<a href="https://www.godisageek.com/category/features/interview/" class="tag-cloud-link tag-link-928 tag-link-position-7" style="font-size: 12px;" aria-label="Interview (219 items)">Interview</a>
<a href="https://www.godisageek.com/category/reviews/ios/" class="tag-cloud-link tag-link-1887 tag-link-position-8" style="font-size: 13.607142857143px;" aria-label="iOS (356 items)">iOS</a>
<a href="https://www.godisageek.com/category/news/" class="tag-cloud-link tag-link-66 tag-link-position-9" style="font-size: 27px;" aria-label="News (19,743 items)">News</a>
<a href="https://www.godisageek.com/category/features/opinion/" class="tag-cloud-link tag-link-3931 tag-link-position-10" style="font-size: 15.44387755102px;" aria-label="Opinion (617 items)">Opinion</a>
<a href="https://www.godisageek.com/category/paid/" class="tag-cloud-link tag-link-496 tag-link-position-11" style="font-size: 14.831632653061px;" aria-label="Paid Placement Advertorials (507 items)">Paid Placement Advertorials</a>
<a href="https://www.godisageek.com/category/reviews/pc/" class="tag-cloud-link tag-link-138 tag-link-position-12" style="font-size: 19.65306122449px;" aria-label="PC (2,185 items)">PC</a>
<a href="https://www.godisageek.com/category/reviews/ps3-reviews/" class="tag-cloud-link tag-link-4928 tag-link-position-13" style="font-size: 16.285714285714px;" aria-label="PlayStation 3 (792 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/category/reviews/ps4-reviews/" class="tag-cloud-link tag-link-11296 tag-link-position-14" style="font-size: 18.658163265306px;" aria-label="PlayStation 4 (1,606 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/category/features/podcasts/" class="tag-cloud-link tag-link-258 tag-link-position-15" style="font-size: 16.05612244898px;" aria-label="Podcasts (746 items)">Podcasts</a>
<a href="https://www.godisageek.com/category/previews/" class="tag-cloud-link tag-link-67 tag-link-position-16" style="font-size: 16.668367346939px;" aria-label="Previews (884 items)">Previews</a>
<a href="https://www.godisageek.com/category/reviews/vita-reviews/" class="tag-cloud-link tag-link-6249 tag-link-position-17" style="font-size: 13.377551020408px;" aria-label="PS Vita (329 items)">PS Vita</a>
<a href="https://www.godisageek.com/category/reviews/" class="tag-cloud-link tag-link-68 tag-link-position-18" style="font-size: 21.948979591837px;" aria-label="Reviews (4,334 items)">Reviews</a>
<a href="https://www.godisageek.com/category/reviews/switch-reviews/" class="tag-cloud-link tag-link-18270 tag-link-position-19" style="font-size: 16.285714285714px;" aria-label="Switch (798 items)">Switch</a>
<a href="https://www.godisageek.com/category/tech/" class="tag-cloud-link tag-link-4934 tag-link-position-20" style="font-size: 12.688775510204px;" aria-label="Tech (266 items)">Tech</a>
<a href="https://www.godisageek.com/category/news/trailers/" class="tag-cloud-link tag-link-1360 tag-link-position-21" style="font-size: 17.816326530612px;" aria-label="Trailers (1,259 items)">Trailers</a>
<a href="https://www.godisageek.com/category/do-not-use/" class="tag-cloud-link tag-link-1 tag-link-position-22" style="font-size: 12.994897959184px;" aria-label="Uncategorised (297 items)">Uncategorised</a>
<a href="https://www.godisageek.com/category/features/video-features/" class="tag-cloud-link tag-link-4894 tag-link-position-23" style="font-size: 17.127551020408px;" aria-label="Video Features (1,022 items)">Video Features</a>
<a href="https://www.godisageek.com/category/reviews/360-reviews/" class="tag-cloud-link tag-link-4927 tag-link-position-24" style="font-size: 15.90306122449px;" aria-label="Xbox 360 (715 items)">Xbox 360</a>
<a href="https://www.godisageek.com/category/reviews/xb1-reviews/" class="tag-cloud-link tag-link-11297 tag-link-position-25" style="font-size: 17.892857142857px;" aria-label="Xbox One (1,285 items)">Xbox One</a></div><div id="reviews_platform-cloud"><a href="https://www.godisageek.com/reviews-platform/3ds-2/" class="tag-cloud-link tag-link-13091 tag-link-position-1" style="font-size: 19.944664031621px;" aria-label="3DS (108 items)">3DS</a>
<a href="https://www.godisageek.com/reviews-platform/android/" class="tag-cloud-link tag-link-19254 tag-link-position-2" style="font-size: 19.173913043478px;" aria-label="Android (81 items)">Android</a>
<a href="https://www.godisageek.com/reviews-platform/apple-arcade/" class="tag-cloud-link tag-link-24626 tag-link-position-3" style="font-size: 14.252964426877px;" aria-label="Apple Arcade (11 items)">Apple Arcade</a>
<a href="https://www.godisageek.com/reviews-platform/google-stadia/" class="tag-cloud-link tag-link-25086 tag-link-position-4" style="font-size: 16.150197628458px;" aria-label="Google Stadia (24 items)">Google Stadia</a>
<a href="https://www.godisageek.com/reviews-platform/htc-vive-2/" class="tag-cloud-link tag-link-16517 tag-link-position-5" style="font-size: 16.328063241107px;" aria-label="HTC Vive (26 items)">HTC Vive</a>
<a href="https://www.godisageek.com/reviews-platform/ios/" class="tag-cloud-link tag-link-19248 tag-link-position-6" style="font-size: 20.241106719368px;" aria-label="iOS (121 items)">iOS</a>
<a href="https://www.godisageek.com/reviews-platform/mac/" class="tag-cloud-link tag-link-19230 tag-link-position-7" style="font-size: 17.098814229249px;" aria-label="Mac (35 items)">Mac</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-quest-2/" class="tag-cloud-link tag-link-27654 tag-link-position-8" style="font-size: 13.185770750988px;" aria-label="Oculus Quest 2 (7 items)">Oculus Quest 2</a>
<a href="https://www.godisageek.com/reviews-platform/oculus-rift/" class="tag-cloud-link tag-link-19459 tag-link-position-9" style="font-size: 16.505928853755px;" aria-label="Oculus Rift (28 items)">Oculus Rift</a>
<a href="https://www.godisageek.com/reviews-platform/pc/" class="tag-cloud-link tag-link-19191 tag-link-position-10" style="font-size: 27px;" aria-label="PC (1,715 items)">PC</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-3-2/" class="tag-cloud-link tag-link-13092 tag-link-position-11" style="font-size: 20.774703557312px;" aria-label="PlayStation 3 (150 items)">PlayStation 3</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-4/" class="tag-cloud-link tag-link-19375 tag-link-position-12" style="font-size: 26.762845849802px;" aria-label="PlayStation 4 (1,555 items)">PlayStation 4</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-5/" class="tag-cloud-link tag-link-27533 tag-link-position-13" style="font-size: 20.95256916996px;" aria-label="PlayStation 5 (163 items)">PlayStation 5</a>
<a href="https://www.godisageek.com/reviews-platform/playstation-vr-3/" class="tag-cloud-link tag-link-17388 tag-link-position-14" style="font-size: 18.403162055336px;" aria-label="PlayStation VR (59 items)">PlayStation VR</a>
<a href="https://www.godisageek.com/reviews-platform/ps-vita/" class="tag-cloud-link tag-link-19301 tag-link-position-15" style="font-size: 20.893280632411px;" aria-label="PS Vita (158 items)">PS Vita</a>
<a href="https://www.godisageek.com/reviews-platform/switch-2/" class="tag-cloud-link tag-link-18271 tag-link-position-16" style="font-size: 25.221343873518px;" aria-label="Switch (841 items)">Switch</a>
<a href="https://www.godisageek.com/reviews-platform/wii/" class="tag-cloud-link tag-link-19177 tag-link-position-17" style="font-size: 12px;" aria-label="Wii (4 items)">Wii</a>
<a href="https://www.godisageek.com/reviews-platform/wii-u/" class="tag-cloud-link tag-link-19311 tag-link-position-18" style="font-size: 18.521739130435px;" aria-label="Wii U (62 items)">Wii U</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-360/" class="tag-cloud-link tag-link-19206 tag-link-position-19" style="font-size: 19.885375494071px;" aria-label="Xbox 360 (105 items)">Xbox 360</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-one/" class="tag-cloud-link tag-link-19453 tag-link-position-20" style="font-size: 26.169960474308px;" aria-label="Xbox One (1,231 items)">Xbox One</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-s/" class="tag-cloud-link tag-link-27669 tag-link-position-21" style="font-size: 20.478260869565px;" aria-label="Xbox Series S (135 items)">Xbox Series S</a>
<a href="https://www.godisageek.com/reviews-platform/xbox-series-x/" class="tag-cloud-link tag-link-27534 tag-link-position-22" style="font-size: 20.656126482213px;" aria-label="Xbox Series X (145 items)">Xbox Series X</a></div></div></div>		
		
	                        
                        </div>
                        
                                        
                                            
                        <div class="span3">
                        
                            <div id="text-17" class="widget clearfix widget_text">			<div class="textwidget"><p>Your home for all your videogame needs. Reviews, videos, podcast, news: we&#8217;ve got the lot: PS5, Xbox Series X, Nintendo Switch, PS4, Xbox, PC Gaming!</p>
</div>
		</div>                        
                        
                        </div>
                        
                                        
                                        
                                        
                </div>                
                
            </div>
            
        </div>
        
    </div>
    


    <div id="subfooter-wrapper">
    
        <div class="container">
    
            <div id="subfooter">
    
                <div class="row">
                    
                    <div class="span6 copyright">
                    
                                                
                            All content copyright GodisaGeek.com                            
                          
                        
                    </div>
                    
                    <div class="span6 credits">
                    
                                                
                            Fonts by <a href="http://www.google.com/fonts/">Google Fonts</a>. Icons by <a href="http://fontello.com/">Fontello</a>. Full Credits <a href="http://www.industrialthemes.com/steam/support/credits">here &raquo;</a>
                        
                                                 
                    
                    </div>
                
                </div>
                
            </div>
            
        </div>
        
    </div>
    

	<script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/bootstrap.min.js"></script>
    <script type="text/javascript" src="https://www.godisageek.com/wp-content/themes/steam/js/plugins.min.js"></script>
    
    <script type="text/javascript">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</script>   
    <script type="text/javascript">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</script>     

<div style="display: none;" id="nxsFavNotice"><div id="nxsFavNoticeCnt">Posting....</div></div><link rel='stylesheet' id='modal-css'  href='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.css?ver=4.3.23' type='text/css' media='all' />
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/jquery/jquery.ui.touch-punch.js?ver=0.2.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-admin/js/iris.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://www.godisageek.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/js-css/jquery.modal.min.js?ver=4.3.23'></script>
<!-- BFA Tags to be placed before the closing body div -->
<div id="celtra-reveal-wrapper" style="position:fixed; height: auto; width: 100%">
<div id="nn_1by1"></div>
</div>
</body>

</html>
